Bug 292987 - Muon crashes everytime I launch (Muon se cierra cada que lo abro)
Summary: Muon crashes everytime I launch (Muon se cierra cada que lo abro)
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-31 18:18 UTC by age_2yk
Modified: 2012-01-31 18:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description age_2yk 2012-01-31 18:18:44 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- Surfing on the Internet wit Mozilla Firefox
-Opened Muon from Aplication Launcher

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff000876780 (LWP 8425))]

Thread 2 (Thread 0x7fefebaac700 (LWP 8430)):
#0  0x00007feffd43c773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007feff9cb1f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007feff9cb2429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fefff5faf3e in QEventDispatcherGlib::processEvents (this=0xc642c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fefff5cecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fefff5ceef7 in QEventLoop::exec (this=0x7fefebaabdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fefff4e627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fefff5b1cbf in QInotifyFileSystemWatcherEngine::run (this=0xcb2e60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fefff4e8d05 in QThreadPrivate::start (arg=0xcb2e60) at thread/qthread_unix.cpp:331
#9  0x00007feffa793efc in start_thread (arg=0x7fefebaac700) at pthread_create.c:304
#10 0x00007feffd44889d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff000876780 (LWP 8425)):
[KCrash Handler]
#6  0x00007fefff536a5e in QtPrivate::QStringList_contains (that=0x7fff90134860, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff90134860) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xc66590) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xc66590, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff90134e30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fefff5e2eba in QMetaObject::activate (sender=0xad2ae0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xad2ae0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff90134f90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fefff5e2eba in QMetaObject::activate (sender=0xc66590, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff90134f90) at kernel/qobject.cpp:3278
#13 0x00007ff000458e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xcd63a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007ff000458f8e in MuonMainWindow::initObject (this=0xc66590) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xc66590) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xc66590, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff90135060) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fefff5e2eba in QMetaObject::activate (sender=0xcf35b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fefff5eaf7f in QSingleShotTimer::timerEvent (this=0xcf35b0) at kernel/qtimer.cpp:308
#19 0x00007fefff5e6789 in QObject::event (this=0xcf35b0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007feffdc09474 in notify_helper (e=0x7fff901355d0, receiver=0xcf35b0, this=0xae52d0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xae52d0, receiver=0xcf35b0, e=0x7fff901355d0) at kernel/qapplication.cpp:4458
#22 0x00007feffdc0e2e1 in QApplication::notify (this=0x7fff901358d0, receiver=0xcf35b0, e=0x7fff901355d0) at kernel/qapplication.cpp:4365
#23 0x00007feffedee466 in KApplication::notify (this=0x7fff901358d0, receiver=0xcf35b0, event=0x7fff901355d0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fefff5cfafc in QCoreApplication::notifyInternal (this=0x7fff901358d0, receiver=0xcf35b0, event=0x7fff901355d0) at kernel/qcoreapplication.cpp:787
#25 0x00007fefff5fcd62 in sendEvent (event=0x7fff901355d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xae6490) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fefff5fa514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007feff9cb1a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007feff9cb2258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007feff9cb2429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fefff5faed6 in QEventDispatcherGlib::processEvents (this=0xabc6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007feffdcb110e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fefff5cecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fefff5ceef7 in QEventLoop::exec (this=0x7fff90135860, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fefff5d3789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff90135b48) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 292093.

Possible duplicates by query: bug 292984, bug 292980, bug 292920, bug 292901, bug 292891.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-31 18:22:34 UTC

*** This bug has been marked as a duplicate of bug 291262 ***