Bug 292980 - Muon Software center crashes every time when starting up.
Summary: Muon Software center crashes every time when starting up.
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-31 16:51 UTC by durham_harry
Modified: 2012-01-31 16:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description durham_harry 2012-01-31 16:51:20 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Clicked on Muon Software package center to open and it crashes every time!

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9573335780 (LWP 1930))]

Thread 2 (Thread 0x7f955eaef700 (LWP 1931)):
#0  0x00007f956ff03773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f956c778f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f956c779429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f95720c1f3e in QEventDispatcherGlib::processEvents (this=0x230a400, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9572095cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9572095ef7 in QEventLoop::exec (this=0x7f955eaeedd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9571fad27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f9572078cbf in QInotifyFileSystemWatcherEngine::run (this=0x23883c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9571fafd05 in QThreadPrivate::start (arg=0x23883c0) at thread/qthread_unix.cpp:331
#9  0x00007f956d25aefc in start_thread (arg=0x7f955eaef700) at pthread_create.c:304
#10 0x00007f956ff0f89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9573335780 (LWP 1930)):
[KCrash Handler]
#6  0x00007f9571ffda5e in QtPrivate::QStringList_contains (that=0x7fffbc15f4c0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffbc15f4c0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x2381ba0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x2381ba0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbc15fa90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f95720a9eba in QMetaObject::activate (sender=0x25455a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x25455a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbc15fbf0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f95720a9eba in QMetaObject::activate (sender=0x2381ba0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffbc15fbf0) at kernel/qobject.cpp:3278
#13 0x00007f9572f1fe7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x23e3040) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f9572f1ff8e in MuonMainWindow::initObject (this=0x2381ba0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x2381ba0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x2381ba0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbc15fcc0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f95720a9eba in QMetaObject::activate (sender=0x23ed130, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f95720b1f7f in QSingleShotTimer::timerEvent (this=0x23ed130) at kernel/qtimer.cpp:308
#19 0x00007f95720ad789 in QObject::event (this=0x23ed130, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f95706d0474 in notify_helper (e=0x7fffbc160230, receiver=0x23ed130, this=0x2232060) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x2232060, receiver=0x23ed130, e=0x7fffbc160230) at kernel/qapplication.cpp:4458
#22 0x00007f95706d52e1 in QApplication::notify (this=0x7fffbc160530, receiver=0x23ed130, e=0x7fffbc160230) at kernel/qapplication.cpp:4365
#23 0x00007f95718b5466 in KApplication::notify (this=0x7fffbc160530, receiver=0x23ed130, event=0x7fffbc160230) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f9572096afc in QCoreApplication::notifyInternal (this=0x7fffbc160530, receiver=0x23ed130, event=0x7fffbc160230) at kernel/qcoreapplication.cpp:787
#25 0x00007f95720c3d62 in sendEvent (event=0x7fffbc160230, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x222f750) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f95720c1514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f956c778a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f956c779258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f956c779429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f95720c1ed6 in QEventDispatcherGlib::processEvents (this=0x22096f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f957077810e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f9572095cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f9572095ef7 in QEventLoop::exec (this=0x7fffbc1604c0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f957209a789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffbc1607a8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292920, bug 292901, bug 292891, bug 292871, bug 292868.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-31 16:59:50 UTC

*** This bug has been marked as a duplicate of bug 291262 ***