Bug 292920 - Muon crashed during first install and get never cured
Summary: Muon crashed during first install and get never cured
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-31 01:29 UTC by telemi
Modified: 2012-01-31 03:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description telemi 2012-01-31 01:29:10 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
muon crashed at 68% installation of updates at first kubuntu use. from then on never been able to start again.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb774d930 (LWP 12439))]

Thread 2 (Thread 0xb3ff9b70 (LWP 12444)):
#0  0x00f2ede6 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x0542ef14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x014078bb in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01408637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01408c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x005d7b37 in QEventDispatcherGlib::processEvents (this=0x8b53d68, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x005a81dd in QEventLoop::processEvents (this=0xb3ff92b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x005a8421 in QEventLoop::exec (this=0xb3ff92b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x004ab90b in QThread::exec (this=0x8c1c0f0) at thread/qthread.cpp:498
#9  0x00588e2d in QInotifyFileSystemWatcherEngine::run (this=0x8c1c0f0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x004ae7b3 in QThreadPrivate::start (arg=0x8c1c0f0) at thread/qthread_unix.cpp:331
#11 0x00f2cd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x054210ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb774d930 (LWP 12439)):
[KCrash Handler]
#7  0x00502e11 in QtPrivate::QStringList_contains (that=0xbfc01154, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc01154) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8acf260) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8acf260, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc01374) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x005afb7d in metacall (argv=0xbfc01374, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8acf260) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8acf260, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc01374) at kernel/qmetaobject.cpp:232
#13 0x005bea6a in QMetaObject::activate (sender=0x8b372c0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8b372c0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8b372c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc014b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x005afb7d in metacall (argv=0xbfc014b8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8b372c0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8b372c0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc014b8) at kernel/qmetaobject.cpp:232
#18 0x005bea6a in QMetaObject::activate (sender=0x8acf260, m=0x80950c0, local_signal_index=0, argv=0xbfc014b8) at kernel/qobject.cpp:3278
#19 0x00c2b7c5 in MuonMainWindow::backendReady (this=0x8acf260, _t1=0x8aa6670) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00c2b933 in MuonMainWindow::initObject (this=0x8acf260) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8acf260) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8acf260, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc015e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x005afb7d in metacall (argv=0xbfc015e4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8acf260) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8acf260, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc015e4) at kernel/qmetaobject.cpp:232
#25 0x005bea6a in QMetaObject::activate (sender=0x8b2a858, m=0x6df238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x005c6375 in QSingleShotTimer::timeout (this=0x8b2a858) at .moc/release-shared/qtimer.moc:82
#27 0x005c642c in QSingleShotTimer::timerEvent (this=0x8b2a858) at kernel/qtimer.cpp:308
#28 0x005c1994 in QObject::event (this=0x8b2a858, e=0xbfc019dc) at kernel/qobject.cpp:1181
#29 0x07204d84 in notify_helper (e=0xbfc019dc, receiver=0x8b2a858, this=0x89bb598) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x89bb598, receiver=0x8b2a858, e=0xbfc019dc) at kernel/qapplication.cpp:4458
#31 0x0720a133 in QApplication::notify (this=0xbfc019dc, receiver=0x8b2a858, e=0xbfc019dc) at kernel/qapplication.cpp:3886
#32 0x009b7971 in KApplication::notify (this=0xbfc01cf0, receiver=0x8b2a858, event=0xbfc019dc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x005a919e in QCoreApplication::notifyInternal (this=0xbfc01cf0, receiver=0x8b2a858, event=0xbfc019dc) at kernel/qcoreapplication.cpp:787
#34 0x005d9c10 in sendEvent (event=0xbfc019dc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x89bf834) at kernel/qeventdispatcher_unix.cpp:603
#36 0x005d7122 in timerSourceDispatch (source=0x89bf800) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0140825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01408990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01408c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x005d7ada in QEventDispatcherGlib::processEvents (this=0x899e238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x072bce7a in QGuiEventDispatcherGlib::processEvents (this=0x899e238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005a81dd in QEventLoop::processEvents (this=0xbfc01c54, flags=...) at kernel/qeventloop.cpp:149
#43 0x005a8421 in QEventLoop::exec (this=0xbfc01c54, flags=...) at kernel/qeventloop.cpp:201
#44 0x005ad19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x07202924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 292901.

Possible duplicates by query: bug 292901, bug 292891, bug 292871, bug 292868, bug 292865.

Reported using DrKonqi
Comment 1 telemi 2012-01-31 01:33:30 UTC
platform is an IBM thinkcenter a50
Comment 2 Jekyll Wu 2012-01-31 03:56:02 UTC

*** This bug has been marked as a duplicate of bug 291262 ***