Bug 292093 - Muon crashes every time I open it
Summary: Muon crashes every time I open it
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-21 05:29 UTC by octavian.szolga
Modified: 2012-01-22 03:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.33 KB, text/plain)
2012-01-22 03:32 UTC, creepshowgames
Details

Note You need to log in before you can comment on or make changes to this bug.
Description octavian.szolga 2012-01-21 05:29:14 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- Custom settings of the application:
It maybe related to the fact that I saved my home settings from Kubuntu 11.04 when there was no Muon and just package manager?

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0c71736780 (LWP 8269))]

Thread 2 (Thread 0x7f0c5d03e700 (LWP 8270)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f0c5d03daf0 in ?? ()
#2  0x00007fff5009a7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f0c71736780 (LWP 8269)):
[KCrash Handler]
#6  0x00007f0c703fda5e in QtPrivate::QStringList_contains (that=0x7fff5006aea0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff5006aea0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xd9fe90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xd9fe90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5006b470) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f0c704a9eba in QMetaObject::activate (sender=0xe58780, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xe58780, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5006b5d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f0c704a9eba in QMetaObject::activate (sender=0xd9fe90, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff5006b5d0) at kernel/qobject.cpp:3278
#13 0x00007f0c7131ce7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xd85230) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f0c7131cf8e in MuonMainWindow::initObject (this=0xd9fe90) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xd9fe90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xd9fe90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5006b6a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f0c704a9eba in QMetaObject::activate (sender=0xe2d9b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f0c704b1f7f in QSingleShotTimer::timerEvent (this=0xe2d9b0) at kernel/qtimer.cpp:308
#19 0x00007f0c704ad789 in QObject::event (this=0xe2d9b0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f0c6ead1424 in notify_helper (e=0x7fff5006bc10, receiver=0xe2d9b0, this=0xc8fa00) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xc8fa00, receiver=0xe2d9b0, e=0x7fff5006bc10) at kernel/qapplication.cpp:4458
#22 0x00007f0c6ead6291 in QApplication::notify (this=0x7fff5006bf10, receiver=0xe2d9b0, e=0x7fff5006bc10) at kernel/qapplication.cpp:4365
#23 0x00007f0c6fcb5126 in KApplication::notify (this=0x7fff5006bf10, receiver=0xe2d9b0, event=0x7fff5006bc10) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f0c70496afc in QCoreApplication::notifyInternal (this=0x7fff5006bf10, receiver=0xe2d9b0, event=0x7fff5006bc10) at kernel/qcoreapplication.cpp:787
#25 0x00007f0c704c3d62 in sendEvent (event=0x7fff5006bc10, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xc8be60) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f0c704c1514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f0c6ab79a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f0c6ab7a258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f0c6ab7a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f0c704c1ed6 in QEventDispatcherGlib::processEvents (this=0xc676f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f0c6eb7907e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f0c70495cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f0c70495ef7 in QEventLoop::exec (this=0x7fff5006bea0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f0c7049a789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff5006c188) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 292087, bug 292078, bug 292074, bug 292054, bug 292031.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-21 06:05:37 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 creepshowgames 2012-01-22 03:32:06 UTC
Created attachment 68084 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

every time i try to open Muon it... Epic Fails!

-- Backtrace (Reduced):
#7  0x002a4e11 in QtPrivate::QStringList_contains (that=0xbfc5cd74, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc5cd74) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8d8b1f8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8d8b1f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc5cf94) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00351b7d in metacall (argv=0xbfc5cf94, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8d8b1f8) at kernel/qmetaobject.cpp:237