Bug 292984 - Muon crash
Summary: Muon crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-31 17:21 UTC by Ronald Arends
Modified: 2012-01-31 17:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald Arends 2012-01-31 17:21:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Everytime i want to start up Muon softwarecentre it crashes

The crash can be reproduced every time.

-- Backtrace:
Application: Muon softwarecentrum (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7effe5372780 (LWP 3524))]

Thread 2 (Thread 0x7effd0821700 (LWP 3528)):
#0  0x00007effde7b3649 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007effde7b4d81 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007effde7b5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007effe40fdf3e in QEventDispatcherGlib::processEvents (this=0x1e43bd0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007effe40d1cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007effe40d1ef7 in QEventLoop::exec (this=0x7effd0820dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007effe3fe927f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007effe40b4cbf in QInotifyFileSystemWatcherEngine::run (this=0x1cbf860) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007effe3febd05 in QThreadPrivate::start (arg=0x1cbf860) at thread/qthread_unix.cpp:331
#9  0x00007effdf296efc in start_thread (arg=0x7effd0821700) at pthread_create.c:304
#10 0x00007effe1f4b89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7effe5372780 (LWP 3524)):
[KCrash Handler]
#6  0x00007effe4039a5e in QtPrivate::QStringList_contains (that=0x7fff2dabb1a0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff2dabb1a0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1c9d2b0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1c9d2b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff2dabb770) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007effe40e5eba in QMetaObject::activate (sender=0x1cfd1e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1cfd1e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff2dabb8d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007effe40e5eba in QMetaObject::activate (sender=0x1c9d2b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff2dabb8d0) at kernel/qobject.cpp:3278
#13 0x00007effe4f5be7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1ccac40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007effe4f5bf8e in MuonMainWindow::initObject (this=0x1c9d2b0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1c9d2b0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1c9d2b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff2dabb9a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007effe40e5eba in QMetaObject::activate (sender=0x1cf8310, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007effe40edf7f in QSingleShotTimer::timerEvent (this=0x1cf8310) at kernel/qtimer.cpp:308
#19 0x00007effe40e9789 in QObject::event (this=0x1cf8310, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007effe270c474 in notify_helper (e=0x7fff2dabbf10, receiver=0x1cf8310, this=0x1af5260) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1af5260, receiver=0x1cf8310, e=0x7fff2dabbf10) at kernel/qapplication.cpp:4458
#22 0x00007effe27112e1 in QApplication::notify (this=0x7fff2dabc210, receiver=0x1cf8310, e=0x7fff2dabbf10) at kernel/qapplication.cpp:4365
#23 0x00007effe38f1466 in KApplication::notify (this=0x7fff2dabc210, receiver=0x1cf8310, event=0x7fff2dabbf10) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007effe40d2afc in QCoreApplication::notifyInternal (this=0x7fff2dabc210, receiver=0x1cf8310, event=0x7fff2dabbf10) at kernel/qcoreapplication.cpp:787
#25 0x00007effe40ffd62 in sendEvent (event=0x7fff2dabbf10, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1af0600) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007effe40fd514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007effde7b4a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007effde7b5258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007effde7b5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007effe40fded6 in QEventDispatcherGlib::processEvents (this=0x1acb6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007effe27b410e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007effe40d1cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007effe40d1ef7 in QEventLoop::exec (this=0x7fff2dabc1a0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007effe40d6789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff2dabc488) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292980, bug 292920, bug 292901, bug 292891, bug 292871.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-31 17:25:54 UTC

*** This bug has been marked as a duplicate of bug 291262 ***