Bug 292901 - Muon Software Centre crashes on opening
Summary: Muon Software Centre crashes on opening
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-30 20:16 UTC by c.a.gamble
Modified: 2012-01-31 03:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description c.a.gamble 2012-01-30 20:16:01 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Muon software Centre crash when opening. This happens to me every time I open this programe.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77b2930 (LWP 4910))]

Thread 2 (Thread 0xb5b03b70 (LWP 4914)):
#0  0x0042ad10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x007c67d5 in do_gettime (frac=0xb5b03020, sec=0xb5b03018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x008994b6 in QTimerInfoList::updateCurrentTime (this=0x8cd23b4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0089980a in QTimerInfoList::timerWait (this=0x8cd23b4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00898053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5b0312c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x008980ed in timerSourcePrepare (source=0x8cd2380, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x06bd888c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x06bd9637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x06bd9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00898b37 in QEventDispatcherGlib::processEvents (this=0x8b77a28, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x008691dd in QEventLoop::processEvents (this=0xb5b032b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00869421 in QEventLoop::exec (this=0xb5b032b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0076c90b in QThread::exec (this=0x8bfb6a0) at thread/qthread.cpp:498
#14 0x00849e2d in QInotifyFileSystemWatcherEngine::run (this=0x8bfb6a0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0076f7b3 in QThreadPrivate::start (arg=0x8bfb6a0) at thread/qthread_unix.cpp:331
#16 0x003a3d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0736b0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77b2930 (LWP 4910)):
[KCrash Handler]
#7  0x007c3e11 in QtPrivate::QStringList_contains (that=0xbfdd20e4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfdd20e4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8b757d8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8b757d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdd2304) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00870b7d in metacall (argv=0xbfdd2304, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8b757d8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8b757d8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfdd2304) at kernel/qmetaobject.cpp:232
#13 0x0087fa6a in QMetaObject::activate (sender=0x8a9ffb0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8a9ffb0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8a9ffb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdd2448) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00870b7d in metacall (argv=0xbfdd2448, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8a9ffb0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8a9ffb0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfdd2448) at kernel/qmetaobject.cpp:232
#18 0x0087fa6a in QMetaObject::activate (sender=0x8b757d8, m=0x80950c0, local_signal_index=0, argv=0xbfdd2448) at kernel/qobject.cpp:3278
#19 0x003f37c5 in MuonMainWindow::backendReady (this=0x8b757d8, _t1=0x8b01d30) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x003f3933 in MuonMainWindow::initObject (this=0x8b757d8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8b757d8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8b757d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdd2574) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00870b7d in metacall (argv=0xbfdd2574, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8b757d8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8b757d8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfdd2574) at kernel/qmetaobject.cpp:232
#25 0x0087fa6a in QMetaObject::activate (sender=0x8bcbf48, m=0x9a0238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00887375 in QSingleShotTimer::timeout (this=0x8bcbf48) at .moc/release-shared/qtimer.moc:82
#27 0x0088742c in QSingleShotTimer::timerEvent (this=0x8bcbf48) at kernel/qtimer.cpp:308
#28 0x00882994 in QObject::event (this=0x8bcbf48, e=0xbfdd296c) at kernel/qobject.cpp:1181
#29 0x04c89d84 in notify_helper (e=0xbfdd296c, receiver=0x8bcbf48, this=0x8aae6e0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8aae6e0, receiver=0x8bcbf48, e=0xbfdd296c) at kernel/qapplication.cpp:4458
#31 0x04c8f133 in QApplication::notify (this=0xbfdd296c, receiver=0x8bcbf48, e=0xbfdd296c) at kernel/qapplication.cpp:3886
#32 0x00f3b971 in KApplication::notify (this=0xbfdd2c80, receiver=0x8bcbf48, event=0xbfdd296c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0086a19e in QCoreApplication::notifyInternal (this=0xbfdd2c80, receiver=0x8bcbf48, event=0xbfdd296c) at kernel/qcoreapplication.cpp:787
#34 0x0089ac10 in sendEvent (event=0xbfdd296c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8aac104) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00898122 in timerSourceDispatch (source=0x8aac0d0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x06bd925f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x06bd9990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x06bd9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00898ada in QEventDispatcherGlib::processEvents (this=0x8a8c238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x04d41e7a in QGuiEventDispatcherGlib::processEvents (this=0x8a8c238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x008691dd in QEventLoop::processEvents (this=0xbfdd2be4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00869421 in QEventLoop::exec (this=0xbfdd2be4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0086e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x04c87924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292891, bug 292871, bug 292868, bug 292865, bug 292823.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-31 03:56:14 UTC

*** This bug has been marked as a duplicate of bug 291262 ***