Bug 292891 - fresh install software center crash
Summary: fresh install software center crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-30 18:22 UTC by Edward
Modified: 2012-01-30 18:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edward 2012-01-30 18:22:28 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Fresh install. activated software center and it crashed as soon as it opened.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7736930 (LWP 1839))]

Thread 2 (Thread 0xb58d6b70 (LWP 1843)):
#0  0x002a5d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00e767d5 in do_gettime (frac=0xb58d6020, sec=0xb58d6018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00f494b6 in QTimerInfoList::updateCurrentTime (this=0x90a7ec4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00f4980a in QTimerInfoList::timerWait (this=0x90a7ec4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00f48053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb58d612c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00f480ed in timerSourcePrepare (source=0x90a7e90, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00cc088c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x00cc1637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x00cc1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00f48b37 in QEventDispatcherGlib::processEvents (this=0x8fdd758, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00f191dd in QEventLoop::processEvents (this=0xb58d62b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00f19421 in QEventLoop::exec (this=0xb58d62b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00e1c90b in QThread::exec (this=0x90a0a30) at thread/qthread.cpp:498
#14 0x00ef9e2d in QInotifyFileSystemWatcherEngine::run (this=0x90a0a30) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00e1f7b3 in QThreadPrivate::start (arg=0x90a0a30) at thread/qthread_unix.cpp:331
#16 0x00551d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x007720ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7736930 (LWP 1839)):
[KCrash Handler]
#7  0x00e73e11 in QtPrivate::QStringList_contains (that=0xbfad6a84, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfad6a84) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8f49920) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8f49920, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfad6ca4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00f20b7d in metacall (argv=0xbfad6ca4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8f49920) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8f49920, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfad6ca4) at kernel/qmetaobject.cpp:232
#13 0x00f2fa6a in QMetaObject::activate (sender=0x8fbbb30, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8fbbb30) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8fbbb30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfad6de8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00f20b7d in metacall (argv=0xbfad6de8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8fbbb30) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8fbbb30, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfad6de8) at kernel/qmetaobject.cpp:232
#18 0x00f2fa6a in QMetaObject::activate (sender=0x8f49920, m=0x80950c0, local_signal_index=0, argv=0xbfad6de8) at kernel/qobject.cpp:3278
#19 0x002c37c5 in MuonMainWindow::backendReady (this=0x8f49920, _t1=0x8fa6010) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x002c3933 in MuonMainWindow::initObject (this=0x8f49920) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8f49920) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8f49920, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfad6f14) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00f20b7d in metacall (argv=0xbfad6f14, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8f49920) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8f49920, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfad6f14) at kernel/qmetaobject.cpp:232
#25 0x00f2fa6a in QMetaObject::activate (sender=0x8fb9830, m=0x1050238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00f37375 in QSingleShotTimer::timeout (this=0x8fb9830) at .moc/release-shared/qtimer.moc:82
#27 0x00f3742c in QSingleShotTimer::timerEvent (this=0x8fb9830) at kernel/qtimer.cpp:308
#28 0x00f32994 in QObject::event (this=0x8fb9830, e=0xbfad730c) at kernel/qobject.cpp:1181
#29 0x03b51d84 in notify_helper (e=0xbfad730c, receiver=0x8fb9830, this=0x8e68568) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8e68568, receiver=0x8fb9830, e=0xbfad730c) at kernel/qapplication.cpp:4458
#31 0x03b57133 in QApplication::notify (this=0xbfad730c, receiver=0x8fb9830, e=0xbfad730c) at kernel/qapplication.cpp:3886
#32 0x034e6971 in KApplication::notify (this=0xbfad7620, receiver=0x8fb9830, event=0xbfad730c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00f1a19e in QCoreApplication::notifyInternal (this=0xbfad7620, receiver=0x8fb9830, event=0xbfad730c) at kernel/qcoreapplication.cpp:787
#34 0x00f4ac10 in sendEvent (event=0xbfad730c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8e6b86c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00f48122 in timerSourceDispatch (source=0x8e6b838) at kernel/qeventdispatcher_glib.cpp:184
#37 0x00cc125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x00cc1990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x00cc1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00f48ada in QEventDispatcherGlib::processEvents (this=0x8e46238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x03c09e7a in QGuiEventDispatcherGlib::processEvents (this=0x8e46238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00f191dd in QEventLoop::processEvents (this=0xbfad7584, flags=...) at kernel/qeventloop.cpp:149
#43 0x00f19421 in QEventLoop::exec (this=0xbfad7584, flags=...) at kernel/qeventloop.cpp:201
#44 0x00f1e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x03b4f924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292871, bug 292868, bug 292865, bug 292823, bug 292818.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-30 18:36:38 UTC

*** This bug has been marked as a duplicate of bug 291262 ***