Bug 275835 - Applications are outlined with the "Demands attention" look, when they don't need to be
Summary: Applications are outlined with the "Demands attention" look, when they don't ...
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-taskbar (show other bugs)
Version: 4.8.2
Platform: Archlinux Packages Linux
: NOR normal with 331 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 274020 280659 286948 303208 304305 320055 321756 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-16 19:16 UTC by Jonas Nyrén
Modified: 2013-07-04 14:36 UTC (History)
36 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments
application highlight in taskbar (260.90 KB, image/png)
2012-05-02 06:17 UTC, Bazilio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Nyrén 2011-06-16 19:16:11 UTC
Version:           unspecified (using Devel) 
OS:                Linux

KDE 4.7 beta 1 (couldn't find it in the version list above..)

Applications (seemingly) randomly get outlined in the plasma panel as if they demand attention, but they don't. I'm not sure if this is actually plasma related or if it is kwin that is doing something weird, but at least it's in the panel that the symptoms are visible so I file it here. 

Sometimes the outline disappears if you click the window in the panel and then click another, sometimes it doesn't help. I can't really make out a reproducible chain of events for it. But it always happens, sooner or later after you get into KDE.

I have no effects enabled, and I have the task bar set to manual sorting without grouping.

Reproducible: Always
Comment 1 Peter Fors 2011-06-16 19:23:56 UTC
Confirmed, this happens on my installation of kde too
Comment 2 Jonas Nyrén 2011-07-13 21:05:04 UTC
This still persists in KDE 4.7rc2.

Using qtcurve widget theme, Oxygen icons, qtcurve window decorations, and produkt desktop theme.

It seems to happen more often with things that you have minimized to the systray and when you restore them the window in the taskbar flashes 3 times like it demands attention, and then has a colored border around it. This sometimes goes away when you switch from the application (with alt-tab or such) to another one. but reappears when you hover the window in the taskbar. I can make a video if that helps..
Comment 3 praecipitator 2011-09-02 07:51:39 UTC
happens here as well.
Using oxygen desktop theme, plastic window decoration, qtcurve widget style, oxygen icons. 
Jonas Nyrén alerady described pretty much what I see. Also, if a window actually needs attention (like instant messaging), the state often gets "stuck" to it.
Comment 4 torge 2011-09-15 13:29:54 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Jean-Philippe Fleury 2011-10-08 20:39:09 UTC
I too have this bug with KDE 4.7.1, not only with default theme, but also with third party desktop themes.
Comment 6 Jean-Philippe Fleury 2011-10-08 20:51:04 UTC
May be related to bug 274020
Comment 7 Jonas Nyrén 2011-10-10 19:21:21 UTC
This does not only happen with newly started applications when you steal their focus, it happens seemingly randomly with applications that have been running for some time.

If this behavior starts and you manage to remove the outline by switching to another task - as soon as your mouse hovers the icon in the taskbar the outline comes back and stays there again.

Already 4 months and no interest from any developer on this bug, it's a sad state of KDE really.

still persists in KDE 4.7.2
Comment 8 jenna 2011-10-17 18:53:33 UTC
I just updated from kubuntu 11.04 to 11.10 and now I am getting this bug.  It only happens with certain applications, though.
ktorrent - the taskbar entry is always highlited
chrome & dolphin - the taskbar entry gets highlited whenever i hover over it
Comment 9 ttrzeciak.mail 2011-12-17 08:47:39 UTC
still persists in KDE 4.7.4
Comment 10 LT 2012-01-03 13:10:06 UTC
Steps to reproduce:
1) Run application like ktorrent or kopete and minimize it to tray.
2) Run another application and make it active.
3) Click on [1] app icon on tray to restore it.
4) Now [1] keeping "demand attention" look.
Using KDE-4.7.3 on gentoo x86-64.
Comment 11 torge 2012-01-03 13:25:36 UTC
I can reproduce the bug using LT's steps and Amarok as application [1] on KDE 4.7.4 on Kubuntu x86-64, too.
Comment 12 Stefan Tittel 2012-02-04 21:47:28 UTC
Any updates? Does this still persist in 4.8.0?
Comment 13 Germano Massullo 2012-03-01 16:21:38 UTC
Hello, I am the bugreporter of an identical bugreport. Alexander Kiselyov told me about other bugreports identical as mine, so I create this post to link all of them so someone of the admins can merge them.

https://bugs.kde.org/show_bug.cgi?id=286948
https://bugs.kde.org/show_bug.cgi?id=275835
https://bugs.kde.org/show_bug.cgi?id=274020
Comment 14 Beat Wolf 2012-03-01 16:37:28 UTC
*** Bug 274020 has been marked as a duplicate of this bug. ***
Comment 15 Beat Wolf 2012-03-01 16:37:32 UTC
*** Bug 286948 has been marked as a duplicate of this bug. ***
Comment 16 Germano Massullo 2012-04-27 15:16:42 UTC
Any news?
Comment 17 jenna 2012-04-30 13:05:52 UTC
i updated both of my computers from kubuntu 11.10 to 12.04, and i'm not getting this issue any more.  kinfocenter reports KDE version 4.8.2.
Comment 18 torge 2012-04-30 13:36:10 UTC
I can still reproduce the bug with the steps from comment 10 on Kubuntu 12.04 with KDE 4.8.2.
Comment 19 Bazilio 2012-05-02 06:17:58 UTC
Created attachment 70798 [details]
application highlight in taskbar
Comment 20 Bazilio 2012-05-02 06:19:55 UTC
(In reply to comment #18)
> I can still reproduce the bug with the steps from comment 10 on Kubuntu
> 12.04 with KDE 4.8.2.

It reproduces after dialog windows in krusader too. Dialog popup (in example: confirm to overwrite files), i close dialog, app still highlight in taskbar.
Comment 21 edfardos 2012-05-16 14:55:24 UTC
Bug exists on KDE4.8.2, provided with Ubuntu 12.04. 

It's brutal on certain themes where the task-bar icon glows white instead of black.  At any point in time I have ~20 items in the task bar, a quarter of which demand attention, so it looks like a checkerboard. 

Once thing I noticed, if you bring an app to the foreground, the taskbar icon un-highlights, then you minimize the app, then you mouse-over the task bar icon, as the mouse leaves the task bar icon, it suddenly highlights again.  

Is there a way to easily disable the app-attention highlight in the task bar completely?  I know it sounds like a simple bug, but it's incredibly frustrating as it causes users to miss attention-required actions and event reminders.

r,
-edfardos
Comment 22 Pablo Duboue 2012-05-18 06:10:43 UTC
If you go to the task manager settings and change the filters to "only show tasks for the current screen" and "force row settings" (with 2 rows) and then back to "normal", it will reset its state to correct behavior for a period of time.
Comment 23 edfardos 2012-05-21 19:28:14 UTC
Confirmed workaround, 

[x]  "Only show tasks from the current desktop"
[apply]
[  ] "Only show tasks from the current desktop"  (uncheck)
[apply]

restores normal attention behavior in task bar for a while...
Comment 24 Jonathan 2012-05-22 01:39:25 UTC
I see this bug in Kubuntu 12.04 (looks like KDE version 4.8.2a-0ubuntu4).

I found an easier workaround than the checkbox setting above, although it's not perfect, and it requires that you have "Taskbar Thumbnails" enabled in desktop effects:

Hover over the taskbar entry until the window thumbnail shows up, and click on the thumbnail. The highlight will go away when you switch back to another window, but when the now-fixed window is active, it will have the "Needs Attention" graphic in the taskbar.

But at least it's not there when you are in a different window...
Comment 25 Germano Massullo 2012-06-26 20:54:31 UTC
Guys, I can confirm again this bug in KDE 4.8.4.
Developers:
what about taking it more seriously? See the vote list, it is more than confirmed!
Comment 26 Rex Dieter 2012-06-26 21:25:39 UTC
i'd like to help debug and diagnose this properly too, but yet to see reliable recipe to reproduce this phenomenon.  (all my previous attempts have failed).
Comment 27 Pablo Duboue 2012-06-26 21:52:20 UTC
My take so far is that it only happens with gnome apps that have
requested attention. The task bar doesn't reset itself properly.

On 6/26/12, Rex Dieter <rdieter@math.unl.edu> wrote:
> https://bugs.kde.org/show_bug.cgi?id=275835
>
> --- Comment #26 from Rex Dieter <rdieter@math.unl.edu> ---
> i'd like to help debug and diagnose this properly too, but yet to see
> reliable
> recipe to reproduce this phenomenon.  (all my previous attempts have
> failed).
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>
Comment 28 Jonathan 2012-06-26 22:25:36 UTC
I see this most often with Amarok and Eclipse. Amarok usually after restoring from the system tray, Eclipse usually at startup. I have not seen this as much (or perhaps at all) during the past week or so, and cannot seem to reproduce while actively trying right now.

Ubuntu package kde-runtime is at 4.8.3.
Comment 29 torge 2012-06-26 23:10:31 UTC
I can still reliably reproduce it with the steps from comment 10 on Kubuntu 12.04 with KDE 4.8.4, using e.g. KTorrent and Dolphin. Thus it doesn't only happen with Gnome apps.
Comment 30 Jonathan 2012-06-27 13:26:56 UTC
Yes, the steps in comment 10 worked to reproduce in 4.8.3 on Kubuntu.

Note that when you switch back to [1], you need to CLICK on it. Using Alt+Tab will not show the needs-attention highlight, but even if you Alt+Tab to it, then away, then click on it, it will show like it needs attention.
Comment 31 Beat Wolf 2012-06-27 15:02:24 UTC
For me its usually eclipse or kopete that "causes" the problem
Comment 32 Rex Dieter 2012-06-27 15:09:54 UTC
I guess I admit defeat then, no amount of filddling with either eclipse, amarok, ktorrent, or kopete allowed me to reproduce this myself (on either my fedora 16/x86_64 box with kde-4.8.4 or fedora 17/x86_64 one with kde-4.8.90 currently)
Comment 33 haldyr 2012-06-28 06:40:03 UTC
I can confirm this problem, but unfortunately I don't know a way to reproduce it. Temporary (!) workaround from comment #23 works. 

It is quite annoying  when windows are highlighted (especially kopete windows..).
Comment 34 Frank Steinmetzger 2012-07-03 23:04:55 UTC
I too have been having this for a looong time now, very often with assorted Krusader windows. I'm running 4.8.3 on Gentoo.

Just now I had it again (which made me reply here finally). I was switching between two windows, from KMyMoney to LibreOffice and Krusader. Whenever I clicked on KMyMoney to bring it to the foreground, its taskbar entry would remain highlighted (non-flashing) in its *selected* state. If I clicked on the LO item and then switched back to KMM with Alt+Tab, the item didn't get highlighted.
Comment 35 bill p. (aka google01103) 2012-07-28 12:28:31 UTC
just add that I have it on 4.8.95
Comment 36 Martin Sandsmark 2012-08-07 16:52:23 UTC
*** Bug 303208 has been marked as a duplicate of this bug. ***
Comment 38 Germano Massullo 2012-08-07 16:56:06 UTC
Hallelujah
Comment 39 nucleo 2012-08-07 20:12:19 UTC
I am still have problems with patch from Comment 37.
Seamonkey started on background of other applications with status 'asking for attention' but this status stays after switching to semonkey window and disappears only after switching to other desktop and back.
Comment 40 nucleo 2012-08-07 23:11:16 UTC
Note that I have taskbar option to show windows only from current desktop.
Konqueror was as background window but when certificate confirmation window appeared it was needed attention but after i switched to konqueror window this state remained.
Comment 41 Mike Robinson 2012-08-09 00:33:20 UTC
Stupid question. Is there any way we can apply the fix or do we need to wait for it to be released. If we need to wait, how can we tell which release it will be included in? I am using KDE 4.9.0 and I'm still having this bug.
Comment 42 Martin Sandsmark 2012-08-09 01:25:42 UTC
As I set above, it should come with 4.9.1.
Comment 43 Gregor Tätzner 2012-08-23 15:08:41 UTC
*** Bug 280659 has been marked as a duplicate of this bug. ***
Comment 44 edfardos 2012-08-24 22:46:46 UTC
I applied the patch to kde 4.8.4, and still get the same behavior (recompiled libtaskmanager.so).  The easiest way for me to replicate it is to simply open kopete.  It demands attention when it's maximized.   click on it, and the task manager un-highlights as you'd expect, but then go back and mouse-over the taskmanager icon for kopete, and it highlights as the mouse leaves the icon.

Was there another code change that I missed?


~/dev/kde-workspace_4.8.4a/kde-workspace-4.8.4a/libs/taskmanager:

void Task::setActive(bool a)
{
    d->active = a;
//edfardos
//  emit changed(StateChanged);

    TaskChanges changes = StateChanged;

    if (demandsAttention() != d->demandedAttention) {
        d->demandedAttention = !d->demandedAttention;
        changes |= AttentionChanged;
    }

    emit changed(changes);
//end edfardos


compiled into /usr/lib/libtaskmanager.so -> /usr/lib/libtaskmanager.so.4.8.0

what'd I miss?
Comment 45 edfardos 2012-08-31 14:10:10 UTC
I think I can confirm the patch fixes one manifestation of the issue (I don't see it happen with chromium or thunderbird or other traditional apps).

However as  Jonas Nyrén said, "It seems to happen more often with things that you have minimized to the systray", specifically kopete.  If I never maximize kopete, the but is completely fixed imho.  Maybe this manifestation is a kopete bug.  But it's fixed otherwise. 

thanks!
-edfardos
Comment 46 Henrik Pauli 2012-09-09 10:19:46 UTC
I'm afraid I experience this one in 4.9 still...
Comment 47 Myriam Schweingruber 2012-09-10 11:56:02 UTC
(In reply to comment #46)
> I'm afraid I experience this one in 4.9 still...

As you can see it was fixed in 4.9.1 which is ahead of 4.9.0
Comment 48 Henrik Pauli 2012-09-10 11:58:59 UTC
I still get it in 4.9.1 too. I have three tasks highlighted at the moment, one of which is a KDE app (Konsole).
Comment 49 Myriam Schweingruber 2012-09-10 15:04:01 UTC
Can somebody else with KDE 4.9.1 reproduce this? Please also test with a new user.
Comment 50 nucleo 2012-09-10 19:06:11 UTC
In KDE 4.9.1 I have the same problems as in Comment 39.
Comment 51 nucleo 2012-09-10 19:12:43 UTC
And for new user problem still appears (when option show windows only from current desktop selected).
Comment 52 bill p. (aka google01103) 2012-09-14 17:09:20 UTC
for me it seems resolved, except for gKrellm which demands attention but then when clicked or restarted it is fine (which would might be considered normal)
Comment 53 Germano Massullo 2012-09-24 16:04:31 UTC
KDE 4.9.1
I updated today, and at the moment I am having this bug with Firefox.
Comment 54 bill p. (aka google01103) 2012-10-02 18:16:34 UTC
happens infrequently  now but seems (iirc) to be non-KDE apps like Opera and even then infrequent and closing and restarting the app clears it.
Comment 55 Mike Robinson 2012-10-02 18:25:42 UTC
This still happens to me with speedcrunch.
Comment 56 Martin Sandsmark 2012-10-02 19:14:35 UTC
could you use xprop and make sure that it isn't actually an application bug (for example if it forgets to clear its own demands attention flag)?

anywho, I've heard that the task manager plasmoid is going to be replaced in the near future with a QML-based one.
Comment 57 Germano Massullo 2012-10-02 19:54:37 UTC
(In reply to comment #56)
> make sure that it isn't actually an application bug
It is not an application bug at all, since I am having this bug with a discrete amount of applications like:
- Amarok
- Pidgin
- Firefox
- others that I forgot at the moment
Comment 58 Martin Sandsmark 2012-10-02 20:59:59 UTC
(In reply to comment #57)
> (In reply to comment #56)
> > make sure that it isn't actually an application bug
> It is not an application bug at all, since I am having this bug with a
> discrete amount of applications like:
> […]

So?

Also make sure you are actually using an up to date version.

But it is fixed for me now, so I'm unsubscribing.
Comment 59 Germano Massullo 2012-10-02 21:03:57 UTC
(In reply to comment #58)
> (In reply to comment #57)
> > (In reply to comment #56)
> > > make sure that it isn't actually an application bug
> > It is not an application bug at all, since I am having this bug with a
> > discrete amount of applications like:
> > […]
> 
> So?
> 
> Also make sure you are actually using an up to date version.
> 
> But it is fixed for me now, so I'm unsubscribing.

They are updated to lastest version
Comment 60 Martin Sandsmark 2013-01-23 05:24:21 UTC
okay, I manage to reproduce it again, unfortunately, I'll see if I can look into this again.
Comment 61 Martin Sandsmark 2013-01-23 05:29:34 UTC
some more comments; one way to reproduce it is to use Juk, and just click its systray icon a lot of times. It happens very intermittently, which makes me suspect we're somehow losing some events or something.

I checked with xprop that the flag is not set for the window.
Comment 62 Martin Sandsmark 2013-01-23 05:30:12 UTC
*** Bug 304305 has been marked as a duplicate of this bug. ***
Comment 63 Martin Sandsmark 2013-01-23 05:47:58 UTC
... and I can't reproduce at all when running tasks in plasmoidviewer, for some reason, makes it very hard to work on a fix.
Comment 64 ariasuni 2013-02-12 17:55:33 UTC
Appends with Firefox when it starts in background in KDE 4.10.
Comment 65 Germano Massullo 2013-02-18 09:53:11 UTC
I am having this trouble right now on Dolphin, KDE 4.9.5 + Fedora 18.
If I can do anything to retrieve useful infos, please let me know
Comment 66 ariasuni 2013-02-21 21:27:29 UTC
Appends today with Kate, KDE 4.10 on Arch Linux. Still don't know why…
Comment 67 Bazilio 2013-02-22 06:18:23 UTC
1.5 years and nothing.. unsubscribing.
Comment 68 ariasuni 2013-02-23 13:26:44 UTC
Ok I found how to reproduce this bug:
– clic on an application icon to launch it
– open Yakuake (or maybe other apps?) before the app is launched
– when the app appear, there are a big chance that she "demand attention" forever
Comment 69 Germano Massullo 2013-02-23 13:40:12 UTC
(In reply to comment #68)
> Ok I found how to reproduce this bug:
> – clic on an application icon to launch it
> – open Yakuake (or maybe other apps?) before the app is launched
> – when the app appear, there are a big chance that she "demand attention"
> forever

Interesting, I do use Yakuake every day (I have it on autostart)
Comment 70 ariasuni 2013-02-23 14:40:06 UTC
I have it on autostart too. If it's not clear, what I mean by "open Yakuake" is "give focus on Yakuake window".
Comment 71 Germano Massullo 2013-03-18 17:38:32 UTC
Confirming on KDE 4.10-1
Comment 72 solazs 2013-05-13 08:08:48 UTC
Comfirming on 4.10.2
Comment 73 ariasuni 2013-05-13 19:09:45 UTC
Confirming on 4.10.3. Maybe you can look at icon-tasks’ code because this plasmoid don’t have this bug.
Comment 74 Hrvoje Senjan 2013-05-25 17:13:15 UTC
*** Bug 320055 has been marked as a duplicate of this bug. ***
Comment 75 Hrvoje Senjan 2013-06-05 22:46:02 UTC
This is fixed with new QML taskmanager in 4.11 :-)
(I've been using Eike's clone for a few weeks, didn't experience the issue neither once)
Comment 76 Martin Sandsmark 2013-06-07 08:41:14 UTC
has it been merged?
Comment 77 Hrvoje Senjan 2013-06-07 23:33:57 UTC
(In reply to comment #76)
> has it been merged?
Yes :-)
Comment 78 bill p. (aka google01103) 2013-06-22 11:38:10 UTC
in 4.11b1 there is intermittent occurrences of this (openSUSE 12.3 x64), sometimes no apps call for attention and infrequently 1 or 2

clicking on the app's task manager tab and the flashing/highlighting stops, pre-4.11b1 the app need to be restarted to fix the demand for attention
Comment 79 Hrvoje Senjan 2013-06-29 11:17:00 UTC
*** Bug 321756 has been marked as a duplicate of this bug. ***
Comment 80 Martin Sandsmark 2013-07-03 11:50:43 UTC
Please explain what you mean.

No applications are able to show that they are able to demand attention, or are some applications demanding attention when they shouldn't? Which applications?
Comment 81 bill p. (aka google01103) 2013-07-03 12:01:08 UTC
(In reply to comment #80)
> Please explain what you mean.
> 
> No applications are able to show that they are able to demand attention, or
> are some applications demanding attention when they shouldn't? Which
> applications?

some apps demanding attention when they shouldn't, Konsole would be an example

this isn't every startup and sometimes different apps but always clicking on the app in the task manager turns off the highlight, previously I needed to restart the app to get rid of the highlighting
Comment 82 Martin Sandsmark 2013-07-03 12:12:22 UTC
adding Eike.
Comment 83 bill p. (aka google01103) 2013-07-03 13:47:17 UTC
fyi -just rebooted - gKrellm, Konsole and Konversation are calling for attention, clicking them in the task manager removes the highlighting
Comment 84 Martin Sandsmark 2013-07-04 08:51:45 UTC
btw, is this when they are launched, and appear behind other windows? if so, that's expected behaviour, AFAIK.
Comment 85 bill p. (aka google01103) 2013-07-04 09:50:11 UTC
(In reply to comment #84)
> btw, is this when they are launched, and appear behind other windows? if so,
> that's expected behaviour, AFAIK.

if true that would be unexpected expected behavior, why would a window call for attention just because it was behind an other window? when you have multiple apps run at startup there's always going to be apps below other apps (especially if they are set to open centered on the desktop). One of the apps calling (gKrellm) is never covered as it is forced to open on the side of the screen but has called for attention.

also the calls for attention are inconsistent - sometimes no apps call
Comment 86 Valerii Malov 2013-07-04 11:11:17 UTC
>if true that would be unexpected expected behavior

See http://docs.kde.org/stable/en/kde-workspace/kcontrol/windowbehaviour/index.html

>Windows that are prevented from stealing focus are marked as demanding attention, which by default means their taskbar entry will be highlighted. This can be changed in the Notifications control module.
Comment 87 Martin Sandsmark 2013-07-04 13:43:55 UTC
ok, please open a new bug if apps aren't set as demanding attention when they should.