Bug 274020 - 4.7: Windows opened on a different workspace keep the "demands attention" design
Summary: 4.7: Windows opened on a different workspace keep the "demands attention" design
Status: RESOLVED DUPLICATE of bug 275835
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-taskbar (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 130 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 283230 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-24 12:38 UTC by Christian (Fuchs)
Modified: 2012-03-01 16:37 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian (Fuchs) 2011-05-24 12:38:25 UTC
Version:           unspecified (using Devel) 
OS:                Linux

In 4.7 the windows keep the "demands attention" state when opened on a different workspace (e.g. via a shortcut and a workspace assigned via window rules), even after activating them. 

Reproducible: Always

Steps to Reproduce:
1) Add a window rule to open an application (e.g. firefox) on a given workspace
2) Switch to a different workspace
3) Open the application 
4) The window in the taskbar has the "demands attention" design  (flashes grey on Air theme) 
5) Activate this application (click on the taskbar entry) 

Actual Results:  
6) The application entry in the taskbar still has the demands attention design (grey)

This is a regression since 4.6

Expected Results:  
The application entry in the taskbar has the "active" design, as it was the case up to 4.6.3 

according to xprop, the demands attention flag is not set on the window. 

KDE is 4.7 from svn/git  (day after tag), Qt is 4.7, Theme is Air for netbooks
Comment 1 Christoph Feck 2011-10-03 23:01:20 UTC
*** Bug 283230 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2011-10-04 09:39:18 UTC
Victor, can you add the steps to reproduce with a single desktop/workspace setup?
Comment 3 Victor Varvaryuk 2011-10-04 13:52:10 UTC
You can find them in the Bug 283230:

Steps to Reproduce:
Launch an app, for example Krusader. While the application loads, start
clicking on some already opened window, until the Krusader loads. 

Actual Results:  
Because you where clicking on on another window, Krusader opened in the
background and demanded attention when it was ready - its entry in the taskbar
flashed 3 time. But if then switch to that window, the highlight doesn't go
away.

Expected Results:  
After you switch to the window that demanded attention - remove the highlight
on its entry in the taskbar.
Comment 4 Jean-Philippe Fleury 2011-10-08 20:53:09 UTC
bug 275835 may be related to the current one.
Comment 5 Jonas Nyrén 2011-10-17 09:59:15 UTC
Can confirm with 4.7.2
Comment 6 Peter Fors 2011-10-17 12:10:34 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 ttrzeciak.mail 2011-12-17 08:44:17 UTC
Still present in 4.7.4
Comment 8 torge 2011-12-27 19:24:46 UTC
On my KDE 4.7.4, I mostly have the "demands attention" bug when I launch Amarok, which might be due to the fact that it needs some time to load and I often start more programs during that time.

Maybe the current discussion about cursor movements in Bug 275469 is also relevant here.
Comment 9 Germano Massullo 2012-03-01 16:21:53 UTC
Hello, I am the bugreporter of an identical bugreport. Alexander Kiselyov told me about other bugreports identical as mine, so I create this post to link all of them so someone of the admins can merge them.

https://bugs.kde.org/show_bug.cgi?id=286948
https://bugs.kde.org/show_bug.cgi?id=275835
https://bugs.kde.org/show_bug.cgi?id=274020
Comment 10 Beat Wolf 2012-03-01 16:37:28 UTC

*** This bug has been marked as a duplicate of bug 275835 ***