Bug 320055 - Taskbar does not always properly clear alert state
Summary: Taskbar does not always properly clear alert state
Status: RESOLVED DUPLICATE of bug 275835
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-taskbar (show other bugs)
Version: 4.10.3
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-20 14:48 UTC by Ralf Jung
Modified: 2013-05-25 17:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Jung 2013-05-20 14:48:35 UTC
Since I upgraded to KDE 4.10, the taskbar does not always properly clear the alert state of windows anymore. Often I end up with windows that demanded attention at some point, but still appear highlighted even though I clicked them long ago. I have to close the windows to get rid of this highlighting.

Reproducible: Sometimes

Steps to Reproduce:
I cannot reproduce this.
Actual Results:  
Sometimes, when a window flashes in the taskbar, if I click it, it keeps the highlighted state. I noticed this with Kopete, Konsole, Firefox and Thunderbird windows.

Expected Results:  
The state should be cleared once I activate the window.

This did not happen with KDE 4.9.

Using xprop, I had a look at the _NET_WM_STATE of such windows: It is empty.
Comment 1 Hrvoje Senjan 2013-05-24 21:37:18 UTC
Ralf, i think i've seen it before 4.10 also (but can't be 100% sure). On a positive note, using current QML port of task manager, and i haven't yet encountered this bug - which i could usually reproduce with e.g. KMail or Konversation raising from tray (icon tasks never suffered from this, and they seem to share a large portion of the code)
Comment 2 Hrvoje Senjan 2013-05-25 17:13:15 UTC

*** This bug has been marked as a duplicate of bug 275835 ***