Bug 321756 - Window keeps highlighted forever in plasma task panel if it was launched in the background
Summary: Window keeps highlighted forever in plasma task panel if it was launched in t...
Status: RESOLVED DUPLICATE of bug 275835
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-taskbar (show other bugs)
Version: 4.10.4
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-29 11:09 UTC by Alicia Boya García (ntrrgc)
Modified: 2013-06-29 11:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Testcase application (199 bytes, text/x-python)
2013-06-29 11:09 UTC, Alicia Boya García (ntrrgc)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alicia Boya García (ntrrgc) 2013-06-29 11:09:07 UTC
When you open an application from the K menu, KDE shows an launch notification in the taskbar while it's opening. If while waiting for that application to finish starting up you switch focus to another window, KDE will open the new application in the background, without stealing the focus of the current active window, and it will make the new application blink in taskbar.
This would be fine if it wasn't the application keeps in highlighted state forever.

Reproducible: Always

Steps to Reproduce:
1. Download the testcase attached and give it execution permissions. You'll need PyQt4 in order to run it.
2. Create a new entry in K menu to launch the testcase application.
3. Launch the testcase from K menu.
4. While it's starting up, focus another application. You can do it several times.
5. After some seconds, the testcase will have been launched and it will be blinking in taskbar. Wait for it to stop blinking and click on it.
Actual Results:  
The application is focused, but it keeps highlighted like when it was blinking. It will keep highlighted until it raises an X11 URGENT hint or it is closed.

Expected Results:  
The application should be focused and the highlight should gone, with the application being shown in taskbar in no different way from other non-now-atention-requesting applications.

I've attached a short video demonstrating the bug.
Comment 1 Alicia Boya García (ntrrgc) 2013-06-29 11:09:35 UTC
Created attachment 80846 [details]
Testcase application
Comment 2 Alicia Boya García (ntrrgc) 2013-06-29 11:14:04 UTC
Here is the demonstration video, at least for some time before it gets removed. http://lasana.rufian.eu/DPRH/
Comment 3 Hrvoje Senjan 2013-06-29 11:17:00 UTC
Fixed in 4.11

*** This bug has been marked as a duplicate of bug 275835 ***