Bug 280659 - task bar entries sporadicly tend to stay highlighted after mouse hover
Summary: task bar entries sporadicly tend to stay highlighted after mouse hover
Status: RESOLVED DUPLICATE of bug 275835
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-taskbar (show other bugs)
Version: 4.7.0
Platform: Archlinux Packages Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-23 18:58 UTC by Bernhard Beschow
Modified: 2012-08-23 15:08 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Beschow 2011-08-23 18:58:51 UTC
Version:           unspecified (using KDE 4.7.0) 
OS:                Linux

There are two atifacts I'm experiencing:

1) Mouse hover sometimes causes sunken (current) task entry to stay highlighted, even when the mouse leaves the task entry.

2) In addition, a non-current task entry may stay highlighted when the mouse leaves that task entry. This results in two entries being highlighted, but none being sunken.

These visual atifacts don't happen when switching tasks using Alt-Tab. In fact, Alt-Tab can be used to resolve these visual artifacts until the mouse hoveres the task items again.

Reproducible: Sometimes

Steps to Reproduce:
Open a couple of different apps, like Firefox, Amarok, Akregator, Konsole, etc. and make them current using the mouse in random order.

Actual Results:  
Some of the task items have a tendency to stay highlighted.

Expected Results:  
The current task should be sunken.
Comment 1 Bernhard Beschow 2011-08-23 19:09:05 UTC
When Amarok or Akregator are recovered from the system tray, their task entries start to blink for a moment until they stay highlighted. That's ok so far. However, when I click on the task entries, I expect them to eventually return to a non-activated state.

I could just reliably trigger the bug when recovering them in arbitrary sequence.

Note that this bug also affects apps that don't have a system tray (like Firefox).
Comment 2 Christoph Feck 2011-08-25 14:37:13 UTC
Related to/duplicate of bug 278869.
Comment 3 Jean-Philippe Fleury 2011-10-08 21:17:09 UTC
I think comment 1 is not the same bug and may be related to a "Demands Attention" state problem described on bug 274020
Comment 4 jenna 2011-10-17 19:01:25 UTC
I am experiencing behavior described in the initial report: some task bar items highlite and stay highlited when they dont need to be.  it is triggered for some programs by hovering the mouse over their taskbar entry and other programs just do it automatically.

I dont know necessarily if i have experienced any "freezing" or "sticking" as described in the duplicate issue from comment #2.

the issue started happening when i updated to from kubuntu 11.04 to 11.10.  affected programs are ktorrent, dolphin, and chrome.  UNaffected programs are konsole, skype, and kate
Comment 5 Maxim Levitsky 2012-02-11 21:43:25 UTC
I have this issue as well. Its very annoying
Comment 6 Gregor Tätzner 2012-08-23 15:08:41 UTC

*** This bug has been marked as a duplicate of bug 275835 ***