Bug 304305 - Taskbar items randomly flash for attention
Summary: Taskbar items randomly flash for attention
Status: RESOLVED DUPLICATE of bug 275835
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-taskbar (show other bugs)
Version: 4.9.80 Beta1
Platform: unspecified Linux
: NOR normal with 6 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-31 00:10 UTC by markuss
Modified: 2013-01-23 05:30 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Juk window entry flashing for attention, even though the window has focus and no attention-demanding action occured. (27.42 KB, image/png)
2012-07-31 00:10 UTC, markuss
Details
app calling for attention though none required (17.64 KB, image/png)
2012-08-20 10:12 UTC, bill p. (aka google01103)
Details
Group in taskbar lit up for attention even though none of the individual windows need attention (34.09 KB, image/png)
2012-10-05 04:03 UTC, Marcus U
Details

Note You need to log in before you can comment on or make changes to this bug.
Description markuss 2012-07-31 00:10:11 UTC
Created attachment 72839 [details]
Juk window entry flashing for attention, even though the window has focus and no attention-demanding action occured.

Some Taskbar items randomly flash for attention – without needing it, obviously, and sometimes even when the window has focus anyway.
I have found no way to reproduce the bug all the time but Dolphin window entries and Juk seem most often affected. With Juk I can sometime reproduce it by closing and opening the main window via the tray icon.

IIRC the bug appeared in 4.8 and still is there in 4.9RC2.
Comment 1 bill p. (aka google01103) 2012-08-20 10:12:09 UTC
I can can confirm this, running KDE 4.9 under openSUSE x64
Comment 2 bill p. (aka google01103) 2012-08-20 10:12:53 UTC
Created attachment 73318 [details]
app calling for attention though none required
Comment 3 bill p. (aka google01103) 2012-09-14 17:10:13 UTC
lately this has been fine
Comment 4 Myriam Schweingruber 2012-09-17 17:44:21 UTC
(In reply to comment #3)
> lately this has been fine

Lately as in 4.9.1? Can this be closed, then?
Comment 5 bill p. (aka google01103) 2012-09-17 17:56:54 UTC
lately is 4.9.1, but I was not only reporter
Comment 6 markuss 2012-09-18 01:16:54 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > lately this has been fine
> 
> Lately as in 4.9.1? Can this be closed, then?

Possibly but I honestly did not look out for it. Give me a few days.
Comment 7 bill p. (aka google01103) 2012-09-18 09:33:53 UTC
spoke too soon, today Chromium will not stop until I close and restart it

if it matters, on my taskbar it highlights for attention not flashes

the issues is better then it was but I guess it still can be intermittent

On Mon, Sep 17, 2012 at 9:16 PM, Markus S. <kamikazow@web.de> wrote:

> https://bugs.kde.org/show_bug.cgi?id=304305
>
> --- Comment #6 from Markus S. <kamikazow@web.de> ---
> (In reply to comment #4)
> > (In reply to comment #3)
> > > lately this has been fine
> >
> > Lately as in 4.9.1? Can this be closed, then?
>
> Possibly but I honestly did not look out for it. Give me a few days.
>
> --
> You are receiving this mail because:
> You voted for the bug.
> You are on the CC list for the bug.
>
Comment 8 bill p. (aka google01103) 2012-09-19 08:26:30 UTC
today Dolphin is highlighted for attention, why? Closing and restarting it fixed it
Comment 9 markuss 2012-09-28 02:44:28 UTC
Yeah, the bug is no longer as serious but my Firefox window (in which I currently type) wants attention although it has focus.
As for Juk the bug was reduced to a degree that opening the window via a click on the tray icon results only in a single attention flash.
Comment 10 Valerii Malov 2012-10-02 18:08:17 UTC
Could be a dupe of bug #275835 ?
Comment 11 markuss 2012-10-03 11:48:31 UTC
(In reply to comment #10)
> Could be a dupe of bug #275835 ?

Maybe but in that bug it is claimed that the bug is fixed in 4.9.1. I use 4.9.1 and this bug is still present.
Comment 12 Marcus U 2012-10-05 03:58:16 UTC
Happened to me with Okular today, I believe this is the same bug. I opened three documents in rapid succession, and they all flashed for attention as they opened up. Even after clicking each of them such that the individual tasks didn't flash for attention, the taskbar item for the group was lit up.

Using KDE 4.9.2 from Fedora 17 repos (64-bit).
Comment 13 Marcus U 2012-10-05 04:03:39 UTC
Created attachment 74347 [details]
Group in taskbar lit up for attention even though none of the individual windows need attention
Comment 14 Marcus U 2012-10-09 02:20:59 UTC
The key to reproducing this bug appears to be launching applications (or several instances of applications) almost at the same time. I've been able to reproduce the bug fairly reliably by doing the following:

1) Launch an application
2) Launch another application (or instance of another app) very fast, such as by opening a document or quickly using KRunner
3) When the task bar icon for the first application starts flashing, click the icon for the second application 

Now, even after the second application has loaded, the task bar icon for the first application should remain lit up (not flashing) and it won't go away even after clicking it/focusing it.

The trick seems to be to not let the first application become active/focused, but I'm not 100% sure of this. I've had some (but limited) success reproducing the bug by having an application already open, then launching another and switching back (focusing) to the first app as soon as the main window of the new app opens up and receives focus.
Comment 15 markuss 2012-10-26 13:52:03 UTC
(In reply to comment #14)

> The trick seems to be to not let the first application become
> active/focused, but I'm not 100% sure of this.
I can confirm this. The cause are applications opening in the background. Easier to reproduce with larger apps that take longer to load.
Comment 16 bill p. (aka google01103) 2012-11-27 11:29:56 UTC
Just to note running 4.9.80 (4.10 beta1) and still experiencing the issue
Comment 17 jnk 2013-01-08 20:39:42 UTC
Same thing here with the Ubuntu's 4.9.3.
I can always reproduce this bug with psi-plus chat windows and have seen it just once with Kmail.
"xprop | grep _NET_WM_STATE_DEMANDS_ATTENTION" does not print anything for the problematic windows.
Comment 18 Martin Sandsmark 2013-01-23 05:30:11 UTC

*** This bug has been marked as a duplicate of bug 275835 ***