Bug 265599 - crash when zooming to certain level
Summary: crash when zooming to certain level
Status: RESOLVED FIXED
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: HI crash (vote)
Target Milestone: 1.1.0
Assignee: marble-bugs
URL:
Keywords:
: 257894 266406 267097 269003 269007 269181 270499 270646 271631 272082 273747 274166 274915 275177 278787 280307 291432 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-06 13:43 UTC by Nelson Chan
Modified: 2012-01-13 13:20 UTC (History)
30 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.0.4


Attachments
New crash information added by DrKonqi (12.93 KB, text/plain)
2011-03-28 21:22 UTC, Bas v.d. Wiel
Details
New crash information added by DrKonqi (11.76 KB, text/plain)
2011-04-19 12:10 UTC, Arthur
Details
New crash information added by DrKonqi (15.22 KB, text/plain)
2011-10-29 12:29 UTC, Beco
Details
New crash information added by DrKonqi (16.08 KB, text/plain)
2011-11-13 09:37 UTC, xylotism
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nelson Chan 2011-02-06 13:43:56 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

Marble crashes when I keep zooming upon certain level (like across 700km altitude, or press zoom button for 14 times)
100% reproducible with empty config & cache with unmaximized window(fullscreen not tested) 
but haven't see it crash with maximized window yet, and sometimes unable to reproduce with unmaximized window again after switching to maximized,  but clearing config & cache it is reproducible again.

Reproducible: Always

Steps to Reproduce:
1. Run marble  (with empty config & cache?  window will be un-maximized by default)
2. Keep pressing zoom button (exactly 14 times for me) 


Actual Results:  
crash

Expected Results:  
zoom in as i click the button

A trace captured by KDE bug reporter tool
*without debugging symbols*

#
Application: Marble Virtual Globe (marble), signal: Segmentation fault
#
[Current thread is 1 (Thread 0x7f8ee6c86760 (LWP 14421))]
#
 
#
Thread 6 (Thread 0x7f8ed448e700 (LWP 14422)):
#
#0  0xffffffffff60017b in ?? ()
#
#1  0x00007f8ed448dae0 in ?? ()
#
#2  0x00007fff331ff6e2 in ?? ()
#
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
#
 
#
Thread 5 (Thread 0x7f8ecbfff700 (LWP 14423)):
#
#0  0xffffffffff60017b in ?? ()
#
#1  0x00007f8ecbffeae0 in ?? ()
#
#2  0x00007fff331ff6e2 in ?? ()
#
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
#
 
#
Thread 4 (Thread 0x7f8ecb7fe700 (LWP 14424)):
#
#0  0x00007f8ee376b113 in poll () from /lib/libc.so.6
#
#1  0x00007f8ede222ed4 in ?? () from /usr/lib/libglib-2.0.so.0
#
#2  0x00007f8ede22340d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#
#3  0x00007f8ee4e3cf66 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#
#4  0x00007f8ee4e11232 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#
#5  0x00007f8ee4e1147c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#
#6  0x00007f8ee4d26d54 in QThread::exec() () from /usr/lib/libQtCore.so.4
#
#7  0x00007f8ee4df2e18 in ?? () from /usr/lib/libQtCore.so.4
#
#8  0x00007f8ee4d2952e in ?? () from /usr/lib/libQtCore.so.4
#
#9  0x00007f8ee2ab0cb0 in start_thread () from /lib/libpthread.so.0
#
#10 0x00007f8ee377344d in clone () from /lib/libc.so.6
#
#11 0x0000000000000000 in ?? ()
#
 
#
Thread 3 (Thread 0x7f8ec97fa700 (LWP 14431)):
#
#0  0x00007f8ee2ab3154 in pthread_mutex_lock () from /lib/libpthread.so.0
#
#1  0x00007f8ede221ebd in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#
#2  0x00007f8ede222d69 in ?? () from /usr/lib/libglib-2.0.so.0
#
#3  0x00007f8ede22340d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#
#4  0x00007f8ee4e3cf66 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#
#5  0x00007f8ee4e11232 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#
#6  0x00007f8ee4e1147c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#
#7  0x00007f8ee4d26d54 in QThread::exec() () from /usr/lib/libQtCore.so.4
#
#8  0x00007f8ee62de8f8 in ?? () from /usr/lib/libmarblewidget.so.11
#
#9  0x00007f8ee4d2952e in ?? () from /usr/lib/libQtCore.so.4
#
#10 0x00007f8ee2ab0cb0 in start_thread () from /lib/libpthread.so.0
#
#11 0x00007f8ee377344d in clone () from /lib/libc.so.6
#
#12 0x0000000000000000 in ?? ()
#
 
#
Thread 2 (Thread 0x7f8ecaffd700 (LWP 14443)):
#
#0  0x00007f8ee2ab578b in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#
#1  0x00007f8ee4d29b82 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#
#2  0x00007f8ee4d1fc18 in ?? () from /usr/lib/libQtCore.so.4
#
#3  0x00007f8ee4d2952e in ?? () from /usr/lib/libQtCore.so.4
#
#4  0x00007f8ee2ab0cb0 in start_thread () from /lib/libpthread.so.0
#
#5  0x00007f8ee377344d in clone () from /lib/libc.so.6
#
#6  0x0000000000000000 in ?? ()
#
 
#
Thread 1 (Thread 0x7f8ee6c86760 (LWP 14421)):
#
[KCrash Handler]
#
#6  0x00007f8ee62d3df3 in ?? () from /usr/lib/libmarblewidget.so.11
#
#7  0x00007f8ee62d4ebd in ?? () from /usr/lib/libmarblewidget.so.11
#
#8  0x00007f8ee62d5172 in ?? () from /usr/lib/libmarblewidget.so.11
#
#9  0x00007f8ee624fa84 in ?? () from /usr/lib/libmarblewidget.so.11
#
#10 0x00007f8ee62423a9 in Marble::MarbleWidget::paintEvent(QPaintEvent*) () from /usr/lib/libmarblewidget.so.11
#
#11 0x00007f8ee422d92a in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#
#12 0x00007f8ee41dc2b4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#
#13 0x00007f8ee41e0dca in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#
#14 0x00007f8ee58555a6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#
#15 0x00007f8ee4e11e9c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#
#16 0x00007f8ee422a7f8 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib/libQtGui.so.4
#
#17 0x00007f8ee43ed590 in ?? () from /usr/lib/libQtGui.so.4
#
#18 0x00007f8ee4220b20 in QWidgetPrivate::syncBackingStore() () from /usr/lib/libQtGui.so.4
#
#19 0x00007f8ee422de32 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#
#20 0x00007f8ee45f164b in QMainWindow::event(QEvent*) () from /usr/lib/libQtGui.so.4
#
#21 0x00007f8ee5954133 in KXmlGuiWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#
#22 0x00007f8ee41dc2b4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#
#23 0x00007f8ee41e0dca in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#
#24 0x00007f8ee58555a6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#
#25 0x00007f8ee4e11e9c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#
#26 0x00007f8ee43ea309 in ?? () from /usr/lib/libQtGui.so.4
#
#27 0x00007f8ee4220388 in QWidget::repaint(QRect const&) () from /usr/lib/libQtGui.so.4
#
#28 0x00007f8ee4220443 in QWidget::repaint() () from /usr/lib/libQtGui.so.4
#
#29 0x00007f8ee6244f7b in Marble::MarbleWidget::zoomView(int, Marble::FlyToMode) () from /usr/lib/libmarblewidget.so.11
#
#30 0x00007f8ee6246a53 in Marble::MarbleWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libmarblewidget.so.11
#
#31 0x00007f8ee4e2731f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#
#32 0x00007f8ee6253d5c in Marble::NavigationWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libmarblewidget.so.11
#
#33 0x00007f8ee4e2731f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#
#34 0x00007f8ee484c942 in QAbstractButton::clicked(bool) () from /usr/lib/libQtGui.so.4
#
#35 0x00007f8ee4594d9b in ?? () from /usr/lib/libQtGui.so.4
#
#36 0x00007f8ee459636b in ?? () from /usr/lib/libQtGui.so.4
#
#37 0x00007f8ee45965dc in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#
#38 0x00007f8ee4652d7a in QToolButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#
#39 0x00007f8ee422d978 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#
#40 0x00007f8ee41dc2b4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#
#41 0x00007f8ee41e164a in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#
#42 0x00007f8ee58555a6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#
#43 0x00007f8ee4e11e9c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#
#44 0x00007f8ee41dd2b5 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#
#45 0x00007f8ee425b908 in ?? () from /usr/lib/libQtGui.so.4
#
#46 0x00007f8ee4259fc9 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#
#47 0x00007f8ee4281502 in ?? () from /usr/lib/libQtGui.so.4
#
#48 0x00007f8ede222992 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#
#49 0x00007f8ede223170 in ?? () from /usr/lib/libglib-2.0.so.0
#
#50 0x00007f8ede22340d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#
#51 0x00007f8ee4e3cf0f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#
#52 0x00007f8ee42811ae in ?? () from /usr/lib/libQtGui.so.4
#
#53 0x00007f8ee4e11232 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#
#54 0x00007f8ee4e1147c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#
#55 0x00007f8ee4e1597b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#
#56 0x0000000000420205 in _start ()
Comment 1 Dennis Nienhüser 2011-02-27 10:36:12 UTC
*** Bug 266406 has been marked as a duplicate of this bug. ***
Comment 2 Dennis Nienhüser 2011-02-27 10:40:11 UTC
*** Bug 257894 has been marked as a duplicate of this bug. ***
Comment 3 Dennis Nienhüser 2011-02-27 10:43:07 UTC
See bug 257894 for a backtrace with full debug info.

When the size of the window is small, the dynamic appearing of the progress bar changes the size of the marble widget. This change is not correctly recognized by Marble, leading to invalid pixels being accessed later.
Comment 4 Dennis Nienhüser 2011-02-27 10:45:07 UTC
*** Bug 267097 has been marked as a duplicate of this bug. ***
Comment 5 Dennis Nienhüser 2011-03-21 04:33:42 UTC
*** Bug 269003 has been marked as a duplicate of this bug. ***
Comment 6 Dennis Nienhüser 2011-03-23 20:30:02 UTC
*** Bug 269181 has been marked as a duplicate of this bug. ***
Comment 7 Bas v.d. Wiel 2011-03-28 21:22:28 UTC
Created attachment 58409 [details]
New crash information added by DrKonqi

marble (1.0.0 (Stable Release)) on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

Using the touchpad scroll function to zoom in on the globe.

-- Backtrace (Reduced):
#6  0x00007ff90c79041d in Marble::AbstractScanlineTextureMapper::pixelValue (this=0x7ff8e0028d20, lon=<value optimized out>, lat=<value optimized out>, scanLine=0x7ff8f8118010) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#7  0x00007ff90c79209d in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x7ff8e0028d20, viewParams=0x886be8, texColorizer=0xb10c30) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#8  0x00007ff90c7922c2 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x7ff8e0028d20, painter=0x7fff77763410, viewParams=0x886be8, dirtyRect=..., texColorizer=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#9  0x00007ff90c70ce04 in Marble::MarbleMapPrivate::paintGround (this=0x886bd0, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:188
#10 0x00007ff90c6ff749 in Marble::MarbleWidget::paintEvent (this=0x88a470, evt=0x7fff77763cf0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:805
Comment 8 Dennis Nienhüser 2011-04-09 22:18:41 UTC
*** Bug 270499 has been marked as a duplicate of this bug. ***
Comment 9 Dennis Nienhüser 2011-04-11 19:45:39 UTC
*** Bug 270646 has been marked as a duplicate of this bug. ***
Comment 10 Dennis Nienhüser 2011-04-11 21:51:08 UTC
This bug gets triggered quite often now. It would be great to have it fixed for 1.1.0 and backported to 1.0. Bernhard, did you make any progress here?
Comment 11 Dennis Nienhüser 2011-04-11 21:55:32 UTC
*** Bug 269007 has been marked as a duplicate of this bug. ***
Comment 12 Dennis Nienhüser 2011-04-11 21:57:11 UTC
*** Bug 240641 has been marked as a duplicate of this bug. ***
Comment 13 Dennis Nienhüser 2011-04-11 22:05:25 UTC
Adding CC lists of the duplicate bugs. Sorry for the bugspam.
Comment 14 Bernhard Beschow 2011-04-14 23:40:21 UTC
Git commit aa598a3a80233718711699562437e77b4cbee875 by Bernhard Beschow.
Committed on 14/04/2011 at 22:34.
Pushed by beschow into branch 'marble-1.1'.

ViewParams: use QSharedPointer to hold the canvas and coast images

* fixes a crash when the appearance of the download progress bar causes a resize of the map during painting

BUG: 265599
RevBy: Dennis Nienhüser

M  +1    -1    src/lib/EquirectScanlineTextureMapper.cpp     
M  +1    -1    src/lib/MercatorScanlineTextureMapper.cpp     
M  +1    -1    src/lib/PlacemarkLayout.cpp     
M  +1    -1    src/lib/SphericalScanlineTextureMapper.cpp     
M  +3    -2    src/lib/TextureColorizer.cpp     
M  +2    -2    src/lib/TileScalingTextureMapper.cpp     
M  +6    -6    src/lib/VectorComposer.cpp     
M  +18   -12   src/lib/ViewParams.cpp     
M  +3    -0    src/lib/ViewParams.h     

http://commits.kde.org/marble/aa598a3a80233718711699562437e77b4cbee875
Comment 15 Arthur 2011-04-19 12:10:52 UTC
Created attachment 59128 [details]
New crash information added by DrKonqi

marble (1.0.2 (Stable Release)) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

Crashes after double-clicking to zoom for 7 times.

-- Backtrace (Reduced):
#6  0x00007f371765a4c3 in Marble::AbstractScanlineTextureMapper::pixelValueF (this=0x2c4a4e0, lon=<value optimized out>, lat=<value optimized out>, scanLine=0x7f37000e2010) at ../../../../marble/src/lib/AbstractScanlineTextureMapper.cpp:130
#7  0x00007f371765b507 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x2c4a4e0, viewParams=0x2927e48, texColorizer=0x2c9d400) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:233
#8  0x00007f371765b782 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x2c4a4e0, painter=0x7fff88e83070, viewParams=0x2927e48, dirtyRect=..., texColorizer=<value optimized out>) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#9  0x00007f37175d7d98 in Marble::MarbleMapPrivate::paintGround (this=0x2927e30, painter=..., dirtyRect=...) at ../../../../marble/src/lib/MarbleMap.cpp:188
#10 0x00007f37175cab30 in Marble::MarbleWidget::paintEvent (this=0x28c5d00, evt=0x7fff88e83920) at ../../../../marble/src/lib/MarbleWidget.cpp:805
Comment 16 Dennis Nienhüser 2011-04-24 22:16:38 UTC
*** Bug 271631 has been marked as a duplicate of this bug. ***
Comment 17 Dennis Nienhüser 2011-05-01 22:26:10 UTC
*** Bug 272082 has been marked as a duplicate of this bug. ***
Comment 18 Dennis Nienhüser 2011-05-01 22:37:40 UTC
Git commit c5bf79a4f508a73b2bef83943af93ca09db123e1 by Dennis Nienhüser.
Committed on 01/05/2011 at 22:43.
Pushed by nienhueser into branch 'master'.

ViewParams: use QSharedPointer to hold the canvas and coast images

* fixes a crash when the appearance of the download progress bar causes a resize of the map during painting

BUG: 265599
RevBy: Dennis Nienhüser
(cherry picked from commit aa598a3a80233718711699562437e77b4cbee875)

M  +1    -1    src/lib/EquirectScanlineTextureMapper.cpp     
M  +1    -1    src/lib/MercatorScanlineTextureMapper.cpp     
M  +1    -1    src/lib/PlacemarkLayout.cpp     
M  +1    -1    src/lib/SphericalScanlineTextureMapper.cpp     
M  +3    -2    src/lib/TextureColorizer.cpp     
M  +2    -2    src/lib/TileScalingTextureMapper.cpp     
M  +7    -6    src/lib/VectorComposer.cpp     
M  +18   -12   src/lib/ViewParams.cpp     
M  +3    -0    src/lib/ViewParams.h     

http://commits.kde.org/marble/c5bf79a4f508a73b2bef83943af93ca09db123e1
Comment 19 Dennis Nienhüser 2011-05-01 22:43:06 UTC
Git commit 3a6a1e280532b79299b8b8a3bc17ed87faeaa834 by Dennis Nienhüser, on behalf of Bernhard Beschow.
Committed on 14/04/2011 at 22:34.
Pushed by nienhueser into branch 'kde-4.6'.

ViewParams: use QSharedPointer to hold the canvas and coast images

* fixes a crash when the appearance of the download progress bar causes a resize of the map during painting

CCBUG: 265599
RevBy: Dennis Nienhüser
FIXED-IN: 1.0.4
(cherry picked from commit aa598a3a80233718711699562437e77b4cbee875)

M  +1    -1    src/lib/EquirectScanlineTextureMapper.cpp     
M  +1    -1    src/lib/MercatorScanlineTextureMapper.cpp     
M  +1    -1    src/lib/PlacemarkLayout.cpp     
M  +1    -1    src/lib/SphericalScanlineTextureMapper.cpp     
M  +3    -2    src/lib/TextureColorizer.cpp     
M  +2    -2    src/lib/TileScalingTextureMapper.cpp     
M  +6    -6    src/lib/VectorComposer.cpp     
M  +18   -12   src/lib/ViewParams.cpp     
M  +3    -0    src/lib/ViewParams.h     

http://commits.kde.org/marble/3a6a1e280532b79299b8b8a3bc17ed87faeaa834
Comment 20 Taco 2011-05-20 19:42:06 UTC
If this is fixed why did it still crash at me
Comment 21 Dennis Nienhüser 2011-05-20 22:13:59 UTC
(In reply to comment #20)
> If this is fixed why did it still crash at me

Which Marble version are you running?
Comment 22 Taco 2011-05-21 09:35:32 UTC
marble version is 1.0.0 , running opensuse 11.4 x64
Comment 23 Dennis Nienhüser 2011-05-21 14:01:34 UTC
*** Bug 273747 has been marked as a duplicate of this bug. ***
Comment 24 Dennis Nienhüser 2011-05-21 14:02:37 UTC
@Taco: It's fixed in Marble 1.0.4 and Marble 1.1.0 and later, but not yet in Marble 1.0.0.
Comment 25 Dennis Nienhüser 2011-05-26 19:37:18 UTC
*** Bug 274166 has been marked as a duplicate of this bug. ***
Comment 26 Dennis Nienhüser 2011-06-07 23:30:53 UTC
*** Bug 274915 has been marked as a duplicate of this bug. ***
Comment 27 Dennis Nienhüser 2011-06-08 15:17:15 UTC
*** Bug 275177 has been marked as a duplicate of this bug. ***
Comment 28 Dennis Nienhüser 2011-08-02 19:17:15 UTC
*** Bug 278787 has been marked as a duplicate of this bug. ***
Comment 29 Bernhard Beschow 2011-08-19 20:16:10 UTC
*** Bug 280307 has been marked as a duplicate of this bug. ***
Comment 30 Beco 2011-10-29 12:29:05 UTC
Created attachment 65010 [details]
New crash information added by DrKonqi

marble (1.0.0 (Stable Release)) on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

- What I was doing when the application crashed:

Brand new instalation. Open marble to test, while browsing web with firefox for other little stuff. Zoom in Sao Paulo, Brazil, and crash.

-- Backtrace (Reduced):
#6  0x00007f1592bd841d in Marble::AbstractScanlineTextureMapper::pixelValue (this=0x7f157c0395e0, lon=<value optimized out>, lat=<value optimized out>, scanLine=0x7f158004b010) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#7  0x00007f1592bda09d in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x7f157c0395e0, viewParams=0x8bebb8, texColorizer=0xaf2dc0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#8  0x00007f1592bda2c2 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x7f157c0395e0, painter=0x7fff34ae78c0, viewParams=0x8bebb8, dirtyRect=..., texColorizer=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#9  0x00007f1592b54e04 in Marble::MarbleMapPrivate::paintGround (this=0x8beba0, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:188
#10 0x00007f1592b47749 in Marble::MarbleWidget::paintEvent (this=0x855c10, evt=0x7fff34ae81a0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:805
Comment 31 xylotism 2011-11-13 09:37:25 UTC
Created attachment 65580 [details]
New crash information added by DrKonqi

marble (1.0.0 (Stable Release)) on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

- What I was doing when the application crashed:
Zooming using mouse wheel on Los Angeles.

-- Backtrace (Reduced):
#6  0x00007fe6df56d41d in Marble::AbstractScanlineTextureMapper::pixelValue (this=0xb44510, lon=<value optimized out>, lat=<value optimized out>, scanLine=0x7fe6c404e010) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#7  0x00007fe6df56f09d in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xb44510, viewParams=0x9940a8, texColorizer=0xb5e6c0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#8  0x00007fe6df56f2c2 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xb44510, painter=0x7fff21d99b50, viewParams=0x9940a8, dirtyRect=..., texColorizer=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#9  0x00007fe6df4e9e04 in Marble::MarbleMapPrivate::paintGround (this=0x994090, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:188
#10 0x00007fe6df4dc749 in Marble::MarbleWidget::paintEvent (this=0x96fc70, evt=0x7fff21d9a430) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:805
Comment 32 Dennis Nienhüser 2012-01-13 13:20:53 UTC
*** Bug 291432 has been marked as a duplicate of this bug. ***