Bug 273747 - Marble Crash during zoom
Summary: Marble Crash during zoom
Status: RESOLVED DUPLICATE of bug 265599
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 1.1.0
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-20 19:34 UTC by Taco
Modified: 2011-05-21 14:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Taco 2011-05-20 19:34:36 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.5-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was zooming in to the Netherlands and it poofed, tried to do it again and crash again, so its everytime reproducable

The crash can be reproduced every time.

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4434362760 (LWP 12538))]

Thread 5 (Thread 0x7f4422126700 (LWP 12539)):
#0  0x00007f44301ea0ae in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f442b4d9876 in g_main_context_check () from /lib64/libglib-2.0.so.0
#2  0x00007f442b4da132 in ?? () from /lib64/libglib-2.0.so.0
#3  0x00007f442b4da650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007f4432591976 in QEventDispatcherGlib::processEvents (this=0x7f40d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f4432566052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f4432566265 in QEventLoop::exec (this=0x7f4422125de0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f443247b1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f4432547968 in QInotifyFileSystemWatcherEngine::run (this=0x7de650) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f443247da5e in QThreadPrivate::start (arg=0x7de650) at thread/qthread_unix.cpp:285
#10 0x00007f44301e7a3f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f4430ea567d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f441a340700 (LWP 12540)):
#0  0x00007f4430e9c503 in poll () from /lib64/libc.so.6
#1  0x00007f442b4da114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007f442b4da650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f4432591976 in QEventDispatcherGlib::processEvents (this=0xa7d5f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f4432566052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4432566265 in QEventLoop::exec (this=0x7f441a33fde0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f443247b1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f4432547968 in QInotifyFileSystemWatcherEngine::run (this=0xa786c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f443247da5e in QThreadPrivate::start (arg=0xa786c0) at thread/qthread_unix.cpp:285
#9  0x00007f44301e7a3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f4430ea567d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f4419b3f700 (LWP 12541)):
#0  0x00007f44301ea0a4 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f442b4d90b6 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#2  0x00007f442b4d9fa9 in ?? () from /lib64/libglib-2.0.so.0
#3  0x00007f442b4da650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007f4432591976 in QEventDispatcherGlib::processEvents (this=0xa80ff0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f4432566052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f4432566265 in QEventLoop::exec (this=0x7f4419b3ede0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f443247b1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f4432547968 in QInotifyFileSystemWatcherEngine::run (this=0xa97370) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f443247da5e in QThreadPrivate::start (arg=0xa97370) at thread/qthread_unix.cpp:285
#10 0x00007f44301e7a3f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f4430ea567d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f441733a700 (LWP 12548)):
#0  0x00007f4432463220 in pthread_getspecific@plt () from /usr/lib64/libQtCore.so.4
#1  0x00007f443247db21 in QThreadData::current () at thread/qthread_unix.cpp:163
#2  0x00007f44325913e9 in postEventSourcePrepare (s=0xbf3780, timeout=0x0) at kernel/qeventdispatcher_glib.cpp:254
#3  0x00007f442b4d984c in g_main_context_check () from /lib64/libglib-2.0.so.0
#4  0x00007f442b4da132 in ?? () from /lib64/libglib-2.0.so.0
#5  0x00007f442b4da650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#6  0x00007f4432591976 in QEventDispatcherGlib::processEvents (this=0xb53440, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#7  0x00007f4432566052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f4432566265 in QEventLoop::exec (this=0x7f4417339dd0, flags=...) at kernel/qeventloop.cpp:201
#9  0x00007f443247b1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#10 0x00007f44339aca48 in Marble::FileStorageWatcher::run (this=0x7cad50) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/FileStorageWatcher.cpp:401
#11 0x00007f443247da5e in QThreadPrivate::start (arg=0x7cad50) at thread/qthread_unix.cpp:285
#12 0x00007f44301e7a3f in start_thread () from /lib64/libpthread.so.0
#13 0x00007f4430ea567d in clone () from /lib64/libc.so.6
#14 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4434362760 (LWP 12538)):
[KCrash Handler]
#6  0x00007f44339a1f43 in Marble::AbstractScanlineTextureMapper::pixelValueF (this=0xab5240, lon=<value optimized out>, lat=<value optimized out>, scanLine=0x7f441629a010) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:130
#7  0x00007f44339a300d in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xab5240, viewParams=0x7ca938, texColorizer=0xb08c50) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:233
#8  0x00007f44339a32c2 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xab5240, painter=0x7fffa67cd7d0, viewParams=0x7ca938, dirtyRect=..., texColorizer=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#9  0x00007f443391de04 in Marble::MarbleMapPrivate::paintGround (this=0x7ca920, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:188
#10 0x00007f4433910749 in Marble::MarbleWidget::paintEvent (this=0x82ae70, evt=0x7fffa67ce0b0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:805
#11 0x00007f44319844ea in QWidget::event (this=0x82ae70, event=0x7fffa67ce0b0) at kernel/qwidget.cpp:8346
#12 0x00007f4431932d14 in QApplicationPrivate::notify_helper (this=0x6b8950, receiver=0x82ae70, e=0x7fffa67ce0b0) at kernel/qapplication.cpp:4445
#13 0x00007f443193b22a in QApplication::notify (this=<value optimized out>, receiver=0x82ae70, e=0x7fffa67ce0b0) at kernel/qapplication.cpp:4324
#14 0x00007f4432ec79e6 in KApplication::notify (this=0x7fffa67d09e0, receiver=0x82ae70, event=0x7fffa67ce0b0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#15 0x00007f4432566bfc in QCoreApplication::notifyInternal (this=0x7fffa67d09e0, receiver=0x82ae70, event=0x7fffa67ce0b0) at kernel/qcoreapplication.cpp:732
#16 0x00007f44319813b2 in sendSpontaneousEvent (this=0x7d22d0, pdev=0xa91ba8, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8d7dd0) at ../../src/corelib/kernel/qcoreapplication.h:218
#17 QWidgetPrivate::drawWidget (this=0x7d22d0, pdev=0xa91ba8, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8d7dd0) at kernel/qwidget.cpp:5433
#18 0x00007f4431b44138 in QWidgetBackingStore::sync (this=0x8d7dd0) at painting/qbackingstore.cpp:1325
#19 0x00007f4431977170 in QWidgetPrivate::syncBackingStore (this=0x77b650) at kernel/qwidget.cpp:1816
#20 0x00007f44319849f2 in QWidget::event (this=0x77b510, event=0x7fffa67cf050) at kernel/qwidget.cpp:8493
#21 0x00007f4431d4247b in QMainWindow::event (this=0x77b510, event=0x7fffa67cf050) at widgets/qmainwindow.cpp:1478
#22 0x00007f4432f70793 in KXmlGuiWindow::event (this=0x77b510, ev=0x7fffa67cf050) at /usr/src/debug/kdelibs-4.6.0/kdeui/xmlgui/kxmlguiwindow.cpp:126
#23 0x00007f4431932d14 in QApplicationPrivate::notify_helper (this=0x6b8950, receiver=0x77b510, e=0x7fffa67cf050) at kernel/qapplication.cpp:4445
#24 0x00007f443193b22a in QApplication::notify (this=<value optimized out>, receiver=0x77b510, e=0x7fffa67cf050) at kernel/qapplication.cpp:4324
#25 0x00007f4432ec79e6 in KApplication::notify (this=0x7fffa67d09e0, receiver=0x77b510, event=0x7fffa67cf050) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#26 0x00007f4432566bfc in QCoreApplication::notifyInternal (this=0x7fffa67d09e0, receiver=0x77b510, event=0x7fffa67cf050) at kernel/qcoreapplication.cpp:732
#27 0x00007f4431b40cb9 in sendEvent (this=0x8d7dd0, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#28 sendUpdateRequest (this=0x8d7dd0, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=<value optimized out>) at painting/qbackingstore.cpp:507
#29 QWidgetBackingStore::markDirty (this=0x8d7dd0, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=<value optimized out>) at painting/qbackingstore.cpp:695
#30 0x00007f44319769d8 in QWidget::repaint (this=0x82ae70, rect=...) at kernel/qwidget.cpp:10250
#31 0x00007f4431976a93 in QWidget::repaint (this=<value optimized out>) at kernel/qwidget.cpp:10206
#32 0x00007f4433912898 in repaint (this=<value optimized out>, newLookAt=<value optimized out>, mode=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:272
#33 Marble::MarbleWidget::flyTo (this=<value optimized out>, newLookAt=<value optimized out>, mode=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:1316
#34 0x00007f443393617c in Marble::MarbleWidgetDefaultInputHandler::Private::ZoomAt (this=<value optimized out>, marbleWidget=0x82ae70, pos=<value optimized out>, newDistance=575.76286887758329) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidgetInputHandler.cpp:271
#35 0x00007f443393771e in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0x96e820, o=<value optimized out>, e=0x7fffa67cfb40) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidgetInputHandler.cpp:738
#36 0x00007f4432566d87 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x82ae70, event=0x7fffa67cfb40) at kernel/qcoreapplication.cpp:847
#37 0x00007f4431932ce1 in QApplicationPrivate::notify_helper (this=0x6b8950, receiver=0x82ae70, e=0x7fffa67cfb40) at kernel/qapplication.cpp:4441
#38 0x00007f443193b656 in QApplication::notify (this=<value optimized out>, receiver=0x82ae70, e=0x7fffa67cfb40) at kernel/qapplication.cpp:4061
#39 0x00007f4432ec79e6 in KApplication::notify (this=0x7fffa67d09e0, receiver=0x82ae70, event=0x7fffa67cfb40) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#40 0x00007f4432566bfc in QCoreApplication::notifyInternal (this=0x7fffa67d09e0, receiver=0x82ae70, event=0x7fffa67cfb40) at kernel/qcoreapplication.cpp:732
#41 0x00007f44319a0225 in sendSpontaneousEvent (this=<value optimized out>, global_x=<value optimized out>, global_y=<value optimized out>, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at ../../src/corelib/kernel/qcoreapplication.h:218
#42 QETWidget::translateWheelEvent (this=<value optimized out>, global_x=<value optimized out>, global_y=<value optimized out>, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at kernel/qapplication_x11.cpp:4476
#43 0x00007f44319b1acd in QETWidget::translateMouseEvent (this=0x77d510, event=0x7fffa67d0610) at kernel/qapplication_x11.cpp:4253
#44 0x00007f44319b04c9 in QApplication::x11ProcessEvent (this=0x7fffa67d09e0, event=0x7fffa67d0610) at kernel/qapplication_x11.cpp:3564
#45 0x00007f44319d80f2 in x11EventSourceDispatch (s=0x6b3d60, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#46 0x00007f442b4d9bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#47 0x00007f442b4da3b0 in ?? () from /lib64/libglib-2.0.so.0
#48 0x00007f442b4da650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#49 0x00007f443259191f in QEventDispatcherGlib::processEvents (this=0x69cc30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#50 0x00007f44319d7d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x00007f4432566052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#52 0x00007f4432566265 in QEventLoop::exec (this=0x7fffa67d0930, flags=...) at kernel/qeventloop.cpp:201
#53 0x00007f443256a6ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#54 0x0000000000421725 in main (argc=1, argv=0x7fffa67d1fe8) at /usr/src/debug/kdeedu-4.6.0/marble/src/kdemain.cpp:351

Possible duplicates by query: bug 273273, bug 272083, bug 272082, bug 271631, bug 269181.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-05-21 14:01:34 UTC

*** This bug has been marked as a duplicate of bug 265599 ***