Bug 278787 - Plasma crashed when selecting "Globe" as the desktop wallpaper
Summary: Plasma crashed when selecting "Globe" as the desktop wallpaper
Status: RESOLVED DUPLICATE of bug 265599
Alias: None
Product: marble
Classification: Unclassified
Component: wallpaper (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-29 14:25 UTC by Amir M
Modified: 2011-08-02 19:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Amir M 2011-07-29 14:25:26 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.5-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
1) in the "Desktop Settings - Plasma Desktop Shell" screen select:
	Layout: Desktop
	Wallpaper: Globe
2) then plasma crashed 

I tryed to repreduce but it didn't crashed again.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff0fb716760 (LWP 4387))]

Thread 4 (Thread 0x7ff0de37f700 (LWP 4395)):
#0  0xffffffffff60014b in ?? ()
#1  0x00007fff1d9ff7a1 in ?? ()
#2  0x00007ff0f5f2d2b3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007ff0fa33a2b2 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007ff0fa3fd33d in QTimerInfoList::updateCurrentTime (this=0xd34380) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007ff0fa3fd6b5 in QTimerInfoList::timerWait (this=0xd34380, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007ff0fa3fc17c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7ff0de37ec4c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007ff0fa3fc225 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007ff0f5c7c087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#10 0x00007ff0f5c7cfa9 in ?? () from /lib64/libglib-2.0.so.0
#11 0x00007ff0f5c7d650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#12 0x00007ff0fa3fc976 in QEventDispatcherGlib::processEvents (this=0xe42cc0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007ff0fa3d1052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007ff0fa3d1265 in QEventLoop::exec (this=0x7ff0de37ede0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007ff0fa2e61e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#16 0x00007ff0fa3b2968 in QInotifyFileSystemWatcherEngine::run (this=0xe43880) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007ff0fa2e8a5e in QThreadPrivate::start (arg=0xe43880) at thread/qthread_unix.cpp:285
#18 0x00007ff0fa059a3f in start_thread () from /lib64/libpthread.so.0
#19 0x00007ff0f8e1467d in clone () from /lib64/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ff0d1de7700 (LWP 4400)):
#0  0x00007ff0f8e0b503 in poll () from /lib64/libc.so.6
#1  0x00007ff0f5c7d114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007ff0f5c7d650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007ff0fa3fc976 in QEventDispatcherGlib::processEvents (this=0x11be0a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff0fa3d1052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff0fa3d1265 in QEventLoop::exec (this=0x7ff0d1de6de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff0fa2e61e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007ff0fa3b2968 in QInotifyFileSystemWatcherEngine::run (this=0x11b0f40) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff0fa2e8a5e in QThreadPrivate::start (arg=0x11b0f40) at thread/qthread_unix.cpp:285
#9  0x00007ff0fa059a3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff0f8e1467d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff0cff12700 (LWP 11085)):
#0  0x00007ff0f8e0b503 in poll () from /lib64/libc.so.6
#1  0x00007ff0f5c7d114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007ff0f5c7d650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007ff0fa3fc976 in QEventDispatcherGlib::processEvents (this=0x865c040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff0fa3d1052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff0fa3d1265 in QEventLoop::exec (this=0x7ff0cff11de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff0fa2e61e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007ff0fa3b2968 in QInotifyFileSystemWatcherEngine::run (this=0xaeac630) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff0fa2e8a5e in QThreadPrivate::start (arg=0xaeac630) at thread/qthread_unix.cpp:285
#9  0x00007ff0fa059a3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff0f8e1467d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff0fb716760 (LWP 4387)):
[KCrash Handler]
#6  pixel (this=<value optimized out>, x=425, y=116) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/StackedTile.cpp:78
#7  Marble::StackedTile::pixel (this=<value optimized out>, x=425, y=116) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/StackedTile.cpp:285
#8  0x00007ff0c431c41d in Marble::AbstractScanlineTextureMapper::pixelValue (this=0x7ff0b0012ef0, lon=<value optimized out>, lat=<value optimized out>, scanLine=0x883aea0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#9  0x00007ff0c431e09d in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x7ff0b0012ef0, viewParams=0xaf18368, texColorizer=0x0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#10 0x00007ff0c431e2c2 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x7ff0b0012ef0, painter=0x7fff1d921c60, viewParams=0xaf18368, dirtyRect=..., texColorizer=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#11 0x00007ff0c4298e04 in Marble::MarbleMapPrivate::paintGround (this=0xaf18350, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:188
#12 0x00007ff0c4299ca5 in Marble::MarbleMap::paint (this=0xad2e810, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:828
#13 0x00007ff0c463cfdd in Marble::MarbleWallpaper::paint (this=0xf1f1540, painter=0x7fff1d921e40, exposedRect=...) at /usr/src/debug/kdeplasma-addons-4.6.0/wallpapers/marble/marble.cpp:201
#14 0x00007ff0ea5b3a3c in ScreenPreviewWidget::paintEvent (this=0x84d5220, event=0x7fff1d922670) at /usr/src/debug/kdebase-workspace-4.6.0/libs/kworkspace/screenpreviewwidget.cpp:174
#15 0x00007ff0f95d24ea in QWidget::event (this=0x84d5220, event=0x7fff1d922670) at kernel/qwidget.cpp:8346
#16 0x00007ff0f9580d14 in QApplicationPrivate::notify_helper (this=0x6bbd40, receiver=0x84d5220, e=0x7fff1d922670) at kernel/qapplication.cpp:4445
#17 0x00007ff0f958922a in QApplication::notify (this=<value optimized out>, receiver=0x84d5220, e=0x7fff1d922670) at kernel/qapplication.cpp:4324
#18 0x00007ff0fb0759e6 in KApplication::notify (this=0x6b1ce0, receiver=0x84d5220, event=0x7fff1d922670) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#19 0x00007ff0fa3d1bfc in QCoreApplication::notifyInternal (this=0x6b1ce0, receiver=0x84d5220, event=0x7fff1d922670) at kernel/qcoreapplication.cpp:732
#20 0x00007ff0f95cf3b2 in sendSpontaneousEvent (this=0x86d2890, pdev=0xf2b5138, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf160cf0) at ../../src/corelib/kernel/qcoreapplication.h:218
#21 QWidgetPrivate::drawWidget (this=0x86d2890, pdev=0xf2b5138, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5433
#22 0x00007ff0f95cff7f in QWidgetPrivate::paintSiblingsRecursive (this=0xf20b210, pdev=0xf2b5138, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5640
#23 0x00007ff0f95cf11a in QWidgetPrivate::drawWidget (this=0xf20b210, pdev=0xf2b5138, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5486
#24 0x00007ff0f95cff7f in QWidgetPrivate::paintSiblingsRecursive (this=0x85b8e10, pdev=0xf2b5138, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5640
#25 0x00007ff0f95cf11a in QWidgetPrivate::drawWidget (this=0x85b8e10, pdev=0xf2b5138, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5486
#26 0x00007ff0f95cff7f in QWidgetPrivate::paintSiblingsRecursive (this=0x852a4c0, pdev=0xf2b5138, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5640
#27 0x00007ff0f95cfe3c in QWidgetPrivate::paintSiblingsRecursive (this=0x852a4c0, pdev=0xf2b5138, siblings=..., index=6, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5627
#28 0x00007ff0f95cf11a in QWidgetPrivate::drawWidget (this=0x852a4c0, pdev=0xf2b5138, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5486
#29 0x00007ff0f95cff7f in QWidgetPrivate::paintSiblingsRecursive (this=0x8587fb0, pdev=0xf2b5138, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5640
#30 0x00007ff0f95cf11a in QWidgetPrivate::drawWidget (this=0x8587fb0, pdev=0xf2b5138, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5486
#31 0x00007ff0f95cff7f in QWidgetPrivate::paintSiblingsRecursive (this=0xf227320, pdev=0xf2b5138, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5640
#32 0x00007ff0f95cf11a in QWidgetPrivate::drawWidget (this=0xf227320, pdev=0xf2b5138, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5486
#33 0x00007ff0f95cff7f in QWidgetPrivate::paintSiblingsRecursive (this=0x86ba050, pdev=0xf2b5138, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5640
#34 0x00007ff0f95cf11a in QWidgetPrivate::drawWidget (this=0x86ba050, pdev=0xf2b5138, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5486
#35 0x00007ff0f95cff7f in QWidgetPrivate::paintSiblingsRecursive (this=0x852de60, pdev=0xf2b5138, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5640
#36 0x00007ff0f95cfe3c in QWidgetPrivate::paintSiblingsRecursive (this=0x852de60, pdev=0xf2b5138, siblings=..., index=1, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5627
#37 0x00007ff0f95cf11a in QWidgetPrivate::drawWidget (this=0x852de60, pdev=0xf2b5138, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xf160cf0) at kernel/qwidget.cpp:5486
#38 0x00007ff0f9792191 in QWidgetBackingStore::sync (this=0xf160cf0) at painting/qbackingstore.cpp:1333
#39 0x00007ff0f95c5170 in QWidgetPrivate::syncBackingStore (this=0x852de60) at kernel/qwidget.cpp:1816
#40 0x00007ff0f95d29f2 in QWidget::event (this=0x8403f00, event=0x7ff0d878b3f0) at kernel/qwidget.cpp:8493
#41 0x00007ff0f9580d14 in QApplicationPrivate::notify_helper (this=0x6bbd40, receiver=0x8403f00, e=0x7ff0d878b3f0) at kernel/qapplication.cpp:4445
#42 0x00007ff0f958922a in QApplication::notify (this=<value optimized out>, receiver=0x8403f00, e=0x7ff0d878b3f0) at kernel/qapplication.cpp:4324
#43 0x00007ff0fb0759e6 in KApplication::notify (this=0x6b1ce0, receiver=0x8403f00, event=0x7ff0d878b3f0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#44 0x00007ff0fa3d1bfc in QCoreApplication::notifyInternal (this=0x6b1ce0, receiver=0x8403f00, event=0x7ff0d878b3f0) at kernel/qcoreapplication.cpp:732
#45 0x00007ff0fa3d53f5 in sendEvent (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.h:215
#46 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.cpp:1373
#47 0x00007ff0fa3fc783 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#48 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#49 0x00007ff0f5c7cbd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#50 0x00007ff0f5c7d3b0 in ?? () from /lib64/libglib-2.0.so.0
#51 0x00007ff0f5c7d650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#52 0x00007ff0fa3fc91f in QEventDispatcherGlib::processEvents (this=0x6b2740, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#53 0x00007ff0f9625d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x00007ff0fa3d1052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#55 0x00007ff0fa3d1265 in QEventLoop::exec (this=0x7fff1d925680, flags=...) at kernel/qeventloop.cpp:201
#56 0x00007ff0fa3d56ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#57 0x00007ff0eaa79da8 in kdemain (argc=1, argv=0x67f430) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#58 0x00000000004075e9 in _start ()

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-08-02 19:17:15 UTC
Looks like a variant of bug 265599, upgrading to KDE 4.6.4 or later should help.

*** This bug has been marked as a duplicate of bug 265599 ***