Bug 257894 - Marble crashes when zooming into the globe
Summary: Marble crashes when zooming into the globe
Status: RESOLVED DUPLICATE of bug 265599
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash with 5 votes (vote)
Target Milestone: 1.0 (KDE 4.6)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-25 17:22 UTC by Utku Aydın
Modified: 2011-02-27 10:40 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Utku Aydın 2010-11-25 17:22:49 UTC
Application: marble (0.80 (1.0 Beta 1))
KDE Platform Version: 4.5.80 (4.6 Beta1)
Qt Version: 4.7.1
Operating System: Linux 2.6.35-ARCH i686

-- Information about the crash:
- What I was doing when the application crashed:
I was zooming in the globe and Marble crashed.

- Distribution method
I have installed Marble from a custom snapshot repository on Arch Linux.

The crash can be reproduced every time.

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb3b9c710 (LWP 3467))]

Thread 6 (Thread 0xb16c8b70 (LWP 3468)):
#0  0xb435fd76 in clock_gettime () from /lib/librt.so.1
#1  0xb6b18c18 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6be5b52 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb6be43a2 in ?? () from /usr/lib/libQtCore.so.4
#4  0xb6be443d in ?? () from /usr/lib/libQtCore.so.4
#5  0xb42cc096 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#6  0xb42ccf33 in ?? () from /usr/lib/libglib-2.0.so.0
#7  0xb42cd604 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#8  0xb6be4be7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0xb6bb6789 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb6bb6a2a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0xb6abfb6b in QThread::exec() () from /usr/lib/libQtCore.so.4
#12 0xb6b9810b in ?? () from /usr/lib/libQtCore.so.4
#13 0xb6ac25f9 in ?? () from /usr/lib/libQtCore.so.4
#14 0xb5aa2e60 in start_thread () from /lib/libpthread.so.0
#15 0xb5d5ff9e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xb0d31b70 (LWP 3469)):
#0  0xb6be464e in ?? () from /usr/lib/libQtCore.so.4
#1  0xb6be46d9 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb42cc7e7 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3  0xb42cd11a in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb42cd604 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb6be4be7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6bb6789 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb6bb6a2a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb6abfb6b in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0xb6b9810b in ?? () from /usr/lib/libQtCore.so.4
#10 0xb6ac25f9 in ?? () from /usr/lib/libQtCore.so.4
#11 0xb5aa2e60 in start_thread () from /lib/libpthread.so.0
#12 0xb5d5ff9e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb0530b70 (LWP 3470)):
#0  0xb5aa6728 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0xb5d6dea6 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0xb42cd194 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb42cd604 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb6be4be7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb6bb6789 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6bb6a2a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb6abfb6b in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0xb6b9810b in ?? () from /usr/lib/libQtCore.so.4
#9  0xb6ac25f9 in ?? () from /usr/lib/libQtCore.so.4
#10 0xb5aa2e60 in start_thread () from /lib/libpthread.so.0
#11 0xb5d5ff9e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xadd2bb70 (LWP 3477)):
#0  0xb6b18be4 in ?? () from /usr/lib/libQtCore.so.4
#1  0xb6be5b52 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6be43a2 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb6be443d in ?? () from /usr/lib/libQtCore.so.4
#4  0xb42cc096 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#5  0xb42ccf33 in ?? () from /usr/lib/libglib-2.0.so.0
#6  0xb42cd604 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#7  0xb6be4be7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb6bb6789 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0xb6bb6a2a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb6abfb6b in QThread::exec() () from /usr/lib/libQtCore.so.4
#11 0xb770f7a0 in Marble::FileStorageWatcher::run (this=0x9f78bf0) at /home/data/build/build/i686/kdeedu/src/kdeedu/marble/src/lib/FileStorageWatcher.cpp:401
#12 0xb6ac25f9 in ?? () from /usr/lib/libQtCore.so.4
#13 0xb5aa2e60 in start_thread () from /lib/libpthread.so.0
#14 0xb5d5ff9e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xaf52eb70 (LWP 3487)):
#0  0xb78b4424 in __kernel_vsyscall ()
#1  0xb5aa77a4 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5d6dca4 in pthread_cond_timedwait () from /lib/libc.so.6
#3  0xb6ac2c5f in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0xb6ab8571 in ?? () from /usr/lib/libQtCore.so.4
#5  0xb6ac25f9 in ?? () from /usr/lib/libQtCore.so.4
#6  0xb5aa2e60 in start_thread () from /lib/libpthread.so.0
#7  0xb5d5ff9e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb3b9c710 (LWP 3467)):
[KCrash Handler]
#7  pixel (this=0xd595688, x=0, y=579) at /home/data/build/build/i686/kdeedu/src/kdeedu/marble/src/lib/StackedTile.cpp:86
#8  Marble::StackedTile::pixel (this=0xd595688, x=0, y=579) at /home/data/build/build/i686/kdeedu/src/kdeedu/marble/src/lib/StackedTile.cpp:296
#9  0xb7704bb2 in Marble::AbstractScanlineTextureMapper::pixelValueApprox (this=0xa03b128, lon=0.39699467156467316, lat=0.81352320276026224, scanLine=<value optimized out>, n=42) at /home/data/build/build/i686/kdeedu/src/kdeedu/marble/src/lib/AbstractScanlineTextureMapper.cpp:394
#10 0xb77063fa in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xa03b128, viewParams=0x9f05f3c) at /home/data/build/build/i686/kdeedu/src/kdeedu/marble/src/lib/SphericalScanlineTextureMapper.cpp:190
#11 0xb766d03e in Marble::MarbleModel::paintGlobe (this=0x9f3a3d8, painter=0xbfaee17c, viewParams=0x9f05f3c, redrawBackground=true, dirtyRect=...) at /home/data/build/build/i686/kdeedu/src/kdeedu/marble/src/lib/MarbleModel.cpp:633
#12 0xb7671af8 in Marble::MarbleMapPrivate::paintGround (this=0x9f05f30, painter=..., dirtyRect=...) at /home/data/build/build/i686/kdeedu/src/kdeedu/marble/src/lib/MarbleMap.cpp:138
#13 0xb7662196 in Marble::MarbleWidget::paintEvent (this=0x9f0e438, evt=0xbfaee744) at /home/data/build/build/i686/kdeedu/src/kdeedu/marble/src/lib/MarbleWidget.cpp:775
#14 0xb61665ae in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#15 0xb610d854 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb61124eb in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0xb714a97a in KApplication::notify (this=0xbfaef4a4, receiver=0x9f0e438, event=0xbfaee744) at /home/data/build/build/i686/kdelibs/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#18 0xb6bb75cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb61631e4 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib/libQtGui.so.4
#20 0xb633fd85 in ?? () from /usr/lib/libQtGui.so.4
#21 0xb6158a53 in QWidgetPrivate::syncBackingStore() () from /usr/lib/libQtGui.so.4
#22 0xb6166c0d in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#23 0xb657a987 in QMainWindow::event(QEvent*) () from /usr/lib/libQtGui.so.4
#24 0xb722944c in KMainWindow::event (this=0x9dd32a0, ev=0xd595720) at /home/data/build/build/i686/kdelibs/src/kdelibs/kdeui/widgets/kmainwindow.cpp:1100
#25 0xb726a48f in KXmlGuiWindow::event (this=0x9dd32a0, ev=0xd595720) at /home/data/build/build/i686/kdelibs/src/kdelibs/kdeui/xmlgui/kxmlguiwindow.cpp:126
#26 0xb610d854 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#27 0xb61124eb in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#28 0xb714a97a in KApplication::notify (this=0xbfaef4a4, receiver=0x9dd32a0, event=0xd595720) at /home/data/build/build/i686/kdelibs/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#29 0xb6bb75cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#30 0xb6bbb1e5 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#31 0xb6bbb3bd in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#32 0xb6be4a34 in ?? () from /usr/lib/libQtCore.so.4
#33 0xb42ccb72 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#34 0xb42cd350 in ?? () from /usr/lib/libglib-2.0.so.0
#35 0xb42cd604 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#36 0xb6be4bac in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#37 0xb61bf265 in ?? () from /usr/lib/libQtGui.so.4
#38 0xb6bb6789 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0xb6bb6a2a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#40 0xb6bbb47f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#41 0xb610b6a7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#42 0x08063cc5 in main (argc=) at /home/data/build/build/i686/kdeedu/src/kdeedu/marble/src/kdemain.cpp:345

Possible duplicates by query: bug 244890.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2010-12-13 08:12:10 UTC
Which projection are you using, Globe? You can see that in the Map View tab on the left. Does switching to a different projection like Mercator make a difference?
Comment 2 Henri Bragge 2011-02-01 19:35:05 UTC
I had the same bug: when zooming in (with mouse scroll), Marble crashed at the same height every time.

Later I changed the window size, and after that it never crashed again. I also did some other things in between, like toggled toolbar on/off and used the UI zoom, so I'm not sure if window size really affected.

No trace available because I cannot reproduce it anymore.

---

Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-ARCH
Comment 3 Dennis Nienhüser 2011-02-27 10:40:11 UTC
I'll mark this as a duplicate of the newer bug 265599 which has a backtrace with debug symbols. The reason for the crash is indeed the window size (which triggers a size change of the marble widget because the progress bar appears, but internally the size is not correctly updated and later now invalid pixels are accessed).

*** This bug has been marked as a duplicate of bug 265599 ***