Bug 269007 - Zoom In
Summary: Zoom In
Status: RESOLVED DUPLICATE of bug 265599
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 1.1.0
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-21 01:18 UTC by Ken Halloran
Modified: 2011-04-11 21:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Halloran 2011-03-21 01:18:47 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: I was using the zoom-in feature when it crashed. KDE 6 opensuse

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6e69545760 (LWP 6679))]

Thread 5 (Thread 0x7f6e57300700 (LWP 6680)):
#0  0x00007f6e6607f503 in poll () from /lib64/libc.so.6
#1  0x00007f6e606bd114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007f6e606bd650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f6e67774976 in QEventDispatcherGlib::processEvents (this=0x872d70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f6e67749052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6e67749265 in QEventLoop::exec (this=0x7f6e572ffde0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f6e6765e1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f6e6772a968 in QInotifyFileSystemWatcherEngine::run (this=0x853250) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f6e67660a5e in QThreadPrivate::start (arg=0x853250) at thread/qthread_unix.cpp:285
#9  0x00007f6e653caa3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f6e6608867d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f6e4f579700 (LWP 6681)):
#0  0xffffffffff600177 in ?? ()
#1  0x00007fff243ff7a1 in ?? ()
#2  0x00007f6e6096d2b3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007f6e676b22b2 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007f6e6777533d in QTimerInfoList::updateCurrentTime (this=0x7f6e50002180) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007f6e677756b5 in QTimerInfoList::timerWait (this=0x7f6e50002180, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007f6e6777417c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f6e4f578c4c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007f6e67774225 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007f6e606bc087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#10 0x00007f6e606bcfa9 in ?? () from /lib64/libglib-2.0.so.0
#11 0x00007f6e606bd650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#12 0x00007f6e67774976 in QEventDispatcherGlib::processEvents (this=0xa9bda0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007f6e67749052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007f6e67749265 in QEventLoop::exec (this=0x7f6e4f578de0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007f6e6765e1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#16 0x00007f6e6772a968 in QInotifyFileSystemWatcherEngine::run (this=0xaa8180) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007f6e67660a5e in QThreadPrivate::start (arg=0xaa8180) at thread/qthread_unix.cpp:285
#18 0x00007f6e653caa3f in start_thread () from /lib64/libpthread.so.0
#19 0x00007f6e6608867d in clone () from /lib64/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f6e4ed78700 (LWP 6682)):
#0  0x00007f6e6607f503 in poll () from /lib64/libc.so.6
#1  0x00007f6e606bd114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007f6e606bd650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f6e67774976 in QEventDispatcherGlib::processEvents (this=0xa9ead0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f6e67749052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6e67749265 in QEventLoop::exec (this=0x7f6e4ed77de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f6e6765e1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f6e6772a968 in QInotifyFileSystemWatcherEngine::run (this=0xabf210) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f6e67660a5e in QThreadPrivate::start (arg=0xabf210) at thread/qthread_unix.cpp:285
#9  0x00007f6e653caa3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f6e6608867d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6e4b571700 (LWP 6689)):
#0  0x00007f6e653ce67e in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f6e606bc846 in g_main_context_check () from /lib64/libglib-2.0.so.0
#2  0x00007f6e606bd132 in ?? () from /lib64/libglib-2.0.so.0
#3  0x00007f6e606bd650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007f6e67774976 in QEventDispatcherGlib::processEvents (this=0xb766b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f6e67749052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f6e67749265 in QEventLoop::exec (this=0x7f6e4b570dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f6e6765e1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f6e68b8fa48 in Marble::FileStorageWatcher::run (this=0x82f200) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/FileStorageWatcher.cpp:401
#9  0x00007f6e67660a5e in QThreadPrivate::start (arg=0x82f200) at thread/qthread_unix.cpp:285
#10 0x00007f6e653caa3f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f6e6608867d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6e69545760 (LWP 6679)):
[KCrash Handler]
#6  0x00007f6e68b84f43 in Marble::AbstractScanlineTextureMapper::pixelValueF (this=0xacdef0, lon=<value optimized out>, lat=<value optimized out>, scanLine=0x7f6e4ccd6010) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:130
#7  0x00007f6e68b8600d in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xacdef0, viewParams=0x8b5ae8, texColorizer=0xb1b8c0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:233
#8  0x00007f6e68b862c2 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xacdef0, painter=0x7fff243a0810, viewParams=0x8b5ae8, dirtyRect=..., texColorizer=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#9  0x00007f6e68b00e04 in Marble::MarbleMapPrivate::paintGround (this=0x8b5ad0, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:188
#10 0x00007f6e68af3749 in Marble::MarbleWidget::paintEvent (this=0x8a4730, evt=0x7fff243a10f0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:805
#11 0x00007f6e66b674ea in QWidget::event (this=0x8a4730, event=0x7fff243a10f0) at kernel/qwidget.cpp:8346
#12 0x00007f6e66b15d14 in QApplicationPrivate::notify_helper (this=0x6b5850, receiver=0x8a4730, e=0x7fff243a10f0) at kernel/qapplication.cpp:4445
#13 0x00007f6e66b1e22a in QApplication::notify (this=<value optimized out>, receiver=0x8a4730, e=0x7fff243a10f0) at kernel/qapplication.cpp:4324
#14 0x00007f6e680aa9e6 in KApplication::notify (this=0x7fff243a3b50, receiver=0x8a4730, event=0x7fff243a10f0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#15 0x00007f6e67749bfc in QCoreApplication::notifyInternal (this=0x7fff243a3b50, receiver=0x8a4730, event=0x7fff243a10f0) at kernel/qcoreapplication.cpp:732
#16 0x00007f6e66b643b2 in sendSpontaneousEvent (this=0x8a4840, pdev=0xac3e28, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0xac3f60) at ../../src/corelib/kernel/qcoreapplication.h:218
#17 QWidgetPrivate::drawWidget (this=0x8a4840, pdev=0xac3e28, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0xac3f60) at kernel/qwidget.cpp:5433
#18 0x00007f6e66d27138 in QWidgetBackingStore::sync (this=0xac3f60) at painting/qbackingstore.cpp:1325
#19 0x00007f6e66b5a170 in QWidgetPrivate::syncBackingStore (this=0x7f7050) at kernel/qwidget.cpp:1816
#20 0x00007f6e66b679f2 in QWidget::event (this=0x7f6f10, event=0x7fff243a2090) at kernel/qwidget.cpp:8493
#21 0x00007f6e66f2547b in QMainWindow::event (this=0x7f6f10, event=0x7fff243a2090) at widgets/qmainwindow.cpp:1478
#22 0x00007f6e68153793 in KXmlGuiWindow::event (this=0x7f6f10, ev=0x7fff243a2090) at /usr/src/debug/kdelibs-4.6.0/kdeui/xmlgui/kxmlguiwindow.cpp:126
#23 0x00007f6e66b15d14 in QApplicationPrivate::notify_helper (this=0x6b5850, receiver=0x7f6f10, e=0x7fff243a2090) at kernel/qapplication.cpp:4445
#24 0x00007f6e66b1e22a in QApplication::notify (this=<value optimized out>, receiver=0x7f6f10, e=0x7fff243a2090) at kernel/qapplication.cpp:4324
#25 0x00007f6e680aa9e6 in KApplication::notify (this=0x7fff243a3b50, receiver=0x7f6f10, event=0x7fff243a2090) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#26 0x00007f6e67749bfc in QCoreApplication::notifyInternal (this=0x7fff243a3b50, receiver=0x7f6f10, event=0x7fff243a2090) at kernel/qcoreapplication.cpp:732
#27 0x00007f6e66d23cb9 in sendEvent (this=0xac3f60, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#28 sendUpdateRequest (this=0xac3f60, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=<value optimized out>) at painting/qbackingstore.cpp:507
#29 QWidgetBackingStore::markDirty (this=0xac3f60, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=<value optimized out>) at painting/qbackingstore.cpp:695
#30 0x00007f6e66b599d8 in QWidget::repaint (this=0x8a4730, rect=...) at kernel/qwidget.cpp:10250
#31 0x00007f6e66b59a93 in QWidget::repaint (this=<value optimized out>) at kernel/qwidget.cpp:10206
#32 0x00007f6e68af631b in repaint (this=<value optimized out>, newZoom=1609, mode=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:272
#33 Marble::MarbleWidget::zoomView (this=<value optimized out>, newZoom=1609, mode=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:539
#34 0x00007f6e68af7dd3 in Marble::MarbleWidget::qt_metacall (this=0x8a4730, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0x7fff243a2340) at /usr/src/debug/kdeedu-4.6.0/build/marble/src/lib/MarbleWidget.moc:310
#35 0x00007f6e6775edef in QMetaObject::activate (sender=0x7fee40, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#36 0x00007f6e68b050dc in Marble::NavigationWidget::qt_metacall (this=0x7fee40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff243a2490) at /usr/src/debug/kdeedu-4.6.0/build/marble/src/lib/NavigationWidget.moc:102
#37 0x00007f6e6775edef in QMetaObject::activate (sender=0x86ab50, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff243a2490) at kernel/qobject.cpp:3272
#38 0x00007f6e67180a32 in QAbstractButton::clicked (this=<value optimized out>, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#39 0x00007f6e66ec8d9b in QAbstractButtonPrivate::emitClicked (this=<value optimized out>) at widgets/qabstractbutton.cpp:546
#40 0x00007f6e66eca35b in QAbstractButtonPrivate::click (this=0x917ca0) at widgets/qabstractbutton.cpp:539
#41 0x00007f6e66eca5cc in QAbstractButton::mouseReleaseEvent (this=0x86ab50, e=0x7fff243a2e20) at widgets/qabstractbutton.cpp:1121
#42 0x00007f6e66f86a7a in QToolButton::mouseReleaseEvent (this=<value optimized out>, e=<value optimized out>) at widgets/qtoolbutton.cpp:721
#43 0x00007f6e66b67538 in QWidget::event (this=0x86ab50, event=0x7fff243a2e20) at kernel/qwidget.cpp:8200
#44 0x00007f6e66b15d14 in QApplicationPrivate::notify_helper (this=0x6b5850, receiver=0x86ab50, e=0x7fff243a2e20) at kernel/qapplication.cpp:4445
#45 0x00007f6e66b1eaac in QApplication::notify (this=<value optimized out>, receiver=0x86ab50, e=0x7fff243a2e20) at kernel/qapplication.cpp:4006
#46 0x00007f6e680aa9e6 in KApplication::notify (this=0x7fff243a3b50, receiver=0x86ab50, event=0x7fff243a2e20) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#47 0x00007f6e67749bfc in QCoreApplication::notifyInternal (this=0x7fff243a3b50, receiver=0x86ab50, event=0x7fff243a2e20) at kernel/qcoreapplication.cpp:732
#48 0x00007f6e66b16d25 in sendEvent (receiver=0x86ab50, event=0x7fff243a2e20, alienWidget=0x86ab50, nativeWidget=0x7f6f10, buttonDown=0x7f6e675e5178, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:215
#49 QApplicationPrivate::sendMouseEvent (receiver=0x86ab50, event=0x7fff243a2e20, alienWidget=0x86ab50, nativeWidget=0x7f6f10, buttonDown=0x7f6e675e5178, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3105
#50 0x00007f6e66b94e08 in QETWidget::translateMouseEvent (this=0x7f6f10, event=<value optimized out>) at kernel/qapplication_x11.cpp:4438
#51 0x00007f6e66b934c9 in QApplication::x11ProcessEvent (this=0x7fff243a3b50, event=0x7fff243a3780) at kernel/qapplication_x11.cpp:3564
#52 0x00007f6e66bbb0f2 in x11EventSourceDispatch (s=0x6b51d0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#53 0x00007f6e606bcbd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#54 0x00007f6e606bd3b0 in ?? () from /lib64/libglib-2.0.so.0
#55 0x00007f6e606bd650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#56 0x00007f6e6777491f in QEventDispatcherGlib::processEvents (this=0x69cc30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#57 0x00007f6e66bbad8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#58 0x00007f6e67749052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#59 0x00007f6e67749265 in QEventLoop::exec (this=0x7fff243a3aa0, flags=...) at kernel/qeventloop.cpp:201
#60 0x00007f6e6774d6ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#61 0x0000000000421725 in main (argc=1, argv=0x7fff243a5158) at /usr/src/debug/kdeedu-4.6.0/marble/src/kdemain.cpp:351

Possible duplicates by query: bug 255681, bug 252561, bug 247416, bug 240641, bug 235364.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-03-21 04:31:22 UTC

*** This bug has been marked as a duplicate of bug 240641 ***
Comment 2 Dennis Nienhüser 2011-04-11 21:55:32 UTC

*** This bug has been marked as a duplicate of bug 265599 ***