Bug 269003 - Marble crashing while zooming in
Summary: Marble crashing while zooming in
Status: RESOLVED DUPLICATE of bug 265599
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: 1.1.0
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-21 00:03 UTC by Steven Ward
Modified: 2011-03-21 04:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Ward 2011-03-21 00:03:13 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-1.fc15.i686 i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:I was zooming in into my home city

- Unusual behavior I noticed:Kmarble unexpectedtidly crashed. I am currently using Fedora 15 Alpha with all the latest updates from 19-03-11

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7856780 (LWP 3915))]

Thread 6 (Thread 0xb57f7b70 (LWP 3934)):
#0  0x428590e4 in postEventSourcePrepare (s=0xb4e01a00, timeout=0x0) at kernel/qeventdispatcher_glib.cpp:253
#1  0x42859178 in postEventSourceCheck (source=0xb4e01a00) at kernel/qeventdispatcher_glib.cpp:270
#2  0x412bc4ac in g_main_context_check (context=0xb4e004e8, max_priority=2147483647, fds=0xb4e01d18, n_fds=1) at gmain.c:2961
#3  0x412bcef0 in g_main_context_iterate (context=0xb4e004e8, block=1093450944, dispatch=1, self=0xb4e00d78) at gmain.c:3088
#4  0x412bd2cf in g_main_context_iteration (context=0xb4e004e8, may_block=1) at gmain.c:3154
#5  0x42859957 in QEventDispatcherGlib::processEvents (this=0xb4e00468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x4282a0fe in QEventLoop::processEvents (this=0xb57f7240, flags=...) at kernel/qeventloop.cpp:149
#7  0x4282a351 in QEventLoop::exec (this=0xb57f7240, flags=...) at kernel/qeventloop.cpp:201
#8  0x4272b32c in QThread::exec (this=0x9ff8928) at thread/qthread.cpp:492
#9  0x4280a7ce in QInotifyFileSystemWatcherEngine::run (this=0x9ff8928) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x4272e254 in QThreadPrivate::start (arg=0x9ff8928) at thread/qthread_unix.cpp:320
#11 0x4105ac8d in start_thread (arg=0xb57f7b70) at pthread_create.c:301
#12 0x4ff9672e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 5 (Thread 0xb4d64b70 (LWP 3935)):
#0  0x004a8416 in __kernel_vsyscall ()
#1  0x4ff8c1ae in __poll (fds=0xb4401b18, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x412cbcec in g_poll (fds=0xb4401b18, nfds=1, timeout=-1) at gpoll.c:132
#3  0x412bce96 in g_main_context_poll (n_fds=1, fds=0x4105dc20, priority=<optimized out>, timeout=<optimized out>, context=0xb44004e8) at gmain.c:3404
#4  g_main_context_iterate (context=0xb44004e8, block=1093450944, dispatch=1, self=0xb4400d78) at gmain.c:3086
#5  0x412bd2cf in g_main_context_iteration (context=0xb44004e8, may_block=1) at gmain.c:3154
#6  0x42859957 in QEventDispatcherGlib::processEvents (this=0xb4400468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#7  0x4282a0fe in QEventLoop::processEvents (this=0xb4d64240, flags=...) at kernel/qeventloop.cpp:149
#8  0x4282a351 in QEventLoop::exec (this=0xb4d64240, flags=...) at kernel/qeventloop.cpp:201
#9  0x4272b32c in QThread::exec (this=0x9fc07d8) at thread/qthread.cpp:492
#10 0x4280a7ce in QInotifyFileSystemWatcherEngine::run (this=0x9fc07d8) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x4272e254 in QThreadPrivate::start (arg=0x9fc07d8) at thread/qthread_unix.cpp:320
#12 0x4105ac8d in start_thread (arg=0xb4d64b70) at pthread_create.c:301
#13 0x4ff9672e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 4 (Thread 0xb43ffb70 (LWP 3936)):
#0  0x412bc690 in g_main_context_dispatch (context=0xa0f3c30) at gmain.c:3011
#1  0x412bcf90 in g_main_context_iterate (context=0xa0f3c30, block=1093450944, dispatch=1, self=0xa0f6d50) at gmain.c:3091
#2  0x412bd2cf in g_main_context_iteration (context=0xa0f3c30, may_block=1) at gmain.c:3154
#3  0x42859957 in QEventDispatcherGlib::processEvents (this=0xa0efd98, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x4282a0fe in QEventLoop::processEvents (this=0xb43ff240, flags=...) at kernel/qeventloop.cpp:149
#5  0x4282a351 in QEventLoop::exec (this=0xb43ff240, flags=...) at kernel/qeventloop.cpp:201
#6  0x4272b32c in QThread::exec (this=0x9fee8c0) at thread/qthread.cpp:492
#7  0x4280a7ce in QInotifyFileSystemWatcherEngine::run (this=0x9fee8c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x4272e254 in QThreadPrivate::start (arg=0x9fee8c0) at thread/qthread_unix.cpp:320
#9  0x4105ac8d in start_thread (arg=0xb43ffb70) at pthread_create.c:301
#10 0x4ff9672e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 3 (Thread 0xb2bfcb70 (LWP 3948)):
#0  __pthread_mutex_lock (mutex=0xa216184) at pthread_mutex_lock.c:131
#1  0x412bbdeb in g_main_context_prepare (context=0xa216180, priority=0xb2bfc0f8) at gmain.c:2763
#2  0x412bcc38 in g_main_context_iterate (context=0xa216180, block=1, dispatch=1, self=0xa216a10) at gmain.c:3071
#3  0x412bd2cf in g_main_context_iteration (context=0xa216180, may_block=1) at gmain.c:3154
#4  0x42859957 in QEventDispatcherGlib::processEvents (this=0xa2035a8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x4282a0fe in QEventLoop::processEvents (this=0xb2bfc220, flags=...) at kernel/qeventloop.cpp:149
#6  0x4282a351 in QEventLoop::exec (this=0xb2bfc220, flags=...) at kernel/qeventloop.cpp:201
#7  0x4272b32c in QThread::exec (this=0x9ffd138) at thread/qthread.cpp:492
#8  0x447131d0 in Marble::FileStorageWatcher::run (this=0x9ffd138) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/FileStorageWatcher.cpp:401
#9  0x4272e254 in QThreadPrivate::start (arg=0x9ffd138) at thread/qthread_unix.cpp:320
#10 0x4105ac8d in start_thread (arg=0xb2bfcb70) at pthread_create.c:301
#11 0x4ff9672e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0xb13f9b70 (LWP 3956)):
#0  0x412bc4cb in g_main_context_check (context=0xb4405010, max_priority=2147483647, fds=0xb4405728, n_fds=1) at gmain.c:2963
#1  0x412bcef0 in g_main_context_iterate (context=0xb4405010, block=1093450944, dispatch=1, self=0xb44fb8c0) at gmain.c:3088
#2  0x412bd2cf in g_main_context_iteration (context=0xb4405010, may_block=1) at gmain.c:3154
#3  0x42859957 in QEventDispatcherGlib::processEvents (this=0xb4405450, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x4282a0fe in QEventLoop::processEvents (this=0xb13f9240, flags=...) at kernel/qeventloop.cpp:149
#5  0x4282a351 in QEventLoop::exec (this=0xb13f9240, flags=...) at kernel/qeventloop.cpp:201
#6  0x4272b32c in QThread::exec (this=0xa99ec98) at thread/qthread.cpp:492
#7  0x4280a7ce in QInotifyFileSystemWatcherEngine::run (this=0xa99ec98) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x4272e254 in QThreadPrivate::start (arg=0xa99ec98) at thread/qthread_unix.cpp:320
#9  0x4105ac8d in start_thread (arg=0xb13f9b70) at pthread_create.c:301
#10 0x4ff9672e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb7856780 (LWP 3915)):
[KCrash Handler]
#7  0x44706ed9 in Marble::AbstractScanlineTextureMapper::pixelValue (this=0xa14d348, lon=-0.12567765613546591, lat=0.98768729431954727, scanLine=0xb0b0e008) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#8  0x44708a25 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xa14d348, viewParams=0xa00020c, texColorizer=0xa15a8c0) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#9  0x44708c4e in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xa14d348, painter=0xbfe76eb8, viewParams=0xa00020c, dirtyRect=..., texColorizer=0xa15a8c0) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#10 0x446fe72a in Marble::TextureLayer::paintGlobe (this=0xa00022c, painter=0xbfe76eb8, viewParams=0xa00020c, dirtyRect=...) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/TextureLayer.cpp:161
#11 0x4467a1b7 in Marble::MarbleMapPrivate::paintGround (this=0xa000200, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleMap.cpp:188
#12 0x4466a34b in Marble::MarbleWidget::paintEvent (this=0x9fe7f78, evt=0xbfe77444) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidget.cpp:805
#13 0x450e740b in QWidget::event (this=0x9fe7f78, event=0xbfe77444) at kernel/qwidget.cpp:8405
#14 0x4508c834 in notify_helper (e=0xbfe77444, receiver=0x9fe7f78, this=0x9e7fc28) at kernel/qapplication.cpp:4462
#15 QApplicationPrivate::notify_helper (this=0x9e7fc28, receiver=0x9fe7f78, e=0xbfe77444) at kernel/qapplication.cpp:4434
#16 0x45091c89 in QApplication::notify (this=0x9e7fc28, receiver=0x9fe7f78, e=0xbfe77444) at kernel/qapplication.cpp:4427
#17 0x42b689e2 in KApplication::notify (this=0xbfe79024, receiver=0x9fe7f78, event=0xbfe77444) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#18 0x4282b0fe in QCoreApplication::notifyInternal (this=0xbfe79024, receiver=0x9fe7f78, event=0xbfe77444) at kernel/qcoreapplication.cpp:731
#19 0x450e41df in sendSpontaneousEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:218
#20 QWidgetPrivate::drawWidget (this=0x9ff8048, pdev=0xa10dfbc, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0xa10d678) at kernel/qwidget.cpp:5492
#21 0x452c96ec in QWidgetBackingStore::sync (this=0xa10d678) at painting/qbackingstore.cpp:1325
#22 0x450d9a3b in QWidgetPrivate::syncBackingStore (this=0x9efe9a0) at kernel/qwidget.cpp:1842
#23 0x450e7da3 in QWidget::event (this=0x9f42060, event=0xbfe77f14) at kernel/qwidget.cpp:8552
#24 0x45507284 in QMainWindow::event (this=0x9f42060, event=0xbfe77f14) at widgets/qmainwindow.cpp:1480
#25 0x42c4c8a4 in KMainWindow::event (this=0x9f42060, ev=0xbfe77f14) at /usr/src/debug/kdelibs-4.6.1/kdeui/widgets/kmainwindow.cpp:1100
#26 0x42c8f433 in KXmlGuiWindow::event (this=0x9f42060, ev=0xbfe77f14) at /usr/src/debug/kdelibs-4.6.1/kdeui/xmlgui/kxmlguiwindow.cpp:126
#27 0x4508c834 in notify_helper (e=0xbfe77f14, receiver=0x9f42060, this=0x9e7fc28) at kernel/qapplication.cpp:4462
#28 QApplicationPrivate::notify_helper (this=0x9e7fc28, receiver=0x9f42060, e=0xbfe77f14) at kernel/qapplication.cpp:4434
#29 0x45091c89 in QApplication::notify (this=0x9e7fc28, receiver=0x9f42060, e=0xbfe77f14) at kernel/qapplication.cpp:4427
#30 0x42b689e2 in KApplication::notify (this=0xbfe79024, receiver=0x9f42060, event=0xbfe77f14) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#31 0x4282b0fe in QCoreApplication::notifyInternal (this=0xbfe79024, receiver=0x9f42060, event=0xbfe77f14) at kernel/qcoreapplication.cpp:731
#32 0x452c5bdc in sendEvent (event=0xbfe77f10, receiver=0x9f42060) at ../../src/corelib/kernel/qcoreapplication.h:215
#33 sendUpdateRequest (updateImmediately=true, widget=0x9f42060) at painting/qbackingstore.cpp:507
#34 QWidgetBackingStore::markDirty (this=0xa10d678, rect=..., widget=0x9fe7f78, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:695
#35 0x450d9042 in repaint (rect=..., this=0x9fe7f78) at kernel/qwidget.cpp:10322
#36 QWidget::repaint (this=0x9fe7f78, rect=...) at kernel/qwidget.cpp:10306
#37 0x450d9152 in QWidget::repaint (this=0x9fe7f78) at kernel/qwidget.cpp:10278
#38 0x44668e4f in Marble::MarbleWidgetPrivate::repaint (this=0xa04d5a8) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidget.cpp:272
#39 0x44694d08 in Marble::MarbleWidgetDefaultInputHandler::Private::ZoomAt (this=0xa051448, marbleWidget=0x9fe7f78, pos=..., newDistance=575.76286887758329) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidgetInputHandler.cpp:271
#40 0x44696c6b in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0xa04daf0, o=0x9fe7f78, e=0xbfe786f4) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidgetInputHandler.cpp:738
#41 0x4282b2a6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9e7fc28, receiver=0x9fe7f78, event=0xbfe786f4) at kernel/qcoreapplication.cpp:846
#42 0x4508c803 in notify_helper (e=0xbfe786f4, receiver=0x9fe7f78, this=0x9e7fc28) at kernel/qapplication.cpp:4458
#43 QApplicationPrivate::notify_helper (this=0x9e7fc28, receiver=0x9fe7f78, e=0xbfe786f4) at kernel/qapplication.cpp:4434
#44 0x450923cd in QApplication::notify (this=0x9fe7f78, receiver=0x9fe7f78, e=0xbfe786f4) at kernel/qapplication.cpp:4078
#45 0x42b689e2 in KApplication::notify (this=0xbfe79024, receiver=0x9fe7f78, event=0xbfe786f4) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#46 0x4282b0fe in QCoreApplication::notifyInternal (this=0xbfe79024, receiver=0x9fe7f78, event=0xbfe786f4) at kernel/qcoreapplication.cpp:731
#47 0x45106bb8 in sendSpontaneousEvent (event=0xbfe786f4, receiver=0x9fe7f78) at ../../src/corelib/kernel/qcoreapplication.h:218
#48 QETWidget::translateWheelEvent (this=0x9f42060, global_x=955, global_y=423, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at kernel/qapplication_x11.cpp:4499
#49 0x451177ee in QETWidget::translateMouseEvent (this=0x9f42060, event=0xbfe78c7c) at kernel/qapplication_x11.cpp:4276
#50 0x4511652d in QApplication::x11ProcessEvent (this=0xbfe79024, event=0xbfe78c7c) at kernel/qapplication_x11.cpp:3587
#51 0x451411d5 in x11EventSourceDispatch (s=0x9e7fa10, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#52 0x412bc81f in g_main_dispatch (context=0x9e66e70) at gmain.c:2440
#53 g_main_context_dispatch (context=0x9e66e70) at gmain.c:3013
#54 0x412bcf90 in g_main_context_iterate (context=0x9e66e70, block=1093450944, dispatch=1, self=0x9e64cb0) at gmain.c:3091
#55 0x412bd2cf in g_main_context_iteration (context=0x9e66e70, may_block=1) at gmain.c:3154
#56 0x428598f8 in QEventDispatcherGlib::processEvents (this=0x9e64bb8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#57 0x45140e6b in QGuiEventDispatcherGlib::processEvents (this=0x9e64bb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#58 0x4282a0fe in QEventLoop::processEvents (this=0xbfe78f84, flags=...) at kernel/qeventloop.cpp:149
#59 0x4282a351 in QEventLoop::exec (this=0xbfe78f84, flags=...) at kernel/qeventloop.cpp:201
#60 0x4282eb5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#61 0x4508a635 in QApplication::exec () at kernel/qapplication.cpp:3736
#62 0x0805c770 in main (argc=) at /usr/src/debug/kdeedu-4.6.1/marble/src/kdemain.cpp:351

Possible duplicates by query: bug 266690, bug 266406, bug 259258.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-03-21 04:33:42 UTC

*** This bug has been marked as a duplicate of bug 265599 ***