Bug 269181 - Marble crashed during a zoom
Summary: Marble crashed during a zoom
Status: RESOLVED DUPLICATE of bug 265599
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 1.1.0
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-22 21:54 UTC by Valéry MARZLIN
Modified: 2011-03-23 20:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valéry MARZLIN 2011-03-22 21:54:59 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
I just started the application, then wrote Paris in the search box, select Paris in the result and zoom by clicking a lot of time on the zoom button then it crashed when was zooming.

-- Backtrace:
Application: Globe Virtuel Marble (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb392b710 (LWP 8126))]

Thread 5 (Thread 0xb1304b70 (LWP 8127)):
#0  0xb591ffcd in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0xb5becd04 in pthread_mutex_lock () from /lib/libc.so.6
#2  0xb3fc52a7 in g_main_context_release () from /lib/libglib-2.0.so.0
#3  0xb3fc6ade in ?? () from /lib/libglib-2.0.so.0
#4  0xb3fc6fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb6acc7b7 in QEventDispatcherGlib::processEvents (this=0x81de518, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6a9d2bd in QEventLoop::processEvents (this=0xb13042b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6a9d4e9 in QEventLoop::exec (this=0xb13042b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb699e7b9 in QThread::exec (this=0x81f6f38) at thread/qthread.cpp:490
#9  0xb6a7d23d in QInotifyFileSystemWatcherEngine::run (this=0x81f6f38) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb69a13aa in QThreadPrivate::start (arg=0x81f6f38) at thread/qthread_unix.cpp:285
#11 0xb591db05 in start_thread () from /lib/libpthread.so.0
#12 0xb5bded5e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb0911b70 (LWP 8128)):
#0  0xb3fc5a76 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#1  0xb3fc68e2 in ?? () from /lib/libglib-2.0.so.0
#2  0xb3fc6fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0xb6acc7b7 in QEventDispatcherGlib::processEvents (this=0x83534d8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0xb6a9d2bd in QEventLoop::processEvents (this=0xb09112b0, flags=...) at kernel/qeventloop.cpp:149
#5  0xb6a9d4e9 in QEventLoop::exec (this=0xb09112b0, flags=...) at kernel/qeventloop.cpp:201
#6  0xb699e7b9 in QThread::exec (this=0x8228f90) at thread/qthread.cpp:490
#7  0xb6a7d23d in QInotifyFileSystemWatcherEngine::run (this=0x8228f90) at io/qfilesystemwatcher_inotify.cpp:248
#8  0xb69a13aa in QThreadPrivate::start (arg=0x8228f90) at thread/qthread_unix.cpp:285
#9  0xb591db05 in start_thread () from /lib/libpthread.so.0
#10 0xb5bded5e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb0110b70 (LWP 8129)):
#0  0xb5921529 in pthread_mutex_unlock () from /lib/libpthread.so.0
#1  0xb5becd44 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0xb3fc5a63 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0xb3fc68e2 in ?? () from /lib/libglib-2.0.so.0
#4  0xb3fc6fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb6acc7b7 in QEventDispatcherGlib::processEvents (this=0x81aab68, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6a9d2bd in QEventLoop::processEvents (this=0xb01102b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6a9d4e9 in QEventLoop::exec (this=0xb01102b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb699e7b9 in QThread::exec (this=0x8357c40) at thread/qthread.cpp:490
#9  0xb6a7d23d in QInotifyFileSystemWatcherEngine::run (this=0x8357c40) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb69a13aa in QThreadPrivate::start (arg=0x8357c40) at thread/qthread_unix.cpp:285
#11 0xb591db05 in start_thread () from /lib/libpthread.so.0
#12 0xb5bded5e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xad10ab70 (LWP 8136)):
#0  0xb407c22b in clock_gettime () from /lib/librt.so.1
#1  0xb69faae5 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6acd726 in updateCurrentTime (this=0x840866c, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x840866c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6acbf6b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xad10a0ec) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6acc00d in timerSourcePrepare (source=0x8408638, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb3fc5a70 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb3fc68e2 in ?? () from /lib/libglib-2.0.so.0
#9  0xb3fc6fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb6acc7b7 in QEventDispatcherGlib::processEvents (this=0x840fe68, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6a9d2bd in QEventLoop::processEvents (this=0xad10a280, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6a9d4e9 in QEventLoop::exec (this=0xad10a280, flags=...) at kernel/qeventloop.cpp:201
#13 0xb699e7b9 in QThread::exec (this=0x81cca10) at thread/qthread.cpp:490
#14 0xb76ca090 in Marble::FileStorageWatcher::run (this=0x81cca10) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/FileStorageWatcher.cpp:401
#15 0xb69a13aa in QThreadPrivate::start (arg=0x81cca10) at thread/qthread_unix.cpp:285
#16 0xb591db05 in start_thread () from /lib/libpthread.so.0
#17 0xb5bded5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb392b710 (LWP 8126)):
[KCrash Handler]
#7  0xb76bd69b in Marble::AbstractScanlineTextureMapper::pixelValueF (this=0xac602808, lon=-0.052810611736346977, lat=0.90765584360884854, scanLine=0xae985008) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:130
#8  0xb76be9ca in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xac602808, viewParams=0x81c8a1c, texColorizer=0x83bfd10) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:233
#9  0xb76becbd in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xac602808, painter=0xbfaa787c, viewParams=0x81c8a1c, dirtyRect=..., texColorizer=0x83bfd10) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#10 0xb76b3e49 in Marble::TextureLayer::paintGlobe (this=0x81c8a3c, painter=0xbfaa787c, viewParams=0x81c8a1c, dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/TextureLayer.cpp:161
#11 0xb7626b1d in Marble::MarbleMapPrivate::paintGround (this=0x81c8a10, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:188
#12 0xb7616456 in Marble::MarbleWidget::paintEvent (this=0x8244778, evt=0xbfaa7e34) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:805
#13 0xb602160a in QWidget::event (this=0x8244778, event=0xbfaa7e34) at kernel/qwidget.cpp:8346
#14 0xb5fc6414 in QApplicationPrivate::notify_helper (this=0x80e69b8, receiver=0x8244778, e=0xbfaa7e34) at kernel/qapplication.cpp:4445
#15 0xb5fcf174 in QApplication::notify (this=0xbfaa9c94, receiver=0x8244778, e=0xbfaa7e34) at kernel/qapplication.cpp:4324
#16 0xb6fbb1f1 in KApplication::notify (this=0xbfaa9c94, receiver=0x8244778, event=0xbfaa7e34) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#17 0xb6a9dfde in QCoreApplication::notifyInternal (this=0xbfaa9c94, receiver=0x8244778, event=0xbfaa7e34) at kernel/qcoreapplication.cpp:732
#18 0xb601e2a2 in sendSpontaneousEvent (this=0x81d7790, pdev=0x8385cf4, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8380ef0) at ../../src/corelib/kernel/qcoreapplication.h:218
#19 QWidgetPrivate::drawWidget (this=0x81d7790, pdev=0x8385cf4, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8380ef0) at kernel/qwidget.cpp:5433
#20 0xb620c627 in QWidgetBackingStore::sync (this=0x8380ef0) at painting/qbackingstore.cpp:1325
#21 0xb601303b in QWidgetPrivate::syncBackingStore (this=0x81b6928) at kernel/qwidget.cpp:1816
#22 0xb60220da in QWidget::event (this=0x8133c58, event=0xbfaa8954) at kernel/qwidget.cpp:8493
#23 0xb644d29c in QMainWindow::event (this=0x8133c58, event=0xbfaa8954) at widgets/qmainwindow.cpp:1478
#24 0xb707eae4 in KMainWindow::event (this=0x8133c58, ev=0xbfaa8954) at /usr/src/debug/kdelibs-4.6.0/kdeui/widgets/kmainwindow.cpp:1100
#25 0xb707ed82 in KXmlGuiWindow::event (this=0x8133c58, ev=0xbfaa8954) at /usr/src/debug/kdelibs-4.6.0/kdeui/xmlgui/kxmlguiwindow.cpp:126
#26 0xb5fc6414 in QApplicationPrivate::notify_helper (this=0x80e69b8, receiver=0x8133c58, e=0xbfaa8954) at kernel/qapplication.cpp:4445
#27 0xb5fcf174 in QApplication::notify (this=0xbfaa9c94, receiver=0x8133c58, e=0xbfaa8954) at kernel/qapplication.cpp:4324
#28 0xb6fbb1f1 in KApplication::notify (this=0xbfaa9c94, receiver=0x8133c58, event=0xbfaa8954) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#29 0xb6a9dfde in QCoreApplication::notifyInternal (this=0xbfaa9c94, receiver=0x8133c58, event=0xbfaa8954) at kernel/qcoreapplication.cpp:732
#30 0xb6208be9 in sendEvent (this=0x8380ef0, rect=..., widget=0x8244778, updateImmediately=true, invalidateBuffer=false) at ../../src/corelib/kernel/qcoreapplication.h:215
#31 sendUpdateRequest (this=0x8380ef0, rect=..., widget=0x8244778, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:507
#32 QWidgetBackingStore::markDirty (this=0x8380ef0, rect=..., widget=0x8244778, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:695
#33 0xb6012782 in QWidget::repaint (this=0x8244778, rect=...) at kernel/qwidget.cpp:10250
#34 0xb60128a1 in QWidget::repaint (this=0x8244778) at kernel/qwidget.cpp:10206
#35 0xb7619c6c in repaint (this=0x8244778, newZoom=1607, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:272
#36 Marble::MarbleWidget::zoomView (this=0x8244778, newZoom=1607, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:539
#37 0xb7619d0a in Marble::MarbleWidget::zoomViewBy (this=0x8244778, zoomStep=40, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:552
#38 0xb7619d8d in Marble::MarbleWidget::zoomIn (this=0x8244778, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:558
#39 0xb761bbbc in Marble::MarbleWidget::qt_metacall (this=0x8244778, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfaa8b9c) at /usr/src/debug/kdeedu-4.6.0/build/marble/src/lib/MarbleWidget.moc:310
#40 0xb6aa48cd in QMetaObject::metacall (object=0x8244778, cl=QMetaObject::InvokeMetaMethod, idx=47, argv=0xbfaa8b9c) at kernel/qmetaobject.cpp:237
#41 0xb6ab4a2c in QMetaObject::activate (sender=0x81b7db0, m=0xb77cf550, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3272
#42 0xb762b675 in Marble::NavigationWidget::zoomIn (this=0x81b7db0) at /usr/src/debug/kdeedu-4.6.0/build/marble/src/lib/NavigationWidget.moc:136
#43 0xb762b9a4 in Marble::NavigationWidget::qt_metacall (this=0x81b7db0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfaa8cf8) at /usr/src/debug/kdeedu-4.6.0/build/marble/src/lib/NavigationWidget.moc:102
#44 0xb6aa48cd in QMetaObject::metacall (object=0x81b7db0, cl=QMetaObject::InvokeMetaMethod, idx=28, argv=0xbfaa8cf8) at kernel/qmetaobject.cpp:237
#45 0xb6ab4a2c in QMetaObject::activate (sender=0x81ed680, m=0xb692f824, local_signal_index=2, argv=0xbfaa8cf8) at kernel/qobject.cpp:3272
#46 0xb66e86cd in QAbstractButton::clicked (this=0x81ed680, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#47 0xb63e35ad in QAbstractButtonPrivate::emitClicked (this=0x8210c50) at widgets/qabstractbutton.cpp:546
#48 0xb63e4e8b in QAbstractButtonPrivate::click (this=0x8210c50) at widgets/qabstractbutton.cpp:539
#49 0xb63e5146 in QAbstractButton::mouseReleaseEvent (this=0x81ed680, e=0xbfaa9424) at widgets/qabstractbutton.cpp:1121
#50 0xb64bc54d in QToolButton::mouseReleaseEvent (this=0x81ed680, e=0xbfaa9424) at widgets/qtoolbutton.cpp:721
#51 0xb60215b0 in QWidget::event (this=0x81ed680, event=0xbfaa9424) at kernel/qwidget.cpp:8200
#52 0xb63e4160 in QAbstractButton::event (this=0x81ed680, e=0xbfaa9424) at widgets/qabstractbutton.cpp:1080
#53 0xb64bdcbc in QToolButton::event (this=0x81ed680, event=0xbfaa9424) at widgets/qtoolbutton.cpp:1163
#54 0xb5fc6414 in QApplicationPrivate::notify_helper (this=0x80e69b8, receiver=0x81ed680, e=0xbfaa9424) at kernel/qapplication.cpp:4445
#55 0xb5fcfc20 in QApplication::notify (this=0xbfaa913c, receiver=0x81ed680, e=0xbfaa9424) at kernel/qapplication.cpp:4006
#56 0xb6fbb1f1 in KApplication::notify (this=0xbfaa9c94, receiver=0x81ed680, event=0xbfaa9424) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#57 0xb6a9dfde in QCoreApplication::notifyInternal (this=0xbfaa9c94, receiver=0x81ed680, event=0xbfaa9424) at kernel/qcoreapplication.cpp:732
#58 0xb5fc745c in sendSpontaneousEvent (receiver=0x81ed680, event=0xbfaa9424, alienWidget=0x81ed680, nativeWidget=0x8133c58, buttonDown=0xb6938c00, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:218
#59 QApplicationPrivate::sendMouseEvent (receiver=0x81ed680, event=0xbfaa9424, alienWidget=0x81ed680, nativeWidget=0x8133c58, buttonDown=0xb6938c00, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3103
#60 0xb6053030 in QETWidget::translateMouseEvent (this=0x8133c58, event=0xbfaa993c) at kernel/qapplication_x11.cpp:4438
#61 0xb605213e in QApplication::x11ProcessEvent (this=0xbfaa9c94, event=0xbfaa993c) at kernel/qapplication_x11.cpp:3442
#62 0xb607c960 in x11EventSourceDispatch (s=0x80de0b0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#63 0xb3fc6509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#64 0xb3fc6d10 in ?? () from /lib/libglib-2.0.so.0
#65 0xb3fc6fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#66 0xb6acc76b in QEventDispatcherGlib::processEvents (this=0x80d1298, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#67 0xb607c55a in QGuiEventDispatcherGlib::processEvents (this=0x80d1298, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#68 0xb6a9d2bd in QEventLoop::processEvents (this=0xbfaa9bf4, flags=...) at kernel/qeventloop.cpp:149
#69 0xb6a9d4e9 in QEventLoop::exec (this=0xbfaa9bf4, flags=...) at kernel/qeventloop.cpp:201
#70 0xb6aa1f90 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#71 0xb5fc4104 in QApplication::exec () at kernel/qapplication.cpp:3719
#72 0x08065935 in main (argc=) at /usr/src/debug/kdeedu-4.6.0/marble/src/kdemain.cpp:351

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-03-23 20:30:02 UTC

*** This bug has been marked as a duplicate of bug 265599 ***