Bug 256900 - Knetworkmanager crashed after restart from "suspend to disk"
Summary: Knetworkmanager crashed after restart from "suspend to disk"
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-14 18:34 UTC by sagenhaftA
Modified: 2011-03-16 04:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sagenhaftA 2010-11-14 18:34:27 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.5.3 (KDE 4.5.3) "release 8"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-default x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Nearly every time, when i restart the system from a "suspend to disk", knetworkmanger crashs.

knetworkmanger starts after that without problems.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  ref (this=0x99eda0) at /usr/include/QtCore/qatomic_x86_64.h:121
#7  QString (this=0x99eda0) at /usr/include/QtCore/qstring.h:715
#8  Knm::Activatable::deviceUni (this=0x99eda0) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#9  0x00007fe1a7fadee8 in compareDevices (first=0x99eda0, second=0x81d8b0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:263
#10 0x00007fe1a7fae213 in activatableLessThan (first=0x99eda0, second=0x81d8b0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:173
#11 0x00007fe1a7faecea in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=
    @0x793c98, lessThan=0x7fe1a7fae1f0 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:351
#12 0x00007fe1a7faeba8 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleUpdate (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:105
#14 0x00007fe1a7f9f5c3 in ActivatableList::activatableChanged (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:144
#15 0x00007fe1a7f9b248 in ActivatableList::qt_metacall (this=0x786eb0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2ea232e0)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_activatablelist.cpp:74
#16 0x00007fe1a758fa1f in QMetaObject::activate (sender=0x81d8b0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#17 0x00007fe1a81e6c31 in Knm::InterfaceConnection::setActivationState (this=0x81d8b0, state=<value optimized out>) at /usr/src/debug/networkmanagement/libs/internals/interfaceconnection.cpp:82
#18 0x00007fe1a7d7686d in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x7fe7c0, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:58
#19 0x00007fe1a7d76899 in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x7fe7c0, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:60
#20 0x00007fe1a7d78a97 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*>::const_iterator> (begin=<value optimized out>, end=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#21 0x00007fe1a7d778a6 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*> > (this=<value optimized out>, status=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#22 NMDBusActiveConnectionMonitor::networkingStatusChanged (this=<value optimized out>, status=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:246
#23 0x00007fe1a7d4ed80 in NMDBusActiveConnectionMonitor::qt_metacall (this=0x7e3310, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2ea234b0)
    at /usr/src/debug/networkmanagement/build/backends/NetworkManager/moc_nmdbusactiveconnectionmonitor.cpp:78
#24 0x00007fe1a758fa1f in QMetaObject::activate (sender=0x7786e0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff2ea234b0) at kernel/qobject.cpp:3295
#25 0x00007fe1a7b224ce in Solid::Control::NetworkManager::Notifier::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/networkmanager.moc:100
#26 0x00007fe1a7b226e3 in Solid::Control::NetworkManager::Notifier::qt_metacall (this=0x7786e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2ea23610)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/networkmanager.moc:83
#27 0x00007fe1a7b22ab0 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x7786e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2ea23610)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/networkmanager_p.moc:76
#28 0x00007fe1a758fa1f in QMetaObject::activate (sender=0x765ec0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff2ea23610) at kernel/qobject.cpp:3295
#29 0x00007fe1a30eeb4e in Solid::Control::Ifaces::NetworkManager::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/ifaces/networkmanager.moc:108
#30 0x00007fe1983f3dab in NMNetworkManager::qt_metacall (this=0x765ec0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2ea23770)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/manager.moc:97
#31 0x00007fe1a758fa1f in QMetaObject::activate (sender=0x7bd900, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff2ea23770) at kernel/qobject.cpp:3295
#32 0x00007fe1983e6b41 in OrgFreedesktopNetworkManagerInterface::StateChanged (this=<value optimized out>, _t1=1)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:176
#33 0x00007fe1983eefce in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x7bd900, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fff2ea23bb0)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:105
#34 0x00007fe1a78b3188 in QDBusConnectionPrivate::deliverCall (this=0x7727d0, object=0x7bd900, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:904
#35 0x00007fe1a78bfecf in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#36 0x00007fe1a758d509 in QObject::event (this=0x7bd900, e=0xb4a010) at kernel/qobject.cpp:1248
#37 0x00007fe1a696d4d4 in QApplicationPrivate::notify_helper (this=0x668220, receiver=0x7bd900, e=0xb4a010) at kernel/qapplication.cpp:4302
#38 0x00007fe1a6975aca in QApplication::notify (this=<value optimized out>, receiver=0x7bd900, e=0xb4a010) at kernel/qapplication.cpp:4185
#39 0x00007fe1a889a7b6 in KApplication::notify (this=0x7fff2ea24690, receiver=0x7bd900, event=0xb4a010) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:310
#40 0x00007fe1a757be4c in QCoreApplication::notifyInternal (this=0x7fff2ea24690, receiver=0x7bd900, event=0xb4a010) at kernel/qcoreapplication.cpp:726
#41 0x00007fe1a757f5ba in sendEvent (receiver=0x0, event_type=0, data=0x632220) at kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x632220) at kernel/qcoreapplication.cpp:1367
#43 0x00007fe1a75a4173 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#44 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#45 0x00007fe1a23e6a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#46 0x00007fe1a23e7270 in ?? () from /usr/lib64/libglib-2.0.so.0
#47 0x00007fe1a23e7510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#48 0x00007fe1a75a467f in QEventDispatcherGlib::processEvents (this=0x6378b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#49 0x00007fe1a6a0e14e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#50 0x00007fe1a757b292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#51 0x00007fe1a757b495 in QEventLoop::exec (this=0x7fff2ea245e0, flags=...) at kernel/qeventloop.cpp:201
#52 0x00007fe1a757f88b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#53 0x000000000040eb73 in _start ()

This bug may be a duplicate of or related to bug 254112, bug 235015.

Possible duplicates by query: bug 256779, bug 256631, bug 256165, bug 255456, bug 255159.

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-17 19:47:55 UTC
[Comment from a bug triager]
This is probably related to bug 256631/bug 210878/bug 215918.
Thanks
Comment 2 Lamarque V. Souza 2011-03-16 04:19:43 UTC

*** This bug has been marked as a duplicate of bug 210878 ***