Bug 215918 - knetworkmanager crashes when restarting NetworkManager
Summary: knetworkmanager crashes when restarting NetworkManager
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: knetworkmanager (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
: 237771 250541 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-24 01:10 UTC by David Benjamin
Modified: 2011-03-19 21:40 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.45 KB, text/plain)
2010-08-01 19:45 UTC, Mikołaj Pastuszko
Details
New crash information added by DrKonqi (6.38 KB, text/plain)
2010-08-08 12:50 UTC, fake name
Details
New crash information added by DrKonqi (7.20 KB, text/plain)
2010-08-12 15:33 UTC, Olaf Dabrunz
Details
New crash information added by DrKonqi (6.68 KB, text/plain)
2010-08-14 21:24 UTC, Yevgeny Kosarzhevsky
Details
backtrace knetworkmanager crash (7.71 KB, text/plain)
2010-09-20 20:12 UTC, Mike Schneider
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Benjamin 2009-11-24 01:10:35 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
When restarting NetworkManager (Ubuntu Karmic, via service restart network-manager), knetworkmanager consistently crashes. The backtrace appears to be different from the other ones, so here's another report.

(This Crash Reporting Assistant is rather fancy; I'm impressed. Although, it's not so good about noticing reports that are duplicates of candidates for duplicates.)

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  0x0000000000000030 in ?? ()
#6  0x00007fb6ade4b519 in QMetaObject::cast (this=0x625f20, obj=0x2abe2d0) at kernel/qmetaobject.cpp:299
#7  0x00007fb6af40b2fa in qobject_cast<Knm::InterfaceConnection const*> (first=0x2abe2d0, second=0x208e300) at /usr/include/qt4/QtCore/qobject.h:456
#8  activatableLessThan (first=0x2abe2d0, second=0x208e300) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:184
#9  0x00007fb6af40b5de in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=)
    at /usr/include/qt4/QtCore/qalgorithms.h:394
#10 0x00007fb6af40b72c in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x1fb02a0, activatable=<value optimized out>)
    at /usr/include/qt4/QtCore/qalgorithms.h:204
#11 SortedActivatableList::handleAdd (this=0x1fb02a0, activatable=<value optimized out>) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:100
#12 0x00007fb6af3fb06b in ActivatableList::addActivatableInternal (this=0x1fcf580, activatable=0x264b900)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:94
#13 0x00007fb6af3fe5dd in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x207ac60, addedConnection=<value optimized out>)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#14 0x00007fb6af3fc490 in NetworkInterfaceActivatableProvider::init (this=0x207ac60)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfaceactivatableprovider.cpp:64
#15 0x00007fb6af3fb7d8 in NetworkInterfaceMonitor::networkInterfaceAdded (this=<value optimized out>, uni=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfacemonitor.cpp:79
#16 0x00007fb6af3f51fd in NetworkInterfaceMonitor::qt_metacall (this=0x2078160, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff21f8c760)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/obj-x86_64-linux-gnu/libs/service/moc_networkinterfacemonitor.cpp:69
#17 0x00007fb6ade5bddc in QMetaObject::activate (sender=0x1fcf2a0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#18 0x00007fb6aef772c5 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#19 0x00007fb6aef77c7c in ?? () from /usr/lib/libsolidcontrol.so.4
#20 0x00007fb6ade5bddc in QMetaObject::activate (sender=0x200e450, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#21 0x00007fb6a4f159c5 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#22 0x00007fb6a4f16d84 in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#23 0x00007fb6a4f19c39 in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#24 0x00007fb6ade5bddc in QMetaObject::activate (sender=0x1f83e10, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#25 0x00007fb6a4f25282 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#26 0x00007fb6a4f256ad in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#27 0x00007fb6ae15dad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#28 0x00007fb6ae164def in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#29 0x00007fb6ade560f9 in QObject::event (this=0x1f83e10, e=0x2ab9410) at kernel/qobject.cpp:1111
#30 0x00007fb6ae54aefc in QApplicationPrivate::notify_helper (this=0x1f27340, receiver=0x1f83e10, e=0x2ab9410) at kernel/qapplication.cpp:4056
#31 0x00007fb6ae5521ce in QApplication::notify (this=0x7fff21f8d8a0, receiver=0x1f83e10, e=0x2ab9410) at kernel/qapplication.cpp:4021
#32 0x00007fb6afc95ab6 in KApplication::notify (this=0x7fff21f8d8a0, receiver=0x1f83e10, event=0x2ab9410) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x00007fb6ade46c2c in QCoreApplication::notifyInternal (this=0x7fff21f8d8a0, receiver=0x1f83e10, event=0x2ab9410) at kernel/qcoreapplication.cpp:610
#34 0x00007fb6ade4780a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1f014d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#35 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1f014d0) at kernel/qcoreapplication.cpp:1247
#36 0x00007fb6ade6f533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#37 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#38 0x00007fb6a9dc6bbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#39 0x00007fb6a9dca588 in ?? () from /lib/libglib-2.0.so.0
#40 0x00007fb6a9dca6b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#41 0x00007fb6ade6f1a6 in QEventDispatcherGlib::processEvents (this=0x1f00d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#42 0x00007fb6ae5df4be in QGuiEventDispatcherGlib::processEvents (this=0x2abe2d0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#43 0x00007fb6ade45532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#44 0x00007fb6ade45904 in QEventLoop::exec (this=0x7fff21f8d7f0, flags=) at kernel/qeventloop.cpp:201
#45 0x00007fb6ade47ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#46 0x000000000040d12f in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/monolithic/main.cpp:45

This bug may be a duplicate of or related to bug 213237

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-24 02:03:36 UTC
The backtrace is indeed a bit different, but it is probably related to bug 210878.
@Will: what do you think ?

Offtopic: the duplicate handling was already improved in KDE4.4 (4.3.4 should get a minor fix to display more accurate possible duplicates too...)

Regards
Comment 2 Will Stephenson 2010-01-05 17:18:05 UTC
Dario: I agree but I'm keeping it open
Comment 3 Mikołaj Pastuszko 2010-08-01 19:45:51 UTC
Created attachment 49732 [details]
New crash information added by DrKonqi

Knetworkmanager crashed when tried to restart networkmanager
Comment 4 Christoph Feck 2010-08-06 11:53:51 UTC
*** Bug 237771 has been marked as a duplicate of this bug. ***
Comment 5 fake name 2010-08-08 12:50:40 UTC
Created attachment 49915 [details]
New crash information added by DrKonqi

knetworkmanager (v0.9) on KDE Platform 4.4.95 (KDE 4.4.95 (KDE 4.5 >= 20100723)) using Qt 4.6.3

- What I was doing when the application crashed:

I restarted NetworkManager with the command /etc/init.d/network try-restart and then KNetworkManager crashed.

-- Backtrace (Reduced):
#7  0x00007f03a5351f9a in qobject_cast<Knm::InterfaceConnection const*> (first=0x84dd90, second=0x84df30) at /usr/include/QtCore/qobject.h:468
#8  activatableLessThan (first=0x84dd90, second=0x84df30) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:183
#9  0x00007f03a5352a93 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=
    @0x711d88, lessThan=0x7f03a5351f30 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:358
#10 0x00007f03a5352817 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x78a0b0, activatable=0xb77ad0)
    at /usr/include/QtCore/qalgorithms.h:187
#11 SortedActivatableList::handleAdd (this=0x78a0b0, activatable=0xb77ad0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
Comment 6 Olaf Dabrunz 2010-08-12 15:33:01 UTC
Created attachment 50061 [details]
New crash information added by DrKonqi

I believe I may have hit the same or a similar bug. But before the crash of KNetworkmanager,
I had an update of the NetworkManger rpm and therefore restarted the network (rcnetwork restart).

Hope the backtrace helps.
Comment 7 Yevgeny Kosarzhevsky 2010-08-14 21:24:02 UTC
Created attachment 50560 [details]
New crash information added by DrKonqi

knetwork manager crashed when network manager restarted
Comment 8 Nicolas L. 2010-09-08 12:03:59 UTC
*** Bug 250541 has been marked as a duplicate of this bug. ***
Comment 9 Mike Schneider 2010-09-20 20:12:47 UTC
Created attachment 51828 [details]
backtrace knetworkmanager crash

Qt: 4.6.3
KDE: 4.4.4 (KDE 4.4.4) "release 2"
KNetworkManager: v0.9
from opensuse package NetworkManager-kde4  0.9.svn1057339 Release 4.1
Comment 10 Lamarque V. Souza 2011-03-19 21:40:38 UTC

*** This bug has been marked as a duplicate of bug 210878 ***