Bug 256631 - KDE service crash on network restart
Summary: KDE service crash on network restart
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
: 256779 257453 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-11 21:12 UTC by Alex Minton
Modified: 2011-02-04 15:15 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.45 KB, text/plain)
2010-12-06 11:02 UTC, nils.giordano
Details
New crash information added by DrKonqi (8.96 KB, text/plain)
2010-12-13 15:16 UTC, fake name
Details
New crash information added by DrKonqi (6.26 KB, text/plain)
2011-01-23 17:00 UTC, Odair Trujillo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Minton 2010-11-11 21:12:49 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.3 (KDE 4.5.3) "release 8"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I'm running openSUSE 11.3 on Dell Inspiron 1564 with Broadcom 4315 wifi chip. When I noticed I have no Internet connection I checked on it and found out I have no drivers loaded, so I just did "modprobe b43" and "rcnetwork restart" to make NetworkManager find my wifi adapter again, which was working fine till last reboot. That's when I got this DrKonqi dialog.

-- Backtrace:
Application: Служба KDE (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  ref (this=0x9027a0) at /usr/include/QtCore/qatomic_x86_64.h:121
#7  QString (this=0x9027a0) at /usr/include/QtCore/qstring.h:715
#8  Knm::Activatable::deviceUni (this=0x9027a0) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#9  0x00007f160bbe8ee8 in compareDevices (first=0x9027a0, second=0x840100) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:263
#10 0x00007f160bbe9213 in activatableLessThan (first=0x9027a0, second=0x840100) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:173
#11 0x00007f160bbe9d2a in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., 
    t=@0x88d740, lessThan=0x7f160bbe91f0 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:356
#12 0x00007f160bbe9ad7 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x8397a0, activatable=0x88cea0)
    at /usr/include/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleAdd (this=0x8397a0, activatable=0x88cea0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#14 0x00007f160bbda293 in ActivatableList::notifyOnAddActivatable (this=<value optimized out>, activatable=0x88cea0) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:118
#15 0x00007f160bbddc9e in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=<value optimized out>, addedConnection=<value optimized out>)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#16 0x00007f160bbdb8cd in NetworkInterfaceActivatableProvider::init (this=0x88dbc0) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#17 0x00007f160bbdae0d in NetworkInterfaceMonitor::networkInterfaceAdded (this=<value optimized out>, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:87
#18 0x00007f160bbd61cd in NetworkInterfaceMonitor::qt_metacall (this=0x7f160c009a60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff776542f0)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#19 0x00007f16289cfa1f in QMetaObject::activate (sender=0x7f8700, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff776542f0) at kernel/qobject.cpp:3295
#20 0x00007f1613932505 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/networkmanager.moc:107
#21 0x00007f1613932ad7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x7f8700, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff77654410)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/networkmanager_p.moc:81
#22 0x00007f16289cfa1f in QMetaObject::activate (sender=0x7f3d70, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff77654410) at kernel/qobject.cpp:3295
#23 0x00007f161350eb85 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/ifaces/networkmanager.moc:115
#24 0x00007f160ae9e04a in NMNetworkManager::deviceAdded (this=0x7f3d70, objpath=...) at /usr/src/debug/kdebase-workspace-4.5.3/solid/networkmanager-0.7/manager.cpp:199
#25 0x00007f160aea7d69 in NMNetworkManager::qt_metacall (this=0x7f3d70, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff776545d0)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/manager.moc:95
#26 0x00007f16289cfa1f in QMetaObject::activate (sender=0x7f5f50, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff776545d0) at kernel/qobject.cpp:3295
#27 0x00007f160ae9aaa2 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#28 0x00007f160aea2f84 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x7f5f50, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff77654a10)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#29 0x00007f1625e00188 in QDBusConnectionPrivate::deliverCall (this=0x7b9ac0, object=0x7f5f50, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#30 0x00007f1625e0cecf in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#31 0x00007f16289cd509 in QObject::event (this=0x7f5f50, e=0x88e7b0) at kernel/qobject.cpp:1248
#32 0x00007f1627b904d4 in QApplicationPrivate::notify_helper (this=0x67f7c0, receiver=0x7f5f50, e=0x88e7b0) at kernel/qapplication.cpp:4302
#33 0x00007f1627b98aca in QApplication::notify (this=<value optimized out>, receiver=0x7f5f50, e=0x88e7b0) at kernel/qapplication.cpp:4185
#34 0x00007f16296217b6 in KApplication::notify (this=0x7fff776554f0, receiver=0x7f5f50, event=0x88e7b0) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:310
#35 0x00007f16289bbe4c in QCoreApplication::notifyInternal (this=0x7fff776554f0, receiver=0x7f5f50, event=0x88e7b0) at kernel/qcoreapplication.cpp:726
#36 0x00007f16289bf5ba in sendEvent (receiver=0x0, event_type=0, data=0x60f500) at kernel/qcoreapplication.h:215
#37 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60f500) at kernel/qcoreapplication.cpp:1367
#38 0x00007f16289e4173 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#39 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#40 0x00007f1624544a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#41 0x00007f1624545270 in ?? () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f1624545510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#43 0x00007f16289e467f in QEventDispatcherGlib::processEvents (this=0x616ba0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#44 0x00007f1627c3114e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007f16289bb292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007f16289bb495 in QEventLoop::exec (this=0x7fff77655440, flags=...) at kernel/qeventloop.cpp:201
#47 0x00007f16289bf88b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#48 0x00007f161a6a04a7 in kdemain (argc=1, argv=0x664f90) at /usr/src/debug/kdelibs-4.5.3/kded/kded.cpp:894
#49 0x00000000004074a9 in launch (argc=1, _name=0x40b267 "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40b0f7 "0") at /usr/src/debug/kdelibs-4.5.3/kinit/kinit.cpp:723
#50 0x0000000000409cba in main (argc=4, argv=0x7fff776564e8, envp=0x7fff77656510) at /usr/src/debug/kdelibs-4.5.3/kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-11-13 13:14:16 UTC
*** Bug 256779 has been marked as a duplicate of this bug. ***
Comment 2 Frank Reininghaus 2010-11-13 13:16:31 UTC
Probably related to bug 210878/bug 215918.
Comment 3 Christoph Feck 2010-11-20 23:27:39 UTC
*** Bug 257453 has been marked as a duplicate of this bug. ***
Comment 4 nils.giordano 2010-12-06 11:02:00 UTC
Created attachment 54196 [details]
New crash information added by DrKonqi

kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed:
I lost my wifi connection so I wanted to restart the network-manager service : I did "sudo service network-manager restart" and kdeinit4 crashed...

-- Backtrace (Reduced):
#6  ref (this=0x1fc9e00) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#7  QString (this=0x1fc9e00) at /usr/include/qt4/QtCore/qstring.h:728
#8  Knm::Activatable::deviceUni (this=0x1fc9e00) at ../../../libs/internals/activatable.cpp:51
#9  0x00007f9bd6199ddd in compareDevices (first=0x1fc9e00, second=0x1f7fe80) at ../../../libs/service/sortedactivatablelist.cpp:262
#10 0x00007f9bd6199f03 in activatableLessThan (first=0x7ffffd49ffc0, second=0x1fc9e00) at ../../../libs/service/sortedactivatablelist.cpp:172
Comment 5 fake name 2010-12-13 15:16:00 UTC
Created attachment 54501 [details]
New crash information added by DrKonqi

knetworkmanager (v0.9) on KDE Platform 4.5.85 (4.6 Beta2) using Qt 4.7.1

- What I was doing when the application crashed:
KnetworkManager crashed after I changed the configuration using yast. I disabled IPv6

- Unusual behavior I noticed:
I can't connect to some networks with IPv6 enabled more than some seconds, but I don't think that it's a KDE mistake.

-- Backtrace (Reduced):
#6  ref (this=0x868af0) at /usr/include/QtCore/qatomic_x86_64.h:121
#7  QString (this=0x868af0) at /usr/include/QtCore/qstring.h:729
#8  Knm::Activatable::deviceUni (this=0x868af0) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#9  0x00007fd564a45f12 in compareDevices (first=<value optimized out>, second=0x868af0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:264
#10 0x00007fd564a46213 in activatableLessThan (first=0x943470, second=0x868af0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:173
Comment 6 Odair Trujillo 2011-01-23 17:00:54 UTC
Created attachment 56352 [details]
New crash information added by DrKonqi

restarting network-manager with: service network-manager restart, the network-manager widget crash and restart.

And on the system tray the icons are overlapped.
Comment 7 Lamarque V. Souza 2011-02-04 15:15:32 UTC

*** This bug has been marked as a duplicate of bug 210878 ***