Bug 256165 - KNetworkmanager segfaults when changing "network connection" from "with ifup" to "with NetworkManager"
Summary: KNetworkmanager segfaults when changing "network connection" from "with ifup"...
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: knetworkmanager (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-05 17:39 UTC by Peter Huyoff
Modified: 2010-11-08 23:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Huyoff 2010-11-05 17:39:49 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.4-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
KNetworkmanager segfaults when changing "network connection" from "with ifup" to "with NetworkManager" in YAST->networking->global options 

The crash can be reproduced every time.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  ref (this=0x822a780) at /usr/include/QtCore/qatomic_i386.h:120
#7  QString (this=0x822a780) at /usr/include/QtCore/qstring.h:715
#8  Knm::Activatable::deviceUni (this=0x822a780) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#9  0xb6f95970 in compareDevices (first=0x822a780, second=0x834f3d0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:262
#10 0xb6f95cd2 in activatableLessThan (first=0x822a780, second=0x834f3d0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:172
#11 0xb6f967e0 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=
    @0x831a5d0, lessThan=0xb6f95ca0 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:356
#12 0xb6f965f3 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x81404b0, activatable=0x834f3d0)
    at /usr/include/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleAdd (this=0x81404b0, activatable=0x834f3d0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#14 0xb6f851d4 in ActivatableList::notifyOnAddActivatable (this=0x8115f28, activatable=0x834f3d0) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:99
#15 0xb6f85253 in ActivatableList::addActivatable (this=0x8115f28, activatable=0x834f3d0) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:83
#16 0xb6f89748 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x82f3d28, addedConnection=0x813f2a0)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:132
#17 0xb6f88222 in WirelessNetworkInterfaceActivatableProvider::networkAppeared (this=0x82f3d28, ssid=...)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:176
#18 0xb6f88b42 in WirelessNetworkInterfaceActivatableProvider::WirelessNetworkInterfaceActivatableProvider (this=0x82f3d28, connectionList=0x8103ac0, activatableList=0x8115f28, interface=0x8203608, 
    parent=0x8122b60, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:76
#19 0xb6f85d2e in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x8122b60, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:71
#20 0xb6f80b65 in NetworkInterfaceMonitor::qt_metacall (this=0x8122b60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfe7b148)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#21 0xb6d63efd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#22 0xb6d72fe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#23 0xb6f0a195 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x812a750, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager.moc:107
#24 0xb6f0a7cc in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x812a750, uni=...) at /usr/src/debug/kdebase-workspace-4.4.4/libs/solid/control/networkmanager.cpp:197
#25 0xb6f0a84e in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x812a750, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfe7b2a8)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager_p.moc:81
#26 0xb6d63efd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#27 0xb6d72fe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#28 0xb37c4135 in NMNetworkManager::networkInterfaceAdded (this=0x810f250, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:134
#29 0xb37c972a in NMNetworkManager::deviceAdded (this=0x810f250, objpath=...) at /usr/src/debug/kdebase-workspace-4.4.4/solid/networkmanager-0.7/manager.cpp:199
#30 0xb37d3f73 in NMNetworkManager::qt_metacall (this=0x810f250, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfe7b428)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:111
#31 0xb6d63efd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#32 0xb6d72fe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#33 0xb37c5745 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x8138860, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#34 0xb37ceb7f in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x8138860, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfe7b65c)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#35 0xb6e98a37 in QDBusConnectionPrivate::deliverCall (this=0x8110990, object=0x8138860, msg=..., metaTypes=..., slotIdx=-1075336260) at qdbusintegrator.cpp:904
#36 0xb6ea6536 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8276d40, object=0x8138860) at qdbusintegrator_p.h:101
#37 0xb6d7093f in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#38 0xb62b2c64 in QApplicationPrivate::notify_helper (this=0x80953b0, receiver=0x8138860, e=0x8276d40) at kernel/qapplication.cpp:4302
#39 0xb62babf7 in QApplication::notify (this=0xbfe7bec0, receiver=0x8138860, e=0x8276d40) at kernel/qapplication.cpp:3706
#40 0xb72279d1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#41 0xb6d5de0e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#42 0xb6d619b4 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#43 0xb6d61b9c in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#44 0xb6d8983d in ?? () from /usr/lib/libQtCore.so.4
#45 0xb5a51b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#46 0xb5a52350 in ?? () from /usr/lib/libglib-2.0.so.0
#47 0xb5a5260e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#48 0xb6d89d4b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#49 0xb636319a in QGuiEventDispatcherGlib::processEvents (this=0x8078610, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0xb6d5d11d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#51 0xb6d5d319 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#52 0xb6d61c70 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#53 0xb62b0164 in QApplication::exec () at kernel/qapplication.cpp:3581
#54 0x08053e59 in _start ()

Possible duplicates by query: bug 255456, bug 255159, bug 254993, bug 254112, bug 253726.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-11-08 23:05:48 UTC

*** This bug has been marked as a duplicate of bug 210878 ***