Bug 255456 - Crash when restarting network (rcnetwork restart on opensuse)
Summary: Crash when restarting network (rcnetwork restart on opensuse)
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-28 00:05 UTC by S. Burmeister
Modified: 2010-11-08 23:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2010-10-28 00:05:42 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.2 (KDE 4.5.2) "release 10"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.4-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

I had to restart the network services so I used rcnetwork restart. I think it was on the starting rather than the stopping part that the crash occured.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE-Dienst (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5977710 (LWP 2068))]

Thread 2 (Thread 0xadcf3b70 (LWP 7072)):
#0  0xb5c8622b in clock_gettime () from /lib/librt.so.1
#1  0xb6e7b75c in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0xb6e7fb16 in updateCurrentTime (this=0x8696134, tm=...) at kernel/qeventdispatcher_unix.cpp:340
#3  QTimerInfoList::timerWait (this=0x8696134, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0xb6e7e56b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xadcf313c) at kernel/qeventdispatcher_glib.cpp:136
#5  0xb6e7e60d in timerSourcePrepare (source=0x8696100, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#6  0xb5bda0c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#7  0xb5bdaf22 in ?? () from /usr/lib/libglib-2.0.so.0
#8  0xb5bdb60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#9  0xb6e7ed97 in QEventDispatcherGlib::processEvents (this=0x836e210, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0xb6e5211d in QEventLoop::processEvents (this=0xadcf32d0, flags=...) at kernel/qeventloop.cpp:149
#11 0xb6e52319 in QEventLoop::exec (this=0xadcf32d0, flags=...) at kernel/qeventloop.cpp:201
#12 0xb6d56403 in QThread::exec (this=0x8371ec8) at thread/qthread.cpp:487
#13 0xae7b3cd7 in ?? () from /usr/lib/kde4/kded_bluedevil.so
#14 0xb6d5904f in QThreadPrivate::start (arg=0x8371ec8) at thread/qthread_unix.cpp:248
#15 0xb6cdeb25 in start_thread () from /lib/libpthread.so.0
#16 0xb60cb46e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5977710 (LWP 2068)):
[KCrash Handler]
#7  ref (this=0x83e35c8) at /usr/include/QtCore/qatomic_i386.h:120
#8  QString (this=0x83e35c8) at /usr/include/QtCore/qstring.h:715
#9  Knm::Activatable::deviceUni (this=0x83e35c8) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#10 0xade44f1b in compareDevices (first=0x81d8070, second=0x83e35c8) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:263
#11 0xade45252 in activatableLessThan (first=0x81d8070, second=0x83e35c8) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:172
#12 0xade45ef8 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=
    @0x8330488, lessThan=0xade45220 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:369
#13 0xade45b73 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x81eda88, activatable=0x869b3d8)
    at /usr/include/QtCore/qalgorithms.h:187
#14 SortedActivatableList::handleAdd (this=0x81eda88, activatable=0x869b3d8) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#15 0xade342d4 in ActivatableList::notifyOnAddActivatable (this=0x81df1d0, activatable=0x869b3d8) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:99
#16 0xade34353 in ActivatableList::addActivatable (this=0x81df1d0, activatable=0x869b3d8) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:83
#17 0xade38226 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x83b64f8, addedConnection=0x81d1830)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#18 0xade359e9 in NetworkInterfaceActivatableProvider::init (this=0x83b64f8) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#19 0xade34dcd in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x81c7dd0, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:87
#20 0xade2fc65 in NetworkInterfaceMonitor::qt_metacall (this=0x81c7dd0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd6ccc8)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#21 0xb6e58efd in QMetaObject::metacall (object=0x81c7dd0, cl=QMetaObject::InvokeMetaMethod, idx=4, argv=0xbfd6ccc8) at kernel/qmetaobject.cpp:237
#22 0xb6e67fe8 in QMetaObject::activate (sender=0x81b9f18, m=0xb06c2560, local_signal_index=1, argv=0xbfd6ccc8) at kernel/qobject.cpp:3295
#23 0xb06a2d25 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x81b9f18, _t1=...) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager.moc:107
#24 0xb06a335c in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x81b9f18, uni=...) at /usr/src/debug/kdebase-workspace-4.5.2/libs/solid/control/networkmanager.cpp:197
#25 0xb06a33de in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x81b9f18, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd6ce28)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager_p.moc:81
#26 0xb6e58efd in QMetaObject::metacall (object=0x81b9f18, cl=QMetaObject::InvokeMetaMethod, idx=10, argv=0xbfd6ce28) at kernel/qmetaobject.cpp:237
#27 0xb6e67fe8 in QMetaObject::activate (sender=0x81b4ca8, m=0xb068b950, local_signal_index=1, argv=0xbfd6ce28) at kernel/qobject.cpp:3295
#28 0xb0686a85 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=0x81b4ca8, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/ifaces/networkmanager.moc:115
#29 0xadd060ea in NMNetworkManager::deviceAdded (this=0x81b4ca8, objpath=...) at /usr/src/debug/kdebase-workspace-4.5.2/solid/networkmanager-0.7/manager.cpp:199
#30 0xadd0e92b in NMNetworkManager::qt_metacall (this=0x81b4ca8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd6cfa8)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/manager.moc:95
#31 0xb6e58efd in QMetaObject::metacall (object=0x81b4ca8, cl=QMetaObject::InvokeMetaMethod, idx=15, argv=0xbfd6cfa8) at kernel/qmetaobject.cpp:237
#32 0xb6e67fe8 in QMetaObject::activate (sender=0x81c9ae8, m=0xadd1c6e4, local_signal_index=0, argv=0xbfd6cfa8) at kernel/qobject.cpp:3295
#33 0xadd02d85 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x81c9ae8, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#34 0xadd097b6 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x81c9ae8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd6d14c)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#35 0xb5e90a37 in QDBusConnectionPrivate::deliverCall (this=0x81b0ad0, object=0x81c9ae8, msg=..., metaTypes=..., slotIdx=-1076443096) at qdbusintegrator.cpp:904
#36 0xb5e9e536 in QDBusCallDeliveryEvent::placeMetaCall (this=0x868bfa0, object=0x81c9ae8) at qdbusintegrator_p.h:101
#37 0xb6e6593f in QObject::event (this=0x81c9ae8, e=0x868bfa0) at kernel/qobject.cpp:1248
#38 0xb638bc64 in QApplicationPrivate::notify_helper (this=0x80ab750, receiver=0x81c9ae8, e=0x868bfa0) at kernel/qapplication.cpp:4302
#39 0xb6393bf7 in QApplication::notify (this=0xbfd6d9b0, receiver=0x81c9ae8, e=0x868bfa0) at kernel/qapplication.cpp:3706
#40 0xb7471941 in KApplication::notify (this=0xbfd6d9b0, receiver=0x81c9ae8, event=0x868bfa0) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#41 0xb6e52e0e in QCoreApplication::notifyInternal (this=0xbfd6d9b0, receiver=0x81c9ae8, event=0x868bfa0) at kernel/qcoreapplication.cpp:726
#42 0xb6e569b4 in sendEvent (receiver=0x0, event_type=0, data=0x8057368) at kernel/qcoreapplication.h:215
#43 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8057368) at kernel/qcoreapplication.cpp:1367
#44 0xb6e56b9c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#45 0xb6e7e83d in sendPostedEvents (s=0x80ad978) at kernel/qcoreapplication.h:220
#46 postEventSourceDispatch (s=0x80ad978) at kernel/qeventdispatcher_glib.cpp:276
#47 0xb5bdab49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#48 0xb5bdb350 in ?? () from /usr/lib/libglib-2.0.so.0
#49 0xb5bdb60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#50 0xb6e7ed4b in QEventDispatcherGlib::processEvents (this=0x805bc88, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#51 0xb643c19a in QGuiEventDispatcherGlib::processEvents (this=0x805bc88, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#52 0xb6e5211d in QEventLoop::processEvents (this=0xbfd6d914, flags=...) at kernel/qeventloop.cpp:149
#53 0xb6e52319 in QEventLoop::exec (this=0xbfd6d914, flags=...) at kernel/qeventloop.cpp:201
#54 0xb6e56c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#55 0xb6389164 in QApplication::exec () at kernel/qapplication.cpp:3581
#56 0xb55941bd in kdemain (argc=1, argv=0x8099358) at /usr/src/debug/kdelibs-4.5.2/kded/kded.cpp:894
#57 0x0804e3f1 in launch (argc=1, _name=0x8052495 "kded4", args=<value optimized out>, cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=
    0x8052343 "0") at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:723
#58 0x08050df8 in main (argc=0, argv=0x0, envp=0x0) at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Christoph Feck 2010-11-08 23:07:04 UTC

*** This bug has been marked as a duplicate of bug 210878 ***