Bug 254112 - knetworkmanager crashes upon resume from suspend to ram
Summary: knetworkmanager crashes upon resume from suspend to ram
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-14 06:50 UTC by jshatch
Modified: 2010-10-23 16:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (8.63 KB, text/plain)
2010-10-21 16:51 UTC, jshatch
Details
New crash information added by DrKonqi (7.91 KB, text/plain)
2010-10-22 19:36 UTC, Mirko Stanisak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jshatch 2010-10-14 06:50:38 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.3-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I suspend the machine and resume and I get this crash.  The crash looks similar to crashes I have seen when restarting the networkmanager service but I do not know if they are the same.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  ref (this=0x7b7bb0) at /usr/include/QtCore/qatomic_x86_64.h:121
#7  QString (this=0x7b7bb0) at /usr/include/QtCore/qstring.h:728
#8  Knm::Activatable::deviceUni (this=0x7b7bb0) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#9  0x00007f962739a428 in compareDevices (first=0x7b7bb0, second=0x79c320) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:263
#10 0x00007f962739a753 in activatableLessThan (first=0x7b7bb0, second=0x79c320) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:173
#11 0x00007f962739b22a in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=
    @0x7b8460, lessThan=0x7f962739a730 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:351
#12 0x00007f962739ab48 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleUpdate (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:105
#14 0x00007f962738b7d3 in ActivatableList::activatableChanged (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:144
#15 0x00007f9627387308 in ActivatableList::qt_metacall (this=0x761980, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcb1643d0)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_activatablelist.cpp:74
#16 0x00007f962695ab5f in QMetaObject::activate (sender=0x79c320, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#17 0x00007f96275d3351 in Knm::InterfaceConnection::setActivationState (this=0x79c320, state=<value optimized out>) at /usr/src/debug/networkmanagement/libs/internals/interfaceconnection.cpp:82
#18 0x00007f96271622ed in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x65e9c0, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:58
#19 0x00007f9627162319 in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x65e9c0, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:60
#20 0x00007f96271643f7 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*>::const_iterator> (begin=<value optimized out>, end=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#21 0x00007f9627162bf6 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*> > (this=<value optimized out>, status=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#22 NMDBusActiveConnectionMonitor::networkingStatusChanged (this=<value optimized out>, status=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:246
#23 0x00007f9627139eb0 in NMDBusActiveConnectionMonitor::qt_metacall (this=0x76e670, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcb164590)
    at /usr/src/debug/networkmanagement/build/backends/NetworkManager/moc_nmdbusactiveconnectionmonitor.cpp:78
#24 0x00007f962695ab5f in QMetaObject::activate (sender=0x760160, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffcb164590) at kernel/qobject.cpp:3272
#25 0x00007f9626f0c79e in Solid::Control::NetworkManager::Notifier::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager.moc:100
#26 0x00007f9626f0c9b3 in Solid::Control::NetworkManager::Notifier::qt_metacall (this=0x760160, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcb1646e0)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager.moc:83
#27 0x00007f9626f0cd80 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x760160, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcb1646e0)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager_p.moc:76
#28 0x00007f962695ab5f in QMetaObject::activate (sender=0x771220, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffcb1646e0) at kernel/qobject.cpp:3272
#29 0x00007f9622477b4e in Solid::Control::Ifaces::NetworkManager::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/ifaces/networkmanager.moc:108
#30 0x00007f9617c88f8b in NMNetworkManager::qt_metacall (this=0x771220, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcb164830)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/manager.moc:97
#31 0x00007f962695ab5f in QMetaObject::activate (sender=0x771320, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffcb164830) at kernel/qobject.cpp:3272
#32 0x00007f9617c7bc71 in OrgFreedesktopNetworkManagerInterface::StateChanged (this=<value optimized out>, _t1=1)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:176
#33 0x00007f9617c843de in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x771320, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fffcb164c70)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:105
#34 0x00007f9626c9c3f8 in QDBusConnectionPrivate::deliverCall (this=0x755ba0, object=0x771320, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:919
#35 0x00007f9626ca7f9f in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#36 0x00007f96269597da in QObject::event (this=0x771320, e=<value optimized out>) at kernel/qobject.cpp:1211
#37 0x00007f9625d08f34 in QApplicationPrivate::notify_helper (this=0x65eaf0, receiver=0x771320, e=0x7d4e90) at kernel/qapplication.cpp:4396
#38 0x00007f9625d1135a in QApplication::notify (this=<value optimized out>, receiver=0x771320, e=0x7d4e90) at kernel/qapplication.cpp:4277
#39 0x00007f9627c85846 in KApplication::notify (this=0x7fffcb165750, receiver=0x771320, event=0x7d4e90) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#40 0x00007f96269459dc in QCoreApplication::notifyInternal (this=0x7fffcb165750, receiver=0x771320, event=0x7d4e90) at kernel/qcoreapplication.cpp:732
#41 0x00007f9626949185 in sendEvent (receiver=0x0, event_type=0, data=0x6322e0) at kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6322e0) at kernel/qcoreapplication.cpp:1373
#43 0x00007f9626970463 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#44 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#45 0x00007f962176ba93 in g_main_dispatch (context=0x661120) at gmain.c:1960
#46 IA__g_main_context_dispatch (context=0x661120) at gmain.c:2513
#47 0x00007f962176c270 in g_main_context_iterate (context=0x661120, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#48 0x00007f962176c510 in IA__g_main_context_iteration (context=0x661120, may_block=1) at gmain.c:2654
#49 0x00007f96269705ff in QEventDispatcherGlib::processEvents (this=0x637970, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#50 0x00007f9625daceee in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x00007f9626944e12 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#52 0x00007f9626945025 in QEventLoop::exec (this=0x7fffcb1656a0, flags=...) at kernel/qeventloop.cpp:201
#53 0x00007f962694943b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#54 0x000000000040ec33 in _start ()

Possible duplicates by query: bug 253726, bug 249270, bug 249226, bug 248662, bug 248408.

Reported using DrKonqi
Comment 1 jshatch 2010-10-21 16:51:09 UTC
Created attachment 52720 [details]
New crash information added by DrKonqi

knetworkmanager (v0.9) on KDE Platform 4.5.2 (KDE 4.5.2) using Qt 4.7.0

- What I was doing when the application crashed:

Every time I resume from suspend it does this.  I have updated to the latest code available in the update channel I am subscribed to.  Same behavior.

-- Backtrace (Reduced):
#6  ref (this=0x7c4c30) at /usr/include/QtCore/qatomic_x86_64.h:121
#7  QString (this=0x7c4c30) at /usr/include/QtCore/qstring.h:728
#8  Knm::Activatable::deviceUni (this=0x7c4c30) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#9  0x00007f6d404a7428 in compareDevices (first=0x7c4c30, second=0x79cad0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:263
#10 0x00007f6d404a7753 in activatableLessThan (first=0x7c4c30, second=0x79cad0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:173
Comment 2 Mirko Stanisak 2010-10-22 19:36:11 UTC
Created attachment 52774 [details]
New crash information added by DrKonqi

knetworkmanager (v0.9) on KDE Platform 4.5.2 (KDE 4.5.2) using Qt 4.7.0

After a suspend to RAM, KNetworkManager has been crashed. After restarting the application, everything worked well again.

-- Backtrace (Reduced):
#6  ref (this=0x7d5690) at /usr/include/QtCore/qatomic_x86_64.h:121
#7  QString (this=0x7d5690) at /usr/include/QtCore/qstring.h:728
#8  Knm::Activatable::deviceUni (this=0x7d5690) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#9  0x00007f532d17224d in compareDevices (first=0x7d5690, second=0x7c51d0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:263
#10 0x00007f532d172373 in activatableLessThan (first=0x7fff5a8d26f0, second=0x7d5690) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:173
Comment 3 Christoph Feck 2010-10-23 16:02:32 UTC

*** This bug has been marked as a duplicate of bug 210878 ***