Bug 254523 - KDE Crash after starup
Summary: KDE Crash after starup
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: 0.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-18 06:12 UTC by Gustavo
Modified: 2010-11-24 19:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo 2010-10-18 06:12:06 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-23-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
The KDE crash after show my desktop.  I have to restart the computer between 2 to 3 times before I can operate normally.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: El gestor de sesiones de KDE (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00b99a27 in _IceTransGetConnectionNumber () from /usr/lib/libICE.so.6
#7  0x02226853 in KSMServer::newConnection (this=0x8c643b0) at ../../ksmserver/server.cpp:831
#8  0x02229acf in KSMServer::qt_metacall (this=0x8c643b0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf869848) at ./server.moc:113
#9  0x067dbc9a in QMetaObject::metacall (object=0x8c643b0, cl=147420968, idx=5, argv=0xbf869848) at kernel/qmetaobject.cpp:237
#10 0x067ea3d5 in QMetaObject::activate (sender=0x8c881c8, m=0x68ea550, local_signal_index=0, argv=0xbf869848) at kernel/qobject.cpp:3293
#11 0x0683b933 in QSocketNotifier::activated (this=0x8c881c8, _t1=10) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#12 0x067f18e7 in QSocketNotifier::event (this=0x8c881c8, e=0xbf869cd4) at kernel/qsocketnotifier.cpp:317
#13 0x030464dc in QApplicationPrivate::notify_helper (this=0x8bb09b0, receiver=0x8c881c8, e=0xbf869cd4) at kernel/qapplication.cpp:4300
#14 0x0304d05e in QApplication::notify (this=0x8bb08c8, receiver=0x8c881c8, e=0xbf869cd4) at kernel/qapplication.cpp:3704
#15 0x00ea4f2a in KApplication::notify (this=0x8bb08c8, receiver=0x8c881c8, event=0xbf869cd4) at ../../kdeui/kernel/kapplication.cpp:302
#16 0x067d6a3b in QCoreApplication::notifyInternal (this=0x8bb08c8, receiver=0x8c881c8, event=0xbf869cd4) at kernel/qcoreapplication.cpp:704
#17 0x068029aa in QCoreApplication::sendEvent (source=0x8bd5d58) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#18 socketNotifierSourceDispatch (source=0x8bd5d58) at kernel/qeventdispatcher_glib.cpp:110
#19 0x047875e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#20 0x0478b2d8 in ?? () from /lib/libglib-2.0.so.0
#21 0x0478b4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#22 0x068025d5 in QEventDispatcherGlib::processEvents (this=0x8b5cb48, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#23 0x03106135 in QGuiEventDispatcherGlib::processEvents (this=0x8b5cb48, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x067d5059 in QEventLoop::processEvents (this=0xbf869f74, flags=) at kernel/qeventloop.cpp:149
#25 0x067d54aa in QEventLoop::exec (this=0xbf869f74, flags=...) at kernel/qeventloop.cpp:201
#26 0x067d969f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#27 0x03046577 in QApplication::exec () at kernel/qapplication.cpp:3579
#28 0x02223d03 in kdemain (argc=1, argv=0x8b9bf10) at ../../ksmserver/main.cpp:311
#29 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x8b98946 "/home/gustavo", envc=27, envs=0x8b98958 "KDE_FULL_SESSION=true", 
    reset_env=true, tty=0x8b98cdc "", avoid_loops=false, startup_id_str=0x8b98ce1 "") at ../../kinit/kinit.cpp:717
#30 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#31 0x0804f16f in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1393
#32 0x0804fe4f in main (argc=4, argv=0xbf86aae4, envp=0xbf86aaf8) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 234557.

Possible duplicates by query: bug 250351, bug 240670, bug 239900, bug 238067, bug 237184.

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-24 19:19:45 UTC
[Comment from a bug triager]
This issue is being tracked at bug 195034. Merging. Thanks

*** This bug has been marked as a duplicate of bug 195034 ***