Bug 238067 - ksmserver crashed on startup
Summary: ksmserver crashed on startup
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: 0.4
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-18 18:43 UTC by Mikko Karjalainen
Modified: 2010-05-21 18:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikko Karjalainen 2010-05-18 18:43:32 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-21-generic i686
Distribution: Debian GNU/Linux 5.0.4 (lenny)

-- Information about the crash:
After updating to KDE to 4.4 ksmserver crashed on startup on the first boot. Also my desktop is blank. Some programs I had open in the last session opened normally but there's no desktop and no plasma. I will reboot again and see what happens.

 -- Backtrace:
Application: KDE:n istunnonhallinta (ksmserver), signal: Segmentation fault
[KCrash Handler]
#6  0x001aada7 in _IceTransGetConnectionNumber () from /usr/lib/libICE.so.6
#7  0x00a7a7e3 in KSMServer::newConnection (this=0x8144770) at ../../ksmserver/server.cpp:831
#8  0x00a7c8bf in KSMServer::qt_metacall (this=0x8144770, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfba7478) at ./server.moc:113
#9  0x053aaaea in QMetaObject::metacall (object=0x8144770, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0xbfba7478) at kernel/qmetaobject.cpp:237
#10 0x053b90b5 in QMetaObject::activate (sender=0x815cd78, m=0x54b86b0, local_signal_index=0, argv=0xbfba7478) at kernel/qobject.cpp:3293
#11 0x0540a7b3 in QSocketNotifier::activated (this=0x815cd78, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#12 0x053c0617 in QSocketNotifier::event (this=0x815cd78, e=0xbfba7904) at kernel/qsocketnotifier.cpp:317
#13 0x0481abec in QApplicationPrivate::notify_helper (this=0x80a2a48, receiver=0x815cd78, e=0xbfba7904) at kernel/qapplication.cpp:4300
#14 0x0482175e in QApplication::notify (this=0x80a2980, receiver=0x815cd78, e=0xbfba7904) at kernel/qapplication.cpp:3704
#15 0x00c777da in KApplication::notify (this=0x80a2980, receiver=0x815cd78, event=0xbfba7904) at ../../kdeui/kernel/kapplication.cpp:302
#16 0x053a58eb in QCoreApplication::notifyInternal (this=0x80a2980, receiver=0x815cd78, event=0xbfba7904) at kernel/qcoreapplication.cpp:704
#17 0x053d16ca in QCoreApplication::sendEvent (source=0x80a5480) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#18 socketNotifierSourceDispatch (source=0x80a5480) at kernel/qeventdispatcher_glib.cpp:110
#19 0x025522e5 in g_main_dispatch (context=0x80a5400) at /build/buildd-glib2.0_2.24.0-1-i386-o5zIuQ/glib2.0-2.24.0/glib/gmain.c:1960
#20 IA__g_main_context_dispatch (context=0x80a5400) at /build/buildd-glib2.0_2.24.0-1-i386-o5zIuQ/glib2.0-2.24.0/glib/gmain.c:2513
#21 0x02556000 in g_main_context_iterate (context=0x80a5400, block=<value optimized out>, dispatch=1, self=0x80a2ca0) at /build/buildd-glib2.0_2.24.0-1-i386-o5zIuQ/glib2.0-2.24.0/glib/gmain.c:2591
#22 0x02556198 in IA__g_main_context_iteration (context=0x80a5400, may_block=1) at /build/buildd-glib2.0_2.24.0-1-i386-o5zIuQ/glib2.0-2.24.0/glib/gmain.c:2654
#23 0x053d12f5 in QEventDispatcherGlib::processEvents (this=0x8081bb0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#24 0x048d9255 in QGuiEventDispatcherGlib::processEvents (this=0x8081bb0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x053a3f09 in QEventLoop::processEvents (this=0xbfba7ba4, flags=) at kernel/qeventloop.cpp:149
#26 0x053a435a in QEventLoop::exec (this=0xbfba7ba4, flags=...) at kernel/qeventloop.cpp:201
#27 0x053a84ef in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#28 0x0481ac87 in QApplication::exec () at kernel/qapplication.cpp:3579
#29 0x00a77cb3 in kdemain (argc=1, argv=0xbfba7e44) at ../../ksmserver/main.cpp:311
#30 0x0804860b in main (argc=1, argv=0xbfba7e44) at ksmserver_dummy.cpp:3

This bug may be a duplicate of or related to bug 195034.

Possible duplicates by query: bug 237184, bug 234557, bug 233286, bug 221568, bug 219006.

Reported using DrKonqi
Comment 1 Lubos Lunak 2010-05-21 18:22:11 UTC

*** This bug has been marked as a duplicate of bug 195034 ***