Bug 250351 - kde service failed at start
Summary: kde service failed at start
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: 0.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-06 12:24 UTC by Christoph Thielecke
Modified: 2010-11-24 19:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Thielecke 2010-09-06 12:24:09 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-19-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I  upgraded to 4.5.1 and sometimes some services failed at start.
Sometimes a crash like this occoured, sometimes lnusertmp failed.

-- Backtrace:
Application: Der KDE-Sitzungsmanager (ksmserver), signal: Segmentation fault
[KCrash Handler]
#7  0x0018fa27 in _IceTransGetConnectionNumber () from /usr/lib/libICE.so.6
#8  0x00207f33 in KSMServer::newConnection (this=0x9d48cd8) at ../../ksmserver/server.cpp:834
#9  0x0020acbf in KSMServer::qt_metacall (this=0x9d48cd8, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfa5e458) at ./server.moc:121
#10 0x08b11d4a in QMetaObject::metacall (object=0x9d48cd8, cl=164278816, idx=5, argv=0xbfa5e458) at kernel/qmetaobject.cpp:237
#11 0x08b24ab5 in QMetaObject::activate (sender=0x9d4c4d0, m=0x8c3d550, local_signal_index=0, argv=0xbfa5e458) at kernel/qobject.cpp:3280
#12 0x08b760a3 in QSocketNotifier::activated (this=0x9d4c4d0, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#13 0x08b297d7 in QSocketNotifier::event (this=0x9d4c4d0, e=0xbfa5e8e4) at kernel/qsocketnotifier.cpp:317
#14 0x0457377c in QApplicationPrivate::notify_helper (this=0x9c71358, receiver=0x9d4c4d0, e=0xbfa5e8e4) at kernel/qapplication.cpp:4396
#15 0x045797ce in QApplication::notify (this=0x9c712f8, receiver=0x9d4c4d0, e=0xbfa5e8e4) at kernel/qapplication.cpp:3798
#16 0x00eb7a9a in KApplication::notify (this=0x9c712f8, receiver=0x9d4c4d0, event=0xbfa5e8e4) at ../../kdeui/kernel/kapplication.cpp:310
#17 0x08b0bfeb in QCoreApplication::notifyInternal (this=0x9c712f8, receiver=0x9d4c4d0, event=0xbfa5e8e4) at kernel/qcoreapplication.cpp:732
#18 0x08b3abca in QCoreApplication::sendEvent (source=0x9c747a8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 socketNotifierSourceDispatch (source=0x9c747a8) at kernel/qeventdispatcher_glib.cpp:110
#20 0x026085e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#21 0x0260c2d8 in ?? () from /lib/libglib-2.0.so.0
#22 0x0260c4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#23 0x08b3a7f5 in QEventDispatcherGlib::processEvents (this=0x9c50568, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#24 0x04634de5 in QGuiEventDispatcherGlib::processEvents (this=0x9c50568, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x08b0aa99 in QEventLoop::processEvents (this=0xbfa5eb84, flags=) at kernel/qeventloop.cpp:149
#26 0x08b0af1a in QEventLoop::exec (this=0xbfa5eb84, flags=...) at kernel/qeventloop.cpp:201
#27 0x08b0f4cf in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#28 0x045725a7 in QApplication::exec () at kernel/qapplication.cpp:3672
#29 0x00204f63 in kdemain (argc=1, argv=0xbfa5ee44) at ../../ksmserver/main.cpp:311
#30 0x0804860b in main (argc=1, argv=0xbfa5ee44) at ksmserver_dummy.cpp:3

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-24 19:19:46 UTC
[Comment from a bug triager]
This issue is being tracked at bug 195034. Merging. Thanks

*** This bug has been marked as a duplicate of bug 195034 ***