Bug 240670 - Plasma or compiz crashed at startup after the laptop was automatically shut down by battery low
Summary: Plasma or compiz crashed at startup after the laptop was automatically shut d...
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: 0.4
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-04 00:20 UTC by Marco Vader
Modified: 2010-06-04 12:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Vader 2010-06-04 00:20:23 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.33.4-95.fc13.x86_64 x86_64

-- Information about the crash:
I used the computer (laptop) on batteries and left it for a while. 
When I came back the machine was powered off due to low batteries.
I started the system and logged in normally, then plasma crashed just after logging in.

There is no startmenu or whatever, the crash reporter popped up.
Some applications from previous sessions opened such as a terminal.
The crash reported needed to install additional debug packages but there was no network connection.
(NetworkManager not started or crashed as well)
I started the network manually in the terminal so as to be able to install the packages and report the bug.

I'am a bit confused by the questions of the crash reporter that requires to select an existing bugreport with the same bug. All these have status Closed. I hope I selected the right one....



The crash can be reproduced some of the time.

 -- Backtrace:
Application: The KDE Session Manager (ksmserver), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#5  _IceTransGetConnectionNumber (ciptr=0x0) at /usr/include/X11/Xtrans/Xtrans.c:1004
#6  0x000000378bc14b6d in KSMServer::newConnection (this=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.4.3/ksmserver/server.cpp:831
#7  0x000000378bc1734a in KSMServer::qt_metacall (this=0x22af150, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fff6f986720)
    at /usr/src/debug/kdebase-workspace-4.4.3/x86_64-redhat-linux-gnu/ksmserver/server.moc:113
#8  0x00000035e756a81f in QMetaObject::activate (sender=0x22a84f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff6f986720) at kernel/qobject.cpp:3293
#9  0x00000035e75acb5e in QSocketNotifier::activated (this=<value optimized out>, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#10 0x00000035e756faa3 in QSocketNotifier::event (this=0x22a84f0, e=0x7fff6f986dd0) at kernel/qsocketnotifier.cpp:317
#11 0x00000035e81aaa0c in QApplicationPrivate::notify_helper (this=0x21edaf0, receiver=0x22a84f0, e=0x7fff6f986dd0) at kernel/qapplication.cpp:4300
#12 0x00000035e81b09db in QApplication::notify (this=<value optimized out>, receiver=0x22a84f0, e=0x7fff6f986dd0) at kernel/qapplication.cpp:4183
#13 0x0000003784006da6 in KApplication::notify (this=0x21ed560, receiver=0x22a84f0, event=0x7fff6f986dd0) at /usr/src/debug/kdelibs-4.4.3/kdeui/kernel/kapplication.cpp:302
#14 0x00000035e7557cdc in QCoreApplication::notifyInternal (this=0x21ed560, receiver=0x22a84f0, event=0x7fff6f986dd0) at kernel/qcoreapplication.cpp:704
#15 0x00000035e757d9ba in sendEvent (source=0x21f1e70) at kernel/qcoreapplication.h:215
#16 socketNotifierSourceDispatch (source=0x21f1e70) at kernel/qeventdispatcher_glib.cpp:110
#17 0x00000035e143bd02 in g_main_dispatch (context=0x21f0d20) at gmain.c:1960
#18 IA__g_main_context_dispatch (context=0x21f0d20) at gmain.c:2513
#19 0x00000035e143fae8 in g_main_context_iterate (context=0x21f0d20, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#20 0x00000035e143fc9c in IA__g_main_context_iteration (context=0x21f0d20, may_block=1) at gmain.c:2654
#21 0x00000035e757d603 in QEventDispatcherGlib::processEvents (this=0x21c9500, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#22 0x00000035e82499de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00000035e7556722 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00000035e75569ec in QEventLoop::exec (this=0x7fff6f987030, flags=...) at kernel/qeventloop.cpp:201
#25 0x00000035e7558cd9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#26 0x000000378bc124b7 in kdemain (argc=35527984, argv=0x7fff6f987100) at /usr/src/debug/kdebase-workspace-4.4.3/ksmserver/main.cpp:311
#27 0x00000035dfc1ec5d in __libc_start_main (main=0x4008a0 <main(int, char**)>, argc=3, ubp_av=0x7fff6f987608, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff6f9875f8) at libc-start.c:226
#28 0x00000000004007d9 in _start ()

This bug may be a duplicate of or related to bug 234557.

Possible duplicates by query: bug 239900, bug 238067, bug 237184, bug 234557, bug 233286.

Reported using DrKonqi
Comment 1 Lubos Lunak 2010-06-04 12:45:58 UTC

*** This bug has been marked as a duplicate of bug 195034 ***