Bug 237184 - Crashed upon starting
Summary: Crashed upon starting
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: 0.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-11 00:14 UTC by Stanley Varnhagen
Modified: 2010-05-12 12:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanley Varnhagen 2010-05-11 00:14:52 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
After changing settings, screen went blank when logging in (except mouse was visable).  Nothing seemed to work (though I could reboot or switch to terminal mode).

 -- Backtrace:
Application: The KDE Session Manager (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00d5ea27 in _IceTransGetConnectionNumber () from /usr/lib/libICE.so.6
#7  0x0140f853 in KSMServer::newConnection (this=0x88c8770) at ../../ksmserver/server.cpp:831
#8  0x01412acf in KSMServer::qt_metacall (this=0x88c8770, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfe6d368) at ./server.moc:113
#9  0x00f04c9a in QMetaObject::metacall (object=0x88c8770, cl=143747728, idx=5, argv=0xbfe6d368) at kernel/qmetaobject.cpp:237
#10 0x00f133d5 in QMetaObject::activate (sender=0x88e2d38, m=0x1013550, local_signal_index=0, argv=0xbfe6d368) at kernel/qobject.cpp:3293
#11 0x00f64933 in QSocketNotifier::activated (this=0x88e2d38, _t1=20) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#12 0x00f1a8e7 in QSocketNotifier::event (this=0x88e2d38, e=0xbfe6d7f4) at kernel/qsocketnotifier.cpp:317
#13 0x033604dc in QApplicationPrivate::notify_helper (this=0x870d778, receiver=0x88e2d38, e=0xbfe6d7f4) at kernel/qapplication.cpp:4300
#14 0x0336705e in QApplication::notify (this=0x870d718, receiver=0x88e2d38, e=0xbfe6d7f4) at kernel/qapplication.cpp:3704
#15 0x00a70f2a in KApplication::notify (this=0x870d718, receiver=0x88e2d38, event=0xbfe6d7f4) at ../../kdeui/kernel/kapplication.cpp:302
#16 0x00effa3b in QCoreApplication::notifyInternal (this=0x870d718, receiver=0x88e2d38, event=0xbfe6d7f4) at kernel/qcoreapplication.cpp:704
#17 0x00f2b9aa in QCoreApplication::sendEvent (source=0x8733100) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#18 socketNotifierSourceDispatch (source=0x8733100) at kernel/qeventdispatcher_glib.cpp:110
#19 0x0136f5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#20 0x013732d8 in ?? () from /lib/libglib-2.0.so.0
#21 0x013734b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#22 0x00f2b5d5 in QEventDispatcherGlib::processEvents (this=0x870d8f8, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#23 0x03420135 in QGuiEventDispatcherGlib::processEvents (this=0x870d8f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00efe059 in QEventLoop::processEvents (this=0xbfe6da94, flags=) at kernel/qeventloop.cpp:149
#25 0x00efe4aa in QEventLoop::exec (this=0xbfe6da94, flags=...) at kernel/qeventloop.cpp:201
#26 0x00f0269f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#27 0x03360577 in QApplication::exec () at kernel/qapplication.cpp:3579
#28 0x0140cd03 in kdemain (argc=1, argv=0x86f8da8) at ../../ksmserver/main.cpp:311
#29 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x86f8826 "/home/stanley", envc=30, envs=0x86f8838 "KDE_FULL_SESSION=true", 
    reset_env=true, tty=0x86f8c40 "", avoid_loops=false, startup_id_str=0x86f8c45 "") at ../../kinit/kinit.cpp:717
#30 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#31 0x0804f16f in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1393
#32 0x0804fe4f in main (argc=4, argv=0xbfe6e604, envp=0xbfe6e618) at ../../kinit/kinit.cpp:1845

Possible duplicates by query: bug 234557, bug 233286, bug 221568, bug 219006, bug 208533.

Reported using DrKonqi
Comment 1 Lubos Lunak 2010-05-12 12:04:44 UTC

*** This bug has been marked as a duplicate of bug 195034 ***