Bug 234557 - KDE session manager crashed on startup
Summary: KDE session manager crashed on startup
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-16 20:31 UTC by Mikko Karjalainen
Modified: 2010-04-17 05:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikko Karjalainen 2010-04-16 20:31:58 UTC
Application that crashed: ksmserver
Version of the application: 0.4
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32-13-generic i686
Distribution: Debian GNU/Linux 5.0.4 (lenny)

What I was doing when the application crashed:
I started my computer normally but KDE session manager crashed soon after showing my desktop picture.

 -- Backtrace:
Application: KDE:n istunnonhallinta (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x062a7da7 in _IceTransGetConnectionNumber () from /usr/lib/libICE.so.6
#7  0x03f72de5 in KSMServer::newConnection (this=0x965edf8) at ../../ksmserver/server.cpp:825
#8  0x03f7311f in KSMServer::qt_metacall (this=0x965edf8, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf9183ac) at ./server.moc:107
#9  0x00270303 in QMetaObject::activate (sender=0x965f190, from_signal_index=4, to_signal_index=4, argv=0xbf9183ac) at kernel/qobject.cpp:3112
#10 0x00270f42 in QMetaObject::activate (sender=0x965f190, m=0x34cd30, local_signal_index=0, argv=0xbf9183ac) at kernel/qobject.cpp:3186
#11 0x002ab9c3 in QSocketNotifier::activated (this=0x965f190, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:83
#12 0x00275907 in QSocketNotifier::event (this=0x965f190, e=0xbf918780) at kernel/qsocketnotifier.cpp:316
#13 0x02e94a94 in QApplicationPrivate::notify_helper (this=0x9566188, receiver=0x965f190, e=0xbf918780) at kernel/qapplication.cpp:4065
#14 0x02e9cbee in QApplication::notify (this=0x9566108, receiver=0x965f190, e=0xbf918780) at kernel/qapplication.cpp:3605
#15 0x00e92e2a in KApplication::notify (this=0x9566108, receiver=0x965f190, event=0xbf918780) at ../../kdeui/kernel/kapplication.cpp:302
#16 0x0025b1eb in QCoreApplication::notifyInternal (this=0x9566108, receiver=0x965f190, event=0xbf918780) at kernel/qcoreapplication.cpp:610
#17 0x002863aa in QCoreApplication::sendEvent (source=0x9568a80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#18 socketNotifierSourceDispatch (source=0x9568a80) at kernel/qeventdispatcher_glib.cpp:110
#19 0x014642e5 in g_main_dispatch (context=0x9568a00) at /build/buildd-glib2.0_2.24.0-1-i386-o5zIuQ/glib2.0-2.24.0/glib/gmain.c:1960
#20 IA__g_main_context_dispatch (context=0x9568a00) at /build/buildd-glib2.0_2.24.0-1-i386-o5zIuQ/glib2.0-2.24.0/glib/gmain.c:2513
#21 0x01468000 in g_main_context_iterate (context=0x9568a00, block=<value optimized out>, dispatch=1, self=0x94d9d00) at /build/buildd-glib2.0_2.24.0-1-i386-o5zIuQ/glib2.0-2.24.0/glib/gmain.c:2591
#22 0x01468198 in IA__g_main_context_iteration (context=0x9568a00, may_block=1) at /build/buildd-glib2.0_2.24.0-1-i386-o5zIuQ/glib2.0-2.24.0/glib/gmain.c:2654
#23 0x00286041 in QEventDispatcherGlib::processEvents (this=0x9565e18, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#24 0x02f34305 in QGuiEventDispatcherGlib::processEvents (this=0x9565e18, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#25 0x0025983a in QEventLoop::processEvents (this=0xbf9189d0, flags=...) at kernel/qeventloop.cpp:149
#26 0x00259c82 in QEventLoop::exec (this=0xbf9189d0, flags=...) at kernel/qeventloop.cpp:201
#27 0x0025c0d9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#28 0x02e94917 in QApplication::exec () at kernel/qapplication.cpp:3525
#29 0x03f6db3b in kdemain (argc=1, argv=0x9510700) at ../../ksmserver/main.cpp:322
#30 0x0804de39 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x951b646 "/home/mikko", envc=24, envs=0x951b656 "KDE_FULL_SESSION=true", 
    reset_env=true, tty=0x951b938 "", avoid_loops=false, startup_id_str=0x951b93d "") at ../../kinit/kinit.cpp:677
#31 0x0804e9ad in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#32 0x0804ee03 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1353
#33 0x0804f657 in main (argc=2, argv=0xbf919374, envp=0xbf919380) at ../../kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Jonathan Thomas 2010-04-17 05:24:10 UTC

*** This bug has been marked as a duplicate of bug 195034 ***