Bug 239900 - KDE session manager crashed at startup
Summary: KDE session manager crashed at startup
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-28 20:10 UTC by zhurichin
Modified: 2010-05-31 09:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zhurichin 2010-05-28 20:10:09 UTC
Application that crashed: ksmserver
Version of the application: 0.4
KDE Version: 4.3.5 (KDE 4.3.5)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-21-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Happens rarely when logging into the system (Kubuntu 9.10 with KDE 4.4).  Don't remember anything special happening to the system before the crash.  Windows are missing their decorations but otherwise seem to be running OK.  No desktop and toolbar.

 -- Backtrace:
Application: The KDE Session Manager (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00b64a47 in _IceTransGetConnectionNumber () from /usr/lib/libICE.so.6
#7  0x072e9ef5 in KSMServer::newConnection (this=0x9119628) at ../../ksmserver/server.cpp:825
#8  0x072ea22f in KSMServer::qt_metacall (this=0x9119628, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfd71368) at ./server.moc:107
#9  0x00f0b263 in QMetaObject::activate (sender=0x91212c0, from_signal_index=4, to_signal_index=4, argv=0xbfd71368) at kernel/qobject.cpp:3113
#10 0x00f0bec2 in QMetaObject::activate (sender=0x91212c0, m=0xfe68b0, local_signal_index=0, argv=0xbfd71368) at kernel/qobject.cpp:3187
#11 0x00f45503 in QSocketNotifier::activated (this=0x91212c0, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:83
#12 0x00f0fc87 in QSocketNotifier::event (this=0x91212c0, e=0xbfd71724) at kernel/qsocketnotifier.cpp:316
#13 0x04b8cf54 in QApplicationPrivate::notify_helper (this=0x9091828, receiver=0x91212c0, e=0xbfd71724) at kernel/qapplication.cpp:4056
#14 0x04b9467c in QApplication::notify (this=0x90917a0, receiver=0x91212c0, e=0xbfd71724) at kernel/qapplication.cpp:3603
#15 0x011bc25a in KApplication::notify (this=0x90917a0, receiver=0x91212c0, event=0xbfd71724) at ../../kdeui/kernel/kapplication.cpp:302
#16 0x00ef56cb in QCoreApplication::notifyInternal (this=0x90917a0, receiver=0x91212c0, event=0xbfd71724) at kernel/qcoreapplication.cpp:610
#17 0x00f202ca in QCoreApplication::sendEvent (source=0x9095000) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#18 socketNotifierSourceDispatch (source=0x9095000) at kernel/qeventdispatcher_glib.cpp:110
#19 0x00760e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#20 0x00764730 in ?? () from /lib/libglib-2.0.so.0
#21 0x00764863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#22 0x00f2002c in QEventDispatcherGlib::processEvents (this=0x9090fc8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#23 0x04c2dbe5 in QGuiEventDispatcherGlib::processEvents (this=0x9090fc8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#24 0x00ef3c79 in QEventLoop::processEvents (this=0xbfd719c4, flags=) at kernel/qeventloop.cpp:149
#25 0x00ef40ca in QEventLoop::exec (this=0xbfd719c4, flags=...) at kernel/qeventloop.cpp:201
#26 0x00ef653f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#27 0x04b8cdd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#28 0x072e3b7b in kdemain (argc=1, argv=0x90390e8) at ../../ksmserver/main.cpp:322
#29 0x0804dde1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x9039f96 "/home/zhur", envc=26, envs=0x9039fa5 "KDE_FULL_SESSION=true", 
    reset_env=true, tty=0x903a2f8 "", avoid_loops=false, startup_id_str=0x903a2fd "") at ../../kinit/kinit.cpp:677
#30 0x0804ea35 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#31 0x0804ee69 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1353
#32 0x0804fbaf in main (argc=2, argv=0xbfd72304, envp=0xbfd72310) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 195034

Reported using DrKonqi
Comment 1 Lubos Lunak 2010-05-31 09:46:37 UTC

*** This bug has been marked as a duplicate of bug 195034 ***