Bug 247420 - crash when starting marble or embedding apps
Summary: crash when starting marble or embedding apps
Status: RESOLVED UNMAINTAINED
Alias: None
Product: marble
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: HI crash (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
: 249708 258915 259631 261199 261710 262034 262513 269973 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-08-11 20:46 UTC by Mikolaj Machowski
Modified: 2018-12-20 18:53 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
marble error (2.44 KB, text/plain)
2011-01-01 16:07 UTC, Leo
Details
New crash information added by DrKonqi (4.51 KB, text/plain)
2011-01-07 22:19 UTC, Leo
Details
New crash information added by DrKonqi (6.23 KB, text/plain)
2011-01-27 00:35 UTC, Leo
Details
New crash information added by DrKonqi (6.87 KB, text/plain)
2011-04-10 18:42 UTC, Karl Ferdinand Ebert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikolaj Machowski 2010-08-11 20:46:40 UTC
Application: digikam (1.4.0 (rev.: 1162240))
KDE Platform Version: 4.5.00 (KDE 4.5.0) (Compiled from sources)
Qt Version: 4.6.2
Operating System: Linux 2.6.31.12-desktop586-1mnb i686
Distribution: "Mandriva Linux 2010.0"

-- Information about the crash:
- What I was doing when the application crashed:
Just typed 'digikam' in krunner

- Unusual behavior I noticed:
Nothing special happened

- Custom settings of the application:
No custom settings
digiKam from trunk, exiv2 from trunk, kdegraphics from trunk, rest from 4.5 branch

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0xb19ec6d0 (LWP 19028))]

Thread 8 (Thread 0xaf7deb70 (LWP 19029)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb47489e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libpthread.so.0
#2  0xb47e2536 in QWaitCondition::wait () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#3  0x082a448e in Digikam::ScanController::run (this=0x8e145d8) at /home/mikolaj/kde/src/extragear/graphics/digikam/digikam/scancontroller.cpp:515
#4  0xb47e1fde in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#5  0xb4744885 in start_thread () from /lib/i686/libpthread.so.0
#6  0xb44fe66e in clone () from /lib/i686/libc.so.6

Thread 7 (Thread 0xaefddb70 (LWP 19032)):
#0  0xb439f02d in ?? () from /usr/lib/libglib-2.0.so.0
#1  0xb439f58e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#2  0xb4919e9f in QEventDispatcherGlib::processEvents () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#3  0xb48eb63d in QEventLoop::processEvents () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#4  0xb48eb99a in QEventLoop::exec () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#5  0xb47de6c4 in QThread::exec () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#6  0xb65ad84d in Digikam::ImageFilterModelWorker::Thread::run (this=0x8e56650)
    at /home/mikolaj/kde/build/extragear/graphics/digikam/digikam/../../../../../src/extragear/graphics/digikam/libs/models/imagefiltermodelthreads.h:66
#7  0xb47e1fde in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#8  0xb4744885 in start_thread () from /lib/i686/libpthread.so.0
#9  0xb44fe66e in clone () from /lib/i686/libc.so.6

Thread 6 (Thread 0xae733b70 (LWP 19033)):
#0  0xb2681016 in clock_gettime () from /lib/i686/librt.so.1
#1  0xb49167b6 in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#2  0x00000001 in ?? ()
#3  0xae733118 in ?? ()
#4  0xb48eda54 in QCoreApplicationPrivate::sendPostedEvents () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#5  0x2fb27517 in ?? ()
#6  0xb4a08674 in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#7  0x08e73934 in ?? ()
#8  0xae7330e8 in ?? ()
#9  0xb491b4db in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 5 (Thread 0xadb9cb70 (LWP 19034)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb47489e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libpthread.so.0
#2  0xb47e2536 in QWaitCondition::wait () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#3  0xb6896a62 in Digikam::ParkingThread::run (this=0x8e6f7a0) at /home/mikolaj/kde/src/extragear/graphics/digikam/libs/threads/threadmanager.cpp:101
#4  0xb47e1fde in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#5  0xb4744885 in start_thread () from /lib/i686/libpthread.so.0
#6  0xb44fe66e in clone () from /lib/i686/libc.so.6

Thread 4 (Thread 0xad39bb70 (LWP 19035)):
#0  0xb47e13f0 in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#1  0xb4919b6f in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#2  0xb439ece8 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#3  0xb439f069 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb439f58e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb4919e9f in QEventDispatcherGlib::processEvents () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#6  0xb48eb63d in QEventLoop::processEvents () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#7  0xb48eb99a in QEventLoop::exec () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#8  0xb47de6c4 in QThread::exec () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#9  0xb47e1fde in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#10 0xb4744885 in start_thread () from /lib/i686/libpthread.so.0
#11 0xb44fe66e in clone () from /lib/i686/libc.so.6

Thread 3 (Thread 0xacb9ab70 (LWP 19036)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb44f3306 in poll () from /lib/i686/libc.so.6
#2  0xb43ac37b in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0xb439f291 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb439f58e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb4919e9f in QEventDispatcherGlib::processEvents () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#6  0xb48eb63d in QEventLoop::processEvents () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#7  0xb48eb99a in QEventLoop::exec () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#8  0xb47de6c4 in QThread::exec () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#9  0xb47e1fde in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#10 0xb4744885 in start_thread () from /lib/i686/libpthread.so.0
#11 0xb44fe66e in clone () from /lib/i686/libc.so.6

Thread 2 (Thread 0xa5ceab70 (LWP 19042)):
#0  0xb2681016 in clock_gettime () from /lib/i686/librt.so.1
#1  0xb49167b6 in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#2  0x00000001 in ?? ()
#3  0x00000000 in ?? ()

Thread 1 (Thread 0xb19ec6d0 (LWP 19028)):
[KCrash Handler]
#7  0xb62c2795 in Marble::GeoSceneTexture::downloadPolicies () from /home/mikolaj/kde/lib/libmarblewidget.so.10
#8  0xb631bb81 in Marble::MarbleModel::addDownloadPolicies () from /home/mikolaj/kde/lib/libmarblewidget.so.10
#9  0xb6320d4f in Marble::MarbleModel::setMapTheme () from /home/mikolaj/kde/lib/libmarblewidget.so.10
#10 0xb632934d in Marble::MarbleMap::setMapThemeId () from /home/mikolaj/kde/lib/libmarblewidget.so.10
#11 0xb6317f8a in Marble::MarbleWidget::setMapThemeId () from /home/mikolaj/kde/lib/libmarblewidget.so.10
#12 0xb6941f0d in Digikam::WorldMapWidget::setMapTheme (this=0x9769340, theme=<value optimized out>) at /home/mikolaj/kde/src/extragear/graphics/digikam/libs/imageproperties/worldmapwidget.cpp:409
#13 0xb6943cc6 in Digikam::WorldMapWidget::readConfig (this=0x975b560, group=@0xbff0112c) at /home/mikolaj/kde/src/extragear/graphics/digikam/libs/imageproperties/worldmapwidget.cpp:364
#14 0xb693cacd in Digikam::ImagePropertiesGPSTab::readConfig (this=0x975ac58) at /home/mikolaj/kde/src/extragear/graphics/digikam/libs/imageproperties/imagepropertiesgpstab.cpp:212
#15 0xb693ded8 in ImagePropertiesGPSTab (this=0x975ac58, parent=0x8f5b690) at /home/mikolaj/kde/src/extragear/graphics/digikam/libs/imageproperties/imagepropertiesgpstab.cpp:194
#16 0xb692d716 in ImagePropertiesSideBar (this=0x96b7258, parent=0x8f5b690, splitter=0x8eed610, side=KMultiTabBar::Right, mimimizedDefault=<value optimized out>)
    at /home/mikolaj/kde/src/extragear/graphics/digikam/libs/imageproperties/imagepropertiessidebar.cpp:77
#17 0x080b4471 in ImagePropertiesSideBarDB (this=0x96b7258, parent=0x8f5b690, splitter=0x8eed610, side=KMultiTabBar::Right, mimimizedDefault=<value optimized out>)
    at /home/mikolaj/kde/src/extragear/graphics/digikam/libs/imageproperties/imagepropertiessidebardb.cpp:88
#18 0x08262a90 in DigikamView (this=0x8f5b690, parent=0x8e7f020, modelCollection=0x8e58390) at /home/mikolaj/kde/src/extragear/graphics/digikam/digikam/digikamview.cpp:175
#19 0x08255c87 in Digikam::DigikamApp::setupView (this=0x8e7f020) at /home/mikolaj/kde/src/extragear/graphics/digikam/digikam/digikamapp.cpp:483
#20 0x08257187 in DigikamApp (this=0x8e7f020) at /home/mikolaj/kde/src/extragear/graphics/digikam/digikam/digikamapp.cpp:229
#21 0x0830e893 in main (argc=1, argv=0xbff018b4) at /home/mikolaj/kde/src/extragear/graphics/digikam/digikam/main.cpp:172

Reported using DrKonqi
Comment 1 Mikolaj Machowski 2010-08-13 16:24:57 UTC
Confirming. When compiled without marble digikam doesn't crash.

Standalone marble crashes immediately with this backtrace:


Application: Marble Desktop Globe (marble), signal: Aborted
[Current thread is 1 (Thread 0xb36939c0 (LWP 26622))]

Thread 2 (Thread 0xb127cb70 (LWP 26624)):
#0  0xb3ede016 in clock_gettime () from /lib/i686/librt.so.1
#1  0xb690a7b6 in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#2  0x00000001 in ?? ()
#3  0xb127c068 in ?? ()
#4  0x00000000 in ?? ()

Thread 1 (Thread 0xb36939c0 (LWP 26622)):
[KCrash Handler]
#7  0xffffe430 in __kernel_vsyscall ()
#8  0xb43ae611 in raise () from /lib/i686/libc.so.6
#9  0xb43aff62 in abort () from /lib/i686/libc.so.6
#10 0xb67cca67 in qt_message_output () from 
/home/mikolaj/kde/qt4/lib/libQtCore.so.4
#11 0xb67ccc3b in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#12 0xb67ccd59 in qFatal () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#13 0xb67ccde5 in qt_assert () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#14 0xb751eed0 in Marble::GeoTagHandler::registerHandler (qName=@0xbf87d724, 
handler=0x8b44418) at 
/home/mikolaj/kde/src/KDE/kdeedu/marble/src/lib/geodata/parser/GeoTagHandler.cpp:59
#15 0xb08abba5 in __static_initialization_and_destruction_0 () from 
/home/mikolaj/kde/lib/libmarblewidget.so.4
#16 0xb099c5a5 in __do_global_ctors_aux () from 
/home/mikolaj/kde/lib/libmarblewidget.so.4
#17 0xb08420e8 in _init () from /home/mikolaj/kde/lib/libmarblewidget.so.4
#18 0xb7745d6c in call_init (l=<value optimized out>, argc=<value optimized 
out>, argv=0xbf87e594, env=0xbf87e59c) at dl-init.c:70
#19 0xb7745ed1 in _dl_init (main_map=0x8b135b8, argc=<value optimized out>, 
argv=<value optimized out>, env=0xbf87e59c) at dl-init.c:134
#20 0xb7749ae3 in dl_open_worker (a=0xbf87d960) at dl-open.c:527
#21 0xb7745996 in _dl_catch_error (objname=<value optimized out>, 
errstring=<value optimized out>, mallocedp=<value optimized out>, 
operate=0xb7749730 <dl_open_worker>, args=0xbf87d960)
    at dl-error.c:178
#22 0xb77492d0 in _dl_open (file=0x8b13330 
"/home/mikolaj/kde/lib/kde4/plugins/marble/QHttpNetworkPlugin.so", mode=<value 
optimized out>, caller_dlopen=0xb68cfdec, nsid=-2, argc=1, argv=0xbf87e594, 
    env=0xbf87e59c) at dl-open.c:615
#23 0xb3eeac0b in ?? () from /lib/libdl.so.2
#24 0xb7745996 in _dl_catch_error (objname=<value optimized out>, 
errstring=<value optimized out>, mallocedp=<value optimized out>, 
operate=0xb3eeab70, args=0xbf87db40) at dl-error.c:178
#25 0xb3eeb00c in ?? () from /lib/libdl.so.2
#26 0xb3eeab41 in dlopen () from /lib/libdl.so.2
#27 0xb68cfdec in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#28 0xb68ca074 in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#29 0xb68ca391 in ?? () from /home/mikolaj/kde/qt4/lib/libQtCore.so.4
#30 0xb68c3893 in QPluginLoader::load () from 
/home/mikolaj/kde/qt4/lib/libQtCore.so.4
#31 0xb68c38c2 in QPluginLoader::instance () from 
/home/mikolaj/kde/qt4/lib/libQtCore.so.4
#32 0xb75a7574 in Marble::PluginManagerPrivate::loadPlugins (this=0x8b01550) 
at /home/mikolaj/kde/src/KDE/kdeedu/marble/src/lib/PluginManager.cpp:156
#33 0xb75a7974 in Marble::PluginManager::createRenderPlugins (this=0x8b01460) 
at /home/mikolaj/kde/src/KDE/kdeedu/marble/src/lib/PluginManager.cpp:90
#34 0xb75a701d in LayerManagerPrivate (this=0x8b2aaa0, dataFacade=0x8b04be8, 
pluginManager=0x8b01460) at 
/home/mikolaj/kde/src/KDE/kdeedu/marble/src/lib/LayerManager.cpp:45
#35 0xb75a5f78 in LayerManager (this=0x8b2a9f8, dataFacade=0x8b04be8, 
pluginManager=0x8b01460, parent=0x8b01390) at 
/home/mikolaj/kde/src/KDE/kdeedu/marble/src/lib/LayerManager.cpp:62
#36 0xb755fbf3 in MarbleModel (this=0x8b01390, parent=0x8b00848) at 
/home/mikolaj/kde/src/KDE/kdeedu/marble/src/lib/MarbleModel.cpp:221
#37 0xb7566809 in MarbleMap (this=0x8b00848) at 
/home/mikolaj/kde/src/KDE/kdeedu/marble/src/lib/MarbleMap.cpp:312
#38 0xb7559e7d in MarbleWidget (this=0x89d00c8, parent=0x8a03448) at 
/home/mikolaj/kde/src/KDE/kdeedu/marble/src/lib/MarbleWidget.cpp:143
#39 0x0805535d in ControlView (this=0x8a03448, parent=0x89c1eb0) at 
/home/mikolaj/kde/src/KDE/kdeedu/marble/src/ControlView.cpp:45
#40 0x08061674 in MarblePart (this=0x8a04b60, parentWidget=0x89c1eb0, 
parent=0x89c1eb0, arguments=@0xbf87dfe0) at 
/home/mikolaj/kde/src/KDE/kdeedu/marble/src/marble_part.cpp:121
#41 0x0805b093 in MainWindow (this=0x89c1eb0, marbleDataPath=@0xbf87e080, 
parent=0x0) at 
/home/mikolaj/kde/src/KDE/kdeedu/marble/src/KdeMainWindow.cpp:41
#42 0x0805a750 in main (argc=1, argv=0xbf87e594) at 
/home/mikolaj/kde/src/KDE/kdeedu/marble/src/kdemain.cpp:249
Comment 2 Dennis Nienhüser 2010-09-11 22:46:16 UTC
*** Bug 249708 has been marked as a duplicate of this bug. ***
Comment 3 Dennis Nienhüser 2010-09-11 22:51:45 UTC
Similar to bug 249708 this should be caused by two different libmarblewidget.so versions being loaded into memory (by plugins). Recompile or delete the outdated plugins as a workaround. You can find those that need to be recompiled by running ldd on each of them. /home/mikolaj/kde/lib/kde4/plugins/marble/QHttpNetworkPlugin.so should be one of them (linking against /home/mikolaj/kde/lib/libmarblewidget.so.4 which is from KDE 4.4).
Comment 4 Dennis Nienhüser 2011-01-01 11:55:09 UTC
*** Bug 261710 has been marked as a duplicate of this bug. ***
Comment 5 Dennis Nienhüser 2011-01-01 12:01:11 UTC
*** Bug 261199 has been marked as a duplicate of this bug. ***
Comment 6 Dennis Nienhüser 2011-01-01 12:05:06 UTC
Bernd, Leo, can you attach your Marble config files here, please? Call

echo "$(kde-config --localprefix)share/config/marblerc"

in a shell to find out its location. Thanks.
Comment 7 Dennis Nienhüser 2011-01-01 12:11:13 UTC
*** Bug 258915 has been marked as a duplicate of this bug. ***
Comment 8 Dennis Nienhüser 2011-01-01 12:13:24 UTC
*** Bug 259631 has been marked as a duplicate of this bug. ***
Comment 9 Dennis Nienhüser 2011-01-01 12:14:03 UTC
*** Bug 259623 has been marked as a duplicate of this bug. ***
Comment 10 Leo 2011-01-01 13:56:15 UTC
(In reply to comment #6)
> Bernd, Leo, can you attach your Marble config files here, please? Call
> 
> echo "$(kde-config --localprefix)share/config/marblerc"
> 
> in a shell to find out its location. Thanks.

here are my homeworks ;)
$ echo "$(kde-config --localprefix)share/config/marblerc"
/home/z-lmutt/.kde/share/config/marblerc
Comment 11 Dennis Nienhüser 2011-01-01 14:31:00 UTC
Hey Leo, thanks for the quick reply. Can you paste (or attach) the file content of /home/z-lmutt/.kde/share/config/marblerc as well, please? It's a text file, you can open it with any text editor.
Comment 12 Leo 2011-01-01 15:03:30 UTC
(In reply to comment #11)
> Hey Leo, thanks for the quick reply. Can you paste (or attach) the file content
> of /home/z-lmutt/.kde/share/config/marblerc as well, please? It's a text file,
> you can open it with any text editor.

Sorry... the file does not exist :(
Comment 13 Leo 2011-01-01 16:07:31 UTC
Created attachment 55440 [details]
marble error
Comment 14 Leo 2011-01-01 16:09:04 UTC
Marble was missing. When I installed it I got the bug in the file attached
Comment 15 Dennis Nienhüser 2011-01-06 12:44:30 UTC
*** Bug 262034 has been marked as a duplicate of this bug. ***
Comment 16 Leo 2011-01-07 22:19:51 UTC
Created attachment 55710 [details]
New crash information added by DrKonqi

marble (0.92 (1.0 Release Candidate 2)) on KDE Platform 4.5.95 (4.6 RC2) using Qt 4.7.0

- What I was doing when the application crashed:

I hope this could have, since the same problem is still in 
$ marble --version
Qt: 4.7.0
Piattaforma di sviluppo KDE: 4.5.95 (4.6 RC2)
Marble Virtual Globe: 0.92 (1.0 Release Candidate 2)


I've also tryed to purge all the files (marble, digikam, showfoto and all the related files) and reinstall all of them, but nothig works :(

-- Backtrace (Reduced):
#6  ref (this=0x120b3e0) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#7  QList (this=0x120b3e0) at /usr/include/qt4/QtCore/qlist.h:118
#8  Marble::GeoSceneTexture::downloadPolicies (this=0x120b3e0) at ../../../../marble/src/lib/geodata/scene/GeoSceneTexture.cpp:207
#9  0x00007fc023103a08 in Marble::MarbleModel::addDownloadPolicies (this=0xf73790, mapTheme=0x125de40) at ../../../../marble/src/lib/MarbleModel.cpp:552
#10 0x00007fc023103f87 in Marble::MarbleModel::setMapTheme (this=0x7fff63098000, mapTheme=0x120b3e0) at ../../../../marble/src/lib/MarbleModel.cpp:256
Comment 17 Dennis Nienhüser 2011-01-09 10:26:16 UTC
*** Bug 262513 has been marked as a duplicate of this bug. ***
Comment 18 Leo 2011-01-27 00:35:52 UTC
Created attachment 56455 [details]
New crash information added by DrKonqi

marble (1.0.0 (Stable Release)) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.0

- What I was doing when the application crashed:

Same situation on the kde4.6 version :(

Starting from the console I get the following data.

$ marble
Time elapsed: 21 ms
Model: Time elapsed: 0 ms
TextureColorizer::setSeaFileLandFile: Time elapsed: 5 ms
KCrash: Application 'marble' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/z-lmutt/.kde/socket-xps1330/kdeinit4__0
QSocketNotifier: Invalid socket 10 and type 'Read', disabling...
QSocketNotifier: Invalid socket 13 and type 'Read', disabling...
QSocketNotifier: Invalid socket 16 and type 'Read', disabling...

[1]+  Fermato                 marble


I've also tried to purge the system from digikam* showfoto* marble* removed the following files

$ sudo rm -Rf ./Immagini/digikam4.db ./.kde/share/apps/digikam ./.kde/share/config/digikamrc ./.local/share/marble

and reinstalled all from scratch.

-- Backtrace (Reduced):
#6  ref (this=0x1d32430) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#7  QList (this=0x1d32430) at /usr/include/qt4/QtCore/qlist.h:118
#8  Marble::GeoSceneTexture::downloadPolicies (this=0x1d32430) at ../../../../marble/src/lib/geodata/scene/GeoSceneTexture.cpp:207
#9  0x00007f2cd796ab58 in Marble::MarbleModel::addDownloadPolicies (this=0x1ab5100, mapTheme=0x1d564e0) at ../../../../marble/src/lib/MarbleModel.cpp:552
#10 0x00007f2cd796b0d7 in Marble::MarbleModel::setMapTheme (this=0x7fff92611fe0, mapTheme=0x1d32430) at ../../../../marble/src/lib/MarbleModel.cpp:256
Comment 19 David 2011-03-29 22:17:03 UTC
Marble 1.0.0, with Qt 4.7.1, KDE 4.6.00 (all provided by openSUSE 11.4) launched with --sync --debug-info

Console output:

FileManager::addFile 
PlacemarkManager::addGeoDataDocument: ""  size  2 
addPlacemarks: Time elapsed: 0 ms for 2 Placemarks. 
Starting to load Plugins. 
=== MarbleDirs: === 
Local Path: "/home/deif/.local/share/marble" 
Plugin Local Path: "/home/deif/.marble/plugins" 
 
Marble Data Path (Run Time) : "" 
Marble Data Path (Compile Time): "/usr/share/kde4/apps/marble/data" 
 
Marble Plugin Path (Run Time) : "" 
Marble Plugin Path (Compile Time): "/usr/lib64/kde4/plugins/marble" 
 
System Path: "/usr/share/kde4/apps/marble/data" 
Plugin System Path: "/usr/lib64/kde4/plugins/marble" 
=================== 
Marble::RenderPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/AprsPlugin.so" 
Marble::AbstractFloatItem plugin loaded from "/usr/lib64/kde4/plugins/marble/CompassFloatItem.so" 
Marble::RenderPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/CrosshairsPlugin.so" 
Marble::RenderPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/ExternalDraw.so" 
Marble::RunnerPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/GosmorePlugin.so" 
Marble::RenderPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/GraticulePlugin.so" 
Marble::RunnerPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/HostipPlugin.so" 
Marble::RunnerPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/LatLonPlugin.so" 
Marble::RunnerPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/LocalDatabasePlugin.so" 
Marble::AbstractFloatItem plugin loaded from "/usr/lib64/kde4/plugins/marble/MapScaleFloatItem.so" 
Marble::RunnerPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/MonavPlugin.so" 
Marble::AbstractFloatItem plugin loaded from "/usr/lib64/kde4/plugins/marble/NavigationFloatItem.so" 
Marble::RunnerPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/NominatimPlugin.so" 
Marble::RunnerPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/OpenRouteServicePlugin.so" 
Marble::AbstractFloatItem plugin loaded from "/usr/lib64/kde4/plugins/marble/OverviewMap.so" 
Marble::AbstractDataPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/Photo.so" 
Marble::RenderPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/PositionMarker.so" 
Marble::AbstractFloatItem plugin loaded from "/usr/lib64/kde4/plugins/marble/ProgressFloatItem.so" 
Marble::NetworkPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/QNamNetworkPlugin.so" 
Marble::AbstractFloatItem plugin loaded from "/usr/lib64/kde4/plugins/marble/RoutingPlugin.so" 
Marble::RunnerPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/RoutinoPlugin.so" 
Marble::RenderPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/StarsPlugin.so" 
Marble::AbstractDataPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/Weather.so" 
Marble::AbstractDataPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/Wikipedia.so" 
Marble::RunnerPlugin plugin loaded from "/usr/lib64/kde4/plugins/marble/YoursPlugin.so" 
Time elapsed: 107 ms
loadMapTheme "earth/bluemarble/bluemarble.dgml" 
DgmlBlendingTagHandler::parse "CloudsBlending" 
loadMapTheme "earth/citylights/citylights.dgml" 
loadMapTheme "earth/openstreetmap/openstreetmap.dgml" 
added download policy ("a.tile.openstreetmap.org", "b.tile.openstreetmap.org", "c.tile.openstreetmap.org") 1 20 
added download policy ("a.tile.openstreetmap.org", "b.tile.openstreetmap.org", "c.tile.openstreetmap.org") 0 2 
loadMapTheme "earth/plain/plain.dgml" 
loadMapTheme "earth/precip-dec/precip-dec.dgml" 
loadMapTheme "earth/precip-july/precip-july.dgml" 
loadMapTheme "earth/schagen1689/schagen1689.dgml" 
loadMapTheme "earth/srtm/srtm.dgml" 
loadMapTheme "earth/temp-dec/temp-dec.dgml" 
loadMapTheme "earth/temp-july/temp-july.dgml" 
loadMapTheme "moon/clementine/clementine.dgml" 
TileLoader::updateTextureLayers "earth/bluemarble" 
TileLoader::updateTextureLayers added texture layer: 21580805 "earth/bluemarble" 
TileLoader::updateTextureLayers added texture layer: 152198867 "earth/clouds" 
TileLoader::updateTextureLayers "earth/citylights" 
TileLoader::updateTextureLayers added texture layer: 224263347 "earth/citylights" 
TileLoader::updateTextureLayers "earth/openstreetmap" 
TileLoader::updateTextureLayers added texture layer: 172664864 "earth/openstreetmap" 
TileLoader::updateTextureLayers "earth/plain" 
ignoring, has no GeoSceneLayer for "plain" 
TileLoader::updateTextureLayers "earth/precip-dec" 
TileLoader::updateTextureLayers added texture layer: 259336627 "earth/precip-dec" 
TileLoader::updateTextureLayers "earth/precip-july" 
TileLoader::updateTextureLayers added texture layer: 123022809 "earth/precip-july" 
TileLoader::updateTextureLayers "earth/schagen1689" 
TileLoader::updateTextureLayers added texture layer: 184308729 "earth/schagen1689" 
TileLoader::updateTextureLayers "earth/srtm" 
TileLoader::updateTextureLayers added texture layer: 180082829 "earth/srtm" 
TileLoader::updateTextureLayers "earth/temp-dec" 
TileLoader::updateTextureLayers added texture layer: 225856787 "earth/temp-dec" 
TileLoader::updateTextureLayers "earth/temp-july" 
TileLoader::updateTextureLayers added texture layer: 124216217 "earth/temp-july" 
TileLoader::updateTextureLayers "moon/clementine" 
TileLoader::updateTextureLayers added texture layer: 263109957 "moon/clementine" 
Use workaround:  0 
Model: Time elapsed: 0 ms
NavigationWidget (sort): Time elapsed: 0  ms 
updateMapThemeModel 
loadMapTheme "earth/bluemarble/bluemarble.dgml" 
DgmlBlendingTagHandler::parse "CloudsBlending" 
loadMapTheme "earth/citylights/citylights.dgml" 
loadMapTheme "earth/openstreetmap/openstreetmap.dgml" 
added download policy ("a.tile.openstreetmap.org", "b.tile.openstreetmap.org", "c.tile.openstreetmap.org") 1 20 
added download policy ("a.tile.openstreetmap.org", "b.tile.openstreetmap.org", "c.tile.openstreetmap.org") 0 2 
loadMapTheme "earth/plain/plain.dgml" 
loadMapTheme "earth/precip-dec/precip-dec.dgml" 
loadMapTheme "earth/precip-july/precip-july.dgml" 
loadMapTheme "earth/schagen1689/schagen1689.dgml" 
loadMapTheme "earth/srtm/srtm.dgml" 
loadMapTheme "earth/temp-dec/temp-dec.dgml" 
loadMapTheme "earth/temp-july/temp-july.dgml" 
loadMapTheme "moon/clementine/clementine.dgml" 
Loading Bookmark File :  "" 
Bookmark file "bookmarks/bookmarks.kml" does not exist in local and system data directory. 
loadMapTheme "earth/bluemarble/bluemarble.dgml" 
DgmlBlendingTagHandler::parse "CloudsBlending" 
loadMapTheme "earth/citylights/citylights.dgml" 
loadMapTheme "earth/openstreetmap/openstreetmap.dgml" 
added download policy ("a.tile.openstreetmap.org", "b.tile.openstreetmap.org", "c.tile.openstreetmap.org") 1 20 
added download policy ("a.tile.openstreetmap.org", "b.tile.openstreetmap.org", "c.tile.openstreetmap.org") 0 2 
loadMapTheme "earth/plain/plain.dgml" 
loadMapTheme "earth/precip-dec/precip-dec.dgml" 
loadMapTheme "earth/precip-july/precip-july.dgml" 
loadMapTheme "earth/schagen1689/schagen1689.dgml" 
loadMapTheme "earth/srtm/srtm.dgml" 
loadMapTheme "earth/temp-dec/temp-dec.dgml" 
loadMapTheme "earth/temp-july/temp-july.dgml" 
loadMapTheme "moon/clementine/clementine.dgml" 
loadMapTheme "earth/srtm/srtm.dgml" 
StackedTileLoader::updateTextureLayers "earth/srtm" 
StackedTileLoader::setTextureLayers 
TextureColorizer::setSeaFileLandFile: Time elapsed: 21 ms
Style reset requested. 
DGML2 Name       :  "Atlas" 
adding container: "cityplacemarks" 
adding container: "baseplacemarks" 
adding container: "elevplacemarks" 
adding container: "observatoryplacemarks" 
adding container: "otherplacemarks" 
adding container: "boundaryplacemarks" 
THEME CHANGED: *** "earth/srtm/srtm.dgml" 
initTheme 
starting parser for "otherplacemarks" 
starting parser for "observatoryplacemarks" 
No recent Default Placemark Cache File available! 
No Default Placemark Source File for  "observatoryplacemarks" 
starting parser for "boundaryplacemarks" 
"Loading Cache File:/usr/share/kde4/apps/marble/data/placemarks/boundaryplacemarks.cache" 
starting parser for "elevplacemarks" 
"Loading Cache File:/usr/share/kde4/apps/marble/data/placemarks/elevplacemarks.cache" 
"Loading Cache File:/usr/share/kde4/apps/marble/data/placemarks/otherplacemarks.cache" 
starting parser for "baseplacemarks" 
"Loading Cache File:/usr/share/kde4/apps/marble/data/placemarks/baseplacemarks.cache" 
starting parser for "cityplacemarks" 
"Loading Cache File:/usr/share/kde4/apps/marble/data/placemarks/cityplacemarks.cache" 
Loading ended true 
placemarksLoaded 
Loading ended true 
placemarksLoaded 
Loading ended true 
placemarksLoaded 
Loading ended true 
placemarksLoaded 
GeoSceneSettings: Property  "showClouds" to true 
Style reset requested. 
kiloBytes 30720 
"Setting tile cache to 30720 kilobytes." 
Theme changed to  "earth/srtm/srtm.dgml" 
true 
FileStorageWatcher: Creating cache size 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "show_crosshairs" with KXMLGUIFactory! 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
marble(22148)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
FileManager::addFile 
PlacemarkManager::addGeoDataDocument: "otherplacemarks"  size  47 
Style reset requested. 
addPlacemarks: Time elapsed: 13 ms for 47 Placemarks. 
FileManager::addFile 
PlacemarkManager::addGeoDataDocument: "baseplacemarks"  size  4 
Style reset requested. 
addPlacemarks: Time elapsed: 2 ms for 4 Placemarks. 
FileManager::addFile 
PlacemarkManager::addGeoDataDocument: "elevplacemarks"  size  13 
Style reset requested. 
addPlacemarks: Time elapsed: 4 ms for 13 Placemarks. 
FileManager::addFile 
PlacemarkManager::addGeoDataDocument: "boundaryplacemarks"  size  255 
Style reset requested. 
addPlacemarks: Time elapsed: 33 ms for 255 Placemarks. 
void Marble::StarsPlugin::loadStars() 
Loading ended true 
placemarksLoaded 
StackedTileLoader::loadTile "0:0:0:0" 
StackedTileLoader::loadTile: tile "earth/srtm" "180082829:0:0:0" QSize(675, 675) 
TileLoader::loadTile "180082829:0:0:0" StateUptodate 
StackedTile::initResultTile: no blending defined => copying top over bottom image 
StackedTileLoader::loadTile "0:0:1:0" 
StackedTileLoader::loadTile: tile "earth/srtm" "180082829:0:1:0" QSize(675, 675) 
TileLoader::loadTile "180082829:0:1:0" StateUptodate 
StackedTile::initResultTile: no blending defined => copying top over bottom image 
static void Marble::VectorComposer::loadCoastlines() 
static void Marble::VectorComposer::loadOverlays() 
Detecting maxLabelHeight ... 
QSocketNotifier: Invalid socket 10 and type 'Read', disabling...
QSocketNotifier: Invalid socket 13 and type 'Read', disabling...
QSocketNotifier: Invalid socket 14 and type 'Read', disabling...
KCrash: Application 'marble' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/home/deif/.kde4/socket-Sobremesa/kdeinit4__0

[1]+  Detenido                marble --sync --debug-info






Backtrace:


Application: Globo virtual Marble (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f69db05a760 (LWP 21956))]

Thread 5 (Thread 0x7f69c8a07700 (LWP 21957)):
#0  0xffffffffff600177 in ?? ()
#1  0x00007fff727c87a1 in ?? ()
#2  0x00007f69d249a2b3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007f69d91df2b2 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007f69d92a233d in QTimerInfoList::updateCurrentTime (this=0x88fa40) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007f69d92a26b5 in QTimerInfoList::timerWait (this=0x88fa40, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007f69d92a117c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f69c8a06c4c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007f69d92a1225 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007f69d21e9087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#10 0x00007f69d21e9fa9 in ?? () from /lib64/libglib-2.0.so.0
#11 0x00007f69d21ea650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#12 0x00007f69d92a1976 in QEventDispatcherGlib::processEvents (this=0x85a6a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007f69d9276052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007f69d9276265 in QEventLoop::exec (this=0x7f69c8a06de0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007f69d918b1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#16 0x00007f69d9257968 in QInotifyFileSystemWatcherEngine::run (this=0x89ad10) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007f69d918da5e in QThreadPrivate::start (arg=0x89ad10) at thread/qthread_unix.cpp:285
#18 0x00007f69d6ef7a3f in start_thread () from /lib64/libpthread.so.0
#19 0x00007f69d7bb567d in clone () from /lib64/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f69c4c0d700 (LWP 21958)):
#0  0xffffffffff600177 in ?? ()
#1  0x00007fff727c87a1 in ?? ()
#2  0x00007f69d249a2b3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007f69d91df2b2 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007f69d92a233d in QTimerInfoList::updateCurrentTime (this=0xabb950) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007f69d92a26b5 in QTimerInfoList::timerWait (this=0xabb950, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007f69d92a117c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f69c4c0cc4c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007f69d92a1225 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007f69d21e9087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#10 0x00007f69d21e9fa9 in ?? () from /lib64/libglib-2.0.so.0
#11 0x00007f69d21ea650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#12 0x00007f69d92a1976 in QEventDispatcherGlib::processEvents (this=0xab8d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007f69d9276052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007f69d9276265 in QEventLoop::exec (this=0x7f69c4c0cde0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007f69d918b1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#16 0x00007f69d9257968 in QInotifyFileSystemWatcherEngine::run (this=0xabe1d0) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007f69d918da5e in QThreadPrivate::start (arg=0xabe1d0) at thread/qthread_unix.cpp:285
#18 0x00007f69d6ef7a3f in start_thread () from /lib64/libpthread.so.0
#19 0x00007f69d7bb567d in clone () from /lib64/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f69c440c700 (LWP 21959)):
#0  0x00007f69d7bac503 in poll () from /lib64/libc.so.6
#1  0x00007f69d21ea114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007f69d21ea650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f69d92a1976 in QEventDispatcherGlib::processEvents (this=0xadfef0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f69d9276052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f69d9276265 in QEventLoop::exec (this=0x7f69c440bde0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f69d918b1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f69d9257968 in QInotifyFileSystemWatcherEngine::run (this=0xad47c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f69d918da5e in QThreadPrivate::start (arg=0xad47c0) at thread/qthread_unix.cpp:285
#9  0x00007f69d6ef7a3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f69d7bb567d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f69c1406700 (LWP 21966)):
#0  0x00007f69d7ba72f5 in _xstat () from /lib64/libc.so.6
#1  0x00007f69d9250b96 in stat64 (this=0xfcef30) at /usr/include/sys/stat.h:504
#2  QFSFileEnginePrivate::doStat (this=0xfcef30) at io/qfsfileengine_unix.cpp:707
#3  0x00007f69d9250d87 in QFSFileEngine::fileFlags (this=0xfc61e0, type=...) at io/qfsfileengine_unix.cpp:820
#4  0x00007f69d920e705 in QFileInfoPrivate::getFileFlags (this=0x2a0ef70, request=...) at io/qfileinfo.cpp:126
#5  0x00007f69d920fa7e in QFileInfo::isDir (this=<value optimized out>) at io/qfileinfo.cpp:890
#6  0x00007f69d92093d8 in QDirIteratorPrivate::checkAndPushDirectory (this=0xf97cc0, fileInfo=...) at io/qdiriterator.cpp:248
#7  0x00007f69d9209613 in QDirIteratorPrivate::advance (this=0xf97cc0) at io/qdiriterator.cpp:220
#8  0x00007f69d920976d in QDirIterator::next (this=0x7f69c1405d70) at io/qdiriterator.cpp:463
#9  0x00007f69da6bc631 in Marble::FileStorageWatcherThread::getCurrentCacheSize (this=0xf9aff0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/FileStorageWatcher.cpp:109
#10 0x00007f69da6bc99a in Marble::FileStorageWatcher::run (this=0x7b1790) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/FileStorageWatcher.cpp:391
#11 0x00007f69d918da5e in QThreadPrivate::start (arg=0x7b1790) at thread/qthread_unix.cpp:285
#12 0x00007f69d6ef7a3f in start_thread () from /lib64/libpthread.so.0
#13 0x00007f69d7bb567d in clone () from /lib64/libc.so.6
#14 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f69db05a760 (LWP 21956)):
[KCrash Handler]
#6  Marble::GeoPainter::drawPolyline (this=0x7fff72604ba0, lineString=..., labelText=..., labelPositionFlags=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/GeoPainter.cpp:558
#7  0x00007f69da7022fc in renderAlternativeRoutes (this=0xa33380, painter=0x7fff72604ba0, viewport=<value optimized out>, renderPos=<value optimized out>, layer=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/routing/RoutingLayer.cpp:246
#8  Marble::RoutingLayer::render (this=0xa33380, painter=0x7fff72604ba0, viewport=<value optimized out>, renderPos=<value optimized out>, layer=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/routing/RoutingLayer.cpp:677
#9  0x00007f69da6770f4 in Marble::LayerManager::renderLayer (this=0x716188, painter=<value optimized out>, viewParams=<value optimized out>, renderPosition=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/LayerManager.cpp:181
#10 0x00007f69da677b3d in Marble::LayerManager::renderLayers (this=0x716188, painter=0x7fff72604ba0, viewParams=0x716178, renderPositions=<value optimized out>) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/LayerManager.cpp:144
#11 0x00007f69da62e13a in Marble::MarbleMapPrivate::paintGround (this=0x716160, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:227
#12 0x00007f69da620749 in Marble::MarbleWidget::paintEvent (this=0x862930, evt=0x7fff72605480) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:805
#13 0x00007f69d86944ea in QWidget::event (this=0x862930, event=0x7fff72605480) at kernel/qwidget.cpp:8346
#14 0x00007f69d8642d14 in QApplicationPrivate::notify_helper (this=0x6bf040, receiver=0x862930, e=0x7fff72605480) at kernel/qapplication.cpp:4445
#15 0x00007f69d864b22a in QApplication::notify (this=<value optimized out>, receiver=0x862930, e=0x7fff72605480) at kernel/qapplication.cpp:4324
#16 0x00007f69d9bd79e6 in KApplication::notify (this=0x7fff72607930, receiver=0x862930, event=0x7fff72605480) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#17 0x00007f69d9276bfc in QCoreApplication::notifyInternal (this=0x7fff72607930, receiver=0x862930, event=0x7fff72605480) at kernel/qcoreapplication.cpp:732
#18 0x00007f69d86913b2 in sendSpontaneousEvent (this=0x876900, pdev=0xb07a48, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xb000f0) at ../../src/corelib/kernel/qcoreapplication.h:218
#19 QWidgetPrivate::drawWidget (this=0x876900, pdev=0xb07a48, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xb000f0) at kernel/qwidget.cpp:5433
#20 0x00007f69d8691f7f in QWidgetPrivate::paintSiblingsRecursive (this=0x74cf80, pdev=0xb07a48, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xb000f0) at kernel/qwidget.cpp:5640
#21 0x00007f69d8691e3c in QWidgetPrivate::paintSiblingsRecursive (this=0x74cf80, pdev=0xb07a48, siblings=..., index=0, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xb000f0) at kernel/qwidget.cpp:5627
#22 0x00007f69d8691e3c in QWidgetPrivate::paintSiblingsRecursive (this=0x74cf80, pdev=0xb07a48, siblings=..., index=2, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xb000f0) at kernel/qwidget.cpp:5627
#23 0x00007f69d869111a in QWidgetPrivate::drawWidget (this=0x74cf80, pdev=0xb07a48, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xb000f0) at kernel/qwidget.cpp:5486
#24 0x00007f69d8691f7f in QWidgetPrivate::paintSiblingsRecursive (this=0x7ebd80, pdev=0xb07a48, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xb000f0) at kernel/qwidget.cpp:5640
#25 0x00007f69d869111a in QWidgetPrivate::drawWidget (this=0x7ebd80, pdev=0xb07a48, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xb000f0) at kernel/qwidget.cpp:5486
#26 0x00007f69d8691f7f in QWidgetPrivate::paintSiblingsRecursive (this=0x7ecbf0, pdev=0xb07a48, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xb000f0) at kernel/qwidget.cpp:5640
#27 0x00007f69d8691e3c in QWidgetPrivate::paintSiblingsRecursive (this=0x7ecbf0, pdev=0xb07a48, siblings=..., index=6, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xb000f0) at kernel/qwidget.cpp:5627
#28 0x00007f69d8691e3c in QWidgetPrivate::paintSiblingsRecursive (this=0x7ecbf0, pdev=0xb07a48, siblings=..., index=9, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xb000f0) at kernel/qwidget.cpp:5627
#29 0x00007f69d869111a in QWidgetPrivate::drawWidget (this=0x7ecbf0, pdev=0xb07a48, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xb000f0) at kernel/qwidget.cpp:5486
#30 0x00007f69d8854191 in QWidgetBackingStore::sync (this=0xb000f0) at painting/qbackingstore.cpp:1333
#31 0x00007f69d8854479 in QWidgetBackingStore::sync (this=0xb000f0, exposedWidget=0x7ec9e0, exposedRegion=...) at painting/qbackingstore.cpp:1130
#32 0x00007f69d86bfb20 in QETWidget::translatePaintEvent (this=0x7ec9e0, event=<value optimized out>) at kernel/qapplication_x11.cpp:5152
#33 0x00007f69d86c08ab in QApplication::x11ProcessEvent (this=0x7fff72607930, event=0x7fff72607560) at kernel/qapplication_x11.cpp:3464
#34 0x00007f69d86e80f2 in x11EventSourceDispatch (s=0x6a05d0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x00007f69d21e9bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#36 0x00007f69d21ea3b0 in ?? () from /lib64/libglib-2.0.so.0
#37 0x00007f69d21ea650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#38 0x00007f69d92a191f in QEventDispatcherGlib::processEvents (this=0x69cc30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#39 0x00007f69d86e7d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007f69d9276052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#41 0x00007f69d9276265 in QEventLoop::exec (this=0x7fff72607880, flags=...) at kernel/qeventloop.cpp:201
#42 0x00007f69d927a6ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#43 0x0000000000421725 in main (argc=1, argv=0x7fff72608f38) at /usr/src/debug/kdeedu-4.6.0/marble/src/kdemain.cpp:351
Comment 20 Dennis Nienhüser 2011-03-30 08:08:45 UTC
(In reply to comment #19)
> Thread 1 (Thread 0x7f69db05a760 (LWP 21956)):
> [KCrash Handler]
> #6  Marble::GeoPainter::drawPolyline (this=0x7fff72604ba0, lineString=...,
> labelText=..., labelPositionFlags=...) at
> /usr/src/debug/kdeedu-4.6.0/marble/src/lib/GeoPainter.cpp:558
> #7  0x00007f69da7022fc in renderAlternativeRoutes (this=0xa33380,
> painter=0x7fff72604ba0, viewport=<value optimized out>, renderPos=<value
> optimized out>, layer=<value optimized out>) at
> /usr/src/debug/kdeedu-4.6.0/marble/src/lib/routing/RoutingLayer.cpp:246

This crash is unrelated to this bug. See bug 263753 and https://bugs.kde.org/show_bug.cgi?id=263753#c7 for a workaround.
Comment 21 Dennis Nienhüser 2011-04-03 11:47:20 UTC
*** Bug 269973 has been marked as a duplicate of this bug. ***
Comment 22 Karl Ferdinand Ebert 2011-04-10 18:42:19 UTC
Created attachment 58775 [details]
New crash information added by DrKonqi

marble (1.0.0 (Stable Release)) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.2

- What I was doing when the application crashed:

Marble crashes at startup. Config file is unrelated to this.

-- Backtrace (Reduced):
#6  ref (this=0x1263900) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#7  QList (this=0x1263900) at /usr/include/qt4/QtCore/qlist.h:118
#8  Marble::GeoSceneTexture::downloadPolicies (this=0x1263900) at ../../../../marble/src/lib/geodata/scene/GeoSceneTexture.cpp:207
#9  0x00007f44a4514b18 in Marble::MarbleModel::addDownloadPolicies (this=0xf492b0, mapTheme=0x12635f0) at ../../../../marble/src/lib/MarbleModel.cpp:552
#10 0x00007f44a4514f17 in Marble::MarbleModel::setMapTheme (this=0xf492b0, mapTheme=0x12635f0) at ../../../../marble/src/lib/MarbleModel.cpp:256
Comment 23 Christoph Feck 2018-12-20 18:53:33 UTC
If this is reproducible with a Qt5-based "marble", please create a new ticket.