Bug 261199 - Marble crashes at start up
Summary: Marble crashes at start up
Status: RESOLVED DUPLICATE of bug 247420
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 1.2 (KDE 4.7)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-25 02:19 UTC by Bernd Müller
Modified: 2011-01-01 12:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Müller 2010-12-25 02:19:11 UTC
Application: marble (0.90 (1.0 Release Candidate 1))
KDE Platform Version: 4.5.90 (4.6 RC1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
Marble crashes at start up. No further info possible. (Blank text)

-- Backtrace:
Application: Marble – Virtueller Globus (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f341711b760 (LWP 3112))]

Thread 4 (Thread 0x7f3401f9f700 (LWP 3115)):
#0  0x00007f340ec86a14 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#1  0x00007f340ec86e78 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f340ec8745c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f34152361e6 in QEventDispatcherGlib::processEvents (this=0x1733bb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f3415208a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f3415208dec in QEventLoop::exec (this=0x7f3401f9edb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f34151132fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f34151e85f8 in QInotifyFileSystemWatcherEngine::run (this=0x17334b0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f341511627e in QThreadPrivate::start (arg=0x17334b0) at thread/qthread_unix.cpp:266
#9  0x00007f340f53d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f3413ae792d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f33fd8e3700 (LWP 3116)):
#0  0x00007f340f540c9d in __pthread_mutex_unlock_usercnt (mutex=0x1908988) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x1908988) at pthread_mutex_unlock.c:290
#2  0x00007f340ec86b51 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0x00007f340ec86e78 in ?? () from /lib/libglib-2.0.so.0
#4  0x00007f340ec8745c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00007f34152361e6 in QEventDispatcherGlib::processEvents (this=0x18fb040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#6  0x00007f3415208a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#7  0x00007f3415208dec in QEventLoop::exec (this=0x7f33fd8e2db0, flags=) at kernel/qeventloop.cpp:201
#8  0x00007f34151132fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#9  0x00007f34151e85f8 in QInotifyFileSystemWatcherEngine::run (this=0x1697710) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f341511627e in QThreadPrivate::start (arg=0x1697710) at thread/qthread_unix.cpp:266
#11 0x00007f340f53d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#12 0x00007f3413ae792d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f33fd0e2700 (LWP 3117)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f33fd0e1a90 in ?? ()
#2  0x00007fff6d9aa852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f341711b760 (LWP 3112)):
[KCrash Handler]
#6  ref (this=0x1aa5920) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#7  QList (this=0x1aa5920) at /usr/include/qt4/QtCore/qlist.h:118
#8  Marble::GeoSceneTexture::downloadPolicies (this=0x1aa5920) at ../../../../marble/src/lib/geodata/scene/GeoSceneTexture.cpp:207
#9  0x00007f34166bd838 in Marble::MarbleModel::addDownloadPolicies (this=0x16dc7a0, mapTheme=0x1a97250) at ../../../../marble/src/lib/MarbleModel.cpp:552
#10 0x00007f34166bddb7 in Marble::MarbleModel::setMapTheme (this=0x7fff6d980d30, mapTheme=0x1aa5920) at ../../../../marble/src/lib/MarbleModel.cpp:256
#11 0x00007f34166c8281 in Marble::MarbleMap::setMapThemeId (this=0x16dc6d0, mapThemeId=<value optimized out>) at ../../../../marble/src/lib/MarbleMap.cpp:940
#12 0x00007f34166bb263 in Marble::MarbleWidget::setMapThemeId (this=0x16dc0b0, mapThemeId=...) at ../../../../marble/src/lib/MarbleWidget.cpp:864
#13 0x000000000042bb53 in Marble::MarblePart::readSettings (this=<value optimized out>) at ../../../marble/src/marble_part.cpp:392
#14 0x00000000004321ad in Marble::MarblePart::MarblePart (this=0x1547580, parentWidget=<value optimized out>, parent=0x1546d20, arguments=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../marble/src/marble_part.cpp:157
#15 0x0000000000421335 in Marble::MainWindow::MainWindow (this=0x1546d20, marbleDataPath=<value optimized out>, parent=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../marble/src/KdeMainWindow.cpp:39
#16 0x0000000000420666 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../marble/src/kdemain.cpp:309

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-01-01 12:01:11 UTC

*** This bug has been marked as a duplicate of bug 247420 ***