Bug 262513 - Marble crashes at startup since KDE 4.6 RC2 update
Summary: Marble crashes at startup since KDE 4.6 RC2 update
Status: RESOLVED DUPLICATE of bug 247420
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 1.2 (KDE 4.7)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-08 12:52 UTC by Florent C.
Modified: 2011-01-09 10:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florent C. 2011-01-08 12:52:16 UTC
Application: marble (0.92 (1.0 Release Candidate 2))
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

Marble crashes when I try to start it since KDE 4.6 RC2 update (Kubuntu 10.10). I tried to remove marblerc but it still crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Globe Virtuel Marble (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8e90af9760 (LWP 17214))]

Thread 4 (Thread 0x7f8e7b9cb700 (LWP 17215)):
#0  __libc_enable_asynccancel () at ../nptl/sysdeps/unix/sysv/linux/x86_64/cancellation.S:66
#1  0x00007f8e8d4b21e8 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:85
#2  0x00007f8e8865d009 in ?? () from /lib/libglib-2.0.so.0
#3  0x00007f8e8865d45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00007f8e8ec0d1e6 in QEventDispatcherGlib::processEvents (this=0x2097a70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f8e8ebdfa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f8e8ebdfdec in QEventLoop::exec (this=0x7f8e7b9cadb0, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f8e8eaea2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f8e8ebbf5f8 in QInotifyFileSystemWatcherEngine::run (this=0x2097370) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f8e8eaed27e in QThreadPrivate::start (arg=0x2097370) at thread/qthread_unix.cpp:266
#10 0x00007f8e88f13971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f8e8d4be92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f8e7730f700 (LWP 17216)):
#0  0x00007f8e8865c628 in g_main_context_check () from /lib/libglib-2.0.so.0
#1  0x00007f8e8865d023 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f8e8865d45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f8e8ec0d1e6 in QEventDispatcherGlib::processEvents (this=0x2379180, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f8e8ebdfa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f8e8ebdfdec in QEventLoop::exec (this=0x7f8e7730edb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f8e8eaea2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f8e8ebbf5f8 in QInotifyFileSystemWatcherEngine::run (this=0x2279ab0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8e8eaed27e in QThreadPrivate::start (arg=0x2279ab0) at thread/qthread_unix.cpp:266
#9  0x00007f8e88f13971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f8e8d4be92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f8e76b0e700 (LWP 17217)):
#0  0x00007f8e8d4b2203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f8e8865d009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f8e8865d45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f8e8ec0d1e6 in QEventDispatcherGlib::processEvents (this=0x2385880, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f8e8ebdfa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f8e8ebdfdec in QEventLoop::exec (this=0x7f8e76b0ddb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f8e8eaea2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f8e8ebbf5f8 in QInotifyFileSystemWatcherEngine::run (this=0x2383170) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8e8eaed27e in QThreadPrivate::start (arg=0x2383170) at thread/qthread_unix.cpp:266
#9  0x00007f8e88f13971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f8e8d4be92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8e90af9760 (LWP 17214)):
[KCrash Handler]
#6  ref (this=0x23ee590) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#7  QList (this=0x23ee590) at /usr/include/qt4/QtCore/qlist.h:118
#8  Marble::GeoSceneTexture::downloadPolicies (this=0x23ee590) at ../../../../marble/src/lib/geodata/scene/GeoSceneTexture.cpp:207
#9  0x00007f8e90097a08 in Marble::MarbleModel::addDownloadPolicies (this=0x20411c0, mapTheme=0x23ed860) at ../../../../marble/src/lib/MarbleModel.cpp:552
#10 0x00007f8e90097f87 in Marble::MarbleModel::setMapTheme (this=0x7ffff180f540, mapTheme=0x23ee590) at ../../../../marble/src/lib/MarbleModel.cpp:256
#11 0x00007f8e900a2442 in Marble::MarbleMap::setMapThemeId (this=0x20410f0, mapThemeId=<value optimized out>) at ../../../../marble/src/lib/MarbleMap.cpp:953
#12 0x00007f8e90095433 in Marble::MarbleWidget::setMapThemeId (this=0x2040ab0, mapThemeId=...) at ../../../../marble/src/lib/MarbleWidget.cpp:864
#13 0x000000000042c023 in Marble::MarblePart::readSettings (this=<value optimized out>) at ../../../marble/src/marble_part.cpp:392
#14 0x000000000043267d in Marble::MarblePart::MarblePart (this=0x1e37090, parentWidget=<value optimized out>, parent=0x1e36d60, arguments=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../marble/src/marble_part.cpp:157
#15 0x0000000000421845 in Marble::MainWindow::MainWindow (this=0x1e36d60, marbleDataPath=<value optimized out>, parent=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../marble/src/KdeMainWindow.cpp:39
#16 0x0000000000420b76 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../marble/src/kdemain.cpp:309

Possible duplicates by query: bug 262034, bug 261199, bug 247420.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-01-09 10:26:16 UTC

*** This bug has been marked as a duplicate of bug 247420 ***