Bug 258915 - Marble widget signal: Aborted (issue startup)
Summary: Marble widget signal: Aborted (issue startup)
Status: RESOLVED DUPLICATE of bug 247420
Alias: None
Product: marble
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-05 15:33 UTC by omega
Modified: 2018-08-27 21:54 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description omega 2010-12-05 15:33:35 UTC
Application: digikam (1.5.0)
KDE Platform Version: 4.5.80 (4.6 Beta1)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-7-generic x86_64
Distribution: Ubuntu natty (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

when i launch digiKam, it fails to open giving many errors in konsole

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
[Current thread is 1 (Thread 0x7f244eabc800 (LWP 22411))]

Thread 15 (Thread 0x7f24313f9710 (LWP 22412)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f24478b80eb in wait (this=<value optimized out>, mutex=0x11fda70, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x11fda70, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000000006c51d5 in Digikam::ScanController::run (this=0x1572030) at /build/buildd/digikam-1.5.0/digikam/scancontroller.cpp:515
#4  0x00007f24478b7a2e in QThreadPrivate::start (arg=0x1572030) at thread/qthread_unix.cpp:285
#5  0x00007f2443ea9971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007f244633c94d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 14 (Thread 0x7f2430bf8710 (LWP 22413)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f2430bf7a30 in ?? ()
#2  0x00007fff0df1a7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 13 (Thread 0x7f24303f7710 (LWP 22414)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f24303f6a40 in ?? ()
#2  0x00007fff0df1a7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 12 (Thread 0x7f242fbf6710 (LWP 22417)):
#0  0x00007f2443eacc9d in __pthread_mutex_unlock_usercnt (mutex=0x18e9c88) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x18e9c88) at pthread_mutex_unlock.c:290
#2  0x00007f2442c410d3 in ?? () from /lib/libglib-2.0.so.0
#3  0x00007f2442c41559 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00007f24479c9f26 in QEventDispatcherGlib::processEvents (this=0x1584020, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f244799e362 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f244799e59c in QEventLoop::exec (this=0x7f242fbf5d50, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f24478b5274 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f24478b7a2e in QThreadPrivate::start (arg=0x151d6b0) at thread/qthread_unix.cpp:285
#9  0x00007f2443ea9971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f244633c94d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f242f0a4710 (LWP 22418)):
#0  0x00007f2442c3ffde in g_main_context_prepare () from /lib/libglib-2.0.so.0
#1  0x00007f2442c40eb4 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f2442c41559 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f24479c9f26 in QEventDispatcherGlib::processEvents (this=0x1796a70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f244799e362 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f244799e59c in QEventLoop::exec (this=0x7f242f0a3d50, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f24478b5274 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f24478b7a2e in QThreadPrivate::start (arg=0x1725910) at thread/qthread_unix.cpp:285
#8  0x00007f2443ea9971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007f244633c94d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f242e8a3710 (LWP 22419)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f24478b80eb in wait (this=<value optimized out>, mutex=0x18eeaa8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x18eeaa8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f244b8ac2d9 in Digikam::ParkingThread::run (this=0x18eea90) at /build/buildd/digikam-1.5.0/libs/threads/threadmanager.cpp:101
#4  0x00007f24478b7a2e in QThreadPrivate::start (arg=0x18eea90) at thread/qthread_unix.cpp:285
#5  0x00007f2443ea9971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007f244633c94d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f242e0a2710 (LWP 22420)):
#0  0x00007f24479c9f28 in QEventDispatcherGlib::processEvents (this=0x19041e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:416
#1  0x00007f244799e362 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#2  0x00007f244799e59c in QEventLoop::exec (this=0x7f242e0a1d50, flags=...) at kernel/qeventloop.cpp:201
#3  0x00007f24478b5274 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#4  0x00007f24478b7a2e in QThreadPrivate::start (arg=0x1766230) at thread/qthread_unix.cpp:285
#5  0x00007f2443ea9971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007f244633c94d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f242d8a1710 (LWP 22421)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f242d8a0a60 in ?? ()
#2  0x00007fff0df1a7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 7 (Thread 0x7f242146a710 (LWP 22422)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007f242a9dfea1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f2443ea9971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f244633c94d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f242002e710 (LWP 22423)):
#0  0x00007f24463352e3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f242aa08fe4 in xine_usec_sleep () from /usr/lib/libxine.so.1
#2  0x00007f242a9ed9b9 in ?? () from /usr/lib/libxine.so.1
#3  0x00007f2443ea9971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007f244633c94d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f241f82d710 (LWP 22424)):
#0  0x00007f24479c98e2 in socketNotifierSourceCheck (source=0x2003280) at kernel/qeventdispatcher_glib.cpp:79
#1  0x00007f2442c40764 in g_main_context_check () from /lib/libglib-2.0.so.0
#2  0x00007f2442c41052 in ?? () from /lib/libglib-2.0.so.0
#3  0x00007f2442c41559 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00007f24479c9f26 in QEventDispatcherGlib::processEvents (this=0x2001bb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f244799e362 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f244799e59c in QEventLoop::exec (this=0x7f241f82cd00, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f24478b5274 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f242ac6a39e in Phonon::Xine::XineThread::run (this=0x1b420e0) at ../../xine/xinethread.cpp:143
#9  0x00007f24478b7a2e in QThreadPrivate::start (arg=0x1b420e0) at thread/qthread_unix.cpp:285
#10 0x00007f2443ea9971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f244633c94d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f241ee27710 (LWP 22425)):
#0  0x00007f2445c00672 in ?? () from /usr/lib/libpulse.so.0
#1  0x00007f2445bf2486 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#2  0x00007f2445bf2b49 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#3  0x00007f2445bf2c00 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#4  0x00007f2445c0061f in ?? () from /usr/lib/libpulse.so.0
#5  0x00007f243d8ac818 in ?? () from /usr/lib/libpulsecommon-0.9.22.so
#6  0x00007f2443ea9971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#7  0x00007f244633c94d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f241a604710 (LWP 22426)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f242a9f1cb3 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f2443ea9971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f244633c94d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f2419dce710 (LWP 22427)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f2419dcda30 in ?? ()
#2  0x00007fff0df1a7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f244eabc800 (LWP 22411)):
[KCrash Handler]
#6  0x00007f2446289ba5 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f244628d6b0 in abort () at abort.c:92
#8  0x00007f24462c343b in __libc_message (do_abort=<value optimized out>, fmt=<value optimized out>) at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#9  0x00007f24462cd4b6 in malloc_printerr (action=3, str=0x7f244639de53 "free(): invalid pointer", ptr=<value optimized out>) at malloc.c:6283
#10 0x00007f244ac86707 in ?? () from /usr/lib/libmarblewidget.so.10
#11 0x00007f244acd3b27 in Marble::MarbleModel::addDownloadPolicies(Marble::GeoSceneDocument*) () from /usr/lib/libmarblewidget.so.10
#12 0x00007f244acd5498 in Marble::MarbleModel::setMapTheme(Marble::GeoSceneDocument*, Marble::Projection) () from /usr/lib/libmarblewidget.so.10
#13 0x00007f244acdb6a7 in Marble::MarbleMap::setMapThemeId(QString const&) () from /usr/lib/libmarblewidget.so.10
#14 0x00007f244acce2f5 in Marble::MarbleWidget::setMapThemeId(QString const&) () from /usr/lib/libmarblewidget.so.10
#15 0x00007f244b948c39 in Digikam::WorldMapWidget::setMapTheme (this=0x223fa10, theme=<value optimized out>) at /build/buildd/digikam-1.5.0/libs/imageproperties/worldmapwidget.cpp:409
#16 0x00007f244b948e77 in Digikam::WorldMapWidget::readConfig (this=0x223fa10, group=...) at /build/buildd/digikam-1.5.0/libs/imageproperties/worldmapwidget.cpp:364
#17 0x00007f244b9468d9 in Digikam::ImagePropertiesGPSTab::readConfig (this=0x223eae0) at /build/buildd/digikam-1.5.0/libs/imageproperties/imagepropertiesgpstab.cpp:212
#18 0x00007f244b9478ab in Digikam::ImagePropertiesGPSTab::ImagePropertiesGPSTab (this=0x223eae0, parent=<value optimized out>) at /build/buildd/digikam-1.5.0/libs/imageproperties/imagepropertiesgpstab.cpp:194
#19 0x00007f244b938060 in Digikam::ImagePropertiesSideBar::ImagePropertiesSideBar (this=0x1924740, parent=0x14e77c0, splitter=<value optimized out>, side=<value optimized out>, mimimizedDefault=<value optimized out>) at /build/buildd/digikam-1.5.0/libs/imageproperties/imagepropertiessidebar.cpp:77
#20 0x0000000000484687 in Digikam::ImagePropertiesSideBarDB::ImagePropertiesSideBarDB (this=0x1924740, parent=0x14e77c0, splitter=<value optimized out>, side=<value optimized out>, mimimizedDefault=<value optimized out>) at /build/buildd/digikam-1.5.0/libs/imageproperties/imagepropertiessidebardb.cpp:88
#21 0x0000000000689f53 in Digikam::DigikamView::DigikamView (this=0x14e77c0, parent=0x1502f20, modelCollection=0x176fcd0) at /build/buildd/digikam-1.5.0/digikam/digikamview.cpp:172
#22 0x000000000066136a in Digikam::DigikamApp::setupView (this=0x1502f20) at /build/buildd/digikam-1.5.0/digikam/digikamapp.cpp:490
#23 0x000000000067a712 in Digikam::DigikamApp::DigikamApp (this=0x1502f20, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /build/buildd/digikam-1.5.0/digikam/digikamapp.cpp:229
#24 0x000000000073a9c7 in main (argc=5, argv=0x7fff0de05d78) at /build/buildd/digikam-1.5.0/digikam/main.cpp:172

Reported using DrKonqi
Comment 1 Martin Klapetek 2010-12-05 19:18:40 UTC
The crash appears to be in Marble library, you may have some mismatched package dependencies. Also, a newer version 1.6.0 was released few weeks ago, I advise you to update and also reinstall your libmarble (kdeedu module), then report back, if the crash still occures.
Comment 2 Dennis Nienhüser 2010-12-06 19:52:41 UTC
Which Marble version is Digikam 1.5 compiled against? I'm a bit confused by your KDE version saying 4.5.80 (4.6 Beta1), while it is Marble 0.10 (KDE 4.5) that is actually used. Please make sure not both Marble 1.0 Beta 1 (KDE 4.6) and Marble 0.10 (KDE 4.5) are installed concurrently.
The Marble version must also match the version the Digikam package was compiled against.
Comment 3 caulier.gilles 2010-12-06 19:59:00 UTC
Go to "Help/Components Info" to see marble version used by digiKam 

Gilles Caulier
Comment 4 Dennis Nienhüser 2011-01-01 12:11:13 UTC

*** This bug has been marked as a duplicate of bug 247420 ***