Bug 249708 - Marble crashes on start
Summary: Marble crashes on start
Status: RESOLVED DUPLICATE of bug 247420
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: 1.0 (KDE 4.6)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-01 09:34 UTC by noinoin
Modified: 2010-09-11 22:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description noinoin 2010-09-01 09:34:28 UTC
Application: marble (PRE-0.11.0 SVN)
KDE Platform Version: 4.5.66 (4.6 >= 20100825) (Compiled from sources)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed: Starting Marble. (it' have to provide more text, but starting mable was realy all i was doing :-) )

The crash can be reproduced every time.

-- Backtrace:
Application: Marble Desktop Globe (marble), signal: Aborted
[Current thread is 1 (Thread 0x7fa8f5cfc760 (LWP 20542))]

Thread 2 (Thread 0x7fa8e1198710 (LWP 20544)):
#0  0x00007fa8efa64f83 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa8eb9d34a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fa8eb9d38fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fa8f3749566 in QEventDispatcherGlib::processEvents (this=0x28557a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fa8f371e992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fa8f371ed6c in QEventLoop::exec (this=0x7fa8e1197db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fa8f3628d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fa8f36ff178 in QInotifyFileSystemWatcherEngine::run (this=0x261b9c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fa8f362b775 in QThreadPrivate::start (arg=0x261b9c0) at thread/qthread_unix.cpp:248
#9  0x00007fa8f339b9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fa8efa716fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa8f5cfc760 (LWP 20542)):
[KCrash Handler]
#6  0x00007fa8ef9bea75 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007fa8ef9c25c0 in *__GI_abort () at abort.c:92
#8  0x00007fa8f3623844 in qt_message_output (msgType=QtFatalMsg, buf=<value optimized out>) at global/qglobal.cpp:2250
#9  0x00007fa8f3623a22 in qt_message (msgType=QtFatalMsg, msg=0x7fa8f37811a8 "ASSERT: \"%s\" in file %s, line %d", ap=0x7fff96006d80) at global/qglobal.cpp:2296
#10 0x00007fa8f3623bd5 in qFatal (msg=0x503e <Address 0x503e out of bounds>) at global/qglobal.cpp:2479
#11 0x00007fa8f52d824d in Marble::GeoTagHandler::registerHandler (qName=..., handler=0x28b05a0) at /home/florian/Source/KDE/kdeedu/marble/src/lib/geodata/parser/GeoTagHandler.cpp:59
#12 0x00007fa8df5611ec in __static_initialization_and_destruction_0 (__initialize_p=<value optimized out>, __priority=<value optimized out>)
    at /home/florian/Source/KDE/kdeedu/marble/src/lib/geodata/handlers/osm-namefinder/SearchResultsTagHandler.cpp:40
#13 0x00007fa8df61ef96 in __do_global_ctors_aux () from /usr/lib/libmarblewidget.so.4
#14 0x00007fa8df511d3b in _init () from /usr/lib/libmarblewidget.so.4
#15 0x00007fa800000000 in ?? ()
#16 0x00007fa8f5b54d65 in call_init (main_map=0x28375b0, argc=-544601920, argv=0x7fff96009138, env=0x7fff96009148) at dl-init.c:70
#17 _dl_init (main_map=0x28375b0, argc=-544601920, argv=0x7fff96009138, env=0x7fff96009148) at dl-init.c:134
#18 0x00007fa8f5b59841 in dl_open_worker (a=<value optimized out>) at dl-open.c:492
#19 0x00007fa8f5b549c6 in _dl_catch_error (objname=<value optimized out>, errstring=<value optimized out>, mallocedp=<value optimized out>, operate=<value optimized out>, args=<value optimized out>)
    at dl-error.c:178
#20 0x00007fa8f5b58ffa in _dl_open (file=0x28358d8 "/usr/lib/kde4/plugins/marble/GpsdPositionProviderPlugin.so", mode=-2147483647, caller_dlopen=0x7fa8f3711433, nsid=-2, argc=1, argv=0x7fa8f378106e, 
    env=0x7fff96009148) at dl-open.c:583
#21 0x00007fa8ec07cf66 in dlopen_doit (a=<value optimized out>) at dlopen.c:67
#22 0x00007fa8f5b549c6 in _dl_catch_error (objname=<value optimized out>, errstring=<value optimized out>, mallocedp=<value optimized out>, operate=<value optimized out>, args=<value optimized out>)
    at dl-error.c:178
#23 0x00007fa8ec07d2ac in _dlerror_run (operate=0x7fa8ec07cf00 <dlopen_doit>, args=0x7fff96007370) at dlerror.c:164
#24 0x00007fa8ec07cee1 in __dlopen (file=<value optimized out>, mode=<value optimized out>) at dlopen.c:88
#25 0x00007fa8f3711433 in QLibraryPrivate::load_sys (this=0x2833f60) at plugin/qlibrary_unix.cpp:205
#26 0x00007fa8f370bcb5 in QLibraryPrivate::loadPlugin (this=0x2833f60) at plugin/qlibrary.cpp:516
#27 0x00007fa8f37054a9 in QPluginLoader::instance (this=0x503e) at plugin/qpluginloader.cpp:201
#28 0x00007fa8f5359878 in Marble::PluginManagerPrivate::loadPlugins (this=0x28532f0) at /home/florian/Source/KDE/kdeedu/marble/src/lib/PluginManager.cpp:183
#29 0x00007fa8f5359b08 in Marble::PluginManager::createRenderPlugins (this=0x2854770) at /home/florian/Source/KDE/kdeedu/marble/src/lib/PluginManager.cpp:92
#30 0x00007fa8f535936a in LayerManagerPrivate (this=0x28b5650, dataFacade=<value optimized out>, pluginManager=0x2854770) at /home/florian/Source/KDE/kdeedu/marble/src/lib/LayerManager.cpp:55
#31 0x00007fa8f5357f5b in LayerManager (this=0x28b71f0, dataFacade=0x2856440, pluginManager=0x2854770, parent=<value optimized out>)
    at /home/florian/Source/KDE/kdeedu/marble/src/lib/LayerManager.cpp:72
#32 0x00007fa8f531a6d1 in MarbleModel (this=0x28545d0, parent=<value optimized out>) at /home/florian/Source/KDE/kdeedu/marble/src/lib/MarbleModel.cpp:256
#33 0x00007fa8f5320044 in MarbleMap (this=0x2853670) at /home/florian/Source/KDE/kdeedu/marble/src/lib/MarbleMap.cpp:285
#34 0x00007fa8f531578e in MarbleWidget (this=0x2852070, parent=0x26414d0) at /home/florian/Source/KDE/kdeedu/marble/src/lib/MarbleWidget.cpp:130
#35 0x0000000000413eeb in ControlView (this=0x26414d0, parent=<value optimized out>) at /home/florian/Source/KDE/kdeedu/marble/src/ControlView.cpp:45
#36 0x00000000004218b0 in MarblePart (this=0x2616cf0, parentWidget=0x264ddc0, parent=<value optimized out>, arguments=<value optimized out>, __in_chrg=<value optimized out>, 
    __vtt_parm=<value optimized out>) at /home/florian/Source/KDE/kdeedu/marble/src/marble_part.cpp:131
#37 0x0000000000419f5b in MainWindow (this=0x264ddc0, marbleDataPath=<value optimized out>, parent=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>)
    at /home/florian/Source/KDE/kdeedu/marble/src/KdeMainWindow.cpp:39
#38 0x00000000004195f4 in main (argc=<value optimized out>, argv=<value optimized out>) at /home/florian/Source/KDE/kdeedu/marble/src/kdemain.cpp:291

Possible duplicates by query: bug 247420.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2010-09-01 21:17:37 UTC
From the backtrace I'd say you have the gpsd position provider plugin compiled against Marble 0.9 lying around in the plugin folder (either self compiled or installed by a marble package). Marble tries to load it and while doing that the old libmarblewidget.so.4 is loaded into memory just next to libmarblewidget.so.11. Currently this leads to a crash because of a static global variable.

To work around it, remove the old plugin / the old Marble installation. The plugin may be /usr/lib/kde4/plugins/marble/GpsdPositionProviderPlugin.so
Comment 2 Dennis Nienhüser 2010-09-11 22:46:16 UTC

*** This bug has been marked as a duplicate of bug 247420 ***