Bug 261710 - Crash at the startup
Summary: Crash at the startup
Status: RESOLVED DUPLICATE of bug 247420
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-31 13:13 UTC by Leo
Modified: 2011-01-01 14:02 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leo 2010-12-31 13:13:50 UTC
Application: showfoto (1.7.0)
KDE Platform Version: 4.5.90 (4.6 RC1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Just trying to open the program clicking on a file in dolphin associated to the program (jpg file)

The crash can be reproduced every time.

-- Backtrace:
Application: showFoto (showfoto), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3aa84b47c0 (LWP 4267))]

Thread 3 (Thread 0x7f3a8f1fa700 (LWP 4268)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f3aa4433e3b in wait (this=<value optimized out>, mutex=0x20f07a8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x20f07a8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f3aa7f0cec2 in Digikam::ParkingThread::run (this=0x20f0790) at /build/buildd/digikam-1.7.0/libs/threads/threadmanager.cpp:119
#4  0x00007f3aa443327e in QThreadPrivate::start (arg=0x20f0790) at thread/qthread_unix.cpp:266
#5  0x00007f3aa41a8971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007f3aa376592d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f3a8e9c4700 (LWP 4269)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f3a8e9c3a30 in ?? ()
#2  0x00007fff09f5c852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f3aa84b47c0 (LWP 4267)):
[KCrash Handler]
#6  0x00007f3aa104360c in Marble::MarbleModel::addDownloadPolicies(Marble::GeoSceneDocument*) () from /usr/lib/libmarblewidget.so.10
#7  0x00007f3aa1048028 in Marble::MarbleModel::setMapTheme(Marble::GeoSceneDocument*, Marble::Projection) () from /usr/lib/libmarblewidget.so.10
#8  0x00007f3aa104f239 in Marble::MarbleMap::setMapThemeId(QString const&) () from /usr/lib/libmarblewidget.so.10
#9  0x00007f3aa1040c05 in Marble::MarbleWidget::setMapThemeId(QString const&) () from /usr/lib/libmarblewidget.so.10
#10 0x00007f3aa7fb3dda in Digikam::WorldMapWidget::setMapTheme (this=0x22ce2b0, theme=<value optimized out>) at /build/buildd/digikam-1.7.0/libs/imageproperties/worldmapwidget.cpp:416
#11 0x00007f3aa7fb7358 in Digikam::WorldMapWidget::readConfig (this=<value optimized out>, group=...) at /build/buildd/digikam-1.7.0/libs/imageproperties/worldmapwidget.cpp:370
#12 0x00007f3aa7faefaa in Digikam::ImagePropertiesGPSTab::readConfig (this=0x22cd470) at /build/buildd/digikam-1.7.0/libs/imageproperties/imagepropertiesgpstab.cpp:215
#13 0x00007f3aa7fb064b in Digikam::ImagePropertiesGPSTab::ImagePropertiesGPSTab (this=0x22cd470, parent=<value optimized out>) at /build/buildd/digikam-1.7.0/libs/imageproperties/imagepropertiesgpstab.cpp:197
#14 0x00007f3aa7f9ad48 in Digikam::ImagePropertiesSideBar::ImagePropertiesSideBar (this=0x20cbd30, parent=0x2176440, splitter=<value optimized out>, side=<value optimized out>, mimimizedDefault=<value optimized out>) at /build/buildd/digikam-1.7.0/libs/imageproperties/imagepropertiessidebar.cpp:77
#15 0x000000000043c626 in ShowFoto::ShowFoto::setupUserArea (this=0x2074a20) at /build/buildd/digikam-1.7.0/showfoto/showfoto.cpp:408
#16 0x000000000043faff in ShowFoto::ShowFoto::ShowFoto (this=0x2074a20, urlList=..., __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /build/buildd/digikam-1.7.0/showfoto/showfoto.cpp:223
#17 0x0000000000436f2f in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/digikam-1.7.0/showfoto/main.cpp:82

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-31 23:31:31 UTC
[Comment from a bug triager]
- Is the Marble application properly installed and updated ?
As bug 247420 and other reports, this could be caused by some old Marble
installation conflicting with the new one.
Thanks
Comment 2 Dennis Nienhüser 2011-01-01 11:55:09 UTC

*** This bug has been marked as a duplicate of bug 247420 ***
Comment 3 Leo 2011-01-01 14:02:13 UTC
(In reply to comment #1)
> [Comment from a bug triager]
> - Is the Marble application properly installed and updated ?
> As bug 247420 and other reports, this could be caused by some old Marble
> installation conflicting with the new one.
> Thanks

I think it is related because I have also the bug 247420 problem :(
Happy new year anyway :)