Bug 269973 - Marble crash at start up
Summary: Marble crash at start up
Status: RESOLVED DUPLICATE of bug 247420
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: 1.1.0
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-03 01:15 UTC by Florian Kriener
Modified: 2011-04-03 11:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Kriener 2011-04-03 01:15:28 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-2-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
- What I was doing when the application crashed:
When I started marble after the upgrade to 4.6.1 (from debian qt-kde.debian.org repository) it crashed immedately.

The crash can be reproduced every time.

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f48accf9780 (LWP 3411))]

Thread 4 (Thread 0x7f48964f3700 (LWP 3412)):
#0  0xffffffffff600132 in ?? ()
#1  0x00007fff411ff841 in ?? ()
#2  0x00007f48a4672e7f in clock_gettime (clock_id=-1773196528, tp=0x7f48964f2b10) at ../sysdeps/unix/clock_gettime.c:100
#3  0x00007f48aadab252 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007f48aae6e7dd in QTimerInfoList::updateCurrentTime (this=0x2861920) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007f48aae6eb65 in QTimerInfoList::timerWait (this=0x2861920, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007f48aae6d5cc in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f48964f2c3c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007f48aae6d675 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007f48a43c2957 in g_main_context_prepare (context=0x2864f90, priority=0x7f48964f2cac) at /tmp/buildd/glib2.0-2.28.4/./glib/gmain.c:2761
#10 0x00007f48a43c3879 in g_main_context_iterate (context=0x2864f90, block=1, dispatch=1, self=<value optimized out>) at /tmp/buildd/glib2.0-2.28.4/./glib/gmain.c:3071
#11 0x00007f48a43c3f1d in g_main_context_iteration (context=0x2864f90, may_block=1) at /tmp/buildd/glib2.0-2.28.4/./glib/gmain.c:3154
#12 0x00007f48aae6dde6 in QEventDispatcherGlib::processEvents (this=0x27fe3f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007f48aae42022 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007f48aae4226c in QEventLoop::exec (this=0x7f48964f2dc0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007f48aad577d4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#16 0x00007f48aae239b8 in QInotifyFileSystemWatcherEngine::run (this=0x27fe1f0) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007f48aad5a035 in QThreadPrivate::start (arg=0x27fe1f0) at thread/qthread_unix.cpp:320
#18 0x00007f48a4e8d8ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#19 0x00007f48a97093cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#20 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f488de70700 (LWP 3413)):
#0  0xffffffffff600132 in ?? ()
#1  0x00007fff411ff841 in ?? ()
#2  0x00007f48a4672e7f in clock_gettime (clock_id=-1914242288, tp=0x7f488de6fb10) at ../sysdeps/unix/clock_gettime.c:100
#3  0x00007f48aadab252 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007f48aae6e7dd in QTimerInfoList::updateCurrentTime (this=0x2a982f0) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007f48aae6eb65 in QTimerInfoList::timerWait (this=0x2a982f0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007f48aae6d5cc in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f488de6fc3c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007f48aae6d675 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007f48a43c2957 in g_main_context_prepare (context=0x2a9a580, priority=0x7f488de6fcac) at /tmp/buildd/glib2.0-2.28.4/./glib/gmain.c:2761
#10 0x00007f48a43c3879 in g_main_context_iterate (context=0x2a9a580, block=1, dispatch=1, self=<value optimized out>) at /tmp/buildd/glib2.0-2.28.4/./glib/gmain.c:3071
#11 0x00007f48a43c3f1d in g_main_context_iteration (context=0x2a9a580, may_block=1) at /tmp/buildd/glib2.0-2.28.4/./glib/gmain.c:3154
#12 0x00007f48aae6dde6 in QEventDispatcherGlib::processEvents (this=0x2a9e370, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007f48aae42022 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007f48aae4226c in QEventLoop::exec (this=0x7f488de6fdc0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007f48aad577d4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#16 0x00007f48aae239b8 in QInotifyFileSystemWatcherEngine::run (this=0x2aa36f0) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007f48aad5a035 in QThreadPrivate::start (arg=0x2aa36f0) at thread/qthread_unix.cpp:320
#18 0x00007f48a4e8d8ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#19 0x00007f48a97093cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#20 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f488d66f700 (LWP 3414)):
#0  __pthread_mutex_unlock_usercnt (mutex=0x2a99518, decr=1) at pthread_mutex_unlock.c:37
#1  0x00007f48a43c294a in g_main_context_prepare (context=0x2a99510, priority=0x7f488d66ecac) at /tmp/buildd/glib2.0-2.28.4/./glib/gmain.c:2759
#2  0x00007f48a43c3879 in g_main_context_iterate (context=0x2a99510, block=1, dispatch=1, self=<value optimized out>) at /tmp/buildd/glib2.0-2.28.4/./glib/gmain.c:3071
#3  0x00007f48a43c3f1d in g_main_context_iteration (context=0x2a99510, may_block=1) at /tmp/buildd/glib2.0-2.28.4/./glib/gmain.c:3154
#4  0x00007f48aae6dde6 in QEventDispatcherGlib::processEvents (this=0x2a9adf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f48aae42022 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f48aae4226c in QEventLoop::exec (this=0x7f488d66edc0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f48aad577d4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007f48aae239b8 in QInotifyFileSystemWatcherEngine::run (this=0x7f4890007460) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f48aad5a035 in QThreadPrivate::start (arg=0x7f4890007460) at thread/qthread_unix.cpp:320
#10 0x00007f48a4e8d8ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#11 0x00007f48a97093cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f48accf9780 (LWP 3411)):
[KCrash Handler]
#6  ref (this=0x2afde30) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#7  QList (this=0x2afde30) at /usr/include/qt4/QtCore/qlist.h:118
#8  Marble::GeoSceneTexture::downloadPolicies (this=0x2afde30) at ../../../../marble/src/lib/geodata/scene/GeoSceneTexture.cpp:207
#9  0x00007f48ac2b0b18 in Marble::MarbleModel::addDownloadPolicies (this=0x27fd4a0, mapTheme=0x2afda80) at ../../../../marble/src/lib/MarbleModel.cpp:552
#10 0x00007f48ac2b0f17 in Marble::MarbleModel::setMapTheme (this=0x27fd4a0, mapTheme=0x2afda80) at ../../../../marble/src/lib/MarbleModel.cpp:256
#11 0x00007f48ac2b653b in Marble::MarbleMap::setMapThemeId (this=0x2857290, mapThemeId=<value optimized out>) at ../../../../marble/src/lib/MarbleMap.cpp:956
#12 0x00007f48ac2acc35 in Marble::MarbleWidget::setMapThemeId (this=0x285ebd0, mapThemeId=...) at ../../../../marble/src/lib/MarbleWidget.cpp:864
#13 0x000000000042bcae in Marble::MarblePart::readSettings (this=0x26d2d80) at ../../../marble/src/marble_part.cpp:392
#14 0x000000000042e8ff in Marble::MarblePart::MarblePart (this=0x26d2d80, parentWidget=<value optimized out>, parent=0x26d92b0, arguments=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../marble/src/marble_part.cpp:157
#15 0x000000000042202d in Marble::MainWindow::MainWindow (this=0x26d92b0, marbleDataPath=<value optimized out>, parent=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../marble/src/KdeMainWindow.cpp:39
#16 0x00000000004211f6 in main (argc=1, argv=0x7fff411dbe48) at ../../../marble/src/kdemain.cpp:309

This bug may be a duplicate of or related to bug 247420.

Possible duplicates by query: bug 262513, bug 262034, bug 261199, bug 247420.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-04-03 11:47:20 UTC

*** This bug has been marked as a duplicate of bug 247420 ***