Bug 185127 - Screen goes black leaving (movable) mouse pointer
Summary: Screen goes black leaving (movable) mouse pointer
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: VHI normal with 3 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 178471 185204 185272 185328 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-02-21 14:11 UTC by Jay Ambee
Modified: 2018-12-23 20:10 UTC (History)
26 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kwin crash (3.35 KB, text/plain)
2009-02-25 22:47 UTC, Jason 'vanRijn' Kasper
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jay Ambee 2009-02-21 14:11:45 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    SuSE RPMs

Linux Distro: OpenSuse 11.1
KDE version 4.2.0 (latest update from OpenSuse-Servers: 21.02.09)

Seems I have to report this as a new bug to get notified:

Since the 4.2.0 edition of KDE I am following the daily updates from the OpenSuse server (as a daily complete package update (newer versions).
Lots of things have improved so far! Great work!!

But since 3 days, after the update (and continuing through the last updates I have an annoying bug, that each time leaves me with the single chance to completely restart the system, though the system itself seems not to be affected.

This is how it goes:
when starting certain programms (dolphin, konsole, various other), opening documents, sometimes when changing system settings, I get, ransomly but reproducably a completely black screen with nothing but a mouse pointer on it. This pointer may be moved and even changes its appearance, like residing on clickable buttons or window borders, but since nothing is displayed I can't produce reactions, nor are there any changes on the screen. 
All this leaves nothing but a complete restart, though the system itself seems unaffected by the crash an no crashreport is displayed. therefore I have nothing but this description of this odd behaviour...

Please could someone help me with this, there are some programs nearly unusable, since I can't even start them without getting this crash ...

Thanks
Jay
Comment 1 Médéric Boquien 2009-02-21 14:18:04 UTC
Hello. I can confirm the problem. I compile from source and the problem appeared a few days ago indeed. A workaround is to trigger a kwin effect or to turn off/on compositing with alt+shift+F12 for instance.
Comment 2 Médéric Boquien 2009-02-21 14:22:01 UTC
Note that i use a Radeon HD 4850 with the binary driver.
Comment 3 Jay Ambee 2009-02-21 14:44:46 UTC
just for the record:
my system is a dell inspiron 9200, the graphics is running on a radeon mobile 7500, described in the KDS sysinfo applet as:
Mesa DRI R300 20060815 AGP 4x x86/MMX/SSE2 TCL
Driver is: 1.3 Mesa 7.2 from the DRI R300 Project

I am currently using the "no compositing"-workaround

but that should no be a solution for all time ....
Comment 4 Bernhard Friedreich 2009-02-21 14:56:34 UTC
Same problem here.

openSUSE 11.1 x64
trunk compiled from source
NVIDIA 9600M GT (with 180.12 driver I think)
Compositing/Desktop effects enabled

What helps for me is to switch to another vty and kill kwin. When I switch back to the desktop-vty the black screen has vanished although I don't have a window manager anymore ^^ -- so I have to start a new one from a vty and everythings working again (including desktop effects)
Comment 5 Bernd Weigelt 2009-02-21 14:57:48 UTC
I can also confirm this, but only on one of three systems. But i think it is
more a openSuSE-buildservice-problem, please add your report there too.

The system is a 1400er Celeron, the two systems without the problem are
64bit-AMD, one Desktop and one Laptop. 

I have made a complete reinstall of the system, before that i got the black
screen, after the installation the system crash everytime, when try to open a
new window.

Last entry in .xsession-errors is:
kwin: X Error (error: <unknown>[DAMAGE+0], request: XDamageDestroy[DAMAGE+2],
resource: 0x180010f)
I tried out two Nvidia (GF6200 and GF6600GT) and ATI Radeon 8500, but nothing
helps. Nvidia driver is 180.29, ATI is the opensource-driver, installed with
openSuSe 11.1.
Comment 6 Bernhard Friedreich 2009-02-21 14:59:49 UTC
What I forgot to mention was that I'm using a recent Qt 4.5 Snapshot.. so maybe
it is related to the switch to Qt 4.5? 

I suspect the openSUSE 11.1 packages of trunk (mentioned by the initial
reporter) are also compiled against Qt 4.5?
Comment 7 Médéric Boquien 2009-02-21 15:18:03 UTC
Bernhard, i do not think it is a Qt 4.5 or a buildservice problem. I use Qt 4.4.3 and KDE is compiled by myself.
Comment 8 Jay Ambee 2009-02-21 16:32:21 UTC
(In reply to comment #4)
> Same problem here.
> 
> openSUSE 11.1 x64
> trunk compiled from source
> NVIDIA 9600M GT (with 180.12 driver I think)
> Compositing/Desktop effects enabled
> 
> What helps for me is to switch to another vty and kill kwin. When I switch back
> to the desktop-vty the black screen has vanished although I don't have a window
> manager anymore ^^ -- so I have to start a new one from a vty and everythings
> working again (including desktop effects)

I would do this if I could switch to another vty ... but I don't get anywhere ... :-(
Comment 9 Jay Ambee 2009-02-21 16:33:43 UTC
(In reply to comment #5)
> I can also confirm this, but only on one of three systems. But i think it is
> more a openSuSE-buildservice-problem, please add your report there too.
> 
> The system is a 1400er Celeron, the two systems without the problem are
> 64bit-AMD, one Desktop and one Laptop. 
> 
> I have made a complete reinstall of the system, before that i got the black
> screen, after the installation the system crash everytime, when try to open a
> new window.
> 
> Last entry in .xsession-errors is:
> kwin: X Error (error: <unknown>[DAMAGE+0], request: XDamageDestroy[DAMAGE+2],
> resource: 0x180010f)
> I tried out two Nvidia (GF6200 and GF6600GT) and ATI Radeon 8500, but nothing
> helps. Nvidia driver is 180.29, ATI is the opensource-driver, installed with
> openSuSe 11.1.

WOW! ... And I was thinking about a reiunstall of the system too ... Now I'm thankfull I didn't do it ...
Comment 10 Nils M. 2009-02-21 17:28:04 UTC
Hello!

I observed this bug, too. My Setup is OpenSuSE 11.0 x86_64 (AMD64), NVIDIA graphics (using proprietary driver) with Packages of KDE 4.2.0 from the Factory-Buildservice. 

On my system it seems that adding a plasmoid or opening the K-menu/lancelot are the most reliable triggers for the black screen. Using opera or kontact f.e. has so far shown a much smaller probability to cause this phenomenon. Anybody similar experiences?

As Jay Ambee  stated the system seems totaly unconvinced by this blackout-behavior. Starting programs by clicking on the then-invisible symbols in plasma works. Blindly opening the program-starter with Alt+F2 and typing "kwin --replace" is processed instantly and brings back the normal view. And until now the Xserver has not complained about anything that might seem related.
Comment 11 Bernd Weigelt 2009-02-21 20:59:59 UTC
Adding plasmoid results 100 percent crash since some days up to two weeks, Kickoff about 80 percent since the last update via zypper on thursday evening, dolphin only one crash, i had enough ;-), other programs tested, but not count.

I gone back to 3.5.10 on the old machine, and then i can use all programs without crash.
Comment 12 Bernd Weigelt 2009-02-22 10:11:25 UTC
I have opened a report on opensuse.
please add your comments there too.

https://bugzilla.novell.com:443/show_bug.cgi?id=478495
Comment 13 Andreas Kuhl 2009-02-22 10:29:17 UTC
I can confirm this but there is a way more easy workaround until the issue is fixed: When the black screen appears, just disable compositing by pressing [ALT]+[SHIFT]+[F12] -> Your windows re-appear. Afterwards, you can re-enable compositing with the same hotkey: [ALT]+[SHIFT]+[F12]
Comment 14 Ruchir Brahmbhatt 2009-02-22 10:36:43 UTC
*** Bug 185204 has been marked as a duplicate of this bug. ***
Comment 15 Karsten König 2009-02-22 11:00:25 UTC
Could you please try to pin down if it is a specific effect causing this?

To do this deactivate all and try to reactivate them one per one and check if it is back.

To the devs:
Is it really necassary to backport new effects?
Comment 16 Bernd Weigelt 2009-02-22 11:08:13 UTC
> Could you please try to pin down if it is a specific effect causing this?

The only thing i could say, is, the crashes happened with a fresh emtpy ~/.kde4,
i have not enough time to disable the desktop-effects.
Ok, i could disable the effects in the configs, but i need this machine working, so i can't test this frequently.
Comment 17 Vincenzo Di Massa 2009-02-22 12:26:45 UTC
I have the same problem:
I have an old nvidia 5600 FX with lstest supported binary driver.
I'm running self compiled sources (kde+qtcopy) on kubuntu.

I notieced that after restarting kwin the bug does not occur for a long while. Dunno if this could help.
Comment 18 Paweł Prażak 2009-02-22 12:36:11 UTC
I've tried trigers you've mentioned but I could not reproduce this bug, I wonder where is the difference between my system and yours.

My system:
Linux 2.6.27.8-9.1-default x86_64
openSUSE 11.1 (x86_64)
Qt: 4.5.0-rc1
KDE: 4.2.00 (KDE 4.2.0) "release 102"
Plasma Workspace: 0.3
x11-video-nvidiaG02-180.29-0.1
Comment 19 Karsten König 2009-02-22 12:41:53 UTC
Pawel if you are using openSUSE repositories it is because your version is outdated, the is no KDE4:Factory build for Qt4.5 on openSUSE 11.1 anymore.

Doesn't apply if you build kde from svn.
Comment 20 Christian Trippe 2009-02-22 13:14:03 UTC
If this problem does not occur if the present window effect is disabled it is probably a duplicate of bug 178471.
Comment 21 Paweł Prażak 2009-02-22 14:24:56 UTC
Karsten, I use up-to-date version, and I have qt 4.5-rc1 (libqt4-4.4.90+4.5.0rc1-35.1.x86_64.rpm), AFAIK KDE4:Factory recently switched to 4.5, so I'm not sure what do you mean.

Regards
Comment 22 Bernd Weigelt 2009-02-22 14:49:35 UTC
I have found this in forums.opensuse.org
I can't test it, because the machine isn't here

http://forums.opensuse.org/applications/408398-newest-kde4-factory-black-screen-when-firefox-starts.html#post1947633
Comment 23 David Nadlinger 2009-02-22 15:01:11 UTC
I also experienced the bug two or three times (KDE trunk, qt-copy trunk, nVidia 177.80). Invoking »Present Windows« helps, I'll do some more research once I get struck by it again.

This seems to be similar to bug 178471 indeed, although I hesitate to mark it as a duplicate, since there are too many details unknown yet.

(I have changed the title since this is apparently not related to plasma at all.)
Comment 24 Karsten König 2009-02-22 15:30:47 UTC
(In reply to comment #21)
> AFAIK KDE4:Factory recently switched to 4.5, so I'm not sure what do you mean.

No, it switched to whatever Qt there is in the main or update repository.
This is Qt4.4.3 for openSUSE 11.1 and Qt4.5rc1 for openSUSE Factory (the to become 11.2)
(check buildservice logs)

But you are right, it will run with Qt4.5 as well (the version build against 4.4.3), but I don't think it's recommended.

Interesting find anyways, that might mean something from trunk got backported which doesn't work on Qt4.4.3
Comment 25 S. Burmeister 2009-02-22 15:36:45 UTC
I can confirm comment 23. It is not related to Qt 4.5, since I run 4.4.3. Disabling the "Present Windows" solves it.

I got the impression that it is related to the number of windows (graphics RAM/cache?). At a certain stage every new window, even opening the menu triggers it. Yet the same actions with not other windows present does not.
Comment 26 Paweł Prażak 2009-02-22 16:13:44 UTC
(In reply to comment #24)
> (In reply to comment #21)
> > AFAIK KDE4:Factory recently switched to 4.5, so I'm not sure what do you mean.
> 
> No, it switched to whatever Qt there is in the main or update repository.
> This is Qt4.4.3 for openSUSE 11.1 and Qt4.5rc1 for openSUSE Factory (the to
> become 11.2)
> (check buildservice logs)

Sorry I forgot that i have http://download.opensuse.org/repositories/KDE:/Qt/openSUSE_11.1/x86_64/ repo added, which contains qt 4.5-rc1

> 
> But you are right, it will run with Qt4.5 as well (the version build against
> 4.4.3), but I don't think it's recommended.

You are right, it's not recommended, but works very good now :)

> Interesting find anyways, that might mean something from trunk got backported
> which doesn't work on Qt4.4.3

Interesting indeed, because I have "Present Windows" turned on and I'm not affected by this bug so far.
Comment 27 Vadym Krevs 2009-02-22 16:33:07 UTC
I can trigger this bug on openSUSE 11.1 for x86_64 (KDE 4.2.0 release 102 from openSUSE's build service), Qt 4.5 from http://download.opensuse.org/repositories/KDE:/Qt/openSUSE_11.1, and NVIDIA driver 180.29 by launching kdiff3 compiled from source (available from kdiff3.sf.net). Just typing kdiff3 in konsole does the "trick". Also it seems to occur (somewhat randomly) when I switch desktops (or click Show Desktop) and attempt to launch an application from a desktop icon.
Comment 28 lucas 2009-02-23 02:29:22 UTC
Please add the following to the ServerLayout section of your /etc/X11/xorg.conf:

Option "BackingStore" "False"
Comment 29 Andreas Kuhl 2009-02-23 08:03:28 UTC
I tried with the "BackingStore" option, but it did not fix the issue for me. Disabling the present windows effect fixes the issue for me so far.
Comment 30 FiNeX 2009-02-23 17:46:21 UTC
I've tried to kill kwin. It has restored himself automatically and the black screen disappeared.
Comment 31 Pedro 2009-02-24 04:02:35 UTC
I have the same problem. I use openSUSE 11.1 and I update KDE4.2 almost every day from opensuse repos. This bug appeared circa 3/4 days ago, I cant be sure.
The description is also similar to bug 178471.

Graphic card: Ati Mobility Radeon X1600 

Backingstore: off

Qt: 4.4.3 (same repo from comment #27)

Drivers:
radeon build from git today
radeonhd build from git today
fglrx 8.11 and 9.2
(I have the "black screen bug" with all this drivers, except when using "AccelMethod" EXA with the radeon and radeonhd drivers)
Comment 32 lucas 2009-02-24 05:39:01 UTC
SVN commit 930721 by lmurray:

Don't run present windows window added/closed hooks if the effect is not
activated. Might be a fix for the black screening?
CCBUG: 178471
CCBUG: 185127


 M  +6 -0      presentwindows.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=930721
Comment 33 lucas 2009-02-24 09:11:17 UTC
*** Bug 185328 has been marked as a duplicate of this bug. ***
Comment 34 i.linty 2009-02-24 09:33:28 UTC
>If this problem does not occur if the present window effect is disabled it is
>probably a duplicate of bug 178471.

I can confirm for my it works disabling "present windows effect" ! see BUG 185328
Comment 35 lucas 2009-02-25 04:18:51 UTC
I need confirmation as to whether the above patch fixed the problem or not. This is now a blocker for 4.2.1 and it cannot be released until this is fixed.
Comment 36 lucas 2009-02-25 04:42:41 UTC
*** Bug 185272 has been marked as a duplicate of this bug. ***
Comment 37 lucas 2009-02-25 07:08:24 UTC
Removing blocker status as this occurs in the original 4.2.0 release and so is not a regression. Why it just suddenly appeared for OpenSuSE users right now I have no idea.
Comment 38 S. Burmeister 2009-02-25 09:39:12 UTC
(In reply to comment #37)
> Removing blocker status as this occurs in the original 4.2.0 release and so is
> not a regression. Why it just suddenly appeared for OpenSuSE users right now I
> have no idea.

Why do you think it happend in 4.2.0? AFAIK it started after a branch-diff was applied, it did not happen with the initial packages for 4.2.0.

Further, if bug 178471 is a duplicate, then there are reoprts from gentoo, arch linux etc.
Comment 39 lucas 2009-02-25 09:46:05 UTC
(In reply to comment #38)
> Why do you think it happend in 4.2.0? AFAIK it started after a branch-diff was
> applied, it did not happen with the initial packages for 4.2.0.

Another developer that is using the same Arch Linux KDE packages as I can reproduce the problem while I can't. The packages were released the day 4.2.0 was released and they have not been updated since.
Comment 40 lucas 2009-02-25 10:00:27 UTC
*** Bug 178471 has been marked as a duplicate of this bug. ***
Comment 41 lucas 2009-02-25 10:00:57 UTC
It is also worth noting the date that bug 178471 was opened, it is well before the release of 4.2.0.
Comment 42 lucas 2009-02-25 10:16:36 UTC
Having a look at the Novell bug report there is a ~/.xsession-errors log that contains near the end of the file:

kwin(3802) KWin::checkGLError: GL error ( PostPaint ): 0x "500"

The next time someone reproduces this can they please check the end of their log for this error. Unfortunately this output can mean pretty much anything, but if everyone gets the same error then that's a start.
Comment 43 Karsten König 2009-02-25 10:30:58 UTC
(In reply to comment #38)
> Why do you think it happend in 4.2.0? AFAIK it started after a branch-diff was
> applied, it did not happen with the initial packages for 4.2.0.

There were a few occasional complaints in IRC and it happened to me with the initial 4.2.0 packages.
So it seems the cause was there in 4.2.0 release already, but a change to 4.2svn made it trigger much faster.

Also the problem is fixed by just disabling "present windows" effect already, I doubt this fixed the root of the problem.

If openSUSE noted changes are correct, the last update to 4.2branch was 18.2.2008, the previous one on 6.2.2008, this results in only
http://websvn.kde.org/?view=rev&sortby=rev&revision=922459
http://websvn.kde.org/?view=rev&sortby=rev&revision=924119
But they look innocent to me =/
Comment 44 manolis 2009-02-25 10:57:10 UTC
I am the original reporter of 178471 which marked as dup.
The bug appeared in my system in a pre 4.2 version. Just before the tagging of the 4.2
Comment 45 Stephan Kulow 2009-02-25 11:32:24 UTC
I just had the same effect - without the GL hit in my .xsession-errors
Comment 46 lucas 2009-02-25 11:34:22 UTC
Can anyone reproduce in XRender mode?
Comment 47 Matt Williams 2009-02-25 16:14:07 UTC
(In reply to comment #46)
> Can anyone reproduce in XRender mode?

Yes, I can reproduce in XRender mode. The bug presents itself in exactly the same way.
Comment 48 Jason 'vanRijn' Kasper 2009-02-25 19:50:02 UTC
Woot. Lucas, I just built kwin from branches/KDE/4.2 and I couldn't reproduce this. I'm not sure if it's because I'm running with your fix, or if I'm running without whatever OpenSUSE 11.1 packages have, but it looks much better. Previously, btw, I could trigger this 100% by doing this: 

for f in $(seq 1 10) ; do glxgears&; done

or by continually opening new urxvt windows.

Can't get it to happen now, as I said. Thanks Lucas! =:)
Comment 49 Paweł Prażak 2009-02-25 20:32:06 UTC
(In reply to comment #48)
> for f in $(seq 1 10) ; do glxgears&; done
Thanks for this :) 
I was finally able to reproduce this bug
for f in $(seq 1 10); do glxgears& done
trigers the bug and the other weird things

- first black screen and movable cursor, just as described than after alt+shift+f12, desktop comes back (sort of)

- afher that, the desktop is shifted right (scrollbar in firefox is now on the left and when I move the mouse far right - it appears on the left), it gets back to normal after ctrl+alt+f1, alt+f7. I've seen this bug before - it was triggered by qt bug (task ID #244185 ), found through arora (http://code.google.com/p/arora/issues/detail?id=262) and qt demo browser. Unfortunately I can't send you a screenshot, because the desktop isn't shifted on screen shot

- whole plasma panel have standard blue background (my wallpaper and bg color are black) - this one is new to me and I don't have workaround yet (I can logoff off course ;) )

funny thing is, that now I can't reproduce it any more (may be it's the blue bg stuff - I'll check it later)
Comment 50 Paweł Prażak 2009-02-25 20:46:55 UTC
> - whole plasma panel have standard blue background (my wallpaper and bg color
> are black) - this one is new to me and I don't have workaround yet

just shift+alt+f12 again, bg is blue only with composition disabled.

I've been able to reproduce it once more (after +20 tries), but I don't know yet how to get 100% reproducibility.
Comment 51 Paweł Prażak 2009-02-25 21:24:23 UTC
I'm able to reproduce this bug every time with 23 glxgears:

for f in $(seq 1 23); do glxgears& done

I've also noticed that "screen shift" bug doesn't occur every time. 

my console says:
...
1670 frames in 5.0 seconds = 333.976 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 225 requests (225 known processed) with 0 events remaining.
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 207 requests (207 known processed) with 0 events remaining.
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 47 requests (46 known processed) with 0 
...


and my xsession-errors:

...
QPainter::begin: Paint device returned engine == 0, type: 3                                                                                                       
QPainter::setFont: Painter not active                                                                                                                             
QPainter::setRenderHint: Painter must be active to set rendering hints                                                                                            
QPainter::setPen: Painter not active                                                                                                                              
QPainter::end: Painter not active, aborted                                                                                                                        
kwin(3543) KWin::checkGLError: GL error ( PostPaint ): 0x "500"
...
Comment 52 Jason 'vanRijn' Kasper 2009-02-25 22:47:13 UTC
Created attachment 31644 [details]
kwin crash

I'm not sure if it's the recent fix for this bug, but I've hit this crash about 5 times this morning.
Comment 53 Andrew Stromme 2009-02-25 23:22:04 UTC
Running 4.2.x branch, compiled this morning. Not sure if this crash is related, but I think it might be. 

(no black screen yet btw)

Application: KWin (kwin), signal SIGSEGV
[?1034h[Thread debugging using libthread_db enabled]
0x00007fbb92d39fd0 in __nanosleep_nocancel () from /lib/libc.so.6
 
Thread 1 (Thread 0x7fbb980bc790 (LWP 8945)):
[KCrash Handler]
#5  0x00007fbb88546562 in KWin::PresentWindowsEffect::setHighlightedWindow (this=0x132a790, w=0x1303480) at /home/astromme/Projects/KDE/kdebase-4.2/workspace/kwin/effects/presentwindows.cpp:1270
#6  0x00007fbb8855103b in KWin::PresentWindowsEffect::rearrangeWindows (this=0x132a790) at /home/astromme/Projects/KDE/kdebase-4.2/workspace/kwin/effects/presentwindows.cpp:487
#7  0x00007fbb88551bb1 in KWin::PresentWindowsEffect::setActive (this=0x132a790, active=<value optimized out>, closingTab=<value optimized out>)
    at /home/astromme/Projects/KDE/kdebase-4.2/workspace/kwin/effects/presentwindows.cpp:1153
#8  0x00007fbb88552643 in KWin::PresentWindowsEffect::tabBoxAdded (this=0x132a790, mode=<value optimized out>) at /home/astromme/Projects/KDE/kdebase-4.2/workspace/kwin/effects/presentwindows.cpp:406
#9  0x00007fbb97dbc39b in KWin::EffectsHandlerImpl::tabBoxAdded (this=<value optimized out>, mode=2) at /home/astromme/Projects/KDE/kdebase-4.2/workspace/kwin/effects.cpp:291
#10 0x00007fbb97d5fafb in KWin::TabBox::show (this=0xd82e90) at /home/astromme/Projects/KDE/kdebase-4.2/workspace/kwin/tabbox.cpp:619
#11 0x00007fbb97d5fb6d in KWin::TabBox::qt_metacall (this=0xd82e90, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=<value optimized out>)
    at /home/astromme/Projects/KDE/kdebase-4.2/build/workspace/kwin/tabbox.moc:66
#12 0x00007fbb9599a8dd in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#13 0x00007fbb95996f53 in QObject::event () from /usr/lib/libQtCore.so.4
#14 0x00007fbb9605b0ad in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#15 0x00007fbb96062aba in QApplication::notify () from /usr/lib/libQtGui.so.4
#16 0x00007fbb974d854b in KApplication::notify () from /usr/lib/libkdeui.so.5
#17 0x00007fbb959883cc in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#18 0x00007fbb959b10a6 in ?? () from /usr/lib/libQtCore.so.4
#19 0x00007fbb959adb3d in ?? () from /usr/lib/libQtCore.so.4
#20 0x00007fbb90b57aa2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#21 0x00007fbb90b5b21d in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#22 0x00007fbb90b5b3db in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#23 0x00007fbb959ada9f in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#24 0x00007fbb960e152f in ?? () from /usr/lib/libQtGui.so.4
#25 0x00007fbb95986d72 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#26 0x00007fbb95986f05 in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#27 0x00007fbb95988fcc in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#28 0x00007fbb97d5db8f in kdemain (argc=1, argv=0x7fffa0206948) at /home/astromme/Projects/KDE/kdebase-4.2/workspace/kwin/main.cpp:519
#29 0x00007fbb92cb9546 in __libc_start_main () from /lib/libc.so.6
#30 0x00000000004007f9 in _start ()
Comment 54 lucas 2009-02-26 10:13:02 UTC
These KWin::PresentWindowsEffect::tabBoxAdded crashes are unrelated, please open a separate report for them please.
Comment 55 lucas 2009-02-28 11:18:49 UTC
SVN commit 933187 by lmurray:

Added debug asserts to present windows. This will hopefully cause KWin
to crash instead of producing black screens making it easier to find the
cause. For the people who can reproduce existing crashes please resubmit
their backtraces with this change applied.
CCBUG: 185127
CCBUG: 185239

 M  +13 -0     presentwindows.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=933187
Comment 56 Vadym Krevs 2009-03-01 18:45:46 UTC
Looks like someone's hit one of these asserts:

https://bugs.kde.org/show_bug.cgi?id=185856
Comment 57 lucas 2009-03-02 08:48:58 UTC
SVN commit 934022 by lmurray:

Correctly handle windows that were closed but not yet deleted when the
present windows desktop effect is activated.
CCBUG: 185127
CCBUG: 185239
BUG: 185856

 M  +3 -8      presentwindows.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=934022
Comment 58 Romain 2009-03-26 15:57:40 UTC
Hi,

May I participate to this whereas I work on ubuntu system ?
Just in case would be be interested in talking about this,

I have a similar problem, Since last update my screen randomly goes black
or freeze and leaves a moveable mouse which does not work any event.

I've read a bit of all that discussion so I have to precise that neither keyboard respond to events so I just can't swith tty and kill kwin. The only thing I may do is a complete restart of my system

I may experience the similar 
error: <unknown>[DAMAGE+0], request: XDamageDestroy[DAMAGE+2]
in my xsession-error file.

I thought as well that it could be linked to an update of qt libs.
anyway, since I disabled all desktop effects, it goes better !

So this is the bug declaration I left on this site:
https://bugs.kde.org/show_bug.cgi?id=188072

Thanks to all who would have a look on this.
Comment 59 Andreas Kuhl 2009-03-29 11:54:38 UTC
Are the patches from above merged into the 4.2.2 branch?
Comment 60 Andreas Kuhl 2009-04-03 08:23:46 UTC
I upgraded to KDE 4.2.2 yesterday and despite the fact that this bug was not fixed in 4.2 branch (according to the changelog), i dared to re-enable the present windows effect. And guess: I did not have a single black screen (or crashing kwin) since yesterday. I made heavy use of the present windows effect and it seems fixed for me now. Can someone confirm this?
Comment 61 Jon Nelson 2009-07-08 18:31:33 UTC
I am experiencing the problem with KDE 4.3 for openSUSE 11.1 (build service).
kwin version is 4.2.95-282.3 as of this writing.
disabling compositing usually leaves me without a taskbar
alt-f2 plus "kwin --replace" as suggested above corrects the issue but this is getting to be pretty annoying.
Comment 62 Artem 2009-08-07 22:40:39 UTC
I can confirm this bug in Debian with KDE 4.2 and KDE 4.3.

In my situation it sometimes appears  after unsuspending from RAM. Disabling compositing by unplugging power cable restore normal view, but disabling compositing manualy (Alt-Shift-F12) restore view incorrectly - there is no plasma in the screen, hotkey for krunner doesn't work two. But Alt-tab works. Switching to console and back to xserver completly restore normal view.

Confiuration  - Lenovo T500
Graphics card - intel GMA 4500MHD, ATI Radeon 3650
this bug appears in both graphics cards.
compositing mode is XRender

*I can attach a screenshot of desktop without plasma(after disabling compositing manualy) if it is necessary? but there is nothing interesting.
Comment 63 Thomas Lübking 2009-08-08 00:16:16 UTC
(In reply to comment #62)
> In my situation it sometimes appears  after unsuspending from RAM. Disabling
> compositing by unplugging power cable restore normal view, but disabling
> compositing manualy (Alt-Shift-F12) restore view incorrectly - there is no
> plasma in the screen, hotkey for krunner doesn't work two. But Alt-tab works.
> Switching to console and back to xserver completly restore normal view.

that's likely no kwin issue - plasma and krunner are independent apps

please check whether plasma & krunner are running at all ("ps -A | grep -E '(plasma|krunner)'")
if not you can start "plasma-desktop --display :0; krunner --display :0" 

if they're up you can try "xrefresh" and see whether the background gets updated (you'll need to have e.g. an open terminal on X11)
Comment 64 Artem 2009-08-11 17:13:26 UTC
Ok, I met this situation again. Plasma and krunner were running, just not rendering. xrefresh helped.
Comment 65 Martin Flöser 2009-12-15 09:51:28 UTC
This bug looks fixed to me. Does anyone who experienced the bug still see this issue?
Comment 66 Ruchir Brahmbhatt 2009-12-15 09:55:27 UTC
I'm on kde 4.4 beta1(4.3.81) in opensuse 11.2 and can't reproduce.
Comment 67 Matt Williams 2009-12-15 11:59:30 UTC
I'm running latest trunk and this issue hasn't presented itself in a long time. Count it as fixed here.
Comment 68 Artem 2009-12-16 10:12:30 UTC
I have met this issue recently. But it appears only once for a long time and it was probably a problem with combination of xorg-xvideo-ati driver and system dist-ugrade. And I can not reproduce it.
Comment 69 Martin Flöser 2010-01-13 14:39:34 UTC
seems to be fixed. If anyone is still experiencing this issue, please reopen.
Comment 70 Jon Nelson 2010-03-26 18:55:54 UTC
I am still experiencing the issue.
openSUSE 11.2, KDE 4.4, qt 4.6.2

Other possibly related bugs: bug 220211 and bug 205803 and bug 197684.