Bug 197684 - Sorry, the screen went blank before I could see it.
Summary: Sorry, the screen went blank before I could see it.
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 4.2.3
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: investigated, triaged
Depends on:
Blocks:
 
Reported: 2009-06-24 03:06 UTC by Devon Garber
Modified: 2018-10-21 04:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Devon Garber 2009-06-24 03:06:08 UTC
Version:            (using KDE 4.2.3)
OS:                Linux
Installed from:    I Don't Know

While using Mozilla Firefox a crash report came then the screen went blank
Comment 1 Dario Andres 2009-06-24 15:44:13 UTC
This is going to be difficult/impossible to triage without a backtrace. :(
If the crash happens regularly we can try another debug methods to try to get information.
Regards
Comment 2 Devon Garber 2009-06-25 18:48:20 UTC
(In reply to comment #1)
> This is going to be difficult/impossible to triage without a backtrace. :(
> If the crash happens regularly we can try another debug methods to try to get
> information.
> Regards
It's happened to me before. But thats when I didn't know how to get here.
Comment 3 Dario Andres 2009-06-28 00:18:17 UTC
Just to be sure, do you had time to see what application crashed after the screen went blank ? Did you saw any other details during that time?
Thanks
Comment 4 Devon Garber 2009-06-28 03:20:40 UTC
(In reply to comment #3)
> Just to be sure, do you had time to see what application crashed after the
> screen went blank ? Did you saw any other details during that time?
> Thanks

I saw the window come up and noticed it said KWin. I couldn't see any other details.
Comment 5 Dario Andres 2009-06-30 21:07:01 UTC
Ok, let's try to get a backtrace.

- Start KDE normally
- Go to a virtual terminal (Ctrl+alt+f1)
- Log as your KDE user
- Export the variable DISPLAY (type "export DISPLAY=:0" and press Return)
- Type "gdb kwin" and press Return
- Type "run --replace" and press Return
KWin will be restarted
- Now go back to the KDE session (ctrl+alt+f7) and try to reproduce the crash (or wait for it )
- Once KWin crashes and the screen goes to black; go back to the virtual terminal (Ctrl+alt+f1)
- Type "set logging on" and press Return (this will force the app to log all the backtrace to the file: gdb.txt )
- Type "bt full" and press Return until the backtrace is fetched
- You can close GDB/that virtual terminal session

You will have now a "gdb.txt" file containing the backtrace of the KWin crash.
Regards
Comment 6 Devon Garber 2009-06-30 22:33:27 UTC
(In reply to comment #5)
> Ok, let's try to get a backtrace.
> 
> - Start KDE normally
> - Go to a virtual terminal (Ctrl+alt+f1)
> - Log as your KDE user
> - Export the variable DISPLAY (type "export DISPLAY=:0" and press Return)
> - Type "gdb kwin" and press Return
> - Type "run --replace" and press Return
> KWin will be restarted
> - Now go back to the KDE session (ctrl+alt+f7) and try to reproduce the crash
> (or wait for it )
> - Once KWin crashes and the screen goes to black; go back to the virtual
> terminal (Ctrl+alt+f1)
> - Type "set logging on" and press Return (this will force the app to log all
> the backtrace to the file: gdb.txt )
> - Type "bt full" and press Return until the backtrace is fetched
> - You can close GDB/that virtual terminal session
> 
> You will have now a "gdb.txt" file containing the backtrace of the KWin crash.
> Regards
Thanks. I'll work on it as soon as I can.
Comment 7 Andrew Crouthamel 2018-09-19 04:28:59 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please mark the bug as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 8 Andrew Crouthamel 2018-10-21 04:49:37 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!