Bug 185272 - kwin crashes causes screen to go black
Summary: kwin crashes causes screen to go black
Status: RESOLVED DUPLICATE of bug 185127
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-22 21:12 UTC by MDB
Modified: 2009-02-25 04:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MDB 2009-02-22 21:12:41 UTC
Version:           KWin: 4.2.00 (KDE 4.2.0) "release 102" (using KDE 4.2.0)
OS:                Linux
Installed from:    SuSE RPMs

Using kde 4.2 from openSUSE Factory release 102

This is happening on multiple machines x86_64 and i586. Both are using the proprietary NVIDIA driver 180-22.

1. Open any application, for instance konsole.
2. Screen goes black.
3. Mouse cursor can be seen and cursor changes to "I" when over location where konsole should be.

Basically, this seems to happen as soon as kwin needs to show a window. I will provide a backtrace.
Comment 1 MDB 2009-02-22 21:29:27 UTC
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb67eb66b in poll () from /lib/libc.so.6
#2  0xb640eef2 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb640f221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb6daefb8 in QEventDispatcherGlib::processEvents (this=0x80619c0, flags={i = -1079644040})
    at kernel/qeventdispatcher_glib.cpp:319
#5  0xb708c7c5 in QGuiEventDispatcherGlib::processEvents (this=0x80619c0, flags={i = -1079643992})
    at kernel/qguieventdispatcher_glib.cpp:198
#6  0xb6d8301a in QEventLoop::processEvents (this=0xbfa5f120, flags={i = -1079643928}) at kernel/qeventloop.cpp:143
#7  0xb6d831da in QEventLoop::exec (this=0xbfa5f120, flags={i = -1079643864}) at kernel/qeventloop.cpp:194
#8  0xb6d85895 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:845
#9  0xb6ff3777 in QApplication::exec () at kernel/qapplication.cpp:3331
#10 0xb7e9deda in kdemain (argc=1, argv=0xbfa5f3a4) at /usr/src/debug/kdebase-workspace-4.2.0/kwin/main.cpp:519
#11 0x080487b2 in main (argc=) at /usr/src/debug/kdebase-workspace-4.2.0/build/kwin/kwin_dummy.cpp:3
Comment 2 MDB 2009-02-22 21:31:41 UTC
Actually this is only (as far as I can tell) happening when konsole is launched. Here's a konsole bt. But, konsole seemed to still be working fine. I just couldn't see the screen.

#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb659b6a7 in poll () from /lib/libc.so.6
#2  0xb6297ef2 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb6298221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb73befb8 in QEventDispatcherGlib::processEvents (this=0x806c238, flags={i = -1078140424})
    at kernel/qeventdispatcher_glib.cpp:319
#5  0xb6ab67c5 in QGuiEventDispatcherGlib::processEvents (this=0x806c238, flags={i = -1078140376})
    at kernel/qguieventdispatcher_glib.cpp:198
#6  0xb739301a in QEventLoop::processEvents (this=0xbfbce2a0, flags={i = -1078140312}) at kernel/qeventloop.cpp:143
#7  0xb73931da in QEventLoop::exec (this=0xbfbce2a0, flags={i = -1078140248}) at kernel/qeventloop.cpp:194
#8  0xb7395895 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:845
#9  0xb6a1d777 in QApplication::exec () at kernel/qapplication.cpp:3331
#10 0xb7f661e2 in kdemain () from /usr/lib/libkdeinit4_konsole.so
#11 0x08048752 in _start ()
Comment 3 lucas 2009-02-23 02:28:59 UTC
Please add the following to the ServerLayout section of your /etc/X11/xorg.conf:

Option "BackingStore" "False"
Comment 4 Marc Benstein 2009-02-24 17:21:46 UTC
Using Option "BackingStore" "False" did not help. The behavior is the same.
Comment 5 lucas 2009-02-25 04:42:41 UTC

*** This bug has been marked as a duplicate of bug 185127 ***