Bug 178471 - Black screen when a new window appears
Summary: Black screen when a new window appears
Status: RESOLVED DUPLICATE of bug 185127
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: VHI normal with 2 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-22 14:56 UTC by manolis
Modified: 2009-02-25 10:00 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
config file causing kwin to go nuts (2.64 KB, application/octet-stream)
2008-12-23 01:40 UTC, manolis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manolis 2008-12-22 14:56:55 UTC
Version:           trunk (using Devel)
Compiler:          gcc 
OS:                Linux
Installed from:    Compiled sources

I open an email
Right click on an image attachment
Open
Gwenview fires up
The screen goes blank (but the windows are there)
After some more Alt+Tab and Present Windows
I get my windows back, but kwin is messed up
Can't fire up new apps, kmenu, krunner (they all run) but don't show up
Alt-tabbing is useless from now on...
only some windows can get focus (a konsole, or a dolphin)
After some messing around with continuous alt_tabs/runs/clicks on the frozen apps kwin enentually collapses and gives me a backtrace
It loads again and all are working fine.. until the next image loading... :-)

(no debugging symbols found)

(no debugging symbols found)
0x00007f0038d50d60 in nanosleep () from /lib/libc.so.6
[Current thread is 0 (process 24522)]

Thread 1 (Thread 0x7f003e008790 (LWP 24522)):
#0  0x00007f0038d50d60 in nanosleep () from /lib/libc.so.6
#1  0x00007f0038d50bb7 in sleep () from /lib/libc.so.6
#2  0x00007f003d259f62 in ?? () from /usr/kde/live/lib64/libkdeui.so.5
#3  0x00007f003d25a5fa in KCrash::defaultCrashHandler () from /usr/kde/live/lib64/libkdeui.so.5
#4  <signal handler called>
#5  0x0000000000008031 in ?? ()
#6  0x00007f003347c50b in ?? () from /usr/kde/live/lib64/kde4/kwin4_effect_builtins.so
#7  0x00007f00334871c1 in ?? () from /usr/kde/live/lib64/kde4/kwin4_effect_builtins.so
#8  0x00007f00334881a2 in ?? () from /usr/kde/live/lib64/kde4/kwin4_effect_builtins.so
#9  0x00007f00334886e5 in ?? () from /usr/kde/live/lib64/kde4/kwin4_effect_builtins.so
#10 0x00007f003dd10c34 in ?? () from /usr/kde/live/lib64/libkdeinit4_kwin.so
#11 0x00007f003dc9916c in ?? () from /usr/kde/live/lib64/libkdeinit4_kwin.so
#12 0x00007f003dc99377 in ?? () from /usr/kde/live/lib64/libkdeinit4_kwin.so
#13 0x00007f003dcbf702 in ?? () from /usr/kde/live/lib64/libkdeinit4_kwin.so
#14 0x00007f003dcad318 in ?? () from /usr/kde/live/lib64/libkdeinit4_kwin.so
#15 0x00007f003b625e2b in QApplication::x11ProcessEvent () from /usr/lib64/qt4/libQtGui.so.4
#16 0x00007f003b64e38b in ?? () from /usr/lib64/qt4/libQtGui.so.4
#17 0x00007f003c5d59b2 in QEventLoop::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#18 0x00007f003c5d5e4d in QEventLoop::exec () from /usr/lib64/qt4/libQtCore.so.4
#19 0x00007f003c5db4af in QCoreApplication::exec () from /usr/lib64/qt4/libQtCore.so.4
#20 0x00007f003dcafcd3 in kdemain () from /usr/kde/live/lib64/libkdeinit4_kwin.so
#21 0x00007f0038ccf5b6 in __libc_start_main () from /lib/libc.so.6
#22 0x0000000000400949 in _start ()
#0  0x00007f0038d50d60 in nanosleep () from /lib/libc.so.6
Comment 1 manolis 2008-12-22 15:19:46 UTC
Maybe it is only gwenview related , because the same berzek happens if I fire up gwenview alone , without kmail.
Comment 2 David Nadlinger 2008-12-22 16:15:12 UTC
It would be great if you could install a debug build of KWin since the backtrace is of very little use without debugging symbols.

Which distro, X Server, graphics driver, etc. are you using? Gwenview works fine for me...
Comment 3 manolis 2008-12-22 17:13:10 UTC
gentoo linux
xorg 1.5.3
nvidia 177.82 binary drivers
does not happen with desktop effects disabled
As for the backtrace, in my system (gentoo linux) getting a backtrace means 
re-compiling kde so on the next update (maybe tommorrow's trunk) I will do it.
Comment 4 manolis 2008-12-22 17:18:15 UTC
As for the backtrace , notice thought, as I mention in my first post, the crash does not happen immediatelly. It is just a longtime consequence of the "bug".
If I manage to restart kwin , the crash does not happen and all come back to life fine.
Comment 5 David Nadlinger 2008-12-22 18:15:11 UTC
You are right, but at least for me the backtrace is the only clue for finding the cause of this bug – to be honest, I don't have any idea what could be happening here.

Is just starting Gwenview enough to trigger the bug or do you need to take any further steps like opening an image?
Comment 6 manolis 2008-12-22 19:40:56 UTC
just to run Gwenview
Comment 7 manolis 2008-12-22 22:01:57 UTC
I will give you the backtrace when I manage to crash kwin.
It boosts to 80% to one of my 4 cores... and stays there ... but is hard to crash even in berzerk mode.
Comment 8 manolis 2008-12-23 01:39:35 UTC
Found a better thing than a backtrace... :-)
The cause of the problem is the old gwenview config gile in share/config I had
I attach the file , to see if you can reproduce the akward behaviour.
Deleting the file the problem solved!!!
Comment 9 manolis 2008-12-23 01:40:32 UTC
Created attachment 29565 [details]
config file causing kwin to go nuts
Comment 10 manolis 2009-01-05 09:50:06 UTC
I was posted the gwenviewrc above some days ago, but the bug remains unconfirmed. 
Haven't anyone managed to reproduce it?
Comment 11 Martin Flöser 2009-01-06 22:17:05 UTC
So do I get it right that you only get a crash in kwin when using an old (from KDE 3?) configuration file for gwenview?

And still could you please provide the backtrace. It makes it much easier for us. You know what to do to crash kwin. Although you provide the config file it does not mean that the crash will appear on our system as things like hardware/drivers might be involved as well.
Comment 12 manolis 2009-01-06 23:11:47 UTC
No you don't get it right Martin. As I mention in my older comments, after I compiled with debug symbols I cannot manage to "crash" kwin after going in "berzerk" mode. The only thing I can do is switch off compositing 3d , or kill&restart kwin.
Also the attatched file is not from kde 3 , as you presume. It is from stable 4.1.3 (the bug appeared in my system in beta2)
And again, as I already mention in my comment #7 backtrace is impossible for a no crash.

Note 1: the "black screen -> berzerk kwin" problem I have is NOT gwenview related, as far as I can tell. I really cannot pinpoint it. Someday it happened when I fired-up a wine application. Don't know really.
Note 2:I made this "fuzzy" bug report, only to match up with someone that does have the same issue, in the hope that we could trace the source of it. I was hoping that the config file of gwenviewrc will be much help.

Comment 13 manolis 2009-01-06 23:39:06 UTC
I just tried my old config file that I kept it. The bug appears in starting gwenview.
Yesterday's trunk
Comment 14 David Nadlinger 2009-01-07 00:09:40 UTC
Well, your configuration file works fine for me and I haven't experienced any similar behavior (sorry for the long delay, I thought I had already responded after you had posted your gwenviewrc).
Comment 15 manolis 2009-01-07 10:11:28 UTC
Too bad. 
Now for the problem:
I managed to totally freeze the desktop, but sadly there is still no crash so no backtrace.
I went to CtrlAlt_F2 to e text terminal and connected gdb to the freezed (100% cpu) kwin.
I get a bt on screen without the crash, but don't know how to save it to a text file, because I don't know so much about gdb. 
Do this bt will help? 
How can I store it to a file to send it?
Comment 16 manolis 2009-01-17 12:40:53 UTC
Same behaviour , with Inkscape launching. 
Comment 17 manolis 2009-01-28 14:37:31 UTC
The bug in 4.2.0 disappear , though I kept ALL my old settings...
Sad I could not trace it ;(
Comment 18 manolis 2009-01-31 10:48:39 UTC
I reopen the bug for 4.2.0
The bug disappeared from everywhere...but it still there.
The first time I click on "Get new themes"...
The screen goes blank, and I see movement of the window towards the left (0,0) pixel.
Kwin goes crazy again. And I have to off/on compositing to restore it.
Notice though my bug report on bug #182548. I think the problematic theme window gets the plasma crash on logout.
Comment 19 Anne-Marie Mahfouf 2009-01-31 20:21:24 UTC
Please change the title of the bug when you reopen if it is not GWenView related now! This is pretty confusing!

"The screen goes blank, and I see movement of the window towards the left (0,0) pixel. Kwin goes crazy again."
This is not really accurate, we need either a screenshot or a backtrace from a crash or steps to reproduce!
Comment 20 manolis 2009-01-31 20:38:18 UTC
There is no crash, so I cannot send any backtrace.
I can reproduce it in the first time I click "New theme". Obviously the window of new theme loads but instead of showing up, I get a black screen.


ps1. I don't know how to change the title of the bug.
ps2. A screenshot (of a black screen) will not help. I don't have a camera to record a video of the problem.
Comment 21 lucas 2009-02-01 04:32:22 UTC
I can't understand the problem you are having. Can someone that does understand please describe how to reproduce it, preferentially expanding on what "crazy" actually means.
Comment 22 Anne-Marie Mahfouf 2009-02-01 09:23:56 UTC
Manolis PLEASE you wrote "I can reproduce it in the first time I click "New theme". Obviously the window of new theme loads but instead of showing up, I get a black screen. "
DESCRIBE THE STEPS YOU ARE DOING like that:
1) I open the Desktop Settings dialog
2) I click here and use this option
3) this dialog appears (screenshot)
4) I choose this option
5) This happens instead of that

In the title bar of each dialog there is a title that you need to write so we can know what you are doing.

You go from GWenView to "new theme" (new theme of what?) in this bug report and nobody can understand your problem.

Changing the bug title is done by clicking on the blue title and it gets editable.
Also change the product please as Lucas, the KWin maintainer obviously cannot make any sense of your problem.

Also you indicated compiled sources: what kdelibs + kdebase revision numbers? trunk or branch?
Comment 23 manolis 2009-02-01 09:50:49 UTC
I will close the report because I cannot have a backtrace. And the bug is too complicated to explain in words.
Comment 24 manolis 2009-02-01 10:23:05 UTC
Here is a video of the problem.
http://koppermind.homelinux.org/files/MOV00007.MP4
I right click on desktop and choose "Appearance Settings"
As you can see I click on "New theme", the window appears and after some msecs
I get black screen.
The applications are still there , and ofcourse plasma is still there.
So I use expose to show all applications. I click on an app and the desktop is back.
BUT kwin has something wrong now. As you can see in 00:25.0 I try alt+tab but the window doesn't change. I then try to drag the shown window from its title but it doesn't go anywhere. It stays on the middle, even the mouse if a crosshair now and is being moved towards the top. 
so to end kwin's nightmare I disable compositing on the end of the video.

Note1: There is no crash on this procedure, so no backtrace
Note2: The bug blacks the screen only the first time I use "New theme" after login. all the next times It works fine.
Note3: I don't open the bug again. I will open a new bug report when I can pinpoint the root of the problem.


Thanks for your time.
Comment 25 Anne-Marie Mahfouf 2009-02-01 12:19:59 UTC
I can't connect to your video. You are saying that when you click on "New Theme..." you get a black screen. 
If you try to get new wallpapers , does it work?
(use the "Get New Wallpapers..." button)
If not, then it's your kdelibs/knewstuff which is crashing. 
If there is no backtrace you could run plasma through gdb to get one.

Is that trunk? what revision number? I also have trunk and GHNS works OK.
Comment 26 lucas 2009-02-01 12:55:34 UTC
Thank you for uploading a video, it is very useful.

1) Please attach your ~/.kde4/share/config/kwinrc
2) Log out, log back in and see if you get another black screen. DO NOT USE ANY KWIN EFFECTS before you manage to reproduce the bug.
3) If you cannot reproduce activate ONE fullscreen (Present windows, desktop grid, desktop cube, etc.) effect then attempt to reproduce again.
4) If it still doesn't happen try another effect, continue as many times as needed until you can reproduce.

By the looks of things there is one effect that is not being completely deactivated and as such is preventing you from moving the windows afterwards.
Comment 27 manolis 2009-02-01 13:41:43 UTC
Lucas I cannot reproduce it anymore.
I think it is related to that Qt-Gui had been updated in the meantime.
In my distro these are the applied fixes:
* Applying 0248-fix-qwidget-scroll-slowness.diff ...                              [ ok ]
 * Applying 0254-fix-qgraphicsproxywidget-deletion-crash.diff ...                  [ ok ]
 * Applying 0256-fix-recursive-backingstore-sync-crash.diff ...                    [ ok ]
 * Applying 0262-fix-treeview-animation-crash.diff ...                             [ ok ]
 * Applying 0263-fix-fontconfig-handling.diff ...                                  [ ok ]
 * Applying 0265-fix-formlayoutcrash.diff ...                                      [ ok ]

and before the update only the 
 * Applying 0254-fix-qgraphicsproxywidget-deletion-crash.diff 
was applied.
Any connection to these?
Comment 28 manolis 2009-02-03 00:46:53 UTC
Nope I got the same thing today with 
Add Widgets ->Download from internet. 
I tried to restore the blackness with a desktop effect and kwin crashed!

this is the backtrace:
Application: KWin (kwin), signal SIGSEGV
0x00007fad832a0d90 in nanosleep () from /lib/libc.so.6

Thread 1 (Thread 0x7fad884f7790 (LWP 4980)):
[KCrash Handler]
#5  0x00007fad7d1dc6b8 in KWin::PresentWindowsEffect::setHighlightedWindow (this=0x9d2100, w=0x9e0020)
    at /home/public/portage/tmp/portage/kde-base/kwin-4.2.0/work/kwin-4.2.0/kwin/effects/presentwindows.cpp:1264
#6  0x00007fad7d1e74ef in KWin::PresentWindowsEffect::rearrangeWindows (this=0x9d2100) at /home/public/portage/tmp/portage/kde-base/kwin-4.2.0/work/kwin-4.2.0/kwin/effects/presentwindows.cpp:481
#7  0x00007fad7d1e7fef in KWin::PresentWindowsEffect::setActive (this=0x9d2100, active=<value optimized out>, closingTab=<value optimized out>)
    at /home/public/portage/tmp/portage/kde-base/kwin-4.2.0/work/kwin-4.2.0/kwin/effects/presentwindows.cpp:1147
#8  0x00007fad7d1e88f5 in KWin::PresentWindowsEffect::borderActivated (this=0x9d2100, border=KWin::ElectricTopLeft)
    at /home/public/portage/tmp/portage/kde-base/kwin-4.2.0/work/kwin-4.2.0/kwin/effects/presentwindows.h:99
#9  0x00007fad88205e84 in KWin::EffectsHandlerImpl::borderActivated (this=<value optimized out>, border=KWin::ElectricTopLeft)
    at /home/public/portage/tmp/portage/kde-base/kwin-4.2.0/work/kwin-4.2.0/kwin/effects.cpp:320
#10 0x00007fad8819e02c in KWin::Workspace::checkElectricBorder (this=0x7bda00, pos=@0x7fff90641c00, now=2194431664)
    at /home/public/portage/tmp/portage/kde-base/kwin-4.2.0/work/kwin-4.2.0/kwin/workspace.cpp:2259
#11 0x00007fad8819e12f in KWin::Workspace::electricBorderEvent (this=0x7bda00, e=0x7fff90642650) at /home/public/portage/tmp/portage/kde-base/kwin-4.2.0/work/kwin-4.2.0/kwin/workspace.cpp:2323
#12 0x00007fad881beca2 in KWin::Workspace::workspaceEvent (this=0x7bda00, e=0x7fff90642650) at /home/public/portage/tmp/portage/kde-base/kwin-4.2.0/work/kwin-4.2.0/kwin/events.cpp:475
#13 0x00007fad881ae738 in KWin::Application::x11EventFilter (this=0x7fff90642a60, e=0x7fff90642650) at /home/public/portage/tmp/portage/kde-base/kwin-4.2.0/work/kwin-4.2.0/kwin/main.cpp:359
#14 0x00007fad85b9cecb in QApplication::x11ProcessEvent () from /usr/lib64/qt4/libQtGui.so.4
#15 0x00007fad85bc584c in ?? () from /usr/lib64/qt4/libQtGui.so.4
#16 0x00007fad81941d14 in ?? () from /usr/lib/libglib-2.0.so.0
#17 0x00007fad81943a95 in ?? () from /usr/lib/libglib-2.0.so.0
#18 0x00007fad81943c6b in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#19 0x00007fad86b7feff in QEventDispatcherGlib::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#20 0x00007fad85bc4f5f in ?? () from /usr/lib64/qt4/libQtGui.so.4
#21 0x00007fad86b4ff82 in QEventLoop::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#22 0x00007fad86b5041d in QEventLoop::exec () from /usr/lib64/qt4/libQtCore.so.4
#23 0x00007fad86b55b4d in QCoreApplication::exec () from /usr/lib64/qt4/libQtCore.so.4
#24 0x00007fad881b1163 in kdemain (argc=3, argv=0x7fff90642f08) at /home/public/portage/tmp/portage/kde-base/kwin-4.2.0/work/kwin-4.2.0/kwin/main.cpp:519
#25 0x00007fad8321f5c6 in __libc_start_main () from /lib/libc.so.6
#26 0x0000000000400949 in _start ()

Comment 29 antony 2009-02-05 15:44:50 UTC
I ve the same problem
xorg-server (1.5.3)
qt (4.4.3)
kde 4.2 (kdemod) arch linux
nvidia 8800
drivers 180.27
I will try to reproduse it like post 26 says,and i ll post my results
Comment 30 antony 2009-02-05 19:30:08 UTC
i found that the problem was present windows.If i disable it everything works fine.........
Comment 31 Andreas Roedl 2009-02-13 10:13:04 UTC
I can confirm this bug. Setting kwin4_effect_presentwindowsEnabled to "false" solves the problem. I was trying to find the cause of the problem took quite a while, because - as the reporter said - it doesn't crash, the screen just goes black.

xorg-server 1.5.3
qt qt-copy from SVN
KDE 4.2.62 (KDE 4.3 >= 20090204)
ati-drivers 8.582
Comment 32 Clas Rurik 2009-02-17 16:02:18 UTC
*** This bug has been confirmed by popular vote. ***
Comment 33 lucas 2009-02-24 05:39:01 UTC
SVN commit 930721 by lmurray:

Don't run present windows window added/closed hooks if the effect is not
activated. Might be a fix for the black screening?
CCBUG: 178471
CCBUG: 185127


 M  +6 -0      presentwindows.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=930721
Comment 34 Andreas Roedl 2009-02-24 10:07:00 UTC
(In reply to comment #33)
> SVN commit 930721 by lmurray:
> 
> Don't run present windows window added/closed hooks if the effect is not
> activated. Might be a fix for the black screening?
> CCBUG: 178471
> CCBUG: 185127
> 
> 
>  M  +6 -0      presentwindows.cpp  
> 
> 
> WebSVN link: http://websvn.kde.org/?view=rev&revision=930721

That fixed it for me, although I'm on trunk (KDE 4.2.64 (KDE 4.3 >= 20090218), rebuilt kwin from SVN r930495). The commit messages there weren't quite insightful so I didn't realize that it has been fixed in the meantime.

Thanks a lot!
Comment 35 lucas 2009-02-25 10:00:27 UTC
Merging with bug 185127 as it has more useful comments.

*** This bug has been marked as a duplicate of bug 185127 ***