Bug 185328 - multiple instances of rdesktop cause black screen with composition enabled
Summary: multiple instances of rdesktop cause black screen with composition enabled
Status: RESOLVED DUPLICATE of bug 185127
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-23 12:25 UTC by i.linty
Modified: 2009-02-24 09:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description i.linty 2009-02-23 12:25:04 UTC
Version:           4.2.0-204.2 (using KDE 4.2.0)
Compiler:          gcc (SUSE Linux) 4.3.2 [gcc-4_3-branch revision 141291] This is gcc on my system but I'm not sure if is that used work compiling kde
OS:                Linux
Installed from:    SuSE RPMs

Opensuse 11.1 64bit and kde4 from repository KDE4:Factory:Desktop

kdebase4-workspace-4.2.0-204.2
kde4-kwin-4.2.0-204.2
libqt4-4.4.3-4.8.2
libqt4-qt3support-4.4.3-4.8.2
libqt4-x11-4.4.3-4.8.2
libqt4-32bit-4.4.3-4.8.2
libqt4-qt3support-32bit-4.4.3-4.8.2
rdesktop-1.6.0-37.4


This is section Device in my Xorg.conf

Section "Device"
  BoardName    "Q33"
  Driver       "intel"
  Identifier   "Device[0]"
  Option       "monitor-VGA" "Monitor[0]"
  VendorName   "Intel"
  Option "AccelMethod" "xaa"
  #Option "XaaNoPixmapCache"
 Option "XAANoOffscreenPixmaps" "1"
  Option "AddARGBGLXVisuals" "True"
 Option "DRI" "True"
EndSection


My system has worked for much time, with compositing enabled. But after an update I have this BUG: When i launch many time rdesktop and I connect to severals remote systems, the Xorg screen goes black, but X11 don't crash. I think is a problem related with  kwin. If I kill kwin and i relaunch it, I can continue to work. If I stop compositing, I have no problems. It's seems a problem related to kwin an rdesktop and the management of windows....
Comment 1 Aaron J. Seigo 2009-02-24 09:04:31 UTC
so .. file this against KWin, not Plasma.

btw, i've had a horrible time with the intel driver included in OpenSuse 11.1. it's a very poor release on the part of the intel people; highly dissapointing in fact. in any case, i'll file this against kwin and let them decide what to do with it.
Comment 2 lucas 2009-02-24 09:11:17 UTC

*** This bug has been marked as a duplicate of bug 185127 ***
Comment 3 i.linty 2009-02-24 09:22:31 UTC
> it's a very poor release on the part of the intel people

In effect on my system:


rpm -qi xorg-x11-7.4-10.6
Name        : xorg-x11                     Relocations: (not relocatable)
Version     : 7.4                               Vendor: openSUSE Build Service
Release     : 10.6                          Build Date: Fri 23 Jan 2009 06:50:56 PM CET
Install Date: Mon 26 Jan 2009 11:33:28 AM CET      Build Host: build13                 
....
rpm -qi xorg-x11-driver-video-unichrome-20081229-5.1
Name        : xorg-x11-driver-video-unichrome  Relocations: (not relocatable)
Version     : 20081229                          Vendor: openSUSE Build Service
Release     : 5.1                           Build Date: Sat 24 Jan 2009 12:51:22 PM CET
Install Date: Mon 26 Jan 2009 11:32:47 AM CET      Build Host: build08    
....
rpm -qi xorg-x11-driver-video-7.4-45.2
Name        : xorg-x11-driver-video        Relocations: (not relocatable)
Version     : 7.4                               Vendor: openSUSE Build Service
Release     : 45.2                          Build Date: Sat 24 Jan 2009 01:14:00 PM CET
Install Date: Mon 26 Jan 2009 11:33:43 AM CET      Build Host: build14
....


I had to install Xorg from Build Service !