Bug 220211 - Screen goes black if I make a window full-screen and I disable, then enable compositing
Summary: Screen goes black if I make a window full-screen and I disable, then enable c...
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-27 03:16 UTC by Grósz Dániel
Modified: 2012-04-14 14:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grósz Dániel 2009-12-27 03:16:38 UTC
Version:            (using KDE 4.3.3)
OS:                Linux
Installed from:    openSUSE RPMs

Make an application full-screen while compositiing is enabled. (E g. Konqueror; most applications produce the bug but Konsole does not). Then disable and then re-enable compositing with its shortcut. Then if you close the app, or press Alt+Tab to switch to an other window, or make the window not full-screen, the screen goes black. Only the mouse cursor is visible.

Then if I disable comositing with its shortcut again, the screen comes back but it I enable compositing again, the screen goes black again. The only way to recover is to run kwin --replace .

I have an eee pc 901 with its Intel 945GME.
Comment 1 Christoph Feck 2009-12-30 20:09:17 UTC
I had the same problem yesterday playing in SMPlayer fullscreen. The video had lags, and I was blaming composite (which is bullshit, since in fullscreen mode, the compositing is effectively disabled), so I disabled it while it was in fullscreen mode. I cannot remember the next actions exactly, but I ended up in black screen whenever I tried to activate compositing, switching it off showed desktop normally. SMPlayer was already terminated.

I also use intel 945, so it may be an upstream bug.
Comment 2 Jon Nelson 2010-03-26 18:52:33 UTC
using an nvidia (proprietary driver for now) I have the same problems.
openSUSE 11.2, KDE 4.2, 4.3 and 4.4

Possibly related: bug 205803
Comment 3 Jon Nelson 2010-03-26 18:56:32 UTC
Also possibly related: bug 185127
Comment 4 Thomas Lübking 2010-03-26 19:41:03 UTC
confirmed (nvidia)

the screen does however not "go black" but just show the root window, but no windows (including the desktop) at all (i've a root pixmap) - so this is _no_ upstream bug.

the reason is ilkely that kwin messes up the suspension/unredirection (rather than pot. tagging all windows invisible) as neither fullscreen aniimations (tabswitch etc.) nor other things (clock) are painted.

interestingly, just activating (unredirected) composition on a window that became fullscreen while compositing is suspended does not cause this.

konsole does btw. not work as it's ARGB by default and thus can not cause unredirecting
Comment 5 RussianNeuroMancer 2012-04-13 00:32:57 UTC
I can't reproduce this issue with KWin 4.8.2.
Comment 6 Thomas Lübking 2012-04-14 14:51:55 UTC
can't reproduce either - now it would be great to figure which change actually fixed it ;-)
(it's not the graphicssystem)

If anyone still experiences this with >= 4.8 - please reopen the bug