Bug 172557 - New problem My eBay crashes
Summary: New problem My eBay crashes
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 173057 173123 173269 173937 176512 180133 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-11 01:06 UTC by James Richard Tyrer
Modified: 2009-01-09 14:53 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Back Trace (5.50 KB, text/plain)
2008-10-11 01:07 UTC, James Richard Tyrer
Details
Back Trace for 4.1.2 (10.25 KB, text/plain)
2008-10-11 01:23 UTC, James Richard Tyrer
Details
Valgrind log for konqueror 4.1.2. (32.44 KB, text/plain)
2008-10-17 20:58 UTC, Raúl
Details
Patch avoiding crash. (640 bytes, patch)
2008-10-17 21:04 UTC, Raúl
Details
Patch suggested by Maksim Orlovich. (1.05 KB, patch)
2008-10-17 22:03 UTC, Raúl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Richard Tyrer 2008-10-11 01:06:32 UTC
Version:           3.5.10 (using KDE 3.5.10)
Compiler:          GCC-4.3.2 
OS:                Linux
Installed from:    Compiled From Sources

Note that this is a NEW problem with Konqueror 3.5.10

Go to www.ebay.com

You need to have an account and be logged in.

Click on "My eBay" in upper right corner of start page.  Crashes every time.
Comment 1 James Richard Tyrer 2008-10-11 01:07:55 UTC
Created attachment 27805 [details]
Back Trace
Comment 2 James Richard Tyrer 2008-10-11 01:23:35 UTC
Created attachment 27806 [details]
Back Trace for 4.1.2

Sorry to report that it also crashed 4.1.2
Comment 3 Raúl 2008-10-17 20:43:45 UTC
Confirmed as well on Debian sid with 3.5.10 and experimental on 4.1.2.

Please dump whole backtrace in comments so it's easier to search for dupes. Thanks

My backtrace for 4.1.2:
Aplicación: Konqueror (konqueror), señal SIGFPE
[Thread debugging using libthread_db enabled]
[New Thread 0x7f1988ca96f0 (LWP 18968)]
[KCrash handler]
#5  0x00007f1979cbfc00 in khtml::FixedTableLayout::layout (this=0x28d0390)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/table_layout.cpp:300
#6  0x00007f1979cbd4d8 in khtml::RenderTable::layout (this=0x28d7458)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_table.cpp:331
#7  0x00007f1979c82645 in khtml::RenderBlock::layoutBlockChildren (
    this=0x28d7390, relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#8  0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x28d7390, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#9  0x00007f1979c82645 in khtml::RenderBlock::layoutBlockChildren (
    this=0x28d72c8, relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#10 0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x28d72c8, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#11 0x00007f1979c82645 in khtml::RenderBlock::layoutBlockChildren (
    this=0x28d7200, relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#12 0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x28d7200, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#13 0x00007f1979c82645 in khtml::RenderBlock::layoutBlockChildren (
    this=0x28cd040, relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#14 0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x28cd040, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#15 0x00007f1979c82645 in khtml::RenderBlock::layoutBlockChildren (
    this=0x28ccf68, relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#16 0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x28ccf68, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#17 0x00007f1979cb2637 in khtml::RenderTableCell::layout (this=0x7fff90dd9070)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_table.cpp:2392
#18 0x00007f1979cb945a in khtml::RenderTableRow::layout (this=0x28ccee8)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_table.cpp:2173
#19 0x00007f1979c96abc in khtml::RenderContainer::layout (this=0x28c9710)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#20 0x00007f1979cbd554 in khtml::RenderTable::layout (this=0x28c9600)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_table.cpp:346
#21 0x00007f1979c82645 in khtml::RenderBlock::layoutBlockChildren (
    this=0x28c9308, relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#22 0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x28c9308, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#23 0x00007f1979c82645 in khtml::RenderBlock::layoutBlockChildren (
    this=0x28c9240, relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#24 0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x28c9240, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#25 0x00007f1979c82645 in khtml::RenderBlock::layoutBlockChildren (
    this=0x28bf870, relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#26 0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x28bf870, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#27 0x00007f1979c80822 in khtml::RenderBlock::insertFloatingObject (
    this=0x15926d8, o=0x28bf870)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#28 0x00007f1979c8093c in khtml::RenderBlock::handleFloatingChild (
    this=0x15926d8, child=0x28bf870, marginInfo=@0x7fff90dd9a40, 
    handled=@0x1cffe70)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:947
#29 0x00007f1979c809d1 in khtml::RenderBlock::handleSpecialChild (
    this=0x15926d8, child=0x28bf870, marginInfo=@0x7fff90dd9a40, 
    compactInfo=@0x7fff90dd9a20, handled=@0x7fff90dd9a5f)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:920
#30 0x00007f1979c824e1 in khtml::RenderBlock::layoutBlockChildren (
    this=0x15926d8, relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:1476
#31 0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x15926d8, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#32 0x00007f1979c82645 in khtml::RenderBlock::layoutBlockChildren (
    this=0x1592548, relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#33 0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x1592548, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#34 0x00007f1979cddf2c in khtml::RenderBody::layout (this=0x1592548)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_body.cpp:91
#35 0x00007f1979c82645 in khtml::RenderBlock::layoutBlockChildren (
    this=0x15923d0, relayoutChildren=false)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#36 0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x15923d0, 
    relayoutChildren=false)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#37 0x00007f1979c82645 in khtml::RenderBlock::layoutBlockChildren (
    this=0x15921e0, relayoutChildren=false)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_object.h:455
#38 0x00007f1979c82f72 in khtml::RenderBlock::layoutBlock (this=0x15921e0, 
    relayoutChildren=false)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_block.cpp:784
#39 0x00007f1979cd8b62 in khtml::RenderCanvas::layout (this=0x15921e0)
    at /build/buildd/kde4libs-4.1.2/khtml/rendering/render_canvas.cpp:187
#40 0x00007f1979b4c62d in KHTMLView::layout (this=0x14ed830)
    at /build/buildd/kde4libs-4.1.2/khtml/khtmlview.cpp:1040
#41 0x00007f1979b4cc98 in KHTMLView::timerEvent (this=0x14ed830, 
    e=<value optimized out>)
    at /build/buildd/kde4libs-4.1.2/khtml/khtmlview.cpp:4143
#42 0x00007f198578cfe3 in QObject::event (this=0x14ed830, e=0x51eb851f)
    at kernel/qobject.cpp:1120
#43 0x00007f1985ef17d6 in QWidget::event (this=0x14ed830, 
    event=0x7fff90dda940) at kernel/qwidget.cpp:7551
#44 0x00007f1986278459 in QAbstractScrollArea::event (this=0x14ed830, 
    e=0x7fff90dda940) at widgets/qabstractscrollarea.cpp:899
#45 0x00007f1979b466e2 in KHTMLView::event (this=0x14ed830, e=0x7fff90dda940)
    at /build/buildd/kde4libs-4.1.2/khtml/khtmlview.cpp:584
#46 0x00007f1985e9fa5d in QApplicationPrivate::notify_helper (this=0xc885e0, 
    receiver=0x14ed830, e=0x7fff90dda940) at kernel/qapplication.cpp:3803
#47 0x00007f1985ea77da in QApplication::notify (this=0x7fff90ddae70, 
    receiver=0x14ed830, e=0x7fff90dda940) at kernel/qapplication.cpp:3768
#48 0x00007f198788c41b in KApplication::notify (this=0x7fff90ddae70, 
    receiver=0x14ed830, event=0x7fff90dda940)
    at /build/buildd/kde4libs-4.1.2/kdeui/kernel/kapplication.cpp:311
#49 0x00007f198577e381 in QCoreApplication::notifyInternal (
    this=0x7fff90ddae70, receiver=0x14ed830, event=0x7fff90dda940)
    at kernel/qcoreapplication.cpp:587
#50 0x00007f19857aa256 in QTimerInfoList::activateTimers (this=0xc8b990)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:209
#51 0x00007f19857a67ad in timerSourceDispatch (source=<value optimized out>)
    at kernel/qeventdispatcher_glib.cpp:160
#52 0x00007f19822d0acb in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#53 0x00007f19822d428d in ?? () from /usr/lib/libglib-2.0.so.0
#54 0x00007f19822d444b in g_main_context_iteration ()
   from /usr/lib/libglib-2.0.so.0
#55 0x00007f19857a670f in QEventDispatcherGlib::processEvents (this=0xc83b00, 
    flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:319
#56 0x00007f1985f3144f in QGuiEventDispatcherGlib::processEvents (
    this=0x7fff90dd9070, flags=<value optimized out>)
    at kernel/qguieventdispatcher_glib.cpp:198
#57 0x00007f198577cca2 in QEventLoop::processEvents (
    this=<value optimized out>, flags={i = -1864520784})
    at kernel/qeventloop.cpp:143
#58 0x00007f198577ce2d in QEventLoop::exec (this=0x7fff90ddabf0, flags=
      {i = -1864520704}) at kernel/qeventloop.cpp:194
#59 0x00007f198577f2dd in QCoreApplication::exec ()
    at kernel/qcoreapplication.cpp:845
#60 0x00007f1988995f71 in kdemain (argc=<value optimized out>, 
    argv=<value optimized out>)
    at /tmp/buildd/kdebase-4.1.2/apps/konqueror/src/konqmain.cpp:227
#61 0x00007f19885971a6 in __libc_start_main () from /lib/libc.so.6
#62 0x0000000000400629 in _start ()
#0  0x00007f1988616ff1 in nanosleep () from /lib/libc.so.6
Comment 4 Maksim Orlovich 2008-10-17 20:54:05 UTC
*** Bug 173057 has been marked as a duplicate of this bug. ***
Comment 5 Maksim Orlovich 2008-10-17 20:55:05 UTC
I don't have an account, but I can guess what's wrong based on the bt: a fixed-layout table where the only %-specified lengths are 0%. JRT, could you test a patch?
Comment 6 Raúl 2008-10-17 20:58:08 UTC
Created attachment 27979 [details]
Valgrind log for konqueror 4.1.2.
Comment 7 Raúl 2008-10-17 21:04:46 UTC
Created attachment 27981 [details]
Patch avoiding crash.

Find attached a patch that avoids the crash. I have tested it against 3.5.10 and find it working. 

Patch has been suggested by Moritz Muehlenhoff as this bug has also been reported on Debian BTS: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502459

I would like some comments, since I'm not sure this is the right way to fix this bug.

Thanks.
Comment 8 Raúl 2008-10-17 22:03:44 UTC
Created attachment 27982 [details]
Patch suggested by Maksim Orlovich.

Hello:

Almost good news, I have tried the attached patch for kdelibs-3.5.10. I didn't get the crash for the Debian BTS bug testcase anymore. But haven't been unable to reproduce the crash on a unpatched kdelibs, so I couldn't test that's totally fixed.

Testing by anyone able to reproduce the bug is appreciated.

Thanks.
Comment 9 A. Spehr 2008-10-19 02:30:08 UTC
*** Bug 173123 has been marked as a duplicate of this bug. ***
Comment 10 Christian Reiner 2008-10-19 18:01:22 UTC
I recompiled kdelibs3-3.5.10-27.4.src.rpm from the opensuse reporitories with the mentioned patch under opensuse-11.0 on an x86-32 cpu. 
I confirm that the patch fixes the crash. 
Comment 11 James Richard Tyrer 2008-10-20 04:05:14 UTC
Yes, the 172557-fix.patch cures the crash on the 3.5 BRANCH (3.5.10++).

However, it still doesn't render the broken code in the *new* eBay "My eBay" page.

Should we commit the patch?
Comment 12 Sebastian Pohle 2008-10-21 13:21:17 UTC
Here's a snippet of html to reproduce the crash (without an ebay account):

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<body>
	<table style="table-layout:fixed; width:100%">
		<tr>
			<td style="width:0%">The 0% causes a crash in konqueror.
			</td>
		</tr>
	</table>
</body>
</html>
Comment 13 Tommi Tervo 2008-10-22 14:38:37 UTC
*** Bug 173269 has been marked as a duplicate of this bug. ***
Comment 14 Maksim Orlovich 2008-10-23 00:03:42 UTC
SVN commit 874965 by orlovich:

Fix crash when fixed-layout tables (wow, someone actually uses those?) 
specify all % width as 0 (affects new ebay myebay version)
BUG: 172557


 M  +4 -2      table_layout.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=874965
Comment 15 Maksim Orlovich 2008-10-23 00:10:00 UTC
SVN commit 874966 by orlovich:

Merged revision 874965:
Fix crash when fixed-layout tables (wow, someone actually uses those?) 
specify all % width as 0 (affects new ebay myebay version)
BUG: 172557

 M  +4 -2      table_layout.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=874966
Comment 16 Maksim Orlovich 2008-10-23 00:13:19 UTC
SVN commit 874968 by orlovich:

Merged revision 874965:
Fix crash when fixed-layout tables (wow, someone actually uses those?) 
specify all % width as 0 (affects new ebay myebay version)
BUG: 172557

 M  +4 -2      table_layout.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=874968
Comment 17 Maksim Orlovich 2008-10-23 00:21:09 UTC
SVN commit 874971 by orlovich:

Regression test for #172557
CCBUG:172557


 A             baseline/tables/172557.html-dom  
 AM            baseline/tables/172557.html-dump.png  
 A             baseline/tables/172557.html-render  
 A             tests/tables/172557.html  


WebSVN link: http://websvn.kde.org/?view=rev&revision=874971
Comment 18 Frank Reininghaus 2008-11-03 22:38:12 UTC
*** Bug 173937 has been marked as a duplicate of this bug. ***
Comment 19 Christopher Layne 2008-11-26 21:33:55 UTC
Don't know how useful this is now since it's been resolved, but I happen to have a full backtrace (this is under 3.5.9):

[Thread debugging using libthread_db enabled]
[New Thread 0x7f53467d7700 (LWP 19682)]
[KCrash handler]
#5  0x00007f533df4b2b2 in khtml::FixedTableLayout::layout (this=0x2713450)
    at table_layout.cpp:300
#6  0x00007f533df48583 in khtml::RenderTable::layout (this=0x2710288)
    at render_table.cpp:299
#7  0x00007f533df2346b in khtml::RenderBlock::layoutBlockChildren (
    this=0x27101c0, relayoutChildren=true) at render_block.cpp:1423
#8  0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x27101c0, 
    relayoutChildren=2) at render_block.cpp:710
#9  0x00007f533df2346b in khtml::RenderBlock::layoutBlockChildren (
    this=0x27100f8, relayoutChildren=true) at render_block.cpp:1423
#10 0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x27100f8, 
    relayoutChildren=2) at render_block.cpp:710
#11 0x00007f533df2346b in khtml::RenderBlock::layoutBlockChildren (
    this=0x2710030, relayoutChildren=true) at render_block.cpp:1423
#12 0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x2710030, 
    relayoutChildren=2) at render_block.cpp:710
#13 0x00007f533df2346b in khtml::RenderBlock::layoutBlockChildren (
    this=0x25e3288, relayoutChildren=true) at render_block.cpp:1423
#14 0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x25e3288, 
    relayoutChildren=2) at render_block.cpp:710
#15 0x00007f533df2346b in khtml::RenderBlock::layoutBlockChildren (
    this=0x25e31b0, relayoutChildren=true) at render_block.cpp:1423
#16 0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x25e31b0, 
    relayoutChildren=2) at render_block.cpp:710
#17 0x00007f533df455e5 in khtml::RenderTableCell::layout (this=0x7fff4e800b00)
    at render_table.cpp:2303
#18 0x00007f533df4595f in khtml::RenderTableRow::layout (this=0x25e3168)
    at render_table.cpp:2106
#19 0x00007f533df3136d in khtml::RenderContainer::layout (this=0x27025c8)
    at khtml/rendering/render_object.h:439
#20 0x00007f533df485d7 in khtml::RenderTable::layout (this=0x27024a8)
    at render_table.cpp:314
#21 0x00007f533df2346b in khtml::RenderBlock::layoutBlockChildren (
    this=0x27021b0, relayoutChildren=true) at render_block.cpp:1423
#22 0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x27021b0, 
    relayoutChildren=2) at render_block.cpp:710
#23 0x00007f533df2346b in khtml::RenderBlock::layoutBlockChildren (
    this=0x27020e8, relayoutChildren=true) at render_block.cpp:1423
#24 0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x27020e8, 
    relayoutChildren=2) at render_block.cpp:710
#25 0x00007f533df2346b in khtml::RenderBlock::layoutBlockChildren (
    this=0x252e3c0, relayoutChildren=true) at render_block.cpp:1423
#26 0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x252e3c0, 
    relayoutChildren=2) at render_block.cpp:710
#27 0x00007f533df21334 in khtml::RenderBlock::insertFloatingObject (
    this=0x19475a8, o=0x252e3c0) at render_block.cpp:1778
#28 0x00007f533df2217f in khtml::RenderBlock::handleFloatingChild (
    this=0x19475a8, child=0x2, marginInfo=@0x7fff4e8015c0, handled=@0x8)
    at render_block.cpp:872
#29 0x00007f533df23195 in khtml::RenderBlock::handleSpecialChild (
    this=0x19475a8, child=0x252e3c0, marginInfo=@0x7fff4e8015c0, 
    compactInfo=@0x7fff4e8015a0, handled=@0x7fff4e8015ff)
    at render_block.cpp:846
#30 0x00007f533df233d5 in khtml::RenderBlock::layoutBlockChildren (
    this=0x19475a8, relayoutChildren=false) at render_block.cpp:1394
#31 0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x19475a8, 
    relayoutChildren=2) at render_block.cpp:710
#32 0x00007f533df2346b in khtml::RenderBlock::layoutBlockChildren (
    this=0x1947418, relayoutChildren=false) at render_block.cpp:1423
#33 0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x1947418, 
    relayoutChildren=2) at render_block.cpp:710
#34 0x00007f533df5c862 in khtml::RenderBody::layout (this=0x1947418)
    at render_body.cpp:97
#35 0x00007f533df2346b in khtml::RenderBlock::layoutBlockChildren (
    this=0x19472b0, relayoutChildren=false) at render_block.cpp:1423
#36 0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x19472b0, 
    relayoutChildren=2) at render_block.cpp:710
#37 0x00007f533df2346b in khtml::RenderBlock::layoutBlockChildren (
    this=0x19470e0, relayoutChildren=false) at render_block.cpp:1423
#38 0x00007f533df23a6d in khtml::RenderBlock::layoutBlock (this=0x19470e0, 
    relayoutChildren=2) at render_block.cpp:710
#39 0x00007f533df58637 in khtml::RenderCanvas::layout (this=0x19470e0)
    at render_canvas.cpp:183
#40 0x00007f533dea21ad in KHTMLView::layout (this=0x1b08760)
    at khtmlview.cpp:835
#41 0x00007f533dea241e in KHTMLView::timerEvent (this=0x7fff4e800b00, e=0x2)
    at khtmlview.cpp:3427
#42 0x00007f5343ca747c in QObject::event (this=0x1b08760, e=0x7fff4e801ef0)
    at kernel/qobject.cpp:741
#43 0x00007f5343cdc213 in QWidget::event (this=0x7fff4e800b00, e=0x2)
    at kernel/qwidget.cpp:4659
#44 0x00007f5343c49775 in QApplication::internalNotify (
    this=<value optimized out>, receiver=0x1b08760, e=0x7fff4e801ef0)
    at kernel/qapplication.cpp:2635
#45 0x00007f5343c4a8da in QApplication::notify (this=0x7fff4e802210, 
    receiver=0x1b08760, e=0x7fff4e801ef0) at kernel/qapplication.cpp:2523
#46 0x00007f534518245c in KApplication::notify (this=0x7fff4e802210, 
    receiver=0x1b08760, event=0x7fff4e801ef0) at kapplication.cpp:545
#47 0x00007f5343c3fe10 in QEventLoop::activateTimers (
    this=<value optimized out>) at kernel/qapplication.h:496
#48 0x00007f5343bfb236 in QEventLoop::processEvents (this=0x152f870, flags=2)
    at kernel/qeventloop_x11.cpp:389
#49 0x00007f5343c5ffe9 in QEventLoop::enterLoop (this=0x152f870)
    at kernel/qeventloop.cpp:198
#50 0x00007f5343c5fe72 in QEventLoop::exec (this=0x7fff4e800b00)
    at kernel/qeventloop.cpp:145
#51 0x00007f533f34eb85 in kdemain (argc=<value optimized out>, 
    argv=<value optimized out>) at konq_main.cc:206
#52 0x000000000040714d in launch (argc=<value optimized out>, 
    _name=0x14f1ea8 "konqueror", args=0x14f1ebb "\001", cwd=0x0, envc=1, 
    envs=0x14f1ed0 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x14f1ed8 "clayne.apple.com;1227731149;206926;4602_TIME3665469766") at kinit.cpp:666
#53 0x00000000004078ab in handle_launcher_request (sock=9) at kinit.cpp:1240
#54 0x0000000000407e01 in handle_requests (waitForPid=0) at kinit.cpp:1441
#55 0x0000000000408c3c in main (argc=5, argv=<value optimized out>, envp=0x0)
    at kinit.cpp:1903
Current language:  auto; currently c
Comment 20 Maksim Orlovich 2008-11-30 02:57:01 UTC
*** Bug 176512 has been marked as a duplicate of this bug. ***
Comment 21 Dario Andres 2009-01-09 14:53:45 UTC
*** Bug 180133 has been marked as a duplicate of this bug. ***