Bug 173123 - crash when visiting eBay
Summary: crash when visiting eBay
Status: RESOLVED DUPLICATE of bug 172557
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: FreeBSD Ports FreeBSD
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2008-10-19 02:14 UTC by Fritz Katz
Modified: 2008-10-19 02:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fritz Katz 2008-10-19 02:14:19 UTC
Version:           Konqueror 3.5.8 (using KDE 3.5.9)
Compiler:          gcc version 4.2.1 20070719  [FreeBSD] 
OS:                FreeBSD
Installed from:    FreeBSD Ports

Visit eBay, login to my_account, browse around and crash.

Using Konqueror 3.5.8 (Using KDE 3.5.8)

I'm on FreeBSD-7, I'll do a portsnap and see if a more recent version of Konqueror is available.
-------------
# uname -rm
7.0-RELEASE i386
-------------

[New Thread 0x29801100 (LWP 100129)]
[Switching to Thread 0x29801100 (LWP 100129)]
[KCrash handler]
#6  0x2a16efde in khtml::FixedTableLayout::layout ()
   from /usr/local/lib/libkhtml.so.6
#7  0x2a16b27b in khtml::RenderTable::layout ()
   from /usr/local/lib/libkhtml.so.6
#8  0x2a13a332 in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#9  0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#10 0x2a13add5 in khtml::RenderBlock::layout ()
   from /usr/local/lib/libkhtml.so.6
#11 0x2a13a332 in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#12 0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#13 0x2a13add5 in khtml::RenderBlock::layout ()
   from /usr/local/lib/libkhtml.so.6
#14 0x2a13a332 in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#15 0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#16 0x2a13add5 in khtml::RenderBlock::layout ()
   from /usr/local/lib/libkhtml.so.6
#17 0x2a13a332 in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#18 0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#19 0x2a13add5 in khtml::RenderBlock::layout ()
   from /usr/local/lib/libkhtml.so.6
#20 0x2a13a332 in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#21 0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#22 0x2a1631c3 in khtml::RenderTableCell::layout ()
   from /usr/local/lib/libkhtml.so.6
#23 0x2a168903 in khtml::RenderTableRow::layout ()
   from /usr/local/lib/libkhtml.so.6
#24 0x2a14be81 in khtml::RenderContainer::layout ()
   from /usr/local/lib/libkhtml.so.6
#25 0x2a16b2eb in khtml::RenderTable::layout ()
   from /usr/local/lib/libkhtml.so.6
#26 0x2a13a332 in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#27 0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#28 0x2a13add5 in khtml::RenderBlock::layout ()
   from /usr/local/lib/libkhtml.so.6
#29 0x2a13a332 in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#30 0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#31 0x2a13add5 in khtml::RenderBlock::layout ()
   from /usr/local/lib/libkhtml.so.6
#32 0x2a13a332 in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#33 0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#34 0x2a13add5 in khtml::RenderBlock::layout ()
   from /usr/local/lib/libkhtml.so.6
#35 0x2a138470 in khtml::RenderBlock::insertFloatingObject ()
   from /usr/local/lib/libkhtml.so.6
#36 0x2a139aa7 in khtml::RenderBlock::handleFloatingChild ()
   from /usr/local/lib/libkhtml.so.6
#37 0x2a139b3a in khtml::RenderBlock::handleSpecialChild ()
   from /usr/local/lib/libkhtml.so.6
#38 0x2a13a1ce in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#39 0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#40 0x2a13add5 in khtml::RenderBlock::layout ()
   from /usr/local/lib/libkhtml.so.6
#41 0x2a13a332 in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#42 0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#43 0x2a13add5 in khtml::RenderBlock::layout ()
   from /usr/local/lib/libkhtml.so.6
#44 0x2a18d4f2 in khtml::RenderBody::layout ()
   from /usr/local/lib/libkhtml.so.6
#45 0x2a13a332 in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#46 0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#47 0x2a13add5 in khtml::RenderBlock::layout ()
   from /usr/local/lib/libkhtml.so.6
#48 0x2a13a332 in khtml::RenderBlock::layoutBlockChildren ()
   from /usr/local/lib/libkhtml.so.6
#49 0x2a13ab12 in khtml::RenderBlock::layoutBlock ()
   from /usr/local/lib/libkhtml.so.6
#50 0x2a186521 in khtml::RenderCanvas::layout ()
   from /usr/local/lib/libkhtml.so.6
#51 0x2a06479f in KHTMLView::layout () from /usr/local/lib/libkhtml.so.6
#52 0x2a0651d2 in KHTMLView::timerEvent () from /usr/local/lib/libkhtml.so.6
#53 0x28d655f1 in QObject::event () from /usr/local/lib/libqt-mt.so.3
#54 0x28d9e96c in QWidget::event () from /usr/local/lib/libqt-mt.so.3
#55 0x28d07d57 in QApplication::internalNotify ()
   from /usr/local/lib/libqt-mt.so.3
#56 0x28d08843 in QApplication::notify () from /usr/local/lib/libqt-mt.so.3
#57 0x287d1332 in KApplication::notify () from /usr/local/lib/libkdecore.so.6
#58 0x28cfd1a2 in QEventLoop::activateTimers ()
   from /usr/local/lib/libqt-mt.so.3
#59 0x28cb7d46 in QEventLoop::processEvents ()
   from /usr/local/lib/libqt-mt.so.3
#60 0x28d1e4e0 in QEventLoop::enterLoop () from /usr/local/lib/libqt-mt.so.3
#61 0x28d1e396 in QEventLoop::exec () from /usr/local/lib/libqt-mt.so.3
#62 0x28d077bf in QApplication::exec () from /usr/local/lib/libqt-mt.so.3
#63 0x2994ce35 in kdemain () from /usr/local/lib/libkdeinit_konqueror.so
#64 0x297e7604 in kdeinitmain () from /usr/local/lib/kde3/konqueror.so
#65 0x0804eb28 in execpath_avoid_loops ()
#66 0x0804f2d8 in execpath_avoid_loops ()
#67 0x0804f7e1 in execpath_avoid_loops ()
#68 0x080501c0 in main ()
Comment 1 A. Spehr 2008-10-19 02:30:08 UTC
Thanks!

Please try the patch in the other bug report.

*** This bug has been marked as a duplicate of bug 172557 ***