Bug 180133 - Konqueror crashes in khtml::FixedTableLayout::layout at /build/buildd/kdelibs-3.5.10/./khtml/rendering/table_layout.cpp:300
Summary: Konqueror crashes in khtml::FixedTableLayout::layout at /build/buildd/kdelibs...
Status: RESOLVED DUPLICATE of bug 172557
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 3.5
Platform: Ubuntu Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-09 14:26 UTC by Klaus Layer
Modified: 2009-01-09 14:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Klaus Layer 2009-01-09 14:26:38 UTC
Version:            (using KDE 3.5.10)
Installed from:    Ubuntu Packages

Konqueror crashes in ebay http://my.ebay.de/ws/eBayISAPI.dll?MyEbay&gbh=1 after logging in to ebay.

backtrace of the crash:

[Thread debugging using libthread_db enabled]
[New Thread 0xb67fd6c0 (LWP 2863)]
[KCrash handler]
#6  0xb5ddbdad in khtml::FixedTableLayout::layout (this=0x9023d30)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/table_layout.cpp:300
#7  0xb5ddfb1a in khtml::RenderTable::layout (this=0x8b13858)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_table.cpp:299
#8  0xb5df9952 in khtml::RenderBlock::layoutBlockChildren (this=0x8b137d4, 
    relayoutChildren=true)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#9  0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x8b137d4, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#10 0xb5e0c755 in khtml::RenderBlock::layout (this=0x8b137d4)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:611
#11 0xb5df9952 in khtml::RenderBlock::layoutBlockChildren (this=0x8b13750, 
    relayoutChildren=true)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#12 0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x8b13750, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#13 0xb5e0c755 in khtml::RenderBlock::layout (this=0x8b13750)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:611
#14 0xb5df9952 in khtml::RenderBlock::layoutBlockChildren (this=0x8b136cc, 
    relayoutChildren=true)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#15 0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x8b136cc, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#16 0xb5e0c755 in khtml::RenderBlock::layout (this=0x8b136cc)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:611
#17 0xb5df9952 in khtml::RenderBlock::layoutBlockChildren (this=0x8939a48, 
    relayoutChildren=true)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#18 0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x8939a48, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#19 0xb5e0c755 in khtml::RenderBlock::layout (this=0x8939a48)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:611
#20 0xb5df9952 in khtml::RenderBlock::layoutBlockChildren (this=0x89399b0, 
    relayoutChildren=true)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#21 0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x89399b0, 
    relayoutChildren=true)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#22 0xb5e0a843 in khtml::RenderTableCell::layout (this=0x89399b0)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_table.cpp:2303
#23 0xb5dde083 in khtml::RenderTableRow::layout (this=0x8939988)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_table.cpp:2106
#24 0xb5dbe951 in khtml::RenderContainer::layout (this=0x8939138)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#25 0xb5ddfb88 in khtml::RenderTable::layout (this=0x8939084)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_table.cpp:314
#26 0xb5df9952 in khtml::RenderBlock::layoutBlockChildren (this=0x8938e94, 
    relayoutChildren=true)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#27 0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x8938e94, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#28 0xb5e0c755 in khtml::RenderBlock::layout (this=0x8938e94)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:611
#29 0xb5df9952 in khtml::RenderBlock::layoutBlockChildren (this=0x8938e10, 
    relayoutChildren=true)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#30 0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x8938e10, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#31 0xb5e0c755 in khtml::RenderBlock::layout (this=0x8938e10)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:611
#32 0xb5df9952 in khtml::RenderBlock::layoutBlockChildren (this=0x8baccf4, 
    relayoutChildren=true)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#33 0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x8baccf4, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#34 0xb5e0c755 in khtml::RenderBlock::layout (this=0x8baccf4)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:611
#35 0xb5dccbb0 in khtml::RenderBlock::insertFloatingObject (this=0x8c7c8ec, 
    o=0x8baccf4)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#36 0xb5dccd17 in khtml::RenderBlock::handleFloatingChild (this=0x8c7c8ec, 
    child=0x8baccf4, marginInfo=@0xbfd95314, handled=@0xbfd9534b)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:872
#37 0xb5dcd99a in khtml::RenderBlock::handleSpecialChild (this=0x8c7c8ec, 
    child=0x8baccf4, marginInfo=@0xbfd95314, compactInfo=@0xbfd95308, 
    handled=@0xbfd9534b)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:846
#38 0xb5df97ee in khtml::RenderBlock::layoutBlockChildren (this=0x8c7c8ec, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:1394
#39 0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x8c7c8ec, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#40 0xb5e0c755 in khtml::RenderBlock::layout (this=0x8c7c8ec)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:611
#41 0xb5df9952 in khtml::RenderBlock::layoutBlockChildren (this=0x8c7c7e4, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#42 0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x8c7c7e4, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#43 0xb5e0c755 in khtml::RenderBlock::layout (this=0x8c7c7e4)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:611
#44 0xb5e0c792 in khtml::RenderBody::layout (this=0x8c7c7e4)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_body.cpp:97
#45 0xb5df9952 in khtml::RenderBlock::layoutBlockChildren (this=0x8c7c6fc, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#46 0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x8c7c6fc, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#47 0xb5e0c755 in khtml::RenderBlock::layout (this=0x8c7c6fc)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:611
#48 0xb5df9952 in khtml::RenderBlock::layoutBlockChildren (this=0x8c7c5c8, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_object.h:440
#49 0xb5e0a354 in khtml::RenderBlock::layoutBlock (this=0x8c7c5c8, 
    relayoutChildren=false)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_block.cpp:710
#50 0xb5e0a761 in khtml::RenderCanvas::layout (this=0x8c7c5c8)
    at /build/buildd/kdelibs-3.5.10/./khtml/rendering/render_canvas.cpp:183
#51 0xb5d2d10e in KHTMLView::layout (this=0x889f358)
    at /build/buildd/kdelibs-3.5.10/./khtml/khtmlview.cpp:839
#52 0xb5d2db3d in KHTMLView::timerEvent (this=0x889f358, e=0xbfd95c08)
    at /build/buildd/kdelibs-3.5.10/./khtml/khtmlview.cpp:3431
#53 0xb7206568 in QObject::event (this=0x889f358, e=0xbfd95c08)
    at kernel/qobject.cpp:744
#54 0xb723ed65 in QWidget::event (this=0x889f358, e=0xbfd95c08)
    at kernel/qwidget.cpp:4681
#55 0xb719cc36 in QApplication::internalNotify (this=0xbfd96228, 
    receiver=0x889f358, e=0xbfd95c08) at kernel/qapplication.cpp:2638
#56 0xb719f564 in QApplication::notify (this=0xbfd96228, receiver=0x889f358, 
    e=0xbfd95c08) at kernel/qapplication.cpp:2526
#57 0xb78a29b2 in KApplication::notify (this=0xbfd96228, receiver=0x889f358, 
    event=0xbfd95c08)
    at /build/buildd/kdelibs-3.5.10/./kdecore/kapplication.cpp:550
#58 0xb712d28d in QApplication::sendEvent (receiver=0x889f358, 
    event=0xbfd95c08) at ../include/qapplication.h:523
#59 0xb718fb19 in QEventLoop::activateTimers (this=0x80e84c8)
    at kernel/qeventloop_unix.cpp:559
#60 0xb714264b in QEventLoop::processEvents (this=0x80e84c8, flags=4)
    at kernel/qeventloop_x11.cpp:392
#61 0xb71b7f90 in QEventLoop::enterLoop (this=0x80e84c8)
    at kernel/qeventloop.cpp:201
#62 0xb71b7c8e in QEventLoop::exec (this=0x80e84c8)
    at kernel/qeventloop.cpp:148
#63 0xb719e7df in QApplication::exec (this=0xbfd96228)
    at kernel/qapplication.cpp:2761
#64 0xb665d90a in kdemain (argc=2, argv=0x80894b8)
    at /build/buildd/kdebase-3.5.10/./konqueror/konq_main.cc:206
#65 0xb7f0f454 in kdeinitmain (argc=2, argv=0x80894b8) at konqueror_dummy.cc:3
#66 0x0804ee20 in launch (argc=2, _name=0x80a2524 "konqueror", 
    args=0x80a2537 "", cwd=0x0, envc=1, envs=0x80a2548 "", reset_env=false, 
    tty=0x0, avoid_loops=false, startup_id_str=0x805100d "0")
    at /build/buildd/kdelibs-3.5.10/./kinit/kinit.cpp:673
#67 0x0804f541 in handle_launcher_request (sock=9)
    at /build/buildd/kdelibs-3.5.10/./kinit/kinit.cpp:1240
#68 0x0804fa7b in handle_requests (waitForPid=0)
    at /build/buildd/kdelibs-3.5.10/./kinit/kinit.cpp:1443
#69 0x0805057d in main (argc=5, argv=0xbfd969b4, envp=0xbfd969cc)
    at /build/buildd/kdelibs-3.5.10/./kinit/kinit.cpp:1908
Comment 1 Dario Andres 2009-01-09 14:53:45 UTC

*** This bug has been marked as a duplicate of bug 172557 ***