Bug 152775 - Tabs cannot be closed using the close tab button
Summary: Tabs cannot be closed using the close tab button
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: tabbing (show other bugs)
Version: 4.0
Platform: unspecified Linux
: NOR major with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 151158 153065 153496 153718 153974 155709 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-11-23 13:48 UTC by Alexander Berger
Modified: 2008-01-29 18:31 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
patch (9.96 KB, patch)
2007-12-29 22:35 UTC, Wouter Becq
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Berger 2007-11-23 13:48:28 UTC
Version:           3.96.1 (KDE 4.0 >= 20071120) (using KDE 3.96.1 (KDE 4.0 >= 20071120), compiled sources)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.22-14-generic

In konqueror's settings I have selected "Show close button instead of website icon". The website icons are then replaced with the close button, so far everything went alright. But pressing the button does not close the corresponding tab.

Using the Key shortcut CTRL-W works as does right clicking on the tab and choosing the context menu entry "close tab". So it looks as if only the close buttons are not working.
Comment 1 Maksim Orlovich 2007-11-23 18:50:17 UTC
Confirm. Also the setting doesn't apply immediately.
Comment 2 Maksim Orlovich 2007-11-28 19:58:10 UTC
*** Bug 153065 has been marked as a duplicate of this bug. ***
Comment 3 Maksim Orlovich 2007-11-28 19:58:53 UTC
*** Bug 151158 has been marked as a duplicate of this bug. ***
Comment 4 Pino Toscano 2007-12-05 17:51:44 UTC
*** Bug 153496 has been marked as a duplicate of this bug. ***
Comment 5 Pino Toscano 2007-12-09 15:23:02 UTC
*** Bug 153718 has been marked as a duplicate of this bug. ***
Comment 6 Pino Toscano 2007-12-13 16:44:59 UTC
*** Bug 153974 has been marked as a duplicate of this bug. ***
Comment 7 Wouter Becq 2007-12-29 22:35:21 UTC
Created attachment 22764 [details]
patch

needs review
Comment 8 Maksim Orlovich 2008-01-14 04:03:11 UTC
*** Bug 155709 has been marked as a duplicate of this bug. ***
Comment 9 lexual 2008-01-19 07:33:42 UTC
That config option has no effect in kde 4.0 what so ever.
Comment 10 András Manţia 2008-01-19 09:41:12 UTC
I fixed yesterday in trunk, might be backported to 4.0.x as well.
Comment 11 Felix Leimbach 2008-01-29 17:45:02 UTC
A backport to 4.0.x would be great as it trips people who use tabs extensively and don't want to open tabs before closing it. Thank you.
Comment 12 Tommi Tervo 2008-01-29 18:31:19 UTC
It's backported to 4.0 branch
http://lists.kde.org/?l=kde-commits&m=120160002223449&w=2